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Hello, this is my first time at writing a guide so please excuse any errors. I decide to write this guide because alot of people seem to be asking how they can convert there DiVX (avi) movies into a SVCD so they can watch on there DVD Player. This guide will go through the entire process I used to put the movie "Spider-man" onto a 2 disc SVCD. I will try to explain each step and why it was done, but I will assume you have a general understanding of encoding and are familiar with the programs used in this guide. Some steps are optional and I will try to make a note of them. Note this is not a just a guide to get a DiVX movie to SVCD, but to make it look as professional as possible by adding chapters etc. 

The following programs were using in this guide: 

DVD2SVCD 1.09 build 3 
VirtualDub 1.4.9 
VCDEasy 1.1.1 
Cinema Craft Encoder SP 2.5 * 
Photo/Paint Program (ie. Photoshop, Photopaint, etc)


* Other versions of Cinema Craft Encoder or TMPGEnc may be used but the encoder settings will not be explained in this guide... not yet anyways. 

1) Preparing the AVI files 

One often overlooked process when making a SVCD from a DiVX source is to make sure the DiVX has no errors or sync problems; If you don't fix errors in the AVI file your encoded MPEG will most likely have sync problems or other errors in it. In this step we will also split the AVI into 2 parts (or 3 if the movie is long). 

a)"Open Video File" up your AVI movie in VirtualDub. If your movie came on more then 1 AVI file (like mine did) you want to load both parts into VirtualDub. Do this by going into "File -> Append AVI segment" and choose the second file of the movie. If you get message that says "VBR audio stream detected" don't worry it'll be fixed when we split the movie a bit later on. Note: You will not be able to join a AVI that uses VBR for audio directly. To get around this you have to resave the file with an uncompressed wav for the audio stream. Step d shows you how to set that up. 

b) Once the movie is loaded you want to get some information about the AVI file. To do this click on "File -> File Information"a window will pop up that looks like this: 


 INCLUDEPICTURE "http://www.vcdhelp.com/forum/images/guides/111846/avi_info.gif" \* MERGEFORMATINET 




The important things we want to take note of are the "Frame size" and the "fps". You may want to write the frame size dimension down somewhere you'll be using it later on. Take a look at the "fps" if it's not a standard rate you may have problems later on. Standard rates would be 23.976, 25, and 29.97. A common problem is the frame rate might be close but not exactly the same as one of the standard rates. For example 23.973 fps, it may not seem like it'll matter but if you don't fix the problem the audio and video will slowly go out of sync when you encode. Why would an AVI file have a slightly off frame rate? That's a good question, the answer is usually because the person who encoded the AVI probably noticed the movie was out of sync. Instead of stretching the audio to match the video (the proper way to fix the problem) the person adjusted the framerate. This is not a problem when playing back on your computer because your computer handle pretty much any frame rate but DVD players rely on standards. There are guides on this site that will help you fix problems like this so I will not explain the steps here. This particular "Spider-man" AVI file has a standard frame rate so I am able to go to the next step. 

c) Now we want to make sure there's no bad frames in the video stream. Once again bad frames can cause sync issues and need to be fixed. There are guides around that explains how to fix these problems if your AVI does contain bad frames. To check for bad frames click on "Video -> Scan video stream for errors" This process will take several minutes. If there's bad frames fix them... if not move on. 

d) First make sure video is set for direct stream copy (we do not want to re encoded when we split). Do this by clicking "Video -> Direct stream copy". Next make sure audio is set for avi and full processing mode. Do this by clicking "Audio -> AVI audio", then "Audio -> Full processing mode". Next click on "Audio -> Conversion" a window that looks like this should appear: 



For "Sampling rate" choose 44100Hz or 48000Hz depending on which rate you will be encoding to later in DVD2SVCD. Also check "High quality" to get a better conversion. The next step is to click on "Audio -> Compression", we want an uncompress audio so we would choose "<No Compression> (PCM)". This will also get rid of the audio sync issue because of the VBR error from step (a) when we save the avi file later. 

e) We are ready to find where we want to split the movie. I know DVD2SVCD can automatically split the movie but it does it by file size so often times the movie will get split during an action scene etc. which I do not like so we are going to find a scene change near the middle of the movie and split it manually. Now we want to find a good spot 
to split the movie. Since my movie is about 121 minutes long and I want to put it on 2 CD's I'll want to split the movie at a scene change around 60 minutes. To do this drag the trackbar underneath the video window to a spot a few minutes before the 60 minute mark. Now use the "Next Key Frame" and "Previous Key Frame" button to find the exact location of a scene change. These buttons are Marked B, and A respectively in the pictures below. Note: If the AVI was encoded properly every scene change should start with a Key Frame, but remember NOT every Key Frame is a scene change. An easy way to check if the Key Frame occurs at a scene change is to goto the Key Frame then press the "left arrow key" on the keyboard to bring it back a frame and see if scene has changed. For example in my movie the scene changes from inside the office building to outside of a diner so that's would be a scene change. 
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So now we have found a good place to split the movie. We want the first part of the movie to contain all the frames from 0 to our Scene Change Key Frame (less 1 frame). To do this we set the beginning and end of selection. Set the "selection start" to frame 0 by dragging the trackbar to the far left until the Frame says 0. Then click the "Set selection start" button (C in the picture). To set the "selection end" move the trackbar until we get the our Key Frame (-1). In my example that would be Frame 82220. Now click the "Set Selection end" button (D in the picture). The blue bar where the trackbar is shows you which part has been selected. Now we save the first part of the movie. Click on "File -> Save as AVI", and give it a name like "part1.avi" or in my case I used "spider1a.avi". It may take a few minutes to save the file. Once the first part is saved we want to save the last half of the movie. Do the same thing as before except your "Start of selection" point will be the Scene Change Key Frame and the "End of selection" point will be the last frame of the AVI. Just remember to use a different file name when you save... I called the second part "spider2a.avi". Now that we have the 2 AVI files split where we want we can finally move onto the next step of actually encoding the file :=) You may first want to play the AVI files with Media Player to make sure nothing has gone wrong and that each part ends at where you wanted it to. 

2) DVD2SVCD.... more then just for DVD's 

I am going to use DVD2SVCD in AVI mode since it automates most of the dirty work. I'm going to assume you're familiar with this program and have it set up already. I'll also go through each of the important tabs and explain what most of the settings are for. The pictures will show the settings I used, but remember this may not necessarily be the best setting. 

a) Misc 
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Make sure that "Input file type" is set to "AVI" or else you won't be able to load the AVI movie later on. 

"Output file type" is set to "MPEG-2" since I'm making a SVCD, if you're making a regular VCD choose "MPEG-1" instead. 

"DVD2SVCD level" set it to "Advanced" or else some of the options in the other tab won't show up. 

Check convert "divx3 to divx4" if your movie is in divx3 format and if you are using CCE to encode. 

b) Conversion 
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"AVI file" load the first part of your movie here in my case it's "spider1a.avi" 

"Selected Audiotracks" there should only be on track and it should be checked automatically. 

Check "NTSC to PAL" if you want your MPEG to be in PAL (25 fps). Maybe useful for people in Europe but I think most PAL DVD players also play back NTSC so is there a point in checking this??? 

"Deinterlace": should be set to "No deinterlacing" unless your movie is interlace which it shouldn't be. 

"Aspect Ratio": There's 3 different settings the easy way to explain is with pictures and a table. My avi file has a resolution of 640x352 approximately 16:9 ratio. The table will show how it would look on a normal TV (4:3) and a widescreen (16:9) with each setting. 

	
	Normal 4:3 TV
	Widescreen 16:9 TV

	4:3 (No borders, encoded as 4:3)
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	16:9 (borders added, encoded as 4:3)
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*

	Anamorphic (no borders, encoded as 16:9)
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**
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*Note: This is how it would look on a 16:9 TV in full screen mode. All 16:9 TV's have a zoom or theatre mode to crop out the black bars so if the TV was in this mode it wi'll look like the 4:3(No borders, encoded as 4:3) picture, not distorted. 
** Note: this is what it 'should' look like on a 4:3 TV but in reality almost all DVD players ignore the anamorphic tag when playing back VCDs or SVCDs so the black bars are not added and your picture will look like the 4:3 (No borders, encoded as 4:3) picture, stretched. 

I my opinion the best mode for AVI's that are in widescreen mode is to use the 16:9 (borders added, encoded as 4:3), this will give you the best compatibility with TV's and players. Note: I actually choose 4:3 (No borders, encoded as 4:3) in my settings because I will be manually adding the letterboxing later on to give me the same effect as doing a 4:3 (borders added, encoded as 4:3). I choose this method because sometimes DVD2SVCD doesn't always letterbox correctly. 

c) Frameserver 
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This is where we set the frameserver to resize our movie and add any special filters that may help improve the final MPEG. 

"Resize to": The first thing to decide is what size we want our MPEG to be, since I'm making a SVCD I'll choose that option. Other options include DVD, CVD, and VCD. At low bitrates the DVD resolution of 720x480 is pretty much out of the question. Some people may decide to use CVD resolution but I find that on a Widescreen HDTV that I watch on, diagonals are noticabley jaggie to the point where it's annoying. VCD resolution might be a good choice if quality isn't important and you want to fit a short movie (80-90 minutes) onto one CD. 

"Resize Method": When resizing I generally use Bicubic Resize. It's a bit slower then the other methods but the quality is better especially 
when resizing in both directions. There are other guides that can explain what the variables b and c do. I usually use a value of (0.33, 0.33) other values to try are (0, 0.6) setting a c value too high tends to sharpen too much so be careful. 

The other filters, like Sharpen and TemporalSmoother I don't really use. DVD's and DiVX are generally fairly noise free so Smoothing isn't necessary. If your AVI contains alot of noise you may want to turn some of these filters on. 

"Add ResampleAudio": Check this if you are using CCE and have an AMD Athlon processor. If not then it's not necessary. It's only used to fix a bug with CCE and Athlon processors. 

"Flip vertical": some AVI codecs tend to flip the movie upside down... cough cough *Microsoft*. If you find after you encode your MPEG is upside down you need to check this. 

"Edit the Avisynth Script File": I checked "Edit as part of Video encoding" because I am going to manually letterbox the video like I decide in step 2b. You can just choose "No editing" if you will not be manually letterboxing. 

d) Audio 
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There's not much to set for audio since we only have one audio track. 

"Audio 1 Bitrate": I choose 224 kps, if audio isn't as important to you, you can give the video more bits to play with by using a lower rate like 192. I wouldn't suggest using anything lower or the audio may not sound too great. 

"Audio 1 downsample 48 -> 44.1": If your DVD player doesn't handle SVCD or VCD with 48 K rate then check this. Also check this if you want a compliant (S)VCD rate. 

"Autodetct Azid gain (2 pass)" This basically normalizes the audio, I usually keep this checked. 

e) Encoder 
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For the encoder I'm using Cinema Craft Encoder 2.5. If you're using a different version of CCE or TMPG you will have different settings. This guide will not cover the other encoder settings so you're on your own if you use those ones. 

"Safe mode (frameserving)": you need to check this if you're using CCE other then version 2.5 or else you'll get a crash when encoding. This will slow down encoding a bit so if you're using CCE 2.5 don't check this. 

"Video Encoding Mode": I'm sure everyone knows the difference 
between CBR and VBR, if not go read the newbie guide. I use a mulipass setting of 4. Any higher won't give you much better bitrate allocation so it's not really worth the extra time. You can also use a setting of 3 if you are impatient. 

"Image Quality Priority": This affects what the encoder will give bit priority too, scenes with lots of moving parts or more static scenes. Values range from 0 to 100. A low value means more priority to complex scenes, so there will be less artifacts (looks like flies along the edges of objects) during action scenes, but on flat static scenes you'll get contour noises, (remember contour maps in geography class? looks like rings around objects). If you are encoding at a very high bit rate this setting doesn't have too much of an effect since there's plenty of bits to go around, but when trying to cram movies onto 2 CD's it can make a big difference in the final output quality. Generally I use a value from 5 to 25, 5 for high action movies and 25 for slow drama's or talkies. Some values to try are 5, 7, 12, 17, 22, 25. 

"Anti noise filter": Since DVD's and DiVX's are generally fairly noise free I keep this unchecked. It makes encoding a bit quicker too if it's unchecked. If your movie has a bit of noise you may want to check this and use a fairly low value 2-7. If you set the value too high you may get a jerky looking encode. 

"Field order": Just leave it at automatic. 

"(Advance settings)": 
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"Linear quantizer scale": Keep this unchecked for a slightly better quality. You should only ever check this if you're encoding MPEG1 (thanks Adam for the info). 

"Zigzag scaning order": For progressive images this gives better quality. Check this if your AVI is progressive (most likely). 

"DVD Compliant": Since we're not making a DVD don't check this 

"Progressive frames": General rule is if the source is progressive make your SVCD progressive. If it's interlaced make your SVCD interlaced. If in VirtuaDub your picture looked like there were horizontal lines (interlace lines) running across the screen then your movie is most likely interlaced. 

"Intra DC decision": Just keep this to Auto. 

"GOP Settings": Don't touch this unless you know what you're doing or you may make your MPEG not readable by normal DVD players. 

f) bbMPEG 
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Not much to set here. 

"Movie offset seconds": I set this to 0 since I don't have sync problems on my dvd players if you have a sync problems set this to 2. On my player if it's set to 2 I tend to lose 2 seconds off the start of the movie. 

"CD Overlap seconds": No need to check this since we've split the movie manually remember. 

"Advance Settings": Change things in there at your own risk. Bad things can happen, so unless you know what you're doing keep away. 

g) Bitrate 
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This is pretty self explanatory. Since we are split the movie into parts manually you may one to set the first three settings to use 1 CD, if you forget to DVD2SVCD will split your already split part if it goes over 76 minutes. I also set all the CD size to 800 because well who uses 74 minute CDs anymore [image: image18.png]


Now the important settings: 

"Max": this is the maximum bitrate the video stream can be. Don't set it higher then your DVD player can handle. 2530 seems to be about the max my and most players can handle. 

"Min": set this to 300. Any lower and some DVD Players will not play it. 

"Min. avg": I keep this unchecked since the average is going to be determined by the movie length anyways. 

"Max. avg": there has to be at least a 200 difference between the average and the max or else CCE may have problems. That's why it's set to 2330. 

Check "warn if total bitrate is too high" if your player can't handle high bitrates. 

h) Finally we encode... 

We can ignore the other tabs thy don't really do anything, except for the "CD Image" tab. Since we're going to author the CD manually with VCD Easy we can check "Don't make image". All our settings are done now and we're ready to encode. Goto the "Conversion" tab and click "Go -> start conversion". DVD2SVCD will start to work now. 

Optional: It'll take a few minutes to encode the audio, after it's done a window will pop up that looks like this (there will be no pop up if you choose not to edit AVIsynth script in DVD2SVCD): 
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This is were we edit the script to do the manual letterboxing for our movie. The DVD2SVCD Q&A has a good explaination on how this is done so I won't try to explain how I got my values. Look at question 62 there. For my movie I edit the script to look like this: 
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Once the script has been edited (don't forget to double check for spelling) click "Save" then click "OK" and let the encoding continue. A few hours later you will have your MPEG file ready to author or burn. 

Optional: If your player doesn't play back SVCD without the header trick, like mine. You will have to load up TMPG, click on "File -> MPEG Tools", click on the "Simple Multiplex" tab. Load up your newly created mpg file, change the "Type" to "MPEG-1 Video CD". Click "Run". 

3) Authoring and burning using VCDEasy and your favourite recording program 

Now that the first half of our movie is encoded we can author our (X)(S)VCD to make it look more professional. If you do not care about this step you can just burn your MPEG file with Nero or another CD Recording program. I like to make my discs look more professional so I like to add a message prompting the viewer to switch disc and I will also try to add chapters and entrypoints so the disc can be navigated more easily. To do this I'll be authoring with VCD Easy. You will also need some other paint or photo editing program to make the change disc message. 

a) Making the change disc still 

I'm going to make my change disc image so that when you are watching the movie it will look like the change disc message appears over the last frame. First we want to capture an image of the last frame of the first part of the movie, right where we split it. There are many ways to do this, I just loaded up the AVI of the first part of the movie, moved the slider to the last frame (with a picture). And just hit the "Print Screen" button on the keyboard to capture the screen to the clipboard. Then I loaded up my photo editing program (Photoshop) and pasted the screen capture so it's ready for editing. I'll assume you're familar with whatever editing program you choose to use so I'll just outline the steps briefly: 
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	Screen capture pasted into Photo Editing Program. 
Resolution: 1024x768
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	Crop around movie frame and resize till horizontal width is 640 pixels. 
Resolution: 640x352
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	Add black borders at top an bottom until we get a horizontal resolution of 480 pixels. In my particular example I had to add 64 pixels boder at the top and bottom. 
I got this number by (480-352)/2=64 
Resolution: 640x480
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	Now add your change disc message using the text overlay tool in your paint program. 
Save the picture as an uncompress bitmap. 
Resolution: 640x480




Once we have the change disc picture created we can make our MPEG still using VCDEasy. Load up VCDEasy, click on the "Tools" then the "MPEG Stills" tab. Change your settings to look like this: 
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Of course your "Input Image" would be whatever you saved your picture as in the previous step. All the other settings should be the same as how I have it except in the "MPEG Still Type" you should check "SVCD" if you're making a true SVCD. I used "VCD 2.0" because my player doesn't play back SVCD without the header trick. Once everything is set up hit "Generate" to make your MPEG Still. 

b) Adding chapters and making the image 

Now we're ready to add chapters. Click on "(S)VCD) on the left side, click the "Main" tab. 
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Click "Add Files" and add the first part of the encoded movie and the change disc MPEG still you made from the previous step. 

"VideCD type": Choose "SVCD 1.0" if you're making a SVCD, choose "VCD 2.0" if you're making a VCD or if you had to use the header trick like I did. I don't think there's ever a reason to choose VCD 1.1, maybe for really old players ??? 

"CD Writer": I'll be using a different program to write the image so I choose "No CD Writer Selected" 

"Volume Label": Just put the name of the movie in here. 

"Bin Output File": The name of the CD Image that VCDEasy will create. 

Now we click the "Chapters" tab. We skipped the "Options" tab because there's really nothing that needs to be changed there so I won't bother. You will get a screen that looks like this: 
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There's not many options here but it's an important part to make professional looking chapters. To add a chapter type the timecode into the "Create a Chapter at" field and then hit okay. You will have to do this for each chapter you want. How did I know what timecode to put in? Good question. This is the probably the slowest and most boring process. Remember in step "1e)" where we found a good scene change spot to split the movie using Virtual Dub? Well to find good spots to insert a chapter point in the movie we do the same thing but instead of splitting the movie we just write down the timecode where these scene changes happen. The time code is shown at the bottom right of the VirtualDub window. So load up the first part of the movie in VirtualDub. And go through the movie and write down 10-12 good places to insert a chapter... the best spots are scene changes like I have said. Note: when you put in the timecode in VCDEasy the actual chapter entry may not be exactly the same ie. you put in 0:03:30.292 and you get 0:03:30:293 don't worry about VCDEasy just finds the closes I frame it can put the entrypoint at. 

Once you have all the chapter points manually inputted. We're almost ready to make the image. You may first want to goto the "Interactivity" tab and make it so that the disc change image stays on the screen for more then 2 seconds (default). This is pretty easy to do, once, you're in the "Interactivity" tab change he "Play Item" so that "Segment - 0002" is selected. Now change the wait time to "Wait Infinite" that's it. 

Now that everything is set click "GO" and VCDEasy will make your image file now (in bin, cue format). Once it's done you can burn the image using CDR Win, Fireburner, Nero, etc. That's it! A DiVX movie converted so you can watch it on your DVD Player! Of course you'll still have to do the same thing fot the second part of the movie [image: image28.png]






You can discuss this guide here.
