SUN CERTIFIED SYSTEM ADMINISTRATOR FOR SOLARIS 7, PART I


The following list of topics is provided to help candidates prepare for Part I of the Sun Certified System Administrator for Solaris 7 examination: Sylvan exam number 310-009.
http://suned.sun.com/USA/certification/csaIobj.html
SYSTEM CONCEPTS. 

· Match the three parts of an operating system (kernel, shell, and file system) to their definitions 

kernel:  Collection of software tha manages the physical (devices) and logical (processes & memory) resources of the computer.

shell:  Software module that provides the interface between the user and the kernel.

file system:  Collection of files stored on a disk drive in a hierarchial structure.

· Identify the three most common shells in the Solaris environment 

The three most common shells for use as command interpreters are the bourne shell (sh), the C shell (csh) and the Korn shell (ksh).  The Bourne shell is the default.
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· Distinguish between multitasking and multiuser 

Multitasking:  A processor can run more than one task

Multiuser:  More than one user can run processes

· Describe the client-server relationship 

Two entities (processes or systems) that cooperate to accomplish a task.  A client requests a server to obtain access to information or perform some operation.  The server provides the information or operation on behalf of the client.  This architecture allows information or specific operations to be performed by a single entity on behalf of multiple clients.  This simplifies the design of the client and provides data consistency by making a single entity (the server) responsible for the data.

· Define the following basic system terms: host, host name, network, IP (Internet Protocol) address, client, and server

host:  A computer system that provides resources to locally and/or remotely logged in users.

hostname:  A name assigned to a host.

network:  A shared medium used by computers to communicate and exhange information.

IP (Internet Protocol):  A unique 32-bit (4-byte or 4-octet) address assigned to a networked computer using the IP addressing scheme.  Consists of four numbers from 0-255.

server:  A computer system that is configured or designed to provide one or more services to other computers via the network.

client:  A computer system that is configured or designed to interact with a user and to provide an interface to one or more services runnin on a server via the network.


THE BOOT PROM. 

· Use OpenBoot PROM commands to identify basic system configuration information 

OpenBoot is the firmware (stored in the boot Programmable Read-Only Memory or PROM) used to boot the operating system, run diagnostics, modify boot-related parameters stored in nonvolatile RAM (NVRAM), and provide a Forth interpreter.  OpenBoot commands entered at the Forth Monitor or OpenBoot ok prompt:


For displaying System Config Data:

Command


Description







banner


Display power-on banner

devalias


Display all current device aliases

.enet-addr


Display ethernet address

.idprom


Display formatted ID PROM contents

module-info


Display CPU speed (OpenBoot 2.x)

printenv


Display current NVRAM parameters & default values

showdevs


Lists installed devices

.speed


Display CPU and bus speeds (OpenBoot 3.x)

.traps



Display a list of SPARC trap types

.version


Display version & date of the boot PROM

For Selecting Boot Devices:

Command


Description







boot cdrom


Boots from local CD-ROM

boot disk


Boots from default hard disk

boot floppy


Foots from diskette drive

boot net


Boots from the network

boot tape


Boots from SCSI tape drive

Check on the following – not sure:

show-disks


Lists device paths for installed SCSI disk controllers

show-displays

Lists device paths for installed display devices


show-nets


Lists device paths for installed ethernet controllers.


show-sbus


Lists all installed & probed Sbus devices.


show-tapes


Lists device paths for installed SCSI tape controllers.


show-ttys


Lists device paths for installed tty devices.

· Use OpenBoot PROM commands to alter the system boot device 

The default boot device can be changed using the setenv boot-device diskn command where n is the disk number, then using the reset command to save the new boot-device value.

· Use OpenBoot PROM commands to perform basic hardware testing 

For Performing Hardware Testing:

Command


Description







pcia-list


Test PCI

probe-scsi


Tests built-in SCSI for connected devices

probe-scsi-all


Tests all SCSI devices

test-all



Tests a group of install devices

test floppy


Tests diskette drive

test /memory


Tests system memory

test net


Tests the on-board Ethernet interface

watch-clock


Monitors system clock

watch-net


Monitors network connection

· Boot the system from more than one device 

The system can be booted from a different boot device and/or program using boot device file options where device is cdrom, disk, floppy, net or tape; file is the name of the program and options are –a (interactive), -h (halt after loading), -s (single user mode).

· Create a custom device alias using nvalias 

At the ok prompt:  nvalias disk2 /sbus/esp/sd@2,0

This would create an alias called disk2 for the device /sbus/esp/sd@2,0
This would be stored in NVRAM and retained until changed.

Another method that creates the same alias which is lost after the system is rebooted:

At the ok prompt:  devalias disk2 /sbus/esp/sd@2,0

· Remove a custom device alias using nvunalias 

At the ok prompt:  nvunalias disk2

· Use the Solaris eeprom command to modify EEPROM parameters 

Format:  eeprom parameter=value
Example:  eeprom auto-boot?=false

· Use boot command options to observe system boot problems 

At the ok prompt:  setenv diag-switch? true

Initialization messages will be sent to tty serial port A rather than to file.

· Use keyboard commands to abort a hung system 

stop + a

Sequence

System Response

stop


Bypasses the POST

stop + a

Aborts the operating system or boot process




(Returns to OpenBoot ok prompt)

stop + d

Enters diagnostic mode

stop + f

Enters the Forth Monitor on TTYA 

(instead of system console)


stop + n

Resets NVRAM contents to default values


INSTALLING THE SOLARIS 7 SOFTWARE ON A STAND-ALONE. 

· Define software configurations, clusters, and packages 

Package:  A software package is a funcational grouping of files & directories.

Cluster:  A logical grouping of packages.  

Solaris 2.x is preconfigured into software groups (collection of clusters & packages).  There are four software groups (five for Sparc platforms).

Software Group
Group Contents







Core


Required operating system files


End User

Windowing Environments:  CDE, OpenWindows


System 

& Motif runtime Libraries.


Support

Power Management (energy saving software)





Basic networking/printer support





Standard UNIX & patch utilities





JAVA Virtual Machine


Developer

End user group plus:

System

Development support


Support

CDE/Motif developer software





Online manual pages





Programming tools & libraries





Extended terminal and X support


Entire 

Developer system group plus:


Distribution
Answerbook2





Enhanced security features





UUCP, DCHP & enhanced networking





support





Additional language & partial locale





Solstice Launcher


Entire

Entire Distribution group plus:

Distribution
Voyager drivers & sun4u X server modules


+ OEM Support
SunFastEthernet


(Sparc only)
PCI, M64 graphic & Fujitsu device drivers

· Identify the hardware requirements for installing the Solaris 7 software on a stand-alone workstation 

SPARC:  Can be installed on most sun4c, sun4u & sun4m platform groups.  Minimum 64MB memory, recommended space for the smallest Solaris 7 software group (End User) is 438MB of hard disk space or largest (Entire Distro with OEM) 909MB of hard disk space.  Use of at least 1GB hard disk is recommended.  WebStart install requires a minimum of 48MB memory & 2GB disk space.  Either a CD-ROM drive or appropriate environment for network installatino is required.

Intel:  Can be installed on most 486DX or better Intel-based systems. Minimum 32MB memory but 64MB is recommended, recommended space for the smallest Solaris 7 software group (End User) is 438MB of hard disk space or largest (Entire Distro with OEM) 895MB of hard disk space.  WebStart install requires a minimum of 48MB memory & 2GB disk space.  Either a CD-ROM drive (and 1.4 diskette drive) or appropriate environment for network installatino is required.

· Prepare an existing system for a standalone installation 

- Backup the existing system files.

- Check if Solaris 7 supports the hardware.

- Check for sufficient disk space.

- Decide on default disk layout or custom disk layout

- Decide to provide configuration info when prompted or to preconfigure

- Decide to use upgrade (merge with existing system) or initial (overwrite existing system).

- Decide on method of installation CD, Network

- Decide on either Solaris Interactive (SunInstall) or Solaris Web Start as the installation program.

· Install the Solaris 7 software on a standalone workstation using SunInstall™

SunInstall:  The Solaris Interactive Installation program is a text-based installation program that guides the installer step-by-step but only installs the Solaris software.  Does not support installation of co-packaged software, co-packaged software must be installed later used the co-packaged installation programs.

Web Start:  The Web Start provides a web browser user interface that allows installation of Solaris & co-packaged software.  The default option is to install all Solaris and co-packaged software; however, this can be changed to allow specific software to be selected.


SOFTWARE PACKAGE ADMINISTRATION. 

· Display software package information 

Information on installed packages is displayed using one of these:  

pkginfo pkg_name
pkginfo –l pkg_name
pkgparam pkg_name 

where pkg_name is the name of the package.

· Add a software package from a CD-ROM drive 

A software package is added from CD-ROM using:  

pkgadd –d /cdrom/cdrom0 pkg_name

Typically packages are placed in /var/spool/pkg.  Use the –d option to specify a different directory path for a package.

· Remove a software package

A software package is removed using:  pkgrm pkg_name
· Add and remove software packages using the Admintool software program 

Add software package:  To display Software Window, select Browse then Software.  To display the Add Software Window, select Edit then Add.  Select the Source Media location, and the Add Software window is displayed.   Select the checkbox of the package to install and click the Add button.

Remove software package:  To display Software Window, select Browse then Software.  Highlight the package to remove using the mouse.  Select Edit then Delete.  In the Warning Window, click Delete button to delete.

· Add a software package from a spooled directory

A software package is added from a default spool directory (/var/spool/pkg) using:  pkgadd pkg_name.  If a different spool directory is used it is specified using the –d argument:  pkgadd –d full_path_to_spool_directory pkg_name


MAINTAINING PATCHES. 

· Obtain current patch information and patches 

Patch information along with security patches & other recommended patches can be obtained from Sun via the World Wide Web (sunsolve.sun.com) or anonymous ftp (sunsolve1.sun.com/pubs/patches).  Or, if a service contract is purchased, patches can be obtained from the regularly distributed patch CD-ROM.

· Verify current patches installed on your system 

All patches applied are listed using:  showrev –p or patchadd –p

Can also use the patchadd command to display a list of installed patches for other system configurations using the –C, -R, and –S arguments.  Example:

patchadd –S solaris7x86 –p

A list of patches applied to a particular patch can be displayed by using pkgparam:  pkgparam SUNWaccu PATCHLIST

· Install patches 

The patchadd command copies files from the spool directory (often /var/spoo/patch is used), determines the Solaris version number of the managing host & the target host, updates the pkginfo file of the patched package with information about the patches that are rendered obsolete by the patch being installed, other patches required with this patch, and patches that are incompatible with this patch.  During the installation errors are recorded under /var/sadm/patch/patch-number/log.

patchadd full_path_patch_filename
Command line aruguments for patchadd:

-M
apply multiple patches

-R
apply patch to the bootable root image of a diskless client

-S
apply patch to an operating system service

-C
apply patch to an install server configuration

-B
specify a different backup directory

-d
do not backup files, cannot remove patch if this arg is used

· Back out patches 

The patchrm command is used to remove a patch.  All files modified by the patch are restored unless:


- The patch was installed using patchadd –d


- The patch was obsoleted by a later patch


- The patch is required by another patch

The patchrm command uses the same –C, -R, -B and –S arguments as the patchadd command.  Additionally you can use the –f argument to force removal of a patch that has been superseded by another patch.


THE BOOT PROCESS. 

· Describe the functionality available at each of the eight system run levels 

Run
init


Level
State


Functionality








0
Power Down

The system is being shut down.  All users are forced 





off the system.  All operating services are stopped in





an orderly manner.  When complete, the system is at





firmware (OpenBoot) mode.  It is safe to turn off the





power to the system & peripherals.

s 
Single User

The system is prepared for maintenance.  Any users

or



are logged off the system.  Any services except the 

S



most basic operating system services are stopped in





an orderly manner.  Any mounted file systems remain





mounted.  A command line interface (with superuser





privileges) is started and associated with the system





console.  This allows the system administrator to 





perform maintenance, such as system backup, 





without interference from users or applications.

1
Administrative

Any logged-on users are not affected.  Multiple users





can log on & use available system resources.  All





services except the most basic operating system





services are stopped in an orderly manner.  Any





mounted files systems remain mounted.  A command





line interface interface (with superuser privileges) I

started and associated with the system console.  This

allows the system administrator to perform mainten- 

ance while allowing users to access the system.


2
Multiuser

The system is setup for normal operations.  Multiple






users can logon and use the system resources.  All 






services, except the Network File System (NFS) service,






are started.  All default file systems are mounted.


3
Multiuser

The system is setup for normal operations.  This is



with NFS

typically the default system state.  Multiple users can






use the system resources.  All services, including 






resource sharing (NFS), are started.  All default file






systems are mounted.


4
Alt Multiuser

Currently, this state is not used and is unavailable.


5
Power


The system is shut down.  All users are logged off


Down


the system.  All operating services are stopped

in an orderly manner.  When complete, it is safe to turn off the power to the system & peripherals.  If supported by the system hard- ware, the power to the system is auto matically turned off.

6
Reboot


The system is shut down (run level 0) and then restarted &

brought back up to the default run level (as defined in the inittab file, typically 3).
· List the phases of the boot process 

SPARC Boot Phases

- Boot PROM:
The Boot PROM phase displays system information and then runs the POST (Power On Self Test) diagnostics.  After completion of the diagnostics, the primary boot program, bootblk, is loaded.  Its function is to locate the secondary boot program, ufsboot, on the boot device.

- Boot Programs:
In the Boot Programs phase, bootblk loads the ufsboot program into memory and executes it.

- Kernel Init:
In the Kernel Initialization phase, the ufsboot program loads the core kernel into memory and causes it to execute.  The kernel initializes its data structures and begins loading other kernel modules on the basis of the /etc/system file using the ufsboot program.  After all the necessary modules are loaded and initialized, the kernel starts the /sbin/init program.

- init:
In the init phase, the init program starts other processes on the basis of the information contained in the /etc/inittab file.  These include a program that calls the run control (rc) scripts that setup various system services.

Intel x86 Boot Phases

- BIOS:
During the BIOS phase, the POST diagnostics are executed.  Then the master boot record, mboot, is read from disk to locate the active partition that contains the pboot program.

- Boot Programs:
In the Boot Programs phase, the pboot programs is loaded, and in turn locates and loads the primary boot program, bootblk.  Then the secondary boot program, either boot.bin or ufsboot, is located in the root file system and loaded.

- Kernel Init:
In the Kernel Initialization phase, the boot.bin or ufsboot program program loads the core kernel into memory & causes it to execute.  The kernel initializes its data structures and begins loading other kernel modules.  After all the necessary modules are loaded and initialized, the kernel starts the /sbin/init program.

- init:
In the init phase, the init program starts other processes on the basis of the information contained in the /etc/inittab file.  These include a program that calls the run control (rc) scripts that setup various system services.

· Explain the main roles of the /sbin/init program 

- Control system processes and services

- Primary purpose is to create or stop processes on the basis of current state of the system utilizing the /etc/inittab file to determine the processes to start or stop, and execute the appropriate rc scripts for that run level.

- Sets default environment variables as defined in /etc/default/init

· Add startup files for additional system services

- Create shell script that accepts command line arguments 'start' & 'stop' to perform appropriate functions.

- Place script in /etc/inid.d directory.

- Determine run level for starting the service.

- Determine two digit number to control start sequence.

- Copy script or create a link to script in the appropriate rc directory starting filename with S and then the two digit number and the service name.

- Determine run level for stopping the service.

- Determine two digit number to control start sequence.

- Copy script or create a link to script in the appropriate rc directory starting filename with K and then the two digit number and the service name.


CHANGING SYSTEM STATES. 

· List at least two reasons for halting a system 

1.  Shutting down system to add/remove hardware.

2.  Preparing for power outage.

· List the five commands used to change system run levels from the command line 

Command

Run Level(s)
Description






halt


0

Stops the processor(s)

init & telinit

0123456s
Processes control initialization

poweroff

5

Stops the processor(s) & powers off system

(if possible)


reboot

6

Reboots the system


shutdown

0123456s
Changes system run level


uadmin

056

Used for administrative control

· Change run levels using the init and shutdown commands 

init 0  



changes run level to 0 to power down the system

shutdown –i 0 –g 600
also changes run level to 0, but gives a

600 seconds (10 minutes) grace period


SYSTEM SECURITY. 

· Use the id command to determine your UID (user identifier) and GID (group identifier) 

id
· Describe the superuser account and its importance to system administration 

The root account is a special administrative account that provides the ultimate in terms of access to data & services, as it can override any file permissions set on the system.

· Describe the purpose of the sysadmin group 

Userid that are a member of the sysadmin group (#14) can perform some selected administrative activities including using admintool.  This allows basic sysadmin functions:  adding/deleting users, printers and software.

· Change user ownership of files and directories 

chown user1 file1

chown 1001 file1 file2

chown –R user1:staff directory1  (changes owner to user1 & group to staff)

· Change group ownership of files and directories 

chgrp other file1

chgrp 14 file1 file2

chgrp –R staff 

· Describe how the who and last commands relate to system security 

last command will display login & logout activity, identifying users currently on and those recently logged on

who command will display users currently logged into the system and can display information about processes, reboots, etc.

· Describe the format of the /etc/passwd, /etc/shadow, and /etc/group files and explain their importance to system security 

/etc/passwd

7 colon delimited fields

username:password:UID:GID:comment:homedir:login shell

root:x:0:1:Super-User:/:/sbin/sh

/etc/shadow
9 colon delimited fields

UID:password:last_changed:minimum:maximum:warning:inactivity:expiration:flag

(example using all fields except flag field)

guest:on7GbE18yYaek:10688:5:30:5:20:10844:

/etc/group
4 colon delimited fields

group_name:password:GID:users

sys::3:root,bin,daemon

· Modify several system default files that enable the system administrator to control and monitor superuser access to the system 

/etc/default/login

- CONSOLE=/dev/console entry (default) will restrict root login to the console, user must login to workstation and su to root or login directly from console.

/etc/default/su
- CONSOLE=/dev/console entry (not default) will display failed & successful attempts to use the su command to the console.

- SULOG=/var/adm/sulog entry (default) will log display failed (noted with "-") & successful (noted with "+") attempts to use the su command to the filename given.  

- SYSLOG=YES entry (default) will log use of the su command using the syslog feature (if properly configured) to capture and log  these messages.

· Restrict access to the root account 

/etc/default/login

- CONSOLE=/dev/console entry (default) will restrict root login to the console, user must login to workstation and su to root or login directly from console.

· Describe how to monitor logins

Can monitor failed login attempts (failed after 5 tries) by creating file /var/adm/loginlog which will enable logging and log failed entries to this file.  To disable, delete this file.  Should have read/write permissions for root only.


ADDING USERS. 

· Use Admintool to create a new group and a new user account 

Run admintool, select Browse->Groups, select Edit->Add

Run admintool, select Browse->Users, select Edit->Add

· Change your password 

passwd or, if you have sysadmin access you can use admintool
· Set up password aging using Admintool 

Run admintool, select Browse->Users, double-click on desired user

Set entries for Minimum Change, Maximum Change, Max Inactive, Expriation Date and Warning.

· Lock a user account using Admintool 

Run admintool, select Browse->Users, double-click on desired user

Set the Password selection to "Account is locked".

· Delete a user account using Admintool 

Run admintool, select Browse->Users, click once on desired user, select Edit->Delete


ADMINISTRATION OF INITIALIZATION FILES. 

· Define a variable in the .profile file 

LPDEST=HPLaser

export LPDEST

· Maintain the /etc/profile file 

The /etc/profile file is the system profile that is executed before a user's profile.  This provides the ability to control & restrict the user environment before the user has an opportunity to make any modifications.

· Customize the templates in the /etc/skel directory 

/etc/skel directory contains templates (local.profile, local.login & local.cshrc) used to create user's .profile, .login and .cshrc files.  Copy template to user's home directory then customize.

· Customize initialization files  

For sh or ksh, modify the file .profile in the user's home directory.

For csh, modify the file .login in the user's home directory.

· Modify the DTSOURCEPROFILE variable so that shell initialization files are read

Edit the file .dtprofile in the user's home direcotry, set variable to DTSOURCEPROFILE=true

ADVANCED FILE PERMISSIONS. 

· Display and change the default permissions (umask) 

umask
will display your current umask setting

umask 022
changes current setting of umask to 022

· Set access control lists on files 

setfacl –s u::rw-, g::r--, o:r-- file1


setfacl –m u:guest:rw-, g:staff:r-- file1

· Explain how the setuid and setgid permissions relate to system security 

setuid permissions:  absolute mode = 4000, symbolic mode = s

(shown as an "s" in the user account permission:  rwsrwxrwx)

Sets the effective UID to owner at execution.

setgid permissions:  absolute mode = 2000, symbolic mode = s

(shown as an "s" in the group account permission:  rwxrwsrwx)

Sets the effective GID to group at execution. 

· Identify and set the sticky permission 

sticky bit permissions:  absolute mode = 1000, symbolic mode = 5

(shown as a "t" in the other account permission:  rwxrwxrwt)

· Describe how the sticky permission protects files and directories

When set for a directory that has write permission for everyone, only the user who created a file or subdirectory in that directory can remove them.


PROCESS CONTROL. 

· Use the ps command to list processes running on the system 

ps –ef

will display all processes in full display format

· Use the kill command to terminate processes running on the system 

kill –KILL 4224 
will kill process with PID of 4224

· Use the pgrep and pkill commands to locate processes and kill them depending on specified criteria 

pgrep adm*

displays processes that contain 'adm' in the program name

pkill –KILL –u user1
kills all processes associated with user: user1

· Use the at command to execute a command at a future time 

at 1400 –f filelist

runs commands in 'filelist' file at 1400

at 1730


runs two scripts listed at 1730

/export/Scripts/backup

/export/Scripts/update

<CTL-D>


(ends list of commands to run)

· State the function of the cron daemon 

The cron daemon is responsible for executing commands at specified times/dates.

· Describe the format of the crontab file 

crontab format
Min 
Hour 
Day
 Month 
Weekday 
Command

10    
3     
  *      
     *      
0,4         
/etc/cron.d/logchecker

Executes at 03:10 on any  Sunday & Thursday of every month 

· Name the two files used to control crontab access 

/etc/cron.d/cron.allow & /etc/cron.d/cron.deny
Lists user account names that are allowed or denied access to the crontab command.  If cron.allow does not exist, users will be allowed if their username is not listed in cron.deny.  If neither file exists, users will be denied access.

· Edit a user's crontab file to schedule nightly backups of the user's home directory

su user1

become user1

crontab –e

edit the user's crontab

30  1  *  *  *  tar cvf  /dev/rmt/0   /export/home/user1

Creates a user cron entry to tar to tape the user's home directory every day at 1:30.


DISK CONFIGURATION AND NAMING. 

· Describe the physical device names that are used to identify a system's devices 

format:  driver-name@unit-address:device aruguments

/sbus@1f,0/esp@0, 4000/sd@3, 0:a

Represents a slice (or partition) of a SCSI disk drive on a SPARC system.  This identifies a device attached to the sbus with a main system bus address of 1f,0; and esp device (SCSI bus) attached at Sbus slot 0, offset 4000; and an sd device (SCSI disk) with a SCISI bus target of 3, a logical unit of 0, and an argument of a, which represents slice a of the disk.

· Identify logical device names used by system administrators to reference disk devices and explain when it is used in the Solaris 7 environment 

raw access – one character at a time  (/dev/rdsk)

block access – via a buffer for accessing large blocks of data  (/dev/dsk)

Identifies the SCSI controller (bus), SCSI target (location on bus), drive (almost always 0), and slice (partition):

/dev/dsk/c0t3d0sa

This identifies a block disk device (/dev/dsk…a raw device would be /dev/rdsk) addresses as SCSI controller 0, SCSI bus target 3, drive 0 and slice (partition) a.

Raw device names would be used for commands like format, newfs & fsck.

Block device names would be used for commands like mount & df.

Some commands accept either format, such as the prtvtoc command.

· Determine the type(s) of disk devices and disk device interfaces on your system using the format utility or dmesg command 

dmesg
displays messages from syslog generated during system boot,

uses instance & physical names to identify devices.


format
supports menu selection of disk devices, both logical device names




and physical device names are displayed.

· Identify the instance device name 

sd0
could be the instance name of the first SCSI disk

· Display system configuration information with prtconf command 

prtconf
displays system configuration information, devices are identified



using the instance name.

· Describe the function of the /etc/path_to_inst file 

Instance device names are mapped in the /etc/path_to_inst file.

"physical name"                                     instance number  "driver binding name"

 "/pci@0,0/pci-ide@7,1/ata@1/sd@0,0"      16                         "sd"

This would map the device to instance device name:  sd16


DISK PARTITIONS AND FORMAT. 

· Define a disk label 

The disk label, or VTOC, contains the partition table &  geometry data about the disk, such as sectors per track, tracks per cylinder, available cylinders, etc.  

· Define disk partitions/slices 

A partition, or disk slice, is a contiguous collection of disk sectors as defined by the partition table.  Once a partition is defined in the partition table, a file system can be created within that partition.

· Display a disk's volume table of contents with the prtvtoc command 

prtvtoc /dev/rdsk/c0d0s0  
displays VTOC, including disk geometry 

and partition table.

· Use the format utility to partition a disk 

format
displays a list of disks, select the disk and it will display the Format 

Menu, select Partition and it will display a partition menu.  From this

menu you can modify the partition table for the disk.

· Use the format utility to create and save a customized partition table 

format
Select & modify partition table as desired (see above).  Save

custom partition table using the Save item of the Format Menu.


INTRODUCTION TO FILE SYSTEMS. 

· Define the term file system 

A logical collection of files & directories contained in a partition.

· Describe the contents of each of the standard Solaris 7 file systems 

root (/)
Top of the hierarchical file system tree.  Contains critical system 



files, such as the kernel and device drivers.

/usr

System files, such as commands & programs, used to administer



and use the system.

/home

User home directories.  On some systems it might be /export/home



or a network-based file system.

/var

System files that change or grow, such as logs, queues & spooling



areas.

/opt

Third-party software & applications.

/tmp

Temporary files cleared each time the system boots.

/proc

Information on active processes.

· Create new ufs file systems 

newfs –v /dev/rdsk/c0d1s7
(-v is for verbose, needs raw device names)

· Describe why fsck is necessary 

It will attempt to make the repairs necessary to eliminate inconsistency when file systems are damaged.

· Describe how to check and repair a file system 

fsck –F ufs /dev/rdsk/c0d1s7


-F specifies the type of file system being checked, command expects raw device names.

· Display disk space usage by file systems 

df
displays mount point, logical block device name, free blocks, number of

 files that can be created for each filesystem

· Display the size of a directory 

du –k

lists the size (in kilobytes) of each subdirectory  and the total

 amount for the current directory.

· Display disk usage by user name

quot  /export/home
lists the number of kilobytes of the file system owned by each user, and the –f option will


include the the number of files 

Output from command:

/dev/rdsk/c0d0s7:

17627   root

    133   dla

        2   guest

         1  sys


MOUNTING FILE SYSTEMS. 

· Mount and unmount local file systems 

mount  /dev/dsk/c0d1s7 /usr2
mount logical block device name (partition)






c0d1s7 at mount point /usr2

umount /usr2


using mount point

unmount /dev/dsk/c0d1s7
using logical block device name

· Mount a file system of a specified file system type 

mount  -f ufs /dev/dsk/c0d1s7 /usr2
specifies UFS large file support

· Mount a file system that disables the default largefiles option 

mount  -f ufs –o nolargefiles /dev/dsk/c0d1s7 /usr2


specifies UFS large file support (greater than 2GB) but specifies nolargefiles.  If large files exist, the mount will fail.

· Set up your system to mount a local file system automatically at boot time

Edit the file /etc/vfstab to add the entry in this format:  Device to Mount, Device to fsck, Mount Point, FS Type, fsck Pass, Mount At Boot, Mount Options

/dev/dsk/c0t1d0s0  /dev/dsk/c0t1d0s0  /home  ufs  2  yes  1


BACKUP AND RECOVERY. 

· Dump a file system to tape using the ufsdump utility 

ufsdump 0u /dev/rdsk/c0t1d0s5



Dump level 0 specifies the entire filesystem, identified by it's logical raw device name, will be backed up to the default tape device (/dev/rmt/0), the u will record dump level & date to /etc/dumpdates.

· Restore files or a file system from tape using the ufsrestore utility 

ufsrestore f /dev/rmt/1 /etc/passwd /etc/default

The f identifies that the following device is to be used (/dev/rmt/1) for the restore, this command will restore the file /etc/password and the directory & subdirectories of /etc/default from the ufsdump on tape.

· Recover the root (/) or /usr filesystems 

1.  Select an available partition (or install & format new disk)

2.  Create a file system using newfs
3.  Mount the new file system on a temporary mount point, then change the directory to the temporary mount point.

4.  Use the ufsrestore command to restore the root or /usr backup to the new file system.

5.  Remove the restoresymtable created by the ufsrestore command to check point the restore.

6.  umount the new file system.

7.  Use the fsck command to check the new file system.

8.  If recovering the root file system, use the installboot command to create a boot block on the new file system.

9.  Reboot the system.

· Back up and restore a directory using the tar utility 

tar cf /dev/rmt/0 /export/home

creates tar file of /export/home on tape 

tar xf /dev/rmt/0
restores the data on the tape

· Position a tape to a selected data set using the mt utility

mt –f  /dev/rmt/0n fsf 4
Specifies the raw tape device 0 , will position the tape

to the fifth data set (skips over four EOF marks)


THE LP PRINT SERVICE. 

· List the operating systems supported by the Solaris print service 

- Solaris 2.x & 7

- SunOS 4.x & 5.x

- HP-UX

· Describe the functions of the line printer (LP) print service 

-  Allows users to print files

-  Provides ability to add, modify & delete printer definitions

-  Porvides print scheduling

-  Supports both local & remote printing

· Describe what a print server and print client are 

print server:  A system that has a local printer attached to it that the system makes available to other systems on the network.

print client:    A system that sends its print requests to a print server.

· Define the terms local printer and remote printer 

local printer:  A printer attached directly to the local system by means of a serial or parallel communication port.

remote printer:  A printer attached to a system (or a network interface device) that functions as a print server.  Accessing a remote printer from a local system requires defining the local system as a client to the remote printer.

· Diagram local and remote print models 

/etc/lp/model/standard

Default print model for a local printer

/etc/lp/model/netstandard
Default print model for a remote printer

The print model is a script that defines how the LP Print Service interfaces with the printers.  The print model is responsible for initializing the printer port and the printer based on information provided by the terminfo database, printing a banner page and multiple copies if requested.  A model might be provided with the printer or custom models created, default models listed above.

· Verify that a printer type exists in the terminfo database 

infocmp hplaser

If hplaser has an entry in terminfo, the terminfo entry

will be displayed.

If you do not know the terminfo name for a printer, examine the subdirectories under /usr/share/lib/terminfo.  Entries for terminals/printers are stored in separate files under one or two levels of subdirectories.  For example, the terminfo entry for a Hewlett-Packard (HP) LaserJet printer is stored in the /usr/share/lib/terminfo/h/hplaserjet file.

· Use Admintool to add a local and a remote printer to a system 

Adding a local printer:
1.  Start admintool
2.  Browse -> Printers, the Printers window is displayed.

3.  Edit->Add->Local Printer, the Add Local Printer window is displayed.

4.  Fill in the following:


- Printer Name


- Description


- Printer Port (/dev/term/a, /dev/term/b, and so on)


- Printer Type (PostScript, HP, DEC, and so on)


- File Contents (PostScript, ASCII, Both, None, Any)


- Fault Notification (Write to Superuser, Mail to Superuser, None)


- Options (Default Printer, Always Print Banner)


- User Access List (default is All, use the Add or Delete button to modify)

Adding a remote printer:

1.  Start admintool
2.  Browse -> Printers, the Printers window is displayed.

3.  Edit->Add->Access to Printer, the Add Access to Printer window is displayed.

4.  Fill in the following:


- Printer Name


- Print Server


- Description


- Option (Default Printer)

· Modify the configuration of a printer using Admintool

Modify a local printer configuration:
1.  Start admintool

2.  Browse -> Printers, the Printers window is displayed.

3.  Highlight the printer to be modified, then select Edit->Modify, the Modify Printer window will display.

4.  The following fields are displayed:


- Printer Name


- Description


- Printer Port (/dev/term/a, /dev/term/b, and so on)


- Printer Type (PostScript, HP, DEC, and so on)


- File Contents (PostScript, ASCII, Both, None, Any)


- Fault Notification (Write to Superuser, Mail to Superuser, None)


- Options (Default Printer, Always Print Banner)


- User Access List (default is All, use the Add or Delete button to modify)

5.  After making changes, click on OK.

Modify a remote printer configuration:
1.  Start admintool
2.  Browse -> Printers, the Printers window is displayed.

3.  Highlight the printer to be modified, then select Edit->Modify, the Modify Printer window will display.

4.  The following fields are displayed:


- Printer Name


- Print Server


- Description


- Option (Default Printer)

5. After making changes, click on OK.


PRINT COMMANDS. 

· Use the lp command to print files 

lp file1


Prints file1 on the default printer

lp file1 file2


Prints file1 & file2 on the default printer

lp –d laser2 –n 3 file1
Prints 3 copies of file1 on printer laser2

· Use the lpstat command to monitor print jobs 

lpstat
-o


shows status of print requests (default)

lpstat –t


shows all status information 

lpstat –a


lists all printers accepting requests

lpstat –u


lists users that have queued print requests

lpstat –c


lists printer classes and class members

· Use the cancel command to cancel print jobs 

cancel laser1-27

Cancels print request with the request ID of laser1-27

· Use lpadmin to set up a printer class 

lpadmin –p laser1 –c draft
Creates a printer class by the name of draft by

assigning printer laser1 to it.

· Manually designate a default printer destination using the lpadmin command or the LPDEST environment variable 

lpadmin –d laser1

Defines laser1 printer as the system default printer.

Define the LPDEST environment variable (usually defined in the user's login profile)

LPDEST=laser2

export LPDEST

The following precedence order is used to determine the destination printer:

1.  Printer specified on the lp command line using the –d argument.

2.  Default printer defined by the LPDEST variable.

3.  Default printer defined by the PRINTER variable.

4.  System default printer.

*If a destination printer is not specified and a default printer is not defined, print jobs are rejected.

· Use the lpmove command to move a queued print request from one printer to another 

lpmove laser2 laser1
Moves all queued print requests from laser2 printer to

laser1 printer.

lpmove laser1-27 laser2
Moves only the print job with the request ID of 

laser1-27 to laser2 printer.

· Assign priorities to print requests and move a job to the top of the queue 

lp –q 10 file2

Prints file2 with a priority of 10

lp –i laser1-27 –q 0

Changes the print job with the request ID of laser1-27

to priority 0, which moves it to the top of the queue.


lp –H immediate file3
Moves the print request for file3 to the top of the

queue.

· Stop and start the LP print service

Starting the LP print service

/usr/lib/lpsched

Print services started

/etc/init.d/lp start
Print services started

Stopping the LP print service

/usr/lib/lpshut

Print services stopped.

/etc/init.d/lp stop
Print services stopped.

