The following list of topics is provided to help candidates prepare for Part II of the Sun Certified System Administrator for Solaris 7 examination: Sylvan exam number 310-010.


THE SOLARIS 7 NETWORK ENVIRONMENT. 

· Describe the network capabilities of the Solaris 7 network environment 

- Remotely providing operating system services for systems with limited or no disk space

- Remotely booting and installing a system

- Remotely providing applications and data

- Providing naming services to identify and locate systems on the network

- Remotely logging into a system

- Transfering files between systems
· Define the following terms: 

Server - A system that provides services to other systems in its networked environment. These services include OS services for diskless clients and AutoClients, Solaris CD image and JumpStart* directory access for remote installations, and file sharing via the Network File System (NFS) service. 

Client - A system that uses remote services from a server. Clients with limited disk space such as diskless, AutoClient and JavaStation* systems require a server to function.

File Server - Provides access to application and user data via the Network File System (NFS) service. 

Diskless Client Server – A system that stores the operating system  for a client that does not have a local hard disk.  The client remotely mounts its root (/) and /usr file systems from this server.

AutoClient Server - A system that provides access to operating system and applications to AutoClient systems via the network 

Standalone - A system that can operate autonomously and does not require a server to function. It has enough disk space to contain root (/), /usr, and /export/home file systems and swap space. Thus it has local access to operating system software, executables, virtual memory space and user created files.

· Describe the basic hardware components and file system configurations for diskless clients, AutoClients, and standalone workstations 

All three configurations require a CPU, memory, monitor, mouse and keyboard. A network interface is required for the diskless and AutoClient systems and is optional for the standalone workstation. A disk is required for the AutoClient and standalone configurations. A CD-ROM drive is also required for the standalone.

The diskless client accesses file systems remotely from a server. The disk on the AutoClient is used for local swapping and caching the root (/) and /usr file systems obtained from the server. The disk on the standalone workstation is used for root (/), /usr, and /export/home file systems and swap space. Thus it has local access to operating system software, executables, virtual memory space and user created files. 

Type

Local Swap
Local File Systems

Remote File Systems

Standalone

Yes
root, /usr, /var, /export/home
None

Diskless Client

No
None


root, /usr, /var, /home

AutoClient

Yes
root, /usr


/var, /home

· Describe the file system configuration for diskless and AutoClient servers, and state the minimum required disk space in (megabytes) Mbytes
The diskless client does not have a disk and must remotely access its root (/), /usr, /home and any other needed file systems from a server. 

The AutoClient system requires a minimum of a 100 MB local disk for swapping and for caching the root (/) and /usr file system downloaded from the AutoClient server. All other file systems must be remotely accessed from the server. 


INSTALLING A SERVER. 

· Identify the three phases of the installation process 

1.  System configuration: There are two methods to preconfigure system information. 

The sysidcfg File Method: A file for each system is created that contains a set lines in the form of KEYWORD=VALUE. The file can either be available over the network or on diskette. 

The Name Service Method: Entries for each system are added to the tables associated with the name service (NIS or NIS+). 

2.  System installation: There are four methods for installing Solaris. 

SunIntall: Interactive.  Provides a step by step guide for installing Solaris software. Any co-packaged software must be installed later. 

Web Start: Interactive.  Provides a web browser user interface for installing both Solaris and co-packaged software 

JumpStart: Automatic.  Provides automatic installation of Solaris software on a new Sparc based system by inserting the Solaris CD and powering on the system. 

Custom JumpStart: Automatic.  Provides automatic installation of Solaris software on groups of systems, but requires preconfiguration. 

3.  Post Installation: Post installation consists of adding the appropriate patches or packages.  Any custom confisguration such as user accounts and environments.

· Identify the minimum required disk space, in Mbytes, for a server installation 

Minimum for 32-bit support is 438MB, for 64-bit support is 532MB.

· Verify that your system meets the hardware requirements for installing the Solaris 7 environment on a server 

Requires a minimum of enough hard disk space to store the configuration of the operating system and applications.  Additionally, a server requires a CD-ROM drive to install Solaris 7 from the CD (or CD available via the network).

· Describe the terms software packages and software clusters 

Software Package: A collection of files and directories required for a software product delivered in a standardized installable/removable format. 

Software Cluster: A collection of two or more related software packages that work together to provide a service or capability (a logical grouping of packages).
· List and describe the software configuration cluster options 

Group
Contents






Core
Minimum operating system

End User
Core + windowing software

Developer
End User + development libraries

Entire Distribution
Developer + enhanced networking

Entire Distro + OEM
Entire Distribution + optional drivers

· Use the Solaris Interactive Installation program to perform local custom installation of the Solaris 7 software

- For new system, power system on. For existing system, enter boot net or boot cdrom at ok prompt. Wait for system to boot

- If prompted, answer configuration questions

- Follow instructions on screen

- If space for diskless clients or AutoClients was allocated, use Solistice Host Manager to complete setup of cliets.

- Install co-packaged software using appropriate procedures.

SOLARIS SYSLOG AND AUDITING UTILITIES. 

· Configure syslog messages by increasing the logging severity level for the login daemons 

· vi the /etc/syslog.conf file to change the daemon facility to a higher level, ie change to auth.notice to log each system login authentication 

· Manually stop & start syslogd to set changes:

· /etc/init.d/syslogd stop
· /etc/init.d/syslogd start 

-     Also, ensure the /etc/default/login file has the entry SYSLOG=YES to log all root logins and attempts.

· Configure syslog messages by increasing the logging severity level for the telnet daemons 

· vi the /etc/syslog.conf file to change the daemon facility to a higher level, ie change to daemon.notice to log each system service (ie ftp, telnet, etc.)

· vi the file /etc/init.d/inetsvc to add trace mode (-t) for inetd, line should read:

· /usr/sbin/inetd –s –t &

· Manually stop & start syslogd to set changes:

· /etc/init.d/syslogd stop
· /etc/init.d/syslogd start
· Must manually stop & start inetsvc
· /etc/init.d/inetsvc stop
· /etc/init.d/inetsvc start
· Given the log from syslog, list the correct actions to limit access to specific users 

You can specify login accounts as a syslog action (multiple users can be specified) for a specific /etc/syslog.conf entry.  Any messages created for that log entry will be written to the associated user account (if the user is logged in). 

· Use the who utility to determine who is logged onto a system 

Shows login name, terminal, login date/time and origination.

· Use the whodo utility to determine what tasks users are performing 

Shows user and the processes that are being executed.

· Use the last utility to determine when the guest user last logged in 

Shows logins/logouts:  shows user logged in and last time account logged in.

· Use the logins utility to list user and login information 

Shows user and login info (account, UID, primary group, GID, /etc/passwd comment field)

· Use the ps utility to determine what processes are running on the system 

Shows processes running on the system.


DEVICE ADMINISTRATION. 

· Define the following terms: serial device, port, serial port, modem, null modem cable, data carrier detect, and port monitor program 

serial device:
a device that communicates using the RS-232 standard

port:
a controlled physical device that can transfer data between entities (input, output, both)

modem:     device used to convert digital data to & from electrical analog signals.

null modem cable:
cable that allows two DTE devices to communicate via serial ports.

data carrier detect:
one of the interchange circuits defined by the RS-232 standard & transmitted on one of the wires in a serial cable.

port monitor program:
     monitors the RS-232 interchange circuits (such as DCD) on the serial ports of the system and provides information to applications as to the status of the interchange circuits.

· Name at least two serial devices

Modems, mice, printers, and in some contexts other computers

· Describe different modes of modem access 

Inbound:
the modem is configured to answer incoming calls & negotiate with the originating modem to establish a connection.

Outbound:
the modem is configured to originate an outgoing call on behalf of a service.

Bidirectional:
modem configuration is a combination of the inbound & outbound configurations.

· Give an example of a data communication equipment (DCE) device and a data terminal equipment (DTE) device

DCE:
modem

DTE:
terminals & computers


THE SERVICE ACCESS FACILITY. 

· Name the top-level SAF process and describe its function 

sac or Service Access Controller

· State the run level at which sac is started 

Run Levels 2, 3 & 4

· Name the two port monitor types available under SAF and describe each 

ttymon & listen

· Name the configuration file that tells sac which port monitors to initialize 

/etc/saf/_sactab
· Define the term service

A program that monitors & sets up connections using the serial ports & network interfaces.

· Name the file used by the ttymon port monitor to initialize the speed and terminal settings for each port 

/etc/ttydefs
· Describe the function of the sacadm, pmadm, and ttyadm commands

sacadm command is used to control the behavior of the SAC

pmadm command is used to control the behavior of the port monitors


ttyadm command is used with pmadm to format entries for the port monitor table (_pmtab)



ADDING TERMINALS AND MODEMS WITH ADMINTOOL. 

· Add a terminal to a system using Admintool 

Run admintool – the Admintool:Users window displays

Select Browse->Serial Ports from the Admintool:Users window 

The Admintool:Serial Ports window displays

Select serial port for the terminal and then select Edit->Modify

The Admintool:Modify Serial Port window displays

Select “Terminal – Hardwired” for the Template

Select desired baud rate

Enter the name of the terminal type

Click OK

· Add a bidirectional modem using Admintool 

Run admintool – the Admintool:Users window displays

Select Browse->Serial Ports from the Admintool:Users window 

The Admintool:Serial Ports window displays

Select serial port for the modem and then select Edit->Modify

The Admintool:Modify Serial Port window displays

Select “Modem – Bidirectional” for the Template

Select desired baud rate

Enter the name of a default terminal type for inbound connections.

Click OK

· Describe the syntax and purpose of the tip command 

tip command is used to connect to a remote system through an RS-232 connection.


Using a hostname:

tip galaxy1


Using a device name:

tip /dev/term/b


Using a phone number:

tip 1-800-321-9876

· Name the file that the tip command uses to identify remote systems and line speeds

/etc/remote


INTRODUCTION TO DISK MANAGEMENT. 

· List the three utilities used to create, check, and mount file systems 

mkfs or newfs to create

fsck to check

mount or mountall to mount

(see notes from Exam I for more detail on these)

· Identify the physical path name differences between standard Solaris file systems and virtual file systems 

Standard Solaris file systems use /dev/rdsk (raw) and /dev/dsk (block)

Virtual file systems use:

DiskSuite metadevices:  
/dev/md/rdsk (raw) and /dev/md/dsk (block)

Volume Manager:       

/dev/vx/rdsk (raw) and /dev/vx/dsk (block)

· List the potential advantages of any virtual disk management application 

· Overcome disk limitations

· Increase performance

· Improve reliability

· Easier administration thru GUI

· List the basic difference between Solstice DiskSuite and Solstice Enterprise Volume Manager 

Both are software products that can be used to increase storage capacity & data availability.  Volume Manager also includes performance analysis tools & dynamic online tuning to provide optimal use of storage.

· List the main advantages of using a concatenated virtual file system 

Provides a means for using slices that might otherwise be too small for use.  Also provides some load balancing between disks & can result in head movement optimization.

· List the main advantage of using a striped virtual file system

Provides a means for using slices that might otherwise be too small for use.  Increase in performance because it allows multiple simultaneous reads & writes.  


NETWORKS. 

· Distinguish among different internetwork terms 

· Describe IP addressing classes A, B, and C 

Class

Octets

Default Subnet Mask

A

1-126

255.0.0.0

B

128-191
255.255.0.0

C

192-223
255.255.255.0

(Remember:  127 Octet is used for localhost – 127.0.0.1)

· Describe the function of each of the following files: 

/etc/inet/hosts  -  ??

/etc/hosts  -  contains loop-back & host information

/etc/nodename  -  contains the system’s hostname

/etc/hostname.xxy  -  contains hostname for that interface

/etc/rcS.d/S30network.sh file uses the ifconfig utility to configure each interface with an IP address & other network info.  It does this by searching for any files of type hostname.xxy in /etc.

(xx = interface type & n is the instance of the interface - ie /etc/hostname.hme0

· Identify users logged in to the local network 

who
· Log in to one machine from another machine on the network    

rlogin or telnet
· Describe the function of the /etc/hosts.equiv and .rhosts files in relation to network security 

· Send ping and spray requests to a remote host to test for response 

The ping command is one of the most common network troubleshooting utilities.  

It is used to determine if a you can reach a system over the network (host is alive).

This is done by sending ECHO_REQUEST datagrams to another host, and if that host if reached it will reply with an ECHO_REQUEST datagram.

Format:

ping hostname

Or

ping ip_address
The spray command is another network troubleshooting utility.

It not only verifies connectivity with the host, but also the correct operation of network interfaces & protocol stacks up to the application layer.

It sends a stream of User Datagram Protocol (UDP) packets to another host, and if that host is reached it will  acknowledge receiving the packets.

Format:

Spray hostname
Or

spray ip_address
· Execute the netstat -i command and interpret the output


CONFIGURING THE NFS ENVIRONMENT. 

· Describe the functions of an NFS server and an NFS client 

The NFS server contains the file resources to be shared with other systems on the network.  The NFS client mounts the file resources shared over the network and presents the file resources as if they were local.

· Make resources available and unavailable for mounting 

share or shareall commands make resources available for mounting

unshare or unshareall commands make resources unavailable for mounting

· Edit the /etc/dfs/dfstab file on an NFS server, to enable sharing of resources 

The /etc/dfs/dfstab file lists resources to share automatically when the system is in Run Level 3 or when the shareall command is used.  Use an editor to modify the file and add a resource to be automatically shared, example:

share –F nfs –o rw /export/home

· Display a server's available resources for mounting 

dfshares command will list shared resources from either the local or remote systems.

· Mount a resource from another system 

mount host1:/export/home /export/home

· Edit the /etc/vfstab file to mount resources on an NFS client 

Use an editor to modify the /etc/vfstab to have remove file resources mounted at boot time, example:

Entered in this order:  device to mount, device to fsck, mount point, FS type, fsck pass, mount at boot, mount options:

host1:/export/home     -     /export/home     nfs     -     yes     soft,bg

· Describe the function of these commands: mountall, umountall, shareall, and unshareall

shareall:
shares all file resources (listed in the /etc/dfs/dfstab file)

unshareall:
unshares currently shared file resources listed in the /etc/dfs/sharetab file

mountall:
mounts resources in the /etc/vfstab file that have Mount At Boot option = yes

umountall:
unmounts all currently mounted resources (listed in the /etc/mnttab file)


CacheFS FILE SYSTEMS AND WebNFS. 

· Describe and configure the CacheFS file system 

When you enable the CacheFS file system, the data read from the remote file system or CD-ROM is stored in a disk-based cache on the local system.  Subsequent read requests to the same data are fulfilled by the local cache, which speeds up client access to the data and decreases network traffic & load on the NFS server.

Configure the CacheFS:

Step 1:   Create cache (cfsadmin)
Step 2:   Create mount_point (mkdir)
Step 3:   Mount cacheFS (mount –F cachefs)
Example:

Step 1:

cfsadmin –c /cache/cache0

Step 2:

mkdir /data
Step 3:

mount –F cachefs –o backfstype=nfs, cachedir=/cache/cache0, 

                  
host1:/export/data /data

(Note:  The command line in Step 3 of the example above is wrapped to improve readability)

· Provide read/write Internet access to an NFS resource through a Web browser

WebNFS extends the NFS protocol to allow client systems to access NFS resources via Web browsers or Java applets without requiring them to be NFS clients.  Browsers access via an NFS URL in the form of  nfs://server/path
Use options of either index and/or public in the share command to enable WebNFS and NFS access, example:

share –F nfs –o rw, public, index=index.html /export/home


USING AUTOMOUNT. 

· List three benefits of using the automount utility 

1. Can reduce network traffic

2. Allows faster booting & shutdown

3. Users don’t need root password to mount/unmount NFS resources

4. Centralize administration of AutoFS mounts via use of a name service

5. Simplifies tracking of resources manually

6. Eliminates need to add NFS mounts in the /etc/vfstab file

· Describe the purpose of each of the types of automount maps 

Master Map:  /etc/auto_master

Read by the automount command during boot up.  Lists the other maps used for establishing the autofs file system.

Direct Map: 
Lists mount points as absolute path names.  This map explicitly indicates the mount point on the client.  Only one Direct Map.  Must be created if desired, by default there is no direct map.

Indirect Map:
Lists the mount points as relative path names.  Uses a relative path to establish the mount point on the client.

· Set up automount to read a direct map 

In the /etc/auto_master file, make a direct map entry such as this which defines the direct map named /etc/auto_direct:

/-
auto_direct
· Describe when the automountd daemon should be restarted

1. When changes are made to the /etc/auto_master file

2. When additions/deletions are made to a direct  map


NAMING SERVICES OVERVIEW. 

· Describe the name service concept 

It centralizes the shared information in a network.  The name server provide information like host names & IP addresses, user names, passwords, etc.  Clients request this information from the name server.

· List the name services available 

Domain Name Service (DNS)

Network Information Service (NIS)

Network Information Service Plus (NIS+)

Federated Naming Service (FNS)

Lightweight Directory Access Protocol (LDAP) {not sure if this is only Solaris 8 or also Solaris 7?}

· Define DNS 

Used within a TCP/IP network to translate host names to their associated IP addresses.  Provides hostname-to-IP-address resolution as well as IP-address-to-hostname resolution.

· Describe NIS service 

Provides centralized lookup for LAN resources such as user accounts, host names & addresses, services, etc that would otherwise be needed on each host of the LAN.

· Describe the function of NIS+ 

Provides centralized lookup for LAN resources and also provides hierarchical naming structure, distributed administration, built-in security authentication & cross-domain lookups. 

· List the table objects of an NIS+ domain 

auto_home
auto_master
bootparams
client_info
cred

ethers

group

hosts

mail_aliases
netgroup
netmasks
networks

passwd

protocols
rpc

sendmailvars
services
timezone

· Explain the difference between authentication and authorization 

Authentication is a method to restrict access to specific users when accessing a remote system.

Authorization is a method to restrict the operations that a user can perform on the remote system once the user has gained access (been authenticated).

· Describe the name service switch process and determine which configuration is appropriate for your network

The name service switch file (/etc/nsswitch.conf) is used by the operating system for network information lookups, it determines which sources of information your system uses & the order in which those sources are used.

Template files are available with Solaris 7 to provide a standardized setup:

/etc/nsswitch.nis
Used for NIS

/etc/nsswitch.nisplus
Used for NIS+

/etc/nsswitch.files
Used for original UNIX /etc files configuration


NIS. 

· Describe the NIS components, master server, slave server, and client, and the NIS processes 

Master server stores the NIS maps and provides this information to requests from the NIS clients.  Can only have one NIS master.

Slave server is a replica of the NIS master and contain copies of the NIS maps, can configure one or more slave servers for redundancy and load sharing.

NIS client binds to the master (or slave) server to obtain access to the information contained in the server’s NIS maps.

NIS processes   -   

Two main processes are:


ypserv


runs on master & slave servers, answers ypbind requests & 

responds to client information requests.


ypbind


runs on all (master, slave and client systems), makes initial 

client-to-server requests, stores binding information, rebinds to

another server if connection lost to initial server, requests NIS map

information


Three daemons used on the NIS master:


rpc.yppasswdd
allows users to change their password, updates the /etc/passwd &





/etc/shadow files on the master, updates NIS password map, ‘pushes’





the NIS password map to slaves


ypxfrd


runs on master only, responds to slave requests to pull maps from 

master, transfers NIS maps at high speed


rpc.ypupdated

runs on  master only, updates the publickey map if secure RPC is

enabled
· Configure a NIS master, slave, and client 

MASTER

1. Copy /etc/nsswitch.files to /etc/nsswitch.conf.

2. Choose a NIS domain name, and execute the command:

domainname your.domainname

3. Create an /etc/defaultdomain file with the domain name in it.

domainname > /etc/defaultdomain

4. Add entries to the /etc/hosts for each slave server

5. Create the following files using the touch command:

/etc/ethers, /etc/bootparams, /etc/locale, /etc/timezone, /etc/netgroup & /etc/netmasks

6. Run the ypinit command to initialize the NIS master server & build the maps:

ypinit –m

7. When prompted, provide information on the NIS slave servers & answer n to exit on non-fatal errors.

8. Enable NIS by copying the /etc/nsswitch.nis file to /etc/nsswitch.conf
9. To start the NIS master server, either reboot or run /usr/lib/netsvc/yp/ypstart
10. Once ypbind is running, complete these steps to build the mail.aliases map:

cd /var/yp

/usr/ccs/bin/make


SLAVE
1. Configure the slave system as a client, run the domainname command to set the domain name (as seen in steps 2 & 3 above)

2. Enable NIS by copying the /etc/nsswitch.nis file to /etc/nsswitch.conf
3. Login as root & run:
ypinit –c
4. When prompted by the ypinit command for one or more NIS servers, enter the closest ones .

5. This completes the client setup.

6. Add an entry for the NIS master server to the /etc/hosts file

7. If the ypbind command is running, stop it by:  /usr/lib/netsvc/yp/ypstop
8. Restart the ypbind by:  /usr/lib/netsvc/yp/ypstart
9. Run the /var/yp/ypinit command using the hostname of the NIS master server for master:

cd /var/yp

ypinit –s master
10. To start the NIS slave server, either reboot or repeat steps 7 & 8.

CLIENT

1. Run the domainname command to set the domain name (as seen in steps 2 & 3 of the master configuration above)

2. Enable NIS by copying the /etc/nsswitch.nis file to /etc/nsswitch.conf
3. Login as root & run:
ypinit –c
4. When prompted by the ypinit command for one or more NIS servers, enter the closest ones.

· List the steps to add a new NIS map 

1. Create a text file in the /var/yp directory with the appropriate information.

2. Run the makedbm command to add the map, using the name of the source file and the name of the map as arguments:

cd /var/yp

makedbm apps.txt apps

3. Run the ypxfr command to distribute the new map onto the slave servers using the new map name as an argument:

/usr/lib/netsvc/yp/ypxfr apps

· Use commands to update and propagate an NIS map

1. Edit the source file (example:  /etc/hosts)

2. Execute the make command from the /var/yp directory using the name of the map being updated as an argument:

cd /var/yp

make hosts

3. The make command will update the map and automatically propagate the updated map

to slave servers.


SOLSTICE ADMINSUITE. 

· List capabilities of the Solstice AdminSuite 

Provides a GUI to automate administration of users, hosts, storage, database, serial ports, printers and groups.  The different managers can be run from the Solstice Launcher.  The Solstice Launcher is run by entering the command:  solstice
· Use Solstice AdminSuite to add a host using Host Manager 

· Use Solstice AdminSuite to view mount point and disk slice information using the Storage Manager 

· Use Solstice AdminSuite to view time zone information using the Database Manager 

· Use Solstice AdminSuite to view the characteristics of a serial port using the Serial Port Manager 

· Use Solstice AdminSuite to add a user using the User Manager 

· Use Solstice AdminSuite to add a user to a group using the Group Manager 

· Use Solstice AdminSuite to add a printer using the Printer Manager


ADDING NETWORK CLIENTS. 

· List the requirements a server must meet to support diskless and AutoClient network clients 

System must be networked and have adequate disk space.

It must have an /export file system with enough space to provide OS services that will be required by network clients.  Must also contain the /export/swap directory for network client swap space (typically 32MB per diskless client)

· Use solstice to add support for a network client 

1. Run Solstice Launcher by command:  solstice
2. Start Host Manager from the Solstice Launcher, Host Manager window displays.

3. Select Edit->Add to display the Add window

4. Type in Host Name, IP Address & Ethernet Address.

5. Select “Solaris Diskless”, “Solaris Dataless” or “Solstice AutoClient” from the Type pull-down menu.

6. Select the appropriate Region/Timezone from the pull-down menu

7. For Diskless:  define the path of the root file system & swap space for use by the client, and define the amount of swap space.  Set the root password.

For Dataless:  if system is not installed, can choose Enable Remote Install.

For AutoClient:  Define the root file system for use by the client and the amount of local

swap space.  Select the appropriate disk configuration from the Disk Config pull-down

menu.  If the system has only a single physical disk, this option is unavailable.  Select the

Enable Disconnectability option to allow the system to continue to operate from the cache if the OS server is unavailable.  Select the Enable Scripts option to setup custom scripts to run part of the boot process.  Set the root password.

8. Click Ok and the Add window closes

9. Select File->Save Changes

· List the steps necessary to create an OS server 

10. Run Solstice Launcher by command:  solstice
11. Start Host Manager from the Solstice Launcher, Host Manager window displays.

12. Select Edit->Add to display the Add window

13. Type in Host Name, IP Address & Ethernet Address.

14. Select “Solaris OS Server” for the System Type from the pull-down menu.

15. Select the time zone region from the pull down menu, then the Timezone.

16. If the system is not already installed, it can be setup for over-the-network installation by clicking the Enable Remote Install checkbox & providing the information on the Install Server, Set Path, OS Release, Boot Server & Profile Server.  Otherwise the operating system must already be installed.

17. Click OK and the Add window is closed.

18. Select File->Save Changes.  An entry for the OS Server is displayed with the list of currently defined systems.

Or you can use the admhostadd command to create an OS server:


Example:

admhostadd –I 192.114.21.6 –e 8:0:19:22:c:d7 –x type=OS_SERVER –x tz=US/Central host3

· Name at least three files in the /etc directory that the Host Manager edits when adding support for a network client

/etc/bootparams

/etc/dfs/dfstab

/etc/ethers/

/etc/hosts

/etc/timezone


JUMPSTART-AUTOMATIC INSTALLATION. 

· Briefly describe the JumpStart feature 

JumpStart is an automatic installation process which enables you to categorize machines on your network and automatically install systems based on the category (class) to which the machine belongs.

Two JumpStart methods are JumpStart and Custom JumpStart.

· List the main components for setting up a network to use automatic installation 

Three main components:

1. Boot & system identification services:  provided by a networked boot server that offers boot parameters & identification information to JumpStart clients.

2. Installation services:
provided by an install server that shares the Solaris Operating Environment installation software to the network for NFS mount by the JumpStart clients.

3. Configuration services:
provided by a configuration server that shares a directory of configuration files to the JumpStart clients.

· Set up the network to automatically provide the information necessary to configure a system 

In the absence of a name service, the sysidcfg file must be present to automate system identification.  You can use the sysidcfg file to answer system identification questions during the initial part of the installation.  The sysidcfg file uses keywords and arguments to provide configuration information.  The location of the sysidcfg file is specified by the –p option of the add_install_client command.

· Create an install server on the network 

1. Ensure the system has an empty directory (/export/install for example) with approx. 700MB of available disk space.

2. Insert the Solaris 7 Software CD-ROM into the CD-ROM drive.
3. Change the directory to the location of the setup_install_server script
(should be:  /cdrom/cdrom0/s0/Solaris_7/Tools)
4. Run the setup_install_server script, example:

./setup_install_server /export/install

· Create a boot server on a subnet 

5. Ensure the system has an empty directory (/export/install for example) with approx. 156MB of available disk space.

6. Insert the Solaris 7 Software CD-ROM into the CD-ROM drive.

7. Change the directory to the location of the setup_install_server script
(should be:  /cdrom/cdrom0/s0/Solaris_7/Tools)
8. Run the setup_install_server script, example:
./setup_install_server –b /export/install

· Create a configuration directory with a customized rules file and class files 

1. Select the system for JumpStart configuration and create a directory where the config files will be stored (/export/config for example).

2. Mount the Solaris 7 CD-ROM and copy the /cdrom/sol_7_sparc/s0/Solaris_7/Misc/jumpstart_sample directory to the /export/config directory.  This contains template config files you can customize.

3. Add an entry to the /etc/dfs/dfstab file to share the config directory, example

share –d “config directory” /export/config

4. Run /etc/nfs.server start command

5. Determine the different classes of machines on the network and reate the /export/config/rules file.

6. Determine what installation parameters to use for each class (category) of machines and create the /export/config/class file for each.

7. Create begin & finish scripts.

8. Run the check script in /export/config directory. The rules.ok file is created in the JumpStart config directory.

· Add install clients to install servers and boot servers 

The add_install_client command must be run from the install server’s Solaris installation image (the CD-ROM or CD-ROM image copied to disk) or the boot server’s boot directory.  Format is:

./add_install_client –e ethernet_addr –I ip_addr –s install_svr:/distr 

–c config_svr:/config_dir –p sysid_config_svr:/sysid_config_dir client_name client_arch

· Boot install clients 

On SPARC systems, at the ok prompt type:  boot net – install

ADMINISTRATION AND CONFIGURATION OF CDE. 

· Configure the CDE Login Manager 

The Login Server has 3 configuration files located in /usr/dt/config directory:

Xconfig
Xservers
Xaccess

To modify one of these configuration files, first copy the file to the /etc/dt/config directory and modify the /etc file copies.  When the Login Server is started, it checks first for the config files in the /etc/dt/config directory and (if not found) in the /usr/dt/config directory. 

The Login Screen has 1 configuration file located in /usr/dt/config/C directory:

Xresources

To modify this configuration file, first copy the file to the /etc/dt/config/C directory and modify the /etc file copies.  When the Login Server is started, it checks first for the config files in the /etc/dt/config/C directory and (if not found) in the /usr/dt/config/C directory. 

· Configure the CDE Session Manager 

Variables:

· Systemwide can be set by creating an executable script under /etc/dt/config/Xsession.d directory.

· User variables can be set by using the .dtprofile script under the user’s home directory.

Resources:

· Systemwide resources are added by modifying the /etc/dt/config/C/sys.resources file.

· Users can define display resources by using the .Xdefaults file under the user’s home directory.

Can also setup command execution at login by creating a /.dt/sessions/sessionetc  file under the user’s home directory.  Or commands to run on exit in the /.dt/sessions/sessionexit file under the users’s home directory.

· Configure environment variables with CDE files 

See notes above for Variables.

· Modify the Workspace Manager menus; including CDE 

WORKSPACE MANAGER

The Workspace Manager has three menus:

1. Front Panel

2. Workspace

3. Window

The notes below cover customizing/modifying the first two in this list.

To access the Window menu, place the cursor in the upper-left of a window and right mouse click.  This will provide functions for moving, closing & setting the size of the window.

· Workspace and Front Panel menus

CUSTOMIZE WORKSPACE MENU

Place the cursor on the workspace background and right mouse click.

The Workspace menu is displayed.

From this menu you can customize or add menu items.

When completed Restart Workspace Manager to accept changes.

CUSTOMIZE FRONT PANEL

To create a customized systemwide Object for the Front Panel

Create a file with the desired configuration Object and Keywords.

Save the file as /etc/dt/appconfig/types/C/object_name.fp   

Then Restart Workspace Manager

Or

To create a customized systemwide Front Panel 

Copy the /usr/dt/appconfig/types/C/dtwm.fp file to /etc/ dt/appconfig/types/C/dtwm.fp

Make modifications and then Restart Workspace Manager

For only an individual user rather than systemwide, do the exact same except place the customized file in $HOME/.dt/types

Then Restart Workspace Manager

Note:   The user’s customized config file will override the systemwide customized config file.  The systemwide config file will override the default config files.
