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1.  CREATING TABLE:

Syntax:-


CREATE TABLE TableName

                      (columnname   datatype(size),



columnname   datatype(size),-------);

Basic elements of this command:-

· The word CREATE TABLE

· The name of the table i.e. TableName

· An opening parenthesis

· Column definations

· A closing parenthesis

· A SQL  terminator(;)

The table& column names must start with a letter of the alphabet but may include letters, numbers& underscores.


Names may be 1 to 30 characters in length & must be unique within the table &cannot be an ORACLE reserve word.

e.g--

SQL>  create table stud1

(rno number(3),

name varchar(20) not null,

total number(3) check (total between 0 and 500) ,

per number(6,2),

sno number(3));

Table created.




             This creates the table named student with the fields (rno, name, total, per).

2. INSERTING DATA INTO TABLE
                  To place a row of information directly into a table use insert sql command.

Syntax:-

 
Insert into tablename(columnname,columnname)

                       values (expression,expression);

 e.g.:-

      SQL>insert into staff1 values (1,'stp','prof',10000);

              1 row created.

Or

      SQL>insert into staff1 (sno,name,total,per)  values (2,’abc’,’lect.’,5000);


 1 row created.


The word values must precede the list of data to be inserted.


While inserting data, character string must be enclosed in single quotation marks

and the fields must be in the same order as the columns are in the table.

SQL> insert into staff1 values (&sno,'&name','&post',&sal);

Enter value for sno: 2

Enter value for name: abc

Enter value for post: lect

Enter value for sal: 5000

old   1: insert into staff1 values(&sno,'&name','&post',&sal)

new   1: insert into staff1 values(2,'abc','lect',5000)

1 row created.

SQL> /

Enter value for sno: 3

Enter value for name: xyz

Enter value for post: hod

Enter value for sal: 15000

old   1: insert into staff1 values(&sno,'&name','&post',&sal)

new   1: insert into staff1 values(3,'xyz','hod',15000)

1 row created.


When you want to repeat the command , use ‘/ ‘ as shown in above example.

            Here ‘&’ is used to read the values from keyboard.

3.   DELETING RECORDS


Delete SQL command is used to remove rows from the table.

Syntax:-


Delete from student;

It deletes all the records in student table.


To remove particular records from table following syntax is used.

Syntax:-



Delete from tablename where condition;

e.g


SQL>delete from student where rno=2;

            1 row deleted.


It deletes record of student whose roll number is 2 from student table.


Delete allows you to commit or rollback the deletion.


There is an additional command for deleting records truncate.

            Truncate automatically deletes all records from the table. The truncate translation cannot be rolled back or committed.

4.   UPDATING RECORDS


The update command is used to change the data values in a table. You can use calculations, string function in setting a value for the update.

· Updating all the rows:-

Syntax:-


Update tablename 



Set columnname=expression, columnname=expression;

E,g.-

        Increase the salary of each employee by 100 in emp table.

SQL> update emp set sal=sal+100;

12 rows updated.

· Updating particular records:-

Syntax:-



Update tablename 




Set columnname=expression,columnname=expression




      Where columnname=expression;

E.g:-

SQL> select * from emp where empno=7654;

  EMPNO ENAME      JOB           MGR   HIREDATE   SAL      COMM    DEPTNO

--------- ---------- --------- --------- ---------  --------- --------- ---------

       7654 MARTIN  SALESMAN  7698  28-SEP-81      1350          1400        30

SQL> update emp set sal=sal+100 where empno=7654;

1 row updated.

e.g :-


Update the name of the employee name to Bill & salary to 4500 whose employee number is 7700.

SQL> update emp1 set name = 'Bill', salary=4500 where eno=7700;

1 row updated.

5.   DESTROYING TABLES

Syntax: -


Drop table tablename;

E.g.:-

        Drop the table emp1.

 SQL>drop table emp1;



Truncate command lets you to remove all the rows in the table & reclaim the space for other uses without removing the table definition from the database.

E.g.:-


SQL>truncate table emp1;

6.   DESCRIBE COMMAND

Syntax: -

Desc[ribe] tablename;


Thus command displays column names, data type & the special attribute connected to the table.

E.g.:-

SQL> desc emp1;

 Name                                Null?    Type

 ------------------------------- -------- ----

 NAME                                               VARCHAR2(15)

 SALARY                                           NUMBER(7,2)

 BDATE                                             DATE

 ENO                                                  NUMBER(4)

7.   RENAMING TABLES

Syntax:-


Rename old_tablename to newtablename;

E.g


SQL>rename emp to emp1;

                     table renamed

8.   SELECTING RECORDS


The ‘select’command is used to view data in the table.

· Selecting all rows & all columns :-

E.g:-


Select data from student table.

SQL> select rno,name,total,per,sno from stud1;

   RNO     NAME                     TOTAL   PER        SNO

--------- -------------------- --------- --------- ---------

          1   aaa                          400         80           2

          2   bbb                          350         70           1

          3   ccc                          275         55           3

3 rows selected.


We can use *(asterik) to view data from all rows & columns from table.

Syntax:-



Select * from tablename;

9.   ALTERING TABLES
SQL> alter table emp1 add (bdate date);

Table altered.

SQL> alter table emp1 modify(name varchar2(15));

Table altered.

Using  DISTINCT keyword:

SQL> select distinct job from emp;

JOB

---------

ANALYST

CLERK

G.M.

MANAGER

4 rows selected.

SQL> select distinct job from emp where deptno=30;

JOB

---------

MANAGER

SALESMAN

The AND Operator:-


SQL> select empno,ename,job,sal,deptno from emp where sal>1000 and sal<3000;

 EMPNO ENAME      JOB             SAL    DEPTNO

--------- ---------- ---------   --------- ---------

      7499  ALLEN      SALESMAN       1600        30

      7521  WARD       SALESMAN       1250        30

      7566  JONES       MANAGER        2975        20

      7654  MARTIN    SALESMAN       1250        30

 4 rows selected.

The OR Operator:-

SQL> select empno,ename,job,sal,deptno from emp where job='PRESIDENT'  or  job='ANALYST';

    EMPNO ENAME      JOB             SAL    DEPTNO

--------- ---------- --------- --------- ---------

        7788  SCOTT      ANALYST       3000        20

        7839  KING        PRESIDENT        10        10

        7902  FORD        ANALYST       3000        20

The NOT Operator:-

SQL>  select empno,ename,job,sal,deptno from emp where  not(job='SALESMAN');

    EMPNO ENAME      JOB             SAL    DEPTNO

--------- ---------- ---------   --------- ---------

        7369 SMITH       CLERK                800        20

        7566 JONES       MANAGER        2975        20

2 rows selected.

IN:-

SQL>  select rno,name,total from stud1 where rno in(1,3,);

      RNO NAME                 TOTAL

--------- -------------------- ---------

           1  aaa                         400

           3  ccc                         275

BETWEEN:-

SQL> select name,per from stud1 where total between 250 and 400;

NAME                  PER

-------------------- ---------

aaa                              80

bbb                              70

LIKE:-

SQL>  select rno,name,total from stud1 where name like '%a';

     RNO NAME                  TOTAL

--------- -------------------- -------- 

           1 aaa                           400

ORDER BY:-

SQL>  select * from stud1 order by total;

    RNO NAME                   TOTAL  PER       SNO

--------- -------------------- --------- --------- ---------

          5 tttt                             220        44         2

          6 hhhhhhh                    222     44.4         2

          3 ccc                             275        55         3

3 rows selected.

SQL> select * from stud1 order by 3;

It displays the same result as above.

GROUP BY:-

SQL> select job ,count(*) from emp group by job ;

JOB             COUNT(*)

---------   ---------

ANALYST               2

CLERK                     2

G.M.                         1

3 rows selected.

HAVING CLAUSE:-

SQL> select deptno ,count(*) from emp group by deptno having deptno=10 or deptno=20;

   DEPTNO  COUNT(*)

   ---------  ---------

            10           3

20 5

It will display the no. of employees in Dept 10 , i.e., here it is 3 empl. And no. of employees in Dept 20 , which is 5. 

10.   SUB-QUERIES

SQL> select * from emp where job=(select job from emp where ename='SCOTT');

   EMPNO ENAME      JOB             MGR HIREDATE        SAL      COMM    DEPTNO

--------- ---------- --------- --------- --------- --------- --------- ---------

        7788  SCOTT      ANALYST      7566  19-APR-87       3100                          20

        7902  FORD        ANALYST      7566   03-DEC-81      3100                          20

11.   NESTED SUBQUERY:

SQL> select ename from emp where sal=(select max(sal) from emp);

ENAME

----------

KING

SQL>  select * from emp where sal=(select max(sal) from emp where sal<(select max(sal) from emp));

    EMPNO ENAME      JOB        MGR HIREDATE   SAL  COMM    DEPTNO

--------- ---------- --------- --------- --------- --------- --------- ---------

       7788 SCOTT      ANALYST  7566 19-APR-87     3100                  20

       7902 FORD       ANALYST   7566 03-DEC-81     3100                  20





12.   USING EDITOR

SQL is a single sentence language , the sentence once typed at the SQL> prompt cannot be corrected in case any mistake is discovered after you press enter (i.e., execute the sentence)     Hence we create an ASCII file , to place the SQL sentences in the ASCII file and avoid the repetitive typing in case of consequtive executions and when these sentences from the file created are to be executed  we can execute it with the --

SQL>run<filename>    OR

SQL>@<filename>   

SQL> ed first

declare

vname stud1.name%type;

begin

select name into vname from stud1 where rno=4;

dbms_output.put_line('Name = ' || vname);

end;

/

SQL> @first

Name = ffff

PL/SQL procedure successfully completed.

SQL>  ed studdisp;

declare

rn number(3);

vname stud1.name%type;

vtotal stud1.total%type;

vper stud1.per%type;

begin

rn:=&rollno;

select name,total,per  into vname,vtotal,vper from stud1 where rno=rn;

dbms_output.put_line('Name = ' || vname);

dbms_output.put_line('Total = ' ||vtotal);

dbms_output.put_line('Percntage = ' || vper);

end;

/

SQL> @studdisp;

Enter value for rollno: 2

old   7: rn:=&rollno;

new   7: rn:=2;

Name = bbb

Total = 350

Percntage = 70

PL/SQL procedure successfully completed.

SQL> ed studmod;

declare

rn number(3);

vtotal stud1.total%type;

vper stud1.per%type;

begin

rn:=&rollno;

select total,per  into vtotal,vper from stud1 where rno=rn;

if (vper>=44) and (vper<45) then

    update stud1 set per=45.0 where rno=rn;

end if;

end;

/

SQL> @studmod;

Enter value for rollno: 5

old   6: rn:=&rollno;

new   6: rn:=5;

PL/SQL procedure successfully completed.

      RNO NAME                     TOTAL       PER       SNO

--------- -------------------- --------- --------- ---------

         5 tttt                       220        44         2

SQL> select * from stud1 where rno=5;

      RNO NAME                     TOTAL       PER       SNO

--------- -------------------- --------- --------- ---------

        5 tttt                       220        45         2

13.   CURSORS

PL/SQL provides cursor which are blocks of memory created every time a query is executed from within the script. The advantage of cursor is that when a query fetches multiple records in the blocks , Cursors allow you to access and manipulate individual record , which otherwise is not possible with normal SQL queries.

Types:-

Implicit Cursor : These cursors are defined , named and managed by PL/SQL itself.

Explicit Cursor :  These cursors are defined , named and managed by explicit declaration within the Script.

SQL> ed studcur1;

declare

cursor disp is

    select name,per from stud1 where sno=2;

vname stud1.name%type;

vper stud1.per%type;

begin

open disp;

loop

   fetch disp into vname,vper;

   exit when disp%notfound;

   dbms_output.put_line('Name = ' || vname);

   dbms_output.put_line('Percntage = ' || vper);

end loop;

close disp;

end;

/

SQL> @studcur1;

Name = aaa

Percntage = 80

Name = ffff

Percntage = 78

Name = tttt

Percntage = 44

Name = hhhhhhh

Percntage = 44.4

PL/SQL procedure successfully completed.

Passing parameter to cursor:

SQL> ed cur_par;

declare

vsno stud1.sno%type;

cursor disp(vs stud1.sno%type) is

    select name,per from stud1 where sno=vs;

vname stud1.name%type;

vper stud1.per%type;

begin

vsno:=&sno;

open disp(vsno);

loop

   fetch disp into vname,vper;

   exit when disp%notfound;

   dbms_output.put_line('Name = ' || vname);

   dbms_output.put_line('Percntage = ' || vper);

end loop;

close disp;

end;

/

SQL> @cur_par;

Enter value for sno: 1

old  12: vsno:=&sno;

new  12: vsno:=1;

Name = bbb

Percntage = 70

PL/SQL procedure successfully completed.

Cursor: using for loop

SQL>  ed studcur2;

declare

cursor disp is

    select name,per from stud1 where sno=2;

begin

for irec in disp

loop

   dbms_output.put_line('Name = ' || irec.name);

   dbms_output.put_line('Percntage = ' || irec.per);

end loop;

end;

/

SQL>  @studcur2;

Name = aaa

Percntage = 80

Name = ffff

Percntage = 78

Name = tttt

Percntage = 44

Name = hhhhhhh

Percntage = 44.4

PL/SQL procedure successfully completed.

       



14. FUNCTIONS
A Procedure or Function is  a logically grouped set of SQL and PL/SQL statements that perform a specific task. A stored procedure or function is a named PL/SQL code block that have been compiled and stored in one of the Oracle engine’s system tables.

By writing procedures and functions redundant coding can be avoided increasing productivity.

A Function must return a value back to the caller. A Function can return only one value to the calling PL/SQL code block.

Functions-----

Create or replace function xyz(y number) return number as 

Begin

Return y*y;

end;

/

sql>@p1

this will give you a PL/SQL block named p1 , where we can write

declare

x number(4);

begin

x:=xyz(10);

insert into test values(x,”after function xyz’);

sql> select * from test;

will give the output as –

srno              remark
100            after function xyz

create or replace function xyz(y number) return Boolean as 

begin

if y>4000 then

return TRUE;

else 

return FALSE;

end if;

end;

/

sql> @p1 

The code in P1 goes as follows –

Declare

X number(4);

Begin

Select sal into x from emp where ename=’RAM’;

If xyz(x) then

Insert into test val(x , ‘greater than 4000’);

Else

Insert into test val(x,’lesser /equal to 4000’);

End if;

End;

/

sql> select * from test;

srno                  remark

100 greater than 4000

15. TRIGGER
A Trigger is event-oriented Program whenever the event occurs the Trigger gets fired automatically related to that particular event . 

Types—

Database Triggers—

These are database objects created via the SQL PLUS tool on the Client and stored on the Server in the Oracle Engine System Table. These database objects consist of following distinct sections 

---- A named database event

---- A PL/SQL Block that will execute when the event occurs

a)-Statement Level Trigger—

It is fired once on behalf of the Triggering Statement independent of the number of rows the triggering statement affects

b)-Row Level Trigger –

It is fired each time a row in the table is affected by the triggering statement

c)-Block Level Trigger  --

It is fired each time a block of statements is affected.

Syntax—

create or replace trigger<trigger name>

{  before, after }

{delete , insert , update [of  column,….. ]}

on  <tablename>

[referencing {old as old, new as new }]

[for each row [ when condition ] ]

declare

     variable declarations ;

     constant declarations ;

begin

PL/SQL sub program body;

Exception

      exception PL/SQL block ;

End;

Selecting  SQL  PLUS  3.3 through Oracle & Developer2000 and Oracle for Windows 95
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Selecting Forms Designer through Developer 2000
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Getting logged on to SQL PLUS by giving username=scott and password=tiger
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The first Screen of SQL PLUS after getting logged on
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Example of Data Entry Block from Developer 2000
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DEVELOPER 2000

Building a new form:

1. Name the Form Module

Double-click on the Designer icon to open the Designer.

Oracle Forms opens the Navigator with a default form called MODULE1, with the name selected.  

· Connect to the Database

· Select File->Connect to connect to the Oracle7 Server.

Oracle Forms displays the Connect dialog.

Fill in the username, password, and database name.

Click Connect.

     3.           Create a Base Table Block
· Select Tools->New Block.

The Designer displays the  New Block window.  The New Block window is a tab-style display, with related fields grouped under four tabs:  General, Items, Layout, and Master/Detail.  As you use this window to create a new block,  you'll fill in items under all the appropriate tabs before clicking OK to accept the settings.

· Click on the Items tab, and do following steps:

a.  Click the Select Columns button.


b.  Click on the ORDER_FILLED column name (last item).


c.  Click on the "Type" list to show the choices.


d.  Click to select Display Item.


· Click on the Layout tab, and set the following options:

Style:
Form (Change from the default, Tabular.)

Orientation:
Vertical (Default.)

Records:
1 (Default.)

Spacing:
10 (Default for Form style.)

4.        Examine the Item Properties


In the Navigator, under Blocks¾ORD_BLK, click on the Items node to expand it. 

Notice that the Text Item icon precedes all the items except for  ORDER_FILLED, which shows the Display Item icon.

·        Examine the Layout

· Select Tools->Layout Editor.

Oracle Forms opens the Layout Editor, displaying ORD_BLK.  

If your layout shows all the items horizontally in a single row, creating a long and narrow form, you may have specified Style as Tabular instead of Form. 

· Save and Run the Form

· Select File->Save to save the ORDERS form to a file.

The status line currently shows Mod:ORDERS File:orders.

Oracle Forms displays the Save As dialog, showing a default name of orders.fmb. 

The file will be saved in the directory displayed, so check the directory, and change if necessary.

Click OK to accept the default name and save the form.

Oracle Forms displays the message: Module saved successfully.

· Select File->Run.

Oracle Forms displays the message: Module generated successfully.

7. Test the Form

· Select Query->Execute.

Press the Down arrow key to move through as many of the database records as you want to see.

· Select Action->Exit to leave the form.

EXERCISES –
1. Create table Client_master with following structure –

Name           Type 
                 Size

Client_No    Primary Key
     Varchar2(6)

Name
   Not null
     Varchar2(20)

Address        

      Varchar2(30)



City
                 
      Varchar2(15)
  

      State
  

      Varchar2(15)

      PinCode       Not null
       Number(6)

      Balancedue  
                   Number(10,2)

2. Insert records in the above Table

3. Write a query to display all the records in the table Client_master

4. Display the record of the Client whose balance due is greater than 0 and less than 3000

5. Update records in table  Client_master set city= Kolhapur for all the Clients

6. Update balancedue=5000 of the Client whose Client_No=4

7. Delete the record of Client whose Name is Ram

8. Display the records of all the Clients living in City Kolhapur or Pune or Bombay.

      Using ‘IN’ Operator or without using ‘IN’ Operator

9. Display the structure of above Table using ‘Describe’ command.

10. Destroy table Client_master along with the data contained in it.

11. Change the city of Client_No=7 to Bombay.

12. Write a  Cursor to update salary of employees= sal + 1 in department no 10 and display the updated records.

13. Write a function which returns a Boolean if value of y=4000 or  greater than 4000 

      it returns true else false.

