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How to start?

Switch on the computer and login.

Go to DOS prompt: Start->Programs->MS-DOS Prompt

If not already on Z: drive, type ‘Z:’ at the prompt and then type ‘bc’ and press ENTER.

Z:\>bc<ENTER>

Borland C++’s IDE(Integrated Development Environment) will open. It may look something like this if no other file is previously opened.

At the top is a menu-bar providing you different menus to help carry out all the tasks in the program development process.

At the bottom is the status bar the contents of which change accordingly as we move at different components of IDE. It is a sort of online help.

Pressing Alt-key and any of the hotkeys (letters in red color e.g. F in File, E in Edit) will activate that menu.

From File menu select New. A new window will open. Write your source code in this window.

About the Borland’s IDE:


The Integrated Development Environment (IDE) is an editor, compiler, linker, project manager, and debugger all in one. In it, you can create, compile, and debug almost all your DOS and Windows applications without ever leaving the IDE. This greatly speeds up your application development, especially during the debugging  (removing logical error) stage, when you are constantly testing, modifying, and recompiling your source code. 

BC++ also include help application, called THELP, which provides access to the IDE’s help files if you choose to use an external text editor. This and many other facilities are integrated into it.

The IDE centers around a fully functional text editor. The text editor in the IDE goes beyond merely allowing you to enter text. You can select a block of text (code) by holding SHIFT key and pressing ARROW keys and perform cut, copy, and paste operations.

Different Windows of IDE:

There are different windows for the IDE. Each window will be having a double border, a number and a title designating the window. You can switch between these windows by pressing F6 key successively or 

Edit Window:

This window is where you write your source code. Whenever you open any source file it is opened in the Edit Window. As you can have more than one file opened, there can be more than one Edit Windows opened but only the active window can be edited.

Message Window:

This window reports the status of compilation and linkage mechanism. Also it reports all the errors in the code and warnings along with the line numbers and source.

Clipboard Window:

This window contains the block of text on which Cut and Copy operations are performed.

Output Window:

This window displays the output of your program and it is not visible within IDE. It cannot be switched using F6 Key; instead you have to use Alt-F5 key combination. Pressing any key will return to the IDE. This window will be blank if the last compilation has graphics output.

Project Window:

In this window all the files included in the current project are listed. Its title indicates the current project.

Writing the C/C++ Program:


Start the BC, create a new file. You will be presented with an empty window. You have to type-in your program’s source code into it. 


To start with there must be only one main() function in the program as the execution starts from main() function and any number of other user-defined functions(not compulsory). 


In this main() function you may use any of the standard C/C++ library function. So you need to specify which of those functions you are going to use in your program. For that, you have to include appropriate header file in your source code.

e.g. hello.c : C Program to display “Hello, World” String

#include <stdio.h>

#include <conio.h>

void main()

{


printf(“\nHello, World”);


getch();

}


In the above program, two header files are included namely: stdio.h and conio.h. stdio.h file contains all standard input output related functions and conio.h file contains all the console(interfacing devices - screen and keyboard) related functions.


In our program we have used two standard C library functions: printf() declared in stdio.h and getch() declared in conio.h.


Remember this file contains C source code. So, you should save this file with .c extension; otherwise, you may get an error. Although, Borland compilers will not report any error. The program will run smoothly. But, if the same program is written in C++ and extension is not .cpp, then the compiler will definitely report an error.


Imp: When any of the library function is used, you have to include appropriate header file. Otherwise, you will get an error from the compiler: “…function not found”.

Compiling and Linking the Program:


After typing in the source code, you need to compile and link the program. The compiler will check for any syntactical (grammatical) errors in the code. If not found, it creates an intermediate file called object file with the same name as filename and extension .obj. The object file(s) obtained are then linked with other object file(s) provided with the library by the linker and executable file with .exe extension is created. This executable file can now be run directly on DOS prompt. Following diagram summarizes the above discussion:

To compile the program choose Compile->Compile or simply press Alt-F9. 

For linking the program with the Standard C Library, choose Compile->Link. 

Now, you can execute your program and see the output. To do so, choose Run->Run or press Ctrl-F9. It will perform all the three tasks: compiling, linking and running in one shot.

Setting Directory Paths for IDE:


When you try to compile the program, compiler may report an error: “Unable to open include file ‘….h’” or “Cannot find ‘….lib’ file”. The only thing is you have specify where the include (header) files and library (.obj and .lib) files can be located. To set this directory paths:


Select Options->Directories… option. It has four directories to be specified:

Include Directories:

Specify the path where the header files are stored. Multiple paths, if any, are separated by semi-colon(;) 

Library Directories:

Specify the path where library and startup files can be found. Again, if these files are dispersed into various directory paths or different subdirectories, specify all the directories separated by semi-colon.

Output Directory:

All the intermediate files and output files(executables) will go into this path.

Source Directories:

Specify where from the source files have to be fetched or where to be stored by default.

If you do not know where these files are stored on the network, give the ‘map’ command at the prompt. This will list out all the drives on the network specifying the different packs such as DOSPACK, WINPACK, etc. From this you can make out, where the include files and library files are located.

If, still you are unable to locate the required files, consult the Lab Assistant.

Problem with Graphics!


Sometimes you may not be able to run graphics on a system. That may be because, you may not have configured the IDE to include or support graphics library. You can enable the Graphics Library from


Options->Linker->Libraries…


Using arrow keys move to “[ ] Graphics Library” option and press SPACE-BAR to select it. The cross will appear in the brackets.


You have to include graphics.h header file in your source file.

Another problem with graphics is 

BGI Error: Graphics not initialized (use ‘initgraph’)


You might have used initgraph() function. Actually this is not the problem with initgraph or the graphics library. Firstly, you may not have specified the correct path to .BGI files. Secondly, while giving the path in double-quotes you have to put double-slash twice as shown below. Otherwise, the compiler will treat it as an escape sequence.


e.g.


int gd=DETECT,gm;

initgraph(&gd,&gm,”q:\\winpack\\bc31\\bgi”);

Projects:


There are many advantages to using a project.

It keeps a list of file dependencies for you and is much easier to use than manually recompiling changed files using the MAKE utility.

It keeps one set of compiler options for one project from affecting an application compiled with different set of compiler options. 

Each project file contains information on the compiler option settings.

Each project file also has an associated desktop file. This file keeps track of the screen layout and cursor location for the editor windows

Select Options->Environment->Preferences->Desktop menu item. Now each time you load a project, the screen will be laid out exactly as you left it last time to the correct location of the cursor.

Project Manager takes care of many things like controlling the project (fatal errors, warnings, etc;), checking auto-dependencies, linking default libraries appropriate to the compiler settings, etc.

Also you can keep list of Project Notes. Select Windows->Project Notes. 

This is the good place to keep notes on revision history, bug reports, or other information related to the project. The contents of Project Notes Window are automatically saved with the project file.

Creating a Project:

To create a new project you have to go through following steps:

From Project menu select Open project…; ‘Open Project File’ dialog box will appear.

In Open Project File text-area type-in the new project’s name and press ENTER. A new project will be created and an empty Project Window will appear.

Next step is to add source files to the project. You can create new source files, if not existing, and add to the project as follows:

From Project menu select Add item…; ‘Add to Project List’ dialog box will appear. 

In that you can directly enter the filename into Name Box or choose from the Files List and either press ENTER or click on Add Button. The selected file will be added to the current project. Similarly add all the required files.

Click on Done Button. The dialog box will close and you will be brought to the Project Window.

Now you can see the list of files belonging to the project in the Project Window. You can scroll through all the files using arrow keys. When you press ENTER key, that file will be opened into the Edit Window. 

Menu Options Provided by IDE:

File Menu:

New : Create a new file in a new Edit Window

Open… : Locate and open an existing file

Save : Save the file in a active Edit Window 

Save as… : Save a file in active window under new name

Save all : Saves all modified files

Change dir… :  Change the current working directory

Print : Print the contents of active window

DOS shell : Temporary exit to DOS 

Quit : Quits the IDE

Edit Menu:

Undo : Undo the previous editor action

Redo : Redo the previously undone action

Cut : Remove the selected text and put it in the clipboard

Copy : Copy the selected text and put it in the clipboard

Paste : Insert selected text from clipboard at the cursor position

Clear : Delete the selected text

Copy example : Copy program example from Help Window into the clipboard

Show clipboard : Open the Clipboard Window and display its contents.

Search Menu:

Find… : Search for the text in the source code

Find and replace : Search for the text and replace it with new text

Search again : Repeat the last Find or Repalce operation

Go to line number… : Move the cursor to a specific line number

Previous error : Move the cursor to the position of  the previous message

Next error : Move the cursor to the position of  the next message

Locate function… : Search for a function declaration while debugging

Run Menu:

Compile Menu:

Debug Menu:

Project Menu:

Options Menu:

Window Menu:

Help Menu:

LIBRARY FUNCTION



The C language is accompanied by a number of library function that carry out various commonly used operations and calculation.  These library functions are not part of the language.  Such functions are standardized in header files by ANSI committee.



The header files that are included in this Appendix are :-

<ctype.h>

Character testing and conversion functions.

<math.h>

Mathematical functions.

<stdio.h>

Standard I/O library functions.

<stdlib.h>

Utility functions such as string conversion routines, memory 




allocation routines, random number generator, etc.

<string.h>

String manipulation functions.

<time.h>

Time manipulation functions.

Note:   The following function parameters are used :

c- character type argument 

d- double precision argument 

f -   file argument 

i-  integer argument

l-  long integer argument

p- pointer argument 

s- string argument

u-  unsigned integer argument.

                An asterisk ‘* ‘ denotes a pointer.

Function 

Data type 

Task




Returned 

<math.h>

ascos( d)

double


Return the arc cosine of d

asin( d)

double 


Return the arc sine of d

atan(d)


double


Return the arc tangent of d

atan2(d1,d2)

double 


Return the arc tangent of d1/d2

ceil(d)


double 


Return a value rounded up to the next higher 







integer.

cos(d)


double


Return the cosine of d.

cosh(d)


double 


Return the hyperbolic cosine of d.

exp(d)


double


Raise e to the power d.

fabs(d)


double 


Return the absolute value of d

floor(d)

double 


Return a value rounded down to the next 







lower integer.

fmod(d1,d2)

double 


Return the remainder of d1/d2 (with same   







Sign as d1).

labs(1) 

long int 

Return the absolute value of 1.

log10(d)

double 


Return the logarithm (base10) of d.

pow(d1,d2)

double 


Return d1 raised to the d2 power

sin(d)


double 


Return the sine do d

sinh(d)


double


Return the hyperbolic sine of d.

sqrt(d)


double 


Return the  square  root of d.

tan(d)


double 


Return the tangent of d.

<stdio.h>

fclose(f)

int 


Close  file f.  Return 0 if file is successfully 







closed.

feof(f)


int 


Determine if an end-of-file condition has 







been reached.  If so, return a nonzero value;







otherwise, return 0.

fgetc(f)


int 


Enter a single character form file f.

fgets(s, i, f)

char*


Enter a single character form file f.

fopen (s1,s2)

file*


Open a file named s1 of type s2.  Return a 







pointer to the file.

fprintf(f,…)

int 


Send data items to file f.

fputc(c,f)

int 


Send a single character to file f.

fputs(s,f)

int


Send a single s to file f.

fread(s, i1, i2, f)
int 


Enter i2 data items, each of size i1 bytes,







from file f to string s.

fscanf(f,…)

int 


Enter data items from file f.

fseek(f,l,1)

int 


Move the pointer for file f a distance 1 bytes 







from location i.

ftell(f)


long int 

Return the current pointer position within 







file f.

fwrite(s,i1,i2)

int 


Send i2 data items, each of sixe i1 bytes 







from string s to file f.

getc(f)


int 


Enter a single character from file f.

getchar(void)

int 


Enter
a single character from the standard 







input device.

gets(s)


char*


Enter string s from the standard input 







device.

puts(s)


int 


Send string s to the standard output device.

printf(…)

int 


Send  data items to the standard output dev.

putc(c,f)

int 


Send a single character to file f.

putchar( c)

int 


Send a single character to the standard 







output device.

rewind(f)

void 


Move the  pointer to the beginning of file f.

scanf(…)

int 


Enter data items from the standard input dev

<stdlib.h>

absi(s)


int 


Return the absolute value of I

atof(s)


double 


Convert string s to a double precision qty.

atoi(s)


int 


Convert string s to an integer.

atol(s)


long 


Convert string s to a long integer.

calloc(u1, u2)

void*


Allocate memory for an array having u1







elements, each of length u2 bytes.  Return a 







pointer to the beginning of the allocated 







space.

exit(u)


void 


Close all files and buffers, and terminate the 







program.( Value of u is assigned by the 







function, to indicate termination status.)

malloc(u)

void*


Allocate au bytes of memory.  Return a







pointer to the beginning of the allocated 







space.

free(p)
`

void 


Free a block of allocated memory whose







beginning is indicated by p.

rand(void)

int 


Return a random positive integer.

Realloc(p,u)

void*


Allocate u bytes of new memory to the 







Pointer variable p.  Return a pointer to the








Beginning of the new memory space.

srand(u)

void


Initialize the random number generator.

system(s)

int 


Pass command string s to the operating 







system.  Return 0 if the command is 








successfully executed; otherwise, return a 







nonzero value rypically –1.

<string.h>

strcmp(s1,s2)

int 


Compare two strings lexicographically.







Return a negative value if s1<s2; 0 if s1







And s2 are identical; and a positive value







If s1>s2.

strcmpi(s1,s2)
int 


Compare two strings lexicographically, 







Without regard to case. Return a negativ







Value if s1<s2; 0 if s1 and s2 are ident-







cal ; and a value if s1>s2.

strcpy (s1, s2)  
char*


Copy string s2 to string s1.

strlen(s)

int 


Return the number of char.s in string s.

strset(s,c)

char* 


Set all characters within s to c(excluding







the terminating null character \0).

<time.h>
difftime(11, 12)
double 


Return the time difference 11-12, where







11 and 12 represent elapsed times beyond 







a designated base time (see the time fun.)

time(p)


long int 

Return the number of seconds elapsed 







beyond a designated base time.

EXERCISE QUESTIONS
Write the C programs for following:

1. To arrange the given numbers(+ve & -ve) in ascending and descending order.

2. To find out the sum of given ‘N’ numbers.

3. To find out the sum of the digits in given number.

4. Reverse the given string.

5. Square of numbers upto N number.

6. To check even or odd number.

7. To write the program for use of switch statement.

8. To find out largest and smallest of N numbers

9. To get the multiplication, addition of two matrices.

10. To find out the factorial of a given number.

11. To generate fibonacci series.

12. To find out the first 100 prime numbers.

13. To perform multiplication of two matrices and to display the product.

14. To draw a line, circle, arc, ellipse, rectangle using graphic commands and to move these figures on the screen.

15. To write a function subprogram in C to calculate sin(x)/cos(x) using series expansion.

16. To find out roots of a polynomial using Newton Raphson method.

17. To find out roots of a given quadratic equation.

18. To integrate a given function using trapezoidal and Simpson’s rule.

19. To find roots of an algebraic equation using Bisection/ Successive approximation method.

20. To solve three simultaneous equations using Gauss elimination method.

