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If you need to create a large, commercial Web site that includes robust features like eCommerce or 
customer support tools, Publisher is probably not the right tool for you. There are other programs, such as 
Microsoft FrontPage or Macromedia Dreamweaver, that will give you better results. However, for creating a 
small or medium-size business Web sites, Publisher can serve quite effectively, allowing you to create Web 
pages and sites -- or convert standard Publisher publications, such as newsletters and brochures, into Web 
documents.  

Publisher can do the following: 

• Convert an existing print publication to Web format.  

• Create a three-page Web site with sample content on each page and link the Web pages using a 
navigation bar. You can then manually add or remove pages and customize the navigation bar.  

• Create an entire Web site with the pages you specify, including multiple levels of organization, 
through the Easy Web Site Builder.  

In this lesson, you'll learn about all these methods. This lesson is more jam-packed with information than 
some of the previous ones in this course, so you only go through simple examples and no complex ones. 
You're provided with the facts and can try them on your own.  

Convert a print publication to Web format

One way to create a Web page (or multiple Web pages that work together as a Web site) is to convert an 
existing publication to Web format. If the existing publication has multiple pages, Publisher will create a 
separate Web page for each page. 

To convert a publication to Web format, open it in Publisher and select File > Convert to Web Publication.
Try it with any single-page publication you have on-hand, or create a new one for this purpose. 

As part of the conversion, Publisher asks whether you want a navigation bar. For a multipage publication 
this can be helpful, but for a single-page publication it's not needed. Navigation bars are discussed later in 
this lesson. 

After the conversion, you'll notice some differences in the publication, such as: 

• The ruler uses pixels as the unit of measurement, rather than inches. A pixel is a unique colored 
dot on a display screen. Pixels are the preferred unit of measurement when working with 
publications designed for onscreen display.  

• The New button on the Standard toolbar changes to a New Web Page button.  
• A few of the buttons on the Objects toolbar are different.  

Figure 6-1 points out some of these differences.  



 
Figure 6-1: A print publication converted to a Web publication has different onscreen features.  
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Even though the publication is formatted for Web use, it's still a standard Publisher publication in .pub 
format; it's not a real Web page yet and won't be until you save it in Web format. (That's explained later in 
this lesson.) 
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After converting the publication to Web format, it might be appropriate to change the page's width and title. 
See the following sections for details. 

Change the page width

You might notice that in Publisher, a Web page is very long (tall) -- probably longer than you'll need. This is 
not a problem, because when the page is displayed in a Web browser any extra length is truncated. The 
page width is an important issue to consider, however, because if the page is greater (in pixels) than your 
audience's display resolution, users have to scroll horizontally to see your page (which is annoying). 
Common display resolutions are 800 x 600 (that is, 800 pixels wide and 600 pixels tall) and 1024 x 768. 
However, some older computers use a lower resolution of 640 x 480. 

Select File > Page Setup, and then click the Layout tab. You'll see that Publisher has the publication set 
up as a Web page with Standard width (for 800 x 600 screens), as shown in Figure 6-2. You can change 
this to Narrow width (640 x 480 display) if you think that some people viewing your page might have that 
lower resolution. 

TIP  
If you do not have a strong opinion about which width is better for your situation, go with Standard. 
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Figure 6-2: Page Setup Layout tab.  

Change the page title

Each page has a title that appears in the title bar when the page is displayed in a Web browser. This is 
separate from the publication's file name.  

To change the page title, display the page, and then select Tools > Web Page Options. The Web Page 
Options dialog box appears. In the Page title text box, replace the default name with the title of your 
choosing, as shown in Figure 6-3. 

 



Figure 6-3: Web Page Options dialog box.  
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There's a lot more to do with Web page creation in Publisher, of course, but before you continue, you 
should learn how to preview and save your work. 

Preview a Web page

To preview the publication in a Web browser (your default one), select File > Web Page Preview or press 
Ctrl + Shift + B. If you're working with a multipage publication, a box appears asking whether you want to 
preview the entire Web site or the current page.  

You're not asked this question if you're working with a single-page publication. 

When previewing, make sure no text is cut off and that font usage is consistent. Evaluate the page width, 
the graphic placement, and anything else that you think your audience might find important. When you're 
done previewing the page, close the browser window and return to Publisher. Now you're ready to save it. 

Save a publication as a Web page

At this point, the Web page is still just an ordinary publication, in Publisher format. You must save it in Web 
format. There are three distinct Web formats you can save in through Publisher 2003: 

• Web Page: This creates a version of the publication in HTML format that retains formatting codes 
for Publisher 2003. You can open this Web page in Publisher for editing later. However, because 
of the extra codes for Publisher, the file size is large. It also creates a folder containing the support 
files for the page, such as its graphics.  

• Web Page, Filtered: This creates a version of the publication in HTML format that does not have 
any Publisher codes. It's a much smaller file than the Web page, but it cannot be reopened for 
editing in Publisher. It also creates a folder for support files.  

• Single File Web Page: This creates a version in a special format called MIME HTML (MHTML, 
often shortened as MHT) that contains the entire publication, including text and graphics, in a 
single file. No folder for support files is needed.  

To save in Web Page or Single File Web Page format, you use the regular Save As dialog box, but change 
the file format in the Save as type drop-down list, as shown in Figure 6-4. 



 
Figure 6-4: Save in Web page or Single File Web Page format using the Save As dialog box.  

To save in the Web page, Filtered format, you must use the File > Publish to the Web option (new in 
Publisher 2003). Even though the command is called Publish to the Web, you can actually use it to publish 
(save) the file anywhere, including to your own hard disk. (You'll find out later in this lesson how to save 
directly to a server.) Except for the name, and the type of file it creates, it's the same as an ordinary save. 
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Hyperlinks are one of the defining features of Web pages. When you click a hyperlink, something happens, 
such as another Web page displaying, an e-mail window opening, or some other action. A hyperlink can be 
either a text or a graphic, and using hot spots, you can make different parts of a single image link to 
different locations. 

The most common type of hyperlink is a text hyperlink, which is typically underlined. Clicking it displays 
whatever page or pointer is associated with the hyperlink. 

A hyperlink can point to any of many different locations, including: 

• Other Web sites  
• Other pages within the same Web site  
• A specific spot on the current Web page  
• An e-mail address  
• A document (not necessarily HTML) on a hard disk (assuming that disk is accessible)  

A graphical hyperlink is functionally identical to a text hyperlink; the only difference is that instead of 
underlined text, it's a graphic. Not all graphics are necessarily hyperlinks. When the user moves the mouse 
pointer over a graphical hyperlink, the pointer changes to a hand. 

 
WARNING  
It may not be obvious to the readers of your Web page that a particular graphic is a hyperlink. Therefore, 
you usually want to include explanatory text either on the graphic or adjacent to it. 
 

To begin a text or graphical hyperlink, select the text or graphic, and then select Insert > Hyperlink, press 



Ctrl + K, or click the Insert Hyperlink button on the Standard toolbar. This opens the Insert Hyperlink dialog 
box. 

Hyperlink to a Web site

Some hyperlinks point to Web addresses, URLs (Uniform Resource Locators) outside of your own Web 
site. For addresses like that, you must enter the full address. In the Insert Hyperlink dialog box, type the 
Web address (the URL) for the Web page in the Address box. 

If you don't know the exact address of the page, there are ways to look it up: 

• To select from pages you've recently viewed in Microsoft Internet Explorer, click Browsed Pages, 
and then select from the list.  

• To select a page by browsing to it from Internet Explorer, click the Browse the Web button (the 
world with the magnifying glass over it). Internet Explorer opens. Navigate to the desired page, 
and then switch back to Publisher and that page's address appears in the Address box.  

• To reuse an address you've previously created a hyperlink for, open the Address box's drop-down 
list, and then select it from there.  

Hyperlink to another page in Your Web site

A problem arises if you want to create a hyperlink that refers to another page in your Publisher publication. 
Eventually, you'll save to the Web and each page in your publication will become a single Web page, but 
you haven't done that yet (perhaps) so there's no URL to which to refer. 

To overcome this problem, you can insert a Place in This Document hyperlink. It makes a note of the page 
to which you want to refer, and then when the publication is saved in Web format, it updates the link to the 
new name and location. 

Later in this lesson, you'll find out how to use navigation bars as another way of linking between the pages 
in your Web publication.  

Start the same as usual, with the Insert > Hyperlink command, and then click Place in This Document. 
This opens a list of all the pages in the current publication. Select the page to which you want the hyperlink 
to refer. 
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Most Web sites consist of more than a single page. A typical Web site 
consists of several pages, each with a consistent navigation bar to help 
you move between them easily. Now that you know how to work with 
individual Web pages, you can begin tying it all together. 

Create a three-page Web site

Publisher has a special set of templates it calls 3-page Web sites. 
They're just what they sound like: They create publications that have 
three pages and are set up for Web use. To create a new 3-page Web 
site, follow these steps: 

1. Start a new publication, and then select Web Sites and E-
mail as the category.  

2. Select Web sites, and then select 3-Page Web Site.  
3. Pick from one of the available designs, the same as with any 

other publication, as shown in Figure 6-5.  

Save with great offers 

When starting up or running 
your own publishing company, 
you need to save on costs 
everywhere you can. 

 

» Save $50 on a PC and 
digital camera, printer or 
scanner 
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Figure 6-5: Use one of the 3-Page Web Site templates.  
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The first page is the home page. The home page is the top-level page 
for the Web site. When you send people the URL for your Web site, 
you send them the address of this page. The other two pages can be 
anything you want them to be. Many templates are available. You can 
also add more pages, or delete one or more of the existing ones. 

Use the task pane to control options for the pages and for the Web site 
as a whole, as you do with other publications based on templates. For 
example, you can control the placement of the navigation bar, as 
shown in Figure 6-6. Customizing the navigation bar is covered later in 
this lesson. 

Figure 6-6: Customize the publication using the task pane's 
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options.  

Enlarge image  

Use the easy Web site builder

The 3-Page Web Site template gives you no choice about the number 
or type of pages you want. When you need more control, the Easy Web 
Site Builder is a better way to go. 

To start a Web site based on the Easy Web Site Builder, follow these 
steps: 

1. Start a new publication, and then select Web Sites and E-
mail as the category.  

2. Select Web sites, and then select Easy Web Site Builder.  
3. Select one of the Easy Web Site templates.  
4. The Easy Web Site Builder displays a dialog box listing many 

types of Web page functionalities, such as telling the 
customers about products or providing lists of hyperlinks. 
Place a checkmark next to each of the functionalities you 
want, and Publisher automatically creates the needed pages, 
as shown in Figure 6-7.  

Figure 6-7: Easy Web Site Builder dialog box.  

There's usually a one-to-one relationship between the functionalities 
and the number of pages created. However, the Sell Products 
functionality creates multiple pages -- a main page and multiple 
subpages branching off of it. These subpages do not appear in the 
navigation bar by default. 

You can redisplay the Easy Web Site Builder at any time to add more 
pages by displaying the Web Site Options task pane, and then clicking 
the Add functionality hyperlink. This method only adds pages; it does 
not remove them. You can also add pages manually, as described in 
the next section. 
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After creating the basic shell of the Web site with a template, you can add and remove pages at will. 

Add pages manually

Publisher comes with page templates for several kinds of additional Web pages you might want for your 
Web site, such as forms, calendars, resumes, and special offers. 

To add a Web page, do any of the following: 

• Select Insert a page from the Web Site Options task pane.  
• Select Insert > Page.  
• Press Ctrl + Shift + N.  

Any of these methods opens the Insert Web Page dialog box. 

To add the page to the Web navigation bar, make sure the Add hyperlink to navigation bars checkbox 
remains checked. (Usually, this is good practice, but occasionally you may want a Web page that's not 
linked to every other page.) If you create a Web page that's not part of the navigation bar, you need to 
insert a hyperlink to it somewhere so that people can access it. 

Remove pages

Removing a page from a Web site is just like removing one from a regular document -- select Edit > Delete 
Page. Publisher removes the deleted page from the navigation bar automatically. 

Customize a page layout

Each page's layout can be separately selected, like with a newsletter. Display the page, and then select a 
layout from the Page Content task pane, as shown in Figure 6-8. 



 
Figure 6-8: Customize the layout of an individual Web page.  

Different types of pages have different layout choices. The default three pages in a 3-page Web site are 
fairly basic, but you can insert additional pages (see next section) that have special elements on them and 
have more layout choices for such pages. 
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The navigation bar contains hyperlinks to each of the pages, and is consistently placed on each page 
(usually). The navigation bar is an important part of a multipage Web site because it enables the audience 
to move easily between the pages. 

There are many different placements available for the navigation bar. Decide among them from the Web 
Site Options task pane, as shown in Figure 6-9. Some of the choices involve having two different navigation 
bars: one at the top or side and another at the bottom. 



 
Figure 6-9: Control navigation bar placement.  

The navigation bar is a special design element like the ones in the Design Gallery. It has its own wizard you 
can activate to set its options. On any Web page, click the navigation bar, and then click the Wizard button 
beneath it. The Navigation Bar task pane appears. In it, you can change nearly every aspect of the 
navigation bar. 

Change links on the navigation bar

Typically, you don't need to add or remove links from the navigation bar, because Publisher handles this 
automatically when you add and remove pages in your publication. However, you might occasionally want 
to include a page on your navigation bar that was not created in Publisher, or that you originally decided not 
to include in the navigation bar. 

To manually add or remove links, or reorder them, follow these steps: 

1. Click the navigation bar. A Wizard button appears beneath it.  
2. Click the Wizard button to open the Navigation Bar task pane.  



3. Click Add, remove and reorder links. This opens the General tab of the Navigation Bar 
Properties dialog box, as shown in Figure 6-10. Here's where you can add, remove, and edit links. 

 
Figure 6-10: Navigation Bar Properties dialog box.  
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4. To modify to which page a link refers, select it on the General tab, and then click Modify Link. A 
dialog box appears from which you can select the desired page.  

5. When you're done working with the navigation bar, click OK.  

From the Navigation Bar task pane, shown in Figure 6-10, you can also change the orientation (Vertical or 
Horizontal), or click More design options to open the Style tab of the Navigation Bar Properties dialog 
box. 

TIP  
The controls that appear in the Navigation Bar Properties dialog box are similar to those in the Navigation 
Bar task pane (shown on the left), but have some additional fine-tuning settings, such as hyperlink 
alignment and maximum number of hyperlinks across. 
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When your Web site is complete, you want to publish it to a Web server so that the Internet public can visit 
it.  

You can save directly to the server from Publisher if you have access to it. (Web servers are usually 
username and password protected.) To transfer files to a Web server, you can use any of the three save 
methods you learned earlier in this lesson, and specify either a Web or FTP (File Transfer Protocol) 
location for the storage. If possible, it's better to use a Web location because it's easier. However, not all 
Web servers allow you to upload to them directly. Some require you to save your Web files to an FTP 
address using the FTP protocol, as explained in the following sections. 

Saving to a Web location

To save to a Web location, click the My Network Places button in the Save As or Publish to the Web 
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dialog box. A list of the network shortcuts you have set up appears. If the desired Web location already 
appears there, double-click it to connect to it. The first time you save to a certain location, you need to set it 
up.  

Type the URL of the Web site in the File name box, and then press Enter. You're prompted for a username 
and password. Enter them, and then click OK to continue. You must have a valid username and password 
for that server; see the system administrator if needed. 

The contents of the Web server appear in the window. Save normally, and the Web page(s) are saved 
directly to the server. 

Saving to an FTP location

Sometimes Web servers can be accessed by two different addresses: their Web address (http://) and their 
FTP address (ftp://). Some servers require that users upload their Web pages using the FTP address. 

To save with FTP, open the Look in drop-down list in the Save As or Publish to the Web dialog box, and 
then select an FTP location under FTP locations. The desired location does not appear, select Add/Modify 
FTP Locations, and then set it up by filling in the dialog box that appears. 

Other transfer methods

Besides the file transfer methods from within Publisher, you can also transfer files to a Web server using a 
variety of other methods. Some versions of Microsoft Windows include a Web Publishing Wizard. You can 
use it to transfer a single file or a single folder to a Web server. You can also download free or shareware 
FTP programs, such as WS_FTP Pro, CuteFTP, and SmartFTP, from the Internet. Or if your company's 
Internet server is accessible from your LAN, you can copy the files as you would any network files.  

Moving on

Congratulations! You made it through to the end of this course. Please feel free to post any last-minute 
questions and comments on the Message Board, which will remain active for two weeks after this lesson's 
posting date.  
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