Introduction to Power BI and Data Visualization
1. What is Power BI?
Power BI is a business analytics tool developed by Microsoft that enables users to visualize data, share insights, and make informed decisions. It helps users connect to various data sources, transform raw data into meaningful reports, and share them with others in their organization. Power BI stands out for its ease of use, interactive visuals, and integration with other Microsoft tools like Excel and Azure.
2. When and by whom was Power BI created?
Power BI was originally conceived by two Microsoft engineers, Amir Netz and Thierry D’Hers, as an internal tool. It was later released to the public in July 2015. Since its launch, Power BI has rapidly grown in popularity and has become one of the leading tools in the business intelligence market.
3. Why do we use Power BI?
Organizations use Power BI for several reasons:
- It provides an easy and effective way to visualize data.
- Users can explore and analyze data without needing advanced technical skills.
- It supports collaboration through sharing dashboards and reports.
- Power BI integrates with a wide range of data sources.
- It helps uncover hidden trends, monitor performance, and make data-driven decisions in real time.
4. Components of Power BI
Power BI is made up of several key components, each serving a unique purpose:

1. Power BI Desktop: A free desktop application for Windows that lets users connect to data, transform it, and build visual reports.
2. Power BI Service: An online SaaS (Software as a Service) platform that allows users to publish, share, and collaborate on reports and dashboards.
3. Power BI Mobile: Apps for Android and iOS devices that allow users to view and interact with reports on the go.
4. Power BI Gateway: A bridge between on-premises data sources and the Power BI Service, enabling scheduled data refreshes.
5. Power BI Report Server: An on-premises report server where users can publish reports created in Power BI Desktop and manage them within the organization's firewall.
5. Use Cases of Each Component
Each component of Power BI has specific use cases:

- Power BI Desktop: Ideal for analysts creating complex reports by connecting to multiple data sources.
- Power BI Service: Used by teams to publish and share reports online and enable collaborative decision-making.
- Power BI Mobile: Enables managers and executives to access real-time insights anywhere and anytime.
- Power BI Gateway: Helps automate data refreshes from secure, on-premises databases.
- Power BI Report Server: Useful for organizations with strict data governance policies who prefer to keep data and reports within their local network.
6. What is Data Visualization?
Data visualization is the process of representing information and data in the form of charts, graphs, maps, and other visual formats. It helps in simplifying complex data and making insights easier to understand. Humans process visual information faster than text, so visualization makes it easier to identify patterns, trends, and outliers in data. Effective data visualization can improve understanding, facilitate decision-making, and communicate findings to a broader audience.
7. How Power BI is Related to Data Visualization
Power BI is a tool built specifically for data visualization and analysis. It provides a drag-and-drop interface to create a wide range of visuals like bar charts, line graphs, pie charts, maps, tables, and more. Users can interactively explore the data, apply filters, and drill down into details. Power BI also supports advanced visual features like KPI indicators, slicers, and custom visuals, enabling users to communicate insights in a compelling and dynamic way.
8. Power BI Desktop Installation
Installing Power BI Desktop is simple and straightforward:

1. Visit the official Power BI website: https://powerbi.microsoft.com/desktop
2. Click on the 'Download free' button to get the installer.
3. Run the installer (.exe file) and follow the on-screen instructions.
4. Once installed, launch Power BI Desktop.
Layout of Power BI Desktop – Explained in Simple Terms
Power BI Desktop is designed to help you explore your data, build reports, and create dashboards without needing to write complex code. Here’s a breakdown of its layout in a simple, human-friendly way, using bullet points to help you remember each part.
Ribbon (Top Menu Bar)
Located at the top, similar to what you see in Word or Excel.
Includes different tabs like Home, Insert, Modeling, View, and Help.
Each tab contains tools for working with data, visuals, formatting, and sharing.
The Home tab is where most of the basic actions like getting data and transforming data happen.
Report View (Main Canvas Area)
This is the central space where you build your report by dragging and dropping charts, tables, and visuals.
You can add multiple pages to your report – think of each as a slide.
Allows easy interaction with visuals, filters, and layout customization.
Data View
Shows your data in a table format, like a spreadsheet.
You can see the actual records, check if your data is clean, and create calculated columns or measures.
Great for doing quick checks and creating new logic using formulas (DAX).
Model View
Displays the relationships between tables in a diagram format.
Used to build or edit connections (joins) between tables.
Helps in understanding how your data tables are linked together for analysis.

Fields Pane
Located on the right side, it shows all your tables and columns from the data you’ve connected.
You can drag these fields into your report to create visuals.
Also allows you to search fields, create measures, or hide items from the report view.
Visualizations Pane
Also on the right side, this section shows different types of charts and visuals you can use.
You can click on a visual type and then assign data to it by dragging fields.
This is also where you adjust formatting – like changing colors, titles, or labels.
Filters Pane
Helps you narrow down the data being shown in your report.
You can apply filters at the visual level (just one chart), page level, or for the entire report.
Drag any field here and select values to control what’s displayed.
Page Tabs
At the bottom of the screen, similar to PowerPoint slides.
Each tab is a separate page of your report.
You can add, rename, duplicate, or hide pages to organize your report.

















What is Power Query?
· Power Query is the tool inside Power BI Desktop used to connect, clean, and transform data.
· Think of Power Query as the data cleaning and preparation kitchen – where all messy ingredients (data) are prepped before cooking (visualization).
· It allows you to load raw data from different sources and shape it without changing the original files.

Role of Power Query in the BI Process
· Power BI has multiple stages: data connection, data transformation, modeling, and visualization.
· Power Query plays a role in the data transformation stage.
· It acts as the middle layer between collecting raw data and creating dashboards.
· It helps ensure that the data is:
· Correctly formatted
· Free of errors or duplicates
· Aggregated or filtered if necessary
· Ready for analysis and reporting

What is the Power BI Report Layer?
· Once data is cleaned using Power Query, it moves to the Power BI Report Layer.
· The report layer is where you:
· Build charts and visualizations
· Use filters, slicers, and drill-down options
· Write DAX formulas to perform calculations
· Design interactive dashboards
· It’s the presentation layer, where users interact with the final output.

Power Query vs Power BI Report Layer
· Power Query is for shaping the data before loading it into the data model.
· Power BI Report Layer is for visualizing and analyzing that data.
· Think of Power Query as behind the scenes and the report layer as on stage.
· Here's how they compare:
· Power Query uses M Language, while the report layer uses DAX.
· Power Query works before data is loaded, the report layer works after.
· Power Query handles raw data; the report layer handles structured data ready for insight.
· In Power Query, you're focused on cleaning and combining. In the report layer, you're focused on analyzing and storytelling.


Layout of Power Query Window & Purpose of Each Part
When you open Power Query Editor, here's what you'll see and how it's used:
Query Pane (left panel)
· Displays a list of all tables (also called queries) you have imported.
· You can rename, group, or organize queries from here.
Data Preview (middle panel)
· Shows a snapshot of your data — usually the first 1,000 rows.
· This is where you see the effect of your transformation steps.
Applied Steps (right panel)
· A list of all actions you’ve taken on the data, in order.
· Includes steps like “Removed Columns,” “Changed Type,” or “Filtered Rows.”
· Every change you make is automatically recorded as a step.
Formula Bar (optional)
· Shows the code behind each applied step.
· Useful when you want to edit or write formulas directly in M language.
Tabs at the top:
Home Tab
· Basic actions: load data, remove rows, keep top rows, change data types, close & apply changes.
· Often used for quick tasks or first-round cleaning.
Transform Tab
· Used for reshaping data: split columns, format text, pivot or unpivot columns, group data.
· Most of your “core transformations” will happen here.
Add Column Tab
· Allows you to create new columns based on existing ones.
· You can add custom columns, conditional columns, or extract part of a column.
View Tab
· Controls visibility of elements like the formula bar and query dependencies view.
· Helpful for tracking the flow of your data steps.

What are Applied Steps and Why Are They Important?
· Applied Steps are like a recorded recipe of how you transformed your data.
· Each time you remove a column, rename something, or filter rows — it gets logged as a step.
· These steps:
· Are reusable — they apply automatically every time you refresh the data.
· Are editable — you can go back and modify or delete a step.
· Help in debugging — if something breaks, you can trace back the issue step by step.

· They ensure your data preparation is automated, consistent, and transparent.

What Does Merging a Table Mean? (Joins in Power Query)
· Merging tables in Power Query is like performing a JOIN operation in databases or Excel VLOOKUP.
· You bring in columns from another table based on a common key column (like Order ID or Customer ID).
· It adds new columns from the second table to the first one, wherever a match is found.
Common types of joins:
· Left Join: Keep all rows from the first table, add data from matching rows in the second.
· Right Join: Keep all rows from the second table, match rows from the first.
· Inner Join: Keep only the rows where a match exists in both tables.
· Full Outer Join: Keep all rows from both tables.
Real-life example:
· Merge an Orders table with a Returns table.
· This lets you add a new column: “Returned? Yes/No,” depending on whether a match exists in the Returns table.

What is a Union in Power Query? (Appending Tables)
· Appending means stacking tables vertically – like adding rows from one table under another.
· Useful when you have the same type of data split across files.
· Example:
· Sales_2022 and Sales_2023 can be appended to create one big Sales table.
· Make sure the column names and data types are consistent for a clean append.

Query Dependencies
· You can view the visual flow of your queries and how they’re connected.
· Helps in large projects to understand how data flows between tables.
Enable Load vs Disable Load
· You can choose whether a query should be loaded into the report layer.
· Disable load for helper or intermediate queries to keep the model clean and efficient.
Reference vs Duplicate
· Duplicate: Makes a copy of a query – independent of the original.
· Reference: Creates a new query that depends on the original – changes in base affect the reference.
· Useful when staging transformations in multiple steps.
Parameters
· You can define dynamic inputs (like filters, file paths, or years).
· Makes your queries flexible and reusable.


Practical 1: Cleaning Up Customer Data for Management Review
Case Scenario:
The Regional Sales Manager at Superstore wants a clean and accurate customer list to design a loyalty program. You’ve been asked to remove duplicates, format text fields, and ensure all records are consistent.
Steps:
1. Open Power BI Desktop.
2. Go to Home → Get Data → Excel.
3. Select the Sample Superstore dataset and click Open.
4. Select the Customers sheet and click Transform Data.
5. In Power Query, examine the column names: “Customer ID”, “Customer Name”, “Segment”, “Country”, etc.
6. If needed, rename columns for clarity (e.g., "Customer Name" → "Full Name").
7. Select the “Customer Name” column → go to Transform tab → Format → Trim, then Clean.
8. Remove null values:
· Filter out blank entries in important columns like “Customer Name” or “Segment”.
9. Select all columns → Right-click → Remove Duplicates.
10. Ensure “Customer ID” is of Text type:
· Select column → Transform tab → Data Type → Text.
11. Rename the query as Cleaned Customers.
12. Click Close & Apply.

Practical 2: Filter and Clean Orders for West Region Sales Analysis
Case Scenario:
The West Region Sales Head is analysing sales performance. They only need the records from the West region, and irrelevant columns should be removed.
Steps:
1. Open Power BI Desktop and connect to the Sample Superstore Excel file.
2. Load the Orders sheet → click Transform Data.
3. In Power Query, filter the “Region” column to only keep “West”.
4. Remove columns not required for regional analysis:
· E.g., “Customer ID”, “Postal Code”.
5. Rename columns if needed (e.g., “Order Date” → “Date of Order”).
6. Change data types:
· “Sales”, “Profit”, “Quantity” → Decimal Number.
· “Order Date” → Date.
7. Apply text cleaning:
· Columns like “Category” or “Sub-Category” → Trim and Clean.
8. Rename the query as West Region Orders.
9. Click Close & Apply.

Practical 3: Creating a Category-wise Summary Table
Case Scenario:
The Marketing Team wants a simple summary showing total sales and profits per product category.
Steps:
1. Load the Orders table via Power Query.
2. In Power Query → select columns “Category”, “Sales”, “Profit”.
3. Group the data:
· Go to Transform tab → Group By.
· Group by “Category”.
· Create aggregation for:
· Total Sales: Sum of Sales
· Total Profit: Sum of Profit
4. Rename columns accordingly.
5. Ensure numeric columns have Decimal Number type.
6. Rename the query to Category Summary.
7. Click Close & Apply.

Practical 4: Combine Sales and Returns Data for Refund Analysis
Case Scenario:
The Operations Team wants to see how many orders were returned from the sales data. You need to merge Orders and Returns tables.
Steps:
1. Load Orders and Returns sheets via Power Query.
2. Select the Orders query → go to Home → Merge Queries.
3. Select the Returns table to merge with.
4. Join on the column “Order ID”.
5. Choose Left Outer Join (all orders + matching returns).
6. Expand the Returns column to get “Returned” field.
7. Rename column as “Is Returned”.
8. Replace nulls in “Is Returned” with “No”, others with “Yes”.
9. Rename the query to Sales with Returns.
10. Click Close & Apply.








Practical 5: Splitting City and State from Location Column
Case Scenario:
Your company is revamping regional marketing campaigns and wants separate columns for City and State extracted from a combined "Location" field.
Steps:
1. Load Orders sheet → click Transform Data.
2. Suppose a new column “Location” exists in format: “City, State”.
3. Select “Location” column → go to Split Column → By Delimiter → Comma.
4. Name the new columns:
· “City” and “State”.
5. Apply Trim and Clean to both columns.
6. Change their data type to Text.
7. Rename the query to Orders Split Location.
8. Click Close & Apply.

Practical 6: Unpivoting Monthly Sales Data
Case Scenario:
The finance team has monthly sales data laid out in columns. They want it converted into a row-based format for trend analysis.
Steps:
1. Load Sales_Monthly.xlsx with columns: “Product”, “Jan”, “Feb”, … “Dec”.
2. In Power Query, select all month columns → Right-click → Unpivot Columns.
3. Rename new columns:
· “Attribute” → “Month”
· “Value” → “Sales”
4. Ensure “Month” is Text, “Sales” is Decimal.
5. Rename the query as Monthly Sales Long Format.
6. Click Close & Apply.

 Practical 7: Creating a Lookup Table for Segments
Case Scenario:
You’re building a data model. You want to extract a distinct list of customer segments to use as a slicer in reports.
Steps:
1. Load Orders table → click Transform Data.
2. Select the “Segment” column → Remove Duplicates.
3. Rename the query to Segment Lookup.
4. Optionally, sort the segment list alphabetically.
5. Click Close & Apply.



Practical 8: Remove Outliers in Sales Values
Case Scenario:
Your BI Analyst suspects that some extremely high sales values are skewing the reports. You’ve been asked to remove sales over ₹10,000.
Steps:
1. Load Orders table → open in Power Query.
2. Select the “Sales” column.
3. Go to Home tab → Keep Rows → Keep Range of Rows, OR apply a filter:
· Filter Sales column → Less Than or Equal To ₹10,000.
4. Review and clean other numeric columns if needed.
5. Rename the query to Orders No Outliers.
6. Click Close & Apply.

Practical 9: Creating a Calculated Column in Power Query
Case Scenario:
The Finance Department wants a new column showing Profit Margin = Profit / Sales.
Steps:
1. Load Orders table → click Transform Data.
2. Go to Add Column tab → Custom Column.
3. Name it Profit Margin.
4. Formula: [Profit] / [Sales]
5. Handle errors:
· Use conditional logic to avoid division by zero if needed.
6. Change data type of “Profit Margin” to Percentage or Decimal.
7. Rename the query to Orders with Margin.
8. Click Close & Apply.

Practical 10: Appending Two Order Tables
Case Scenario:
Superstore has regional data files. You want to combine North and South Region data stored in separate Excel sheets.
Steps:
1. Load Orders_North and Orders_South sheets into Power Query.
2. Go to Home → Append Queries.
3. Choose the two tables to append → click OK.
4. The result combines rows from both tables.
5. Rename the query as All Orders Combined.
6. Ensure column names, data types, and structure match before appending.
7. Click Close & Apply.




Foundations of Data Modelling

What is data modelling in BI
· the process of organizing raw data into a structure that supports accurate, fast analysis and reporting.
· it defines the tables, keys, relationships and rules that let visuals compute correct results.
· good data modelling converts messy source files into a consistent, query-friendly shape (fact + lookup/dimension tables).
Why data modelling is essential for accurate analysis
· ensures calculations aggregate correctly (no double counting, no missing joins).
· enforces consistent business logic across the report (single source of truth for e.g., product names, dates).
· improves performance — a clean model reduces data duplication and unnecessary calculations.
· simplifies report building for end users (they drag fields, not rebuild logic).
Star schema vs Snowflake schema (overview & when to use)
· Star schema
· one central fact table (transactions) connected directly to several denormalized dimension tables (date, product, customer, region).
· easy to understand and performant for queries.
· preferred for most Power BI models and self-service analytics.
· Snowflake schema
· dimensions are normalized into multiple related tables (e.g., product → product_category → product_department).
· may reduce redundancy but makes relationships deeper and can complicate visuals.
· used when data governance requires normalized structure or when dimension tables are large with repeated values.
· Fact tables and Dimension (lookup) tables
· Fact table
· contains transactional, numeric, and date measures (e.g., Orders: OrderID, OrderDate, Sales, Quantity, Profit).
· usually very large and is the main source for SUM/AVG measures.
· Dimension table
· contains descriptive attributes used for slicing and grouping (e.g., Product, Customer, Employee, Date).
· typically smaller, with unique rows per key (e.g., one row per ProductID).
· design rule: keep facts narrow (measures + foreign keys) and dimensions descriptive.
· Cardinality and relationship types
· One-to-Many (1: or 1 →)
· dimension table has unique key values; fact table contains many rows pointing to each dimension key.
· typical: Product (1) → Orders (*).
· Many-to-One
· equivalent view from other side; Power BI shows Many-to-One (*:1) when configuring.
· One-to-One (1:1)
· both tables have unique keys; rare in reporting, can be modeled as merged table.
· Many-to-Many
· both tables have duplicate values in the key column; creates ambiguity.
· use carefully — often solved with a bridge (helper) table or by redesigning model.
· Cross-filter direction: Single vs Both
· Single (one direction)
· filter flows from dimension → fact only (recommended).
· prevents ambiguous filter propagation; best for star schema.
· Both (bi-directional)
· filters flow both ways (dimension↔fact).
· useful when two fact tables must filter each other through a common dimension, but increases risk of ambiguous relationships and performance issues.
· Best practices for clean, maintainable models
· adopt a star schema when possible.
· create a single Date (calendar) table and mark it as the date table.
· use surrogate integer keys for joins where possible (integer joins are faster).
· ensure data types match across joined columns (text vs number).
· check uniqueness of dimension keys (they should be unique).
· hide technical columns (IDs) from report view; show friendly names instead.
· prefer measures (DAX) over calculated columns for aggregations (measures are computed on the fly).
· minimize bi-directional filters; prefer explicit DAX or bridge tables for many-to-many.
· limit columns in the model: do not load unused columns.
· name relationships and tables meaningfully; use consistent naming conventions.
· document the model (query and table purpose), especially for team use.

Practical 1 — Load data into Power BI (set the stage)
Goal
Bring Orders, People, and Return into Power BI so everyone is working with the same base.
Steps
· Open Power BI Desktop.
· Home → Get data → Excel.
· Browse to Sample Superstore.xlsx → Open.
· In Navigator, tick Orders, People, Returns.
· Click Transform Data (so you can check types before loading).
· In Power Query, quickly scan each table:
· Orders: confirm Order ID is Text, Order Date Date, Sales/Profit/Quantity/Discount Decimal or Whole Number as appropriate.
· People: confirm the region/person columns are Text.
· Returns: confirm Order ID is Text, returned flag Text (often “Yes” values).
· Click Close & Apply to load.
Outcome
All three tables appear in Report view and Model view, ready for modelling.

Practical 2 — Identify fact vs dimensions and name them clearly
Goal
Label tables so students visually separate transactions (fact) from lookups (dimensions).
Steps
· Go to Model view (left pane icon with boxes).
· Decide roles:
· Orders → Fact (transaction lines).
· People → Dimension (region → person mapping).
· Returns → Dimension (which orders were returned).
· Rename tables for clarity:
· Right-click Orders → Rename → Fact_Orders.
· Right-click People → Rename → Dim_People.
· Right-click Returns → Rename → Dim_Returns.
· (Optional) In Properties pane, add a short Description for each table so students see intent.
Outcome
A clearly labelled model that already teaches star-schema thinking.







Practical 3 — Understand the fact table: classify columns
Goal
Train eyes to separate keys, measures, and descriptors in the fact.
Steps
· Switch to Data view.
· Select Fact_Orders.
· Scan columns and classify out loud:
· Keys / Foreign Keys: Order ID, Customer ID, Product ID, Region.
· Measures (numerics to aggregate): Sales, Profit, Quantity, Discount.
· Descriptors (slice/group fields): Category, Sub-Category, Segment, City, State, Ship Mode.
· Dates: Order Date, Ship Date.
· For numeric columns you don’t want accidentally averaged (e.g., IDs stored as numbers), set Data type to Text or Do not summarize in the Column tools.
· (Optional) Add Description to a couple of columns (good modelling hygiene).
Outcome
Students can tell which fields will drive relationships vs. visuals.

Practical 4 — Create the first relationship: People ↔ Orders (Region)
Goal
· Build a clean Many-to-One from Dim_People (one row per Region) to Fact_Orders (many orders per Region).
Steps
· First, ensure uniqueness in Dim_People[Region]:
· If you suspect duplicates, right-click Dim_People → Edit query (opens Power Query).
· In Power Query, select Region → Home → Remove Rows → Remove Duplicates (if each region should have a single “Person”).
· Close & Apply.
· Go to Model view.
· Drag Dim_People[Region] onto Fact_Orders[Region].
· In the relationship dialog:
· Cardinality: One to many (1: )* with 1 on Dim_People, * on Fact_Orders.
· Cross filter direction: Single (from People → Orders).
· Active: checked.
· Click OK.
Outcome
· Region in People now filters Orders. You’ve shown a classic dimension→fact setup.




Practical 5 — Cardinality and cross-filter direction (show the impact, then revert)
Goal
· Let students “feel” what cross-filter means by toggling it—then return to recommended settings.
Steps
· In Model view, double-click the Dim_People ↔ Fact_Orders relationship line.
· Change Cross filter direction from Single to Both → OK.
· Switch to Report view:
· Add a Table visual.
· Put Dim_People[Person] (or Region) and Fact_Orders[Sales] in the table.
· Add a Slicer with Dim_People[Region].
· Interact a bit; explain how filters flow both ways now (and why that can cause ambiguity in larger models).
· Go back to Model view and revert cross-filter to Single (best practice).
Outcome
Notice why Single is the default rule and when Both can be risky.

Practical 6 — Create the Returns relationship: Returns ↔ Orders (Order ID)
Goal
· Add a second dimension and discuss “one order, many lines” nuance.
Steps
· Confirm types match:
· In Data view, ensure Fact_Orders[Order ID] is Text.
· Ensure Dim_Returns[Order ID] is Text.
· Check uniqueness of Dim_Returns[Order ID]:
· If needed, open Power Query on Dim_Returns → Home → Group By on Order ID with Count → verify all counts = 1 → remove the step after checking.
· Go to Model view.
· Drag Dim_Returns[Order ID] onto Fact_Orders[Order ID].
· In the dialog:
· Cardinality: One to many (1:*) with 1 on Dim_Returns, * on Fact_Orders (because Orders table has multiple lines per Order ID).
· Cross filter direction: Single (from Returns → Orders).
· Active: checked.
· Click OK.
Outcome
· You now have two clean dimension relationships feeding the fact—exactly what a star wants.




Practical 7 — Quick relationship test with simple visuals
Goal
· Validate that relationships work before moving on.
Steps
· Go to Report view.
· Insert a Card visual:
· Drag Fact_Orders[Sales] into it (shows total Sales).
· Insert a Table visual:
· Add Dim_People[Region] and Fact_Orders[Sales].
· Insert another Table visual:
· Add Dim_Returns[Order ID] and Fact_Orders[Sales] (Power BI will show sales tied to returned order IDs).
· Add a Slicer with Dim_People[Region] and click a region.
· Watch both tables and the card change—filters are flowing from dimensions to fact.
Outcome
· Visual proof that the model behaves as expected.

Practical 8 — Star vs Snowflake (build a tiny snowflake on purpose)
Goal
Demonstrate what a snowflake looks like by normalizing a dimension one step.
Steps
· Create a product dimension from Orders:
· Data view → Transform Data (Power Query).
· Right-click Fact_Orders → Reference (not Duplicate).
· In the new query, keep only product columns: Product ID, Product Name, Sub-Category, Category.
· Select Product ID → Home → Remove Duplicates (enforce uniqueness).
· Rename query to Dim_Product.
· Close & Apply.
· Create a higher-level category dimension:
· Model view → right-click Dim_Product → Create a new table (or do it in Power Query).
· Easiest in Power Query: Reference Dim_Product, keep only Sub-Category, Category, remove duplicates, rename to Dim_Category.
· Close & Apply.
· Create relationships:
· Fact_Orders[Product ID] → Dim_Product[Product ID] (Many to One, Single).
· Dim_Product[Sub-Category] → Dim_Category[Sub-Category] (Many to One, Single).
· Explain:
· Now filters can flow Dim_Category → Dim_Product → Fact_Orders.
· This is a snowflake (a dimension feeding a dimension).
· Note the trade-off: more joins, potentially slower queries; star is preferred unless you truly need normalized dims.
Outcome
Students can now visually distinguish star (direct) vs snowflake (one more hop).

Practical 9 — Build two tiny tests that prove the model’s logic
Goal
· Cement understanding with quick, low-effort visuals that use different dimensions.
Steps
· Report view → add a Matrix:
· Rows: Dim_Category[Category], Dim_Category[Sub-Category].
· Values: Fact_Orders[Sales].
· Confirm drill behavior and totals look sensible.
· Add another Table:
· Columns: Dim_People[Person] (or Manager/Region) and Fact_Orders[Profit].
· Add two Slicers:
· Slicer 1: Dim_People[Region].
· Slicer 2: Dim_Category[Category].
· Play with slicers; call out how independent dimensions both filter the same fact cleanly.
Outcome
Students see filter propagation from multiple dimensions at once—core to a star model.

Practical 10 — Clean up the model (best-practice polish)
Goal
· End with a professional-grade model that’s tidy and safe for report authors.
Steps
· Model view:
· Hide technical columns from report view (IDs you don’t want dragged into visuals):
· Right-click column → Hide in report view.
· Set Summarization to Do not summarize for IDs and codes (Column tools).
· Ensure relationship directions are Single and cardinalities are correct (1 on dimensions, * on fact).
· Data view:
· Confirm data types are correct and consistent across joins (Text ↔ Text, Integer ↔ Integer).
· If month names exist, set Sort by Column (e.g., Month Name sorted by Month Number) to avoid alphabetical months.
· (Optional) Create display folders:
· Model view → select a table → for related columns, set Display folder (e.g., “Geography”, “Product Details”) to make the Fields pane friendlier.
· Save the file with a meaningful name (e.g., Superstore_Model_Star.pbix).
Outcome
· A clean, comprehensible, and robust model that reflects everything you’ve taught.

Creating & Managing Relationships 
Case Study Context:
Imagine you are a newly joined data analyst at “Superstore Pvt. Ltd.” The management has provided you the Sample Superstore dataset, which includes Orders, Returns, and People tables. Your task is to build a reporting model in Power BI. To do this effectively, you need to manage relationships between these tables.

Concepts 
· Automatic relationships: Power BI sometimes auto-detects links (e.g., Orders[Region] ↔ People [Region]).
· Manual relationships: Needed when Power BI doesn’t detect or makes wrong assumptions.
· Ambiguous relationships: Happens when two tables can connect through multiple paths (e.g., Orders ↔ Returns and Orders ↔ People).
· Primary & Foreign Keys: Just like in databases, relationships depend on unique identifiers (PK) and repeated fields (FK).

Exercise 1: Break and Recreate a Relationship Manually
Scenario:
The CEO asks you to check if there are sales managers assigned by region and compare them with Orders. The system didn’t create this link automatically.
Steps:
1. Open Power BI Desktop → Load Orders and People tables from Sample Superstore dataset.
2. Go to Model View (left pane).
3. Notice Power BI might auto-detect Region between Orders and People.
4. Delete this relationship by right-click → Delete.
5. Now recreate manually: Drag Orders[Region] → People[Region].
6. Set Cardinality = Many-to-One (Many Orders per One Region Manager).
7. Cross-filter direction = Single.
8. Test: Create a Table visual with People[Person] and Orders[Sales].
→ Now you can see sales per region manager.


Exercise 2: Change Cross-Filter Direction
Scenario:
Regional Managers want to see who is responsible for their orders and compare across different dimensions.
Steps:
1. Keep the relationship from Exercise 1 (Orders[Region] ↔ People[Region]).
2. Open relationship settings → Change Cross filter direction = Both.
3. Create a Matrix visual:
· Rows = People[Person]
· Columns = Orders[Category]
· Values = Orders[Sales]
4. Notice how filtering works both ways now. Example: Selecting one region manager filters orders correctly.
5. Compare result with Single filter direction (revert & test).

Exercise 3: Many-to-Many Problem & Bridge Table
Scenario:
Management wants to analyse returns. Each order may appear multiple times in Returns, and orders can be linked to multiple return reasons → leading to a many-to-many issue.
Steps:
1. Load Orders and Returns tables.
· Orders[Order ID]
· Returns[Order ID]
2. In Model view, link Orders[Order ID] ↔ Returns[Order ID].
· Notice the relationship shows Many-to-Many.
3. Create a simple Table visual:
· Add Returns[Returned]
· Add Orders[Sales]
· You may see duplicate values or inflated totals.
4. Fix with a bridge table:
· Create a new table → Home → Enter Data → Name it UniqueOrders → Add column Order ID (unique IDs from Orders).
· Relate:
· UniqueOrders[Order ID] ↔ Orders[Order ID] (1:M)
· UniqueOrders[Order ID] ↔ Returns[Order ID] (1:M)
· Now both connect through a bridge.
5. Test again with a Table visual. The inflated totals problem is solved.






[bookmark: _Hlk217668294]

Calculated Columns

Concepts
· What is a Calculated Column?
· A calculated column is a new column you create in your table using DAX (Data Analysis Expressions).
· It’s stored row by row inside the data model.
· Think of it as adding a new field to your dataset that didn’t originally exist.
· Calculated Column vs. Measure:
· Calculated Column: Stored in the table; calculated row by row. Useful when you need to categorize, group, or filter.
· Measure: Calculated on the fly during aggregation; doesn’t take up storage. Useful for calculations like SUM, AVERAGE, or ratios.
· When to Use Calculated Columns?
· When you need to apply row-level logic.
· Examples:
· Classifying sales as “High” or “Low.”
· Extracting year/month from a date.
· Calculating profit for each order.
· Storage & Performance Considerations:
· Every calculated column increases the size of your data model.
· Use them only when absolutely necessary (row-level logic).
· Prefer measures for aggregations.


Scenario 1: Calculating Profit % for Each Order
Business Context: The sales team wants to know what is the % of profit they are making per order, not just at the total level.
Steps:
1. Open Power BI Desktop.
2. Load the Orders table from the Sample Superstore dataset.
3. Go to Data View (left-side icons, the table symbol).
4. Select the Orders table.
5. In the ribbon, click Modeling → New Column.
6. Enter this formula:
7. Profit = [Sales] - [Cost]
(If you don’t have “Cost,” use [Sales] - [Discount] or add a dummy “Cost” column in Excel before import.)
8. Press Enter. You now have a Profit column calculated for each row.
9. Test it: Create a Table visual and add Order ID, Sales, Cost, and Profit.
· You should see Profit calculated per order.

Scenario 2: Creating a Sales Category
Business Context: Management wants to classify each order into categories:
· “High Value” if Sales > 500
· “Medium Value” if Sales between 200–500
· “Low Value” if Sales < 200
Steps:
1. Stay in the Orders table.
2. Click Modeling → New Column.
3. Enter this formula:
4. Sales Category =
5. IF([Sales] > 500, "High Value",
6.    IF([Sales] >= 200, "Medium Value", "Low Value"))
7. Press Enter.
8. Check the result: In Data View, scroll right and see the new Sales Category column.
9. Test it: Create a Pie Chart with Sales Category as the Legend and Sales as the Values.
· You’ll see how much revenue comes from High, Medium, and Low orders.

Scenario 3: Extracting Date Parts (Year, Month, Quarter)
Business Context: The finance team needs reports grouped by Year, Quarter, and Month for trend analysis.
Steps:
1. In the Orders table, select Modeling → New Column.
2. For Year, type:
3. Order Year = YEAR([Order Date])
4. Create another new column for Month:
5. Order Month = FORMAT([Order Date], "MMMM")
6. Create another new column for Quarter:
7. Order Quarter = "Q" & FORMAT([Order Date], "Q")
8. Press Enter after each formula.
9. Test it: Create a Table visual with Order Date, Order Year, Order Quarter, and Order Month.
· You’ll see the extracted values for each row.









· What is a Measure?
A formula that calculates something (like total sales, average profit) based on filters (region, year, category).
Measures are dynamic → they change when you use slicers.
Unlike calculated columns, they don’t take up storage because they calculate on the fly.
· Why Measures are better than Calculated Columns?
· Calculated column → stored in the table row by row (e.g., profit per order).
· Measure → works on totals/aggregates (e.g., total profit across all orders).
Example: If you want “profit margin %”, it should be a measure, not a column.
· Key DAX functions (beginner level):
· SUM → add values.
· AVERAGE → average values.
· COUNTROWS → count rows.
· DIVIDE → division with safety (avoid divide by zero).
· CALCULATE → apply filters to change calculation (we’ll just use it once in a simple way).


Practical 1 — Total Sales
Scenario: Manager asks: “What is the total sales amount?”
Steps:
1. In Power BI, right-click on the Orders table → select New Measure.
2. Enter this formula:
3. Total Sales = SUM(Orders[Sales])
4. Create a Card visual and drag Total Sales.
5. Add a Slicer for Region.
6. Notice the number changes when you filter — that’s the power of measures!

Practical 2 — Total Profit
Scenario: Finance team asks: “How much profit did we make?”
Steps:
1. New measure:
2. Total Profit = SUM(Orders[Profit])
3. Create a Card visual and drag Total Profit.
4. Add a Table visual with Category and Total Profit.
5. See how profit changes across categories.






Practical 3 — Profit Margin %
Scenario: Boss asks: “What % of our sales is profit?”
Steps:
1. First, make sure you already have Total Profit and Total Sales.
2. New measure:
3. Profit Margin % = DIVIDE ([Total Profit], [Total Sales], 0)
(This avoids errors when Sales = 0).
4. Format as Percentage.
5. Add a Table visual with Category, Total Sales, Total Profit, Profit Margin %.

Practical 4 — Average Sales per Order
Scenario: Sales manager asks: “On average, how much do we sell per order?”
Steps:
1. New measure:
2. Avg Sales per Order = AVERAGE(Orders[Sales])
3. Create a Card visual for this measure.
4. Add a slicer for Segment to compare averages between Consumer, Corporate, Home Office.

Practical 5 — Number of Orders
Scenario: Logistics team asks: “How many orders did we process?”
Steps:
1. New measure:
2. Order Count = COUNTROWS(Orders)
3. Create a Card visual with Order Count.
4. Add a slicer for Region or Category to see how counts change.

Summary:
· Measures are flexible: they automatically adjust based on filters and slicers.
· Columns are fixed row-by-row: but measures are calculated at the time of analysis.
· With just SUM, AVERAGE, COUNTROWS, DIVIDE you can answer most real-world business questions.
· You don’t need complex DAX to start — just these basics can build 80% of dashboards!











Managing Hierarchies

Concepts
· What is a Hierarchy in Power BI?
· A hierarchy is a logical structure that organizes data into different levels.
· Example: Date Hierarchy (Year → Quarter → Month → Day).
· It allows users to start at a high level and drill down into more detail.
· Why are Hierarchies Useful?
· Simplifies navigation: Instead of selecting multiple fields each time, you just drag the hierarchy.
· Supports drill-down analysis: Users can zoom into details (e.g., from yearly sales down to daily sales).
· Improves visuals: Keeps reports interactive and more meaningful.

Common Types of Hierarchies in Business Reports:
1. Date Hierarchy – Year → Quarter → Month → Day.
3. Example: Analyze sales from yearly trends down to daily sales.
2. Geography Hierarchy – Country → State → City.
3. Example: Understand performance at national, regional, and city levels.
3. Product Hierarchy – Category → Sub-Category → Product Name.
3. Example: Track sales at the product line level down to individual items.
Drill-Up and Drill-Down in Power BI:
· Drill-Down: Click an element (like 2023 sales) and move to the next level (quarters or months).
· Drill-Up: Move back to higher-level summaries (from month back to quarter, or year).
· Helps both managers (high-level summary) and analysts (detailed breakdown).

Practical Using Sample Superstore

Practical 1: Create a Date Hierarchy (Year → Quarter → Month → Day)
Scenario: The management wants to analyze sales trends over time — starting at yearly trends but with the ability to drill down into quarters, months, and individual days.
Steps:
1. Open Power BI Desktop and load the Sample Superstore dataset.
2. In the Fields pane, locate the Order Date column (Orders table).
3. By default, Power BI automatically detects a Date Hierarchy for this column.
· Expand Order Date and you’ll see Year, Quarter, Month, Day.
4. Drag the entire Order Date Hierarchy into the Axis of a visual (e.g., Column Chart).
5. Drag Sales into the Values field.
6. You’ll now see Sales by Year.
7. To drill down:
· Click the drill-down arrow (or right-click a year and select Drill Down).
· Move into Quarter → Month → Day.
8. To drill up:
· Click the Drill Up button (an upward arrow on the visual).
Result: An interactive time-based hierarchy where you can move between yearly and daily views of sales.

Practical 2: Create a Geography Hierarchy (Country → State → City)
Scenario: Regional managers want to track sales performance at different geographic levels — from country totals down to each city.
Steps:
1. In the Fields pane, locate the geography-related columns in the Orders table:
· Country
· State
· City
2. Right-click on the Country field and select Create hierarchy.
· This creates a new hierarchy starting with Country.
3. Rename it Geography Hierarchy (click the three dots → Rename).
4. Drag State into this hierarchy (under Country).
5. Drag City into this hierarchy (under State).
6. Now drag the Geography Hierarchy into the Axis of a visual (e.g., TreeMap or Bar Chart).
7. Add Sales into Values.
8. The visual will initially show Sales by Country.
9. Use the drill-down button to go deeper → State level → City level.
Result: A flexible hierarchy that allows you to zoom into different geographic levels for sales analysis.

Practical 3: Demonstrate Drill-Up & Drill-Down
Scenario: Your CEO asks, “Show me U.S. sales, but also let me explore which states and cities contribute the most.”
Steps:
1. Use the Geography Hierarchy created earlier.
2. Insert a Map Visual or Bar Chart.
3. Place the Geography Hierarchy in Location/Axis.
4. Place Sales in Values.
5. The visual shows Country-level sales (only “United States” in Superstore).
6. Click the drill-down button to move to State level.
7. Drill further into City level.
8. Use drill-up button to move back.

1. Column & Bar Charts (Clustered / Stacked)
When to use
· Compare quantities across categories (e.g., Sales by Category).
· Use column for time trends by period on x-axis; use bar when category names are long or many.
· Use stacked version to show contribution of parts to totals.
Practical 1 — Sales by Category (Clustered Column)
Scenario: The Sales Manager wants to see which product categories bring the most revenue.
Steps:
1. Open Report view, add a blank page named “Sales by Category”.
2. From Visualizations choose Clustered column chart.
3. From Fields, drag Category → Axis, drag Sales → Values.
4. (If Order Date used) remove any Year hierarchy from Axis — keep Category only.
5. Format: Visualizations → Format pane → Data labels → turn on, adjust font size.
6. Title: “Total Sales by Category”. Save.
Practical 2 — Sales by Sub-Category per Category (Stacked Column)
Scenario: Marketing wants to see sub-category contribution within each category.
Steps:
1. New page: “Category Breakdown”.
2. Insert Stacked column chart.
3. Drag Category → Axis, Sub-Category → Legend, Sales → Values.
4. Format: Legend position, rotate labels if overlapping.
5. Add slicer for Year so users can filter to a specific year.

2. Line Chart & Area Chart
When to use
· Line chart: show continuous trends over time (monthly/weekly sales).
· Area chart: emphasize magnitude of change and cumulative effect; stacked area shows part-to-whole over time.
Practical 1 — Monthly Sales Trend (Line Chart)
Scenario: CFO wants trend of sales across months to spot seasonality.
Steps:
1. Page: “Monthly Trend”.
2. Add Line chart.
3. Drag Order Date → Axis (ensure it uses Month or Month Year, not full hierarchy if you want month-level), drag Sales → Values.
4. Format: X-axis type = Continuous if you want smooth timeline.
5. Add data label for last point; add forecast (Analytics pane → Forecast) optionally.




Practical 2 — Stacked Area for Category Trends
Scenario: See how each category contributes to monthly sales trend.
Steps:
1. Add Stacked area chart.
2. Drag Order Date → Axis (Month), Sales → Values, Category → Legend.
3. Format: Transparency and legend; enable tooltip.
4. Interact with a slicer (Year) to isolate specific year trend.

3. Combo Chart (Line & Column)
When to use
· Compare two measures with different scales (e.g., Sales as column and Profit Margin as line).
· Show relationship between amount and rate.
Practical 1 — Sales (Column) vs Profit Margin (Line)
Scenario: Executive wants to see Sales and Profit Margin together.
Steps:
1. Page: “Sales vs Margin”.
2. Add Line and stacked column chart (combo).
3. Drag Order Date → Axis (Year or Month).
4. Drag Sales → Column values, create a measure Profit Margin = DIVIDE(SUM(Orders[Profit]), SUM(Orders[Sales])) and drag to Line values.
5. Format: set secondary axis for Margin if needed.
Practical 2 — Quantity vs Average Price
Scenario: Product team wants to compare quantity sold vs average price per unit.
Steps:
1. Create measure AvgPrice = DIVIDE(SUM(Orders[Sales]), SUM(Orders[Quantity])).
2. Add combo chart; Order Date → Axis, Quantity → Column Values, AvgPrice → Line Values.
3. Format axes and data labels.

4. Pie & Donut Charts
When to use
· Show part-to-whole for a limited number of categories (not for many tiny slices).
· Good for quick market-share style visuals.
Practical 1 — Market Share by Region (Donut)
Scenario: Marketing wants the share of sales by region.
Steps:
1. Page: “Market Share”.
2. Insert Donut chart.
3. Drag Region → Legend, Sales → Values.
4. Add data labels: show percentage and value in Format → Details labels.

Practical 2 — Sales Share by Top 5 Products (Pie)
Scenario: Product manager wants to see top contributors.
Steps:
1. Create a Top N filter or measure to select top 5 products by Sales (Filter pane → Product Name → Top N → 5 by Sales).
2. Insert Pie chart and drag Product Name → Legend, Sales → Values.
3. Format labels and legend.

5. Treemap
When to use
· Show hierarchical proportions; use when many categories but you want area-based comparison.
· Good for category/sub-category visualizations where space is compact.
Practical 1 — Treemap of Category/Sub-category Sales
Scenario: Quick visual of which sub-categories dominate.
Steps:
1. Page: “Treemap Category”.
2. Insert Treemap.
3. Drag Category → Group, Sub-Category → Details (or add both to group), Sales → Values.
4. Format: labels to show both name and value.
Practical 2 — Profit Contribution by Sub-Category
Scenario: Finance wants to spot high-profit sub-categories.
Steps:
1. Insert Treemap; Sub-Category → Group, Profit → Values.
2. Use Conditional formatting if needed (Format → Data colors) via measure buckets.

6. Scatter & Bubble Charts
When to use
· Show relationships between two numeric measures; bubble size adds third metric (e.g., Sales vs Profit with Quantity as size).
· Useful for outlier detection and segmentation.
Practical 1 — Sales vs Profit Scatter
Scenario: Identify products with high sales but low profit (potential problem).
Steps:
1. Page: “Sales vs Profit”.
2. Insert Scatter chart.
3. Drag Sales → X Axis, Profit → Y Axis, Product Name → Details, Quantity → Size (optional).
4. Add Category → Legend to color points.
5. Format data labels and tooltip.


Practical 2 — Bubble Chart for Customer Value
Scenario: Spot top customers by revenue and profitability.
Steps:
1. Create an aggregated table or use Customers as Details.
2. Scatter: X = Total Sales, Y = Profit, Size = Number of Orders (Count), Details = Customer Name.
3. Use slicer for Year.

7. Map Visuals (Bubble Map)
When to use
· Visualize geospatial distribution of measures (sales by city/state).
· Works well when location data is present and reasonably accurate.
Practical 1 — Sales by State (Bubble Map)
Scenario: Logistics wants hotspots of sales.
Steps:
1. Page: “Sales Map”.
2. Select State column in Data view → Column tools → Data Category → State or Province.
3. Insert Map visual (bubble map).
4. Drag State → Location, Sales → Size, Sales or State → Tooltips.
5. Format map style and bubble size.
Practical 2 — City-level Sales (Map)
Scenario: Field team needs city-level areas to visit.
Steps:
1. Set City column data category to City.
2. Insert Map; Location = City, Size = Sales.
3. Add Region to Legend if you want color differentiation (note: some map visuals ignore legend).

8. Filled Map (Choropleth) & Shape Map
When to use
· Filled map (choropleth): color regions by value (e.g., Sales per state). Great for relative intensity.
· Shape map: use your own TopoJSON to map custom regions or finer control.
Practical 1 — Filled Map of Sales per State
Scenario: Show intensity of sales across states.
Steps:
1. Ensure State data category set to State.
2. Insert Filled map.
3. Location = State, Color saturation (or Values) = Sales.
4. Format color scale and legend.



9. Table Visual
When to use
· Show raw/tabular data with exact numeric values; useful for detailed reports and export.
· Best for exact reporting, lists, or data checking.
Practical 1 — Detailed Sales Table
Scenario: Finance needs a detailed order-level listing with sales and profit.
Steps:
1. Page: “Sales Table”.
2. Insert Table visual.
3. Add fields: Order ID, Order Date, Customer Name, Product Name, Sales, Profit, Quantity.
4. Format numeric columns (column tools → Format → Currency), sort by Sales.
Practical 2 — Conditional Formatting in Table
Scenario: Highlight orders where Profit is negative.
Steps:
1. In the Table visual, click the down arrow of Profit in Values → Conditional formatting → Background color (or Font color).
2. Set rules: Red for negative values, green for positive.
3. Apply and verify.

10. Matrix Visual
When to use
· Cross-tab reports with row/column groups and subtotals (like pivot tables).
· Good for hierarchical drill-down and compact aggregation.
Practical 1 — Sales Matrix by Region & Category
Scenario: Manager wants sales by Region (rows) and Category (columns).
Steps:
1. Page: “Sales Matrix”.
2. Insert Matrix.
3. Rows = Region, Columns = Category, Values = Sales.
4. Turn on Row subtotals and column subtotals from Format.
Practical 2 — Drill on Matrix with Date Hierarchy
Scenario: Show Year → Quarter → Month breakdown.
Steps:
1. Matrix Rows = Region, Columns = Order Date (use hierarchy), Values = Sales.
2. In visual header, enable Drill Down and demonstrate clicking to drill into quarters and months.




11. Cards, Multi-row Card & KPI
When to use
· Cards: show single value KPIs (Total Sales, Total Orders).
· Multi-row Card: show a small set of KPIs together.
· KPI visual: show a metric vs target or trend context.
Practical 1 — KPI Dashboard Top Cards
Scenario: On the dashboard, show Total Sales, Total Profit, Total Orders.
Steps:
1. Insert three Card visuals.
2. Card 1 → Sales (Sum), Card 2 → Profit, Card 3 → create measure TotalOrders = DISTINCTCOUNT(Orders[Order ID]) and drag.
3. Format size and font consistent.
Practical 2 — KPI with Target
Scenario: Show Sales vs Target for the year.
Steps:
1. Create measure SalesTarget (enter a number or derive).
2. Insert KPI visual.
3. Indicator → Sales, Target goal → SalesTarget, Trend Axis → Order Date (Month).
4. Format goal and status colors.

12. Ribbon Chart
When to use
· Show ranking changes across time or categories (how top items move rank).
· Useful for tracking top N changes.
Practical 1 — Top 5 Products Rank by Year
Scenario: See how product ranks changed across years.
Steps:
1. Insert Ribbon chart.
2. Axis = Year, Legend = Product Name, Values = Sales.
3. In filters, set Top N = 5 by Sales for each year.
4. Format ribbons and labels.
Practical 2 — Region Rank Changes by Quarter
Scenario: Compare Region rank over quarters.
Steps:
1. Ribbon Axis = Quarter, Legend = Region, Values = Sales.
2. Apply color formatting.





13. Slicer (visual filter)
When to use
· Let users filter report pages interactively by selecting values (year, region, category).
· Slicers are not data visuals but fundamental UI controls.
Practical 1 — Year Slicer
Scenario: Allow user to select fiscal year across visuals.
Steps:
1. Insert Slicer visual.
2. Drag Order Date → if a hierarchy appears, use Year; or create a Year column in model and use it.
3. Format as dropdown or list.
Practical 2 — Multi-select Slicers & Sync
Scenario: Slicer for Region with sync across pages.
Steps:
1. Add Region slicer, go to View → Sync slicers → set it to sync across selected pages.
2. Allow multi-select by toggling “Multi-select with CTRL” in Format.

Power BI Service
The Power BI Service is Microsoft’s online platform where you can share, collaborate, and access reports and dashboards from anywhere using a web browser. While Power BI Desktop is mainly for building reports, the Service is all about publishing, sharing, and working together on those reports.

Key Concepts
1. Publishing Reports
· Once you build a report in Power BI Desktop, you can publish it to the Power BI Service with a single click.
· This makes your report available online, so you don’t need to send files back and forth.
Example: A sales manager creates a monthly sales report in Desktop and publishes it to the Service so that the entire team can view it in real time.

2. Workspaces
· Workspaces are like shared folders in the Power BI Service.
· There are two types:
· My Workspace → your personal space for private reports.
· Shared/Team Workspaces → where teams can collaborate.
· In workspaces, you can organize datasets, reports, and dashboards.
Example: The Finance team creates a workspace where only finance staff can access reports.



3. Managing Access & Permissions
· Power BI lets you control who can view, edit, or share reports.
· Roles include:
· Viewer → can only see reports.
· Contributor → can add/edit content.
· Admin → full control.
Example: In a retail company, store managers may get “Viewer” access, while regional managers may get “Contributor” access.

4. Dashboards
· A dashboard is a single page view that combines visuals from different reports.
· You can “pin” charts or KPIs from various reports into one dashboard for a quick summary.
· Dashboards are highly interactive and great for executive decision-making.
Example: A CEO’s dashboard shows Total Sales, Profit Margin, and Top 5 Products all in one page.

5. Scheduling Data Refresh
· Reports in Power BI Service stay up-to-date with automatic refreshes.
· You can schedule daily/weekly refreshes so data is always current.
· This is especially useful when reports connect to live databases or cloud apps.
Example: A marketing dashboard refreshes every morning at 7 AM with the latest campaign data.

Why Power BI Service is Important
· Access reports anytime, anywhere (mobile, tablet, web).
· Collaboration → Teams work on the same reports without emailing files.
· Data Security → Controlled sharing with permissions.
· Real-Time Decisions → Always updated dashboards with scheduled refresh.















Final Project: Build a Superstore Sales Dashboard
Goal:
Create an interactive dashboard to analyse Superstore’s performance by Sales, Profit,
Categories, Regions, and Time.

 High-Level Flow
1. Connect to data
2. Clean & transform data
3. Create relationships
4. Add calculated columns (if not yet done)
5. Add basic measures
6. Build hierarchies
7. Create visuals for different KPIs
8. Format the report & add interactivity
9. Design the final dashboard page
10. Publish to Power BI Service (optional showcase)

Step-By-Step Instructions
Step 1: Connect to Sample Superstore Data
1. Open Power BI Desktop.
2. Click Get Data → Excel Workbook.
3. Browse to the Sample Superstore.xlsx file.
4. Select these sheets/tables:
· Orders
· Returns (optional)
· People (optional)
5. Click Load to bring data into Power BI.

Step 2: Inspect & Clean Data
1. Go to Data View and scan columns for blank or inconsistent values.
2. In Transform Data (Power Query):
· Remove any unnecessary columns (e.g., Row ID if unused).
· Ensure Order Date and Ship Date are Date type.
· Check data types for numeric fields (Sales, Profit, Quantity, etc.).
3. Close & Apply changes.





Step 3: Create Relationships
1. Go to Model View.
2. Verify that:
· Orders[Customer ID] → People[Person] (if relevant)
· Orders[Order ID] → Returns[Order ID] (if using Returns)
3. Drag to create relationships if missing.

Step 4: Add Calculated Columns

In Data View → Table: Orders → New Column, create:
· Profit = [Sales] – [Cost] (if Cost column exists)
· Sales Category = IF( [Sales]>1000,"Large", IF([Sales]>500,"Medium","Small"))
2. Create Year, Month, Quarter columns using the Order Date field:
· Year = YEAR([Order Date])
· Month = FORMAT([Order Date],"MMM")
· Quarter = "Q"&FORMAT([Order Date],"Q")

Step 5: Create Basic Measures
1. Go to Modeling → New Measure:
· Total Sales = SUM(Orders[Sales])
· Total Profit = SUM(Orders[Profit])
· Profit Margin = DIVIDE([Total Profit],[Total Sales])

Step 6: Build Hierarchies
1. In Data View, create a Date Hierarchy:
· Right-click Order Date → New Hierarchy → add Year, Quarter, Month.
2. Create a Geography Hierarchy:
· Add Country → State → City.
3. These hierarchies help with drill-down in visuals.













Step 7: Create Visuals
Switch to Report View and build visuals on a blank page:
	Visual
	Purpose

	Card (Total Sales, Total Profit, Profit Margin)
	Key KPIs at top

	Column Chart: Sales by Category
	See which product categories sell the most

	Line Chart: Monthly Sales Trend
	Show seasonality and growth

	Map / Filled Map: Sales by State
	Show regional performance

	Stacked Bar: Top 10 Customers by Sales
	Identify best customers

	TreeMap: Profit by Sub-Category
	See contribution of sub-categories



Step 8: Add Interactivity
1. Add Slicers for:
· Year
· Region
· Category
2. Test drill-up & drill-down in charts with hierarchies.

Step 9: Format & Polish Dashboard
1. Rename report page to “Executive Dashboard”.
2. Arrange visuals neatly in a 2-row grid layout:
· KPIs at the top (cards)
· Charts/maps below for deeper analysis
3. Apply a built-in Theme (View → Themes) for a professional look.
4. Add a Title Text Box: “Superstore Sales Dashboard”.
5. Add company logo or relevant icon (Insert → Image).

Step 10: Publish to Power BI Service (Optional)
1. Sign in to your Power BI account.
2. Click Home → Publish → Select Workspace.
3. Open the report in Power BI Service to share with classmates or colleagues.
4. Create a Dashboard in the Service by pinning key visuals.
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