banner


Ayuda de R_porter 1.2


Septiembre 2006

Este programa sirve para registrar los archivos guardados en CD's o DVD's (aunque puede usarse para buscar en cualquier unidad o carpeta). Imagina que tienes una colección enorme de MP3, videos, documentos, programas, etc que respaldas continuamente, el problema es cuando tienes que encontrar algo en ellos, la solución de escribir pacientemente encima de ellos lo que contienen no siempre funciona y nunca es completa, a veces es tanta la perdida de tiempo que muchas veces prefieres buscarlo de nuevo en internet a buscarlo en tus backups. Es ahí donde este programa es extremadamente útil para mi, y me ahorra mucho tiempo, gracias a el puedo ver a simple vista que tienen mis backups usando su explorador integrado, o puedo buscar rapidamente por titulo o nombre algún documento o archivo, solo necesito escribir encima del CD o DVD su código para poder encontrarlo.

 

A diferencia de otros programas este programa permite hacer búsquedas precisas, y personalizables, ya que usa una base de datos para almacenar sus registros. Tiene muchos filtros pre-configurados, como buscar por autor, tamaño, nombre, tipo, categoría, etc, los cuales se pueden combinar de muchas formas creando consultas complejas, usuarios avanzados pueden usar su interprete SQL para crear consultas personalizada. Tiene la capacidad de soportar plugins por lo cual se puede, si se quiere, extender su funcionalidad.


Paso a paso: como comenzar tu colección de música:

  1. Instala el programa en modo completo. Si no tienes WinXP es posible que necesites instalar también el MDAC 2.7 o superior, el control MS Script y el soporte de VB6. Todos estos componentes son gratuitos y deberas encontrarlos por tu cuenta en internet. (Generalmente estos componentes estarán ya instalados en tu sistema así que solo debes pensar en descargarlos si el programa no arranca normalmente)

  2. Si el programa se ha instalado correctamente estarás en la ventana principal. (Si te sale algún mensaje diciendo que no estas conectado a un Base de Datos ignóralo, lo harás a continuación)



  3. Crea el DSN para la base de datos por defecto que viene con el instalador (Archivo r_porter.mdb dentro de la carpeta [data]). Usa el menú: [Datos]->[Crear DSN]
    en el cuadro que sale tienes que seleccionar la opción [Origen de datos de sistema] como se muestra:



  4. En el dialogo que sale selecciona el controlador Microsoft Access Driver (si no lo encuentras es que no tienes instalado el MSDAC y tienes que instalarlo primero):



  5. Ingresa el nombre del DNS como se muestra R_porter, usa el botón [Seleccionar...] para seleccionar la base de datos r_porter.mdb (buscala en el directorio en que instalaste el programa dentro de la carpeta [Data]) Cuando aceptes el DSN ya se habrá creado.



  6. De vuelta en el programa principal conéctate a la base de datos. Usa el menú: [Datos]->[Conectar a la BD]
    En el cuadro que sale veras que aparecen los DSN registrados, selecciona el que creaste en el paso anterior, ingresa la contraseña por defecto que es "ex". Prueba la conexión con el botón [Conectar], si la conexión es exitosa verás un mensaje abajo indicando Conexión exitosa [BD].



  7. Los pasos del 3 al 6 sólo son necesarios la primera vez que instalas el programa o si cambias de base de datos, el programa tratará de cargar el DSN R_porter por defecto cada vez que se inicie.

  8. Inserta el CD donde guardas tus archivos a tu lectora.

  9. Selecciona la unidad donde esta el CD que quieres explorar, la opción [Por Unidades] deberá estar activa.



  10. Dale click a [Opciones Avanzadas] y en el cuadro de diálogo que se muestra selecciona la pestaña [1) General]. Si tus archivos están en múltiples carpetas tienes que activar la casilla [Incluir Subdirectorios en la exploración] de lo contrario solo se explorará la carpeta raíz del CD. Activa luego la casilla [Agregar resultados a la BD].
    Recuerda que si esta opción no está activada las pestañas [2) Anexión BD] y [3) MP3] estarán desactivadas, por lo tanto no te olvides de hacerlo.



  11. Ahora dale click a la pestaña [2) Anexión BD]. En esta pestaña puedes ingresar el nombre del medio "música-01" por ejemplo, yo ordeno mis archivos MP3 por género en diferentes carpetas, si esto es así para ti activa la casilla [Establecer genero por subdirectorio]. También acostumbro llamar a mis archivos con la convención: autor-nombre.mp3, si tienes esa convención activa la casilla [Considerar archivo como (autor - nombre)]. Casi siempre debes de activar la opción [Establecer tipo por extensión] para establecer el tipo del registro de acuerdo a la extensión que tenga el nombre del archivo (en nuestro caso MP3). La prioridad es la prioridad que se le asignarán a todos los archivos. Es bueno poner una prioridad de uno o cero para asignar prioridades mayores a archivos más importantes posteriormente.
    Para guardar información de la estructura de tus CD's o DVD's (directorios y subdirectorios) activa la opción [Añadir información de directorios a la BD]. Esto es muy importante si quieres usar la vista de exploración.



  12. Como este es un CD de MP3 dale click a la pestaña [3) MP3], en la ventana que te sale activa las opciones [Extraer calidad de archivos MP3] y [Añadir información MPEG - Audio (MP3)], con esto el programa extraerá automáticamente el bitrate del archivo MP3, lo cual es útil si tienes varios archivos de la misma canción y quieres saber cual suena mejor. La opción [VBR] si esta activa tratará de determinar si el MP3 tiene bitrate variable (en cuyo caso dirá que vale cero). El algoritmo para extraer toda esta información de los archivos usa un buffer de búsqueda del tamaño indicado. Si no sabes lo que es esto sería buena idea dejarlo en los valores por defecto. Dicho en forma simple: a mayor buffer la exploración es mas lenta, a menor buffer los resultados son menos preciso (algunos MP3 pueden estar corruptos o tener un Tag ID3v2 muy grande). Cierra el cuadro de opciones pulsando el botón [Aceptar]



  13. Todo esta listo para empezar. Dale click a [Iniciar Exploración] y te saldrá otra ventana con un reporte a medida que se anexan los registros a la base de datos. Puedes cancelar la operación con [Detener] o la tecla [ESC]



  14. Ahora usa el menú [Datos]->[Control de Registros] para ver los resultados. Como el enfoque esta sobre el campo [Nombre] si presionas ahora la tecla [ENTER] se mostrarán todos los archivos registrados:



  15. La vista de exploración es sumamente útil para ver el contenido de tus discos. Para cargarla selecciona el menú [Datos]->[Explorar BD]:



  16. Hay varias opciones para la busqueda, por ejemplo para buscar solo las canciones cuyo nombre tengan la palabra "fall" escribe eso en el campo [Nombre], dale click al botón que tiene al costado, y en las opciones que salen selecciona [Que contenga... (palabra completa)] luego presiona la tecla [ENTER].



  17. ¿Quieres crear tu propia consulta?. Usa el menú [Avanzado]->[Ejecutar comando SQL] En la ventana que sale puedes ingresar la consulta SQL que quieras.



  18. Para ver la estructura de la base de datos usa el menú: [Datos]->[Ver estructura de la BD] así podrás saber las tablas y campos de la base de datos.



  19. En la ventana SQL ingresa: SELECT * FROM file WHERE (id_file>0) AND (id_file<10). Presiona la tecla [F5]



  20. Te saldrá una ventana con los resultados en una tabla.



  21. También puedes usar plugins con el programa, por ejemplo el plugin [exPlugin_explorer] permite también ver la estructura de archivos de la base de datos. Pero para poder usarlo primero tienes que registrarlo. Desde la ventana principal selecciona el Menú [Plugins]->[Registrar plugin], selecciona el DLL: exPlugin_explorer.dll y dale click a [Abrir]. Te saldrá un mensaje diciendo que el registro se realizo con éxito.



  22. Ahora abre el control de plugins con [F4].



  23. Dale doble click al plugin seleccionado y se cargara la ventana de exploración del plugin.



  24. MUY IMPORTANTE: recuerda hacer un respaldo de tus base de datos (puedes tener muchas bases de datos cada una para guardar tipos de archivos diferentes). Usa el DSN R_porter para la base de datos que uses frecuentemente. Las bases de datos no necesitan estar en el mismo directorio del programa, ubicalos donde te sea fácil hacerles copias de seguridad. (Es el DSN el que debe apuntar a la ruta correcta) Si se pierde la base de datos toda tu información se perderá.

 

 

 

 

 

 

 

 


Diseño y coordinación : Esaú Rodriguez Oscanoa - Lima - Perú

Esta página se ve mejor en Mozilla Firefox a 1024x768


Hosted by www.Geocities.ws

1