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BAB 6 : PENGENALAN KEPADA MACROMEDIA FLASH MX 

 

6.1 Pengenalan 

 

Macromedia Flash MX merupakan sebuah perisian Pengarangan Multimedia yang sangat popular. 

Perisian ini digunakan dalam menghasilkan produk-produk Multimedia seperti CD-Interaktif, 

Persembahan Multimedia, Laman Web, permainan komputer, animasi dan banyak lagi. Ia merupakan 

perisian pengarangan berasaskan masa di mana Garis Masa akan digunakan semasa proses 

pengarangan. 

 

 

Gambarajah : Macromedia Flash MX 

 

6.2 Memulakan Aplikasi Macromedia Flash MX 

 

Berikut adalah langkah-langkah untuk memulakan perisian Flash: 

 

 Klik pada butang Start. 

 Klik pada All Programs. 

 Klik pada folder Macromedia. 

 Pilih Macromedia Flash MX. 

 

 

Gambarajah : Memulakan Macromedia Flash MX 
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6.3 Antaramuka Macromedia Flash MX 

 

Gambarajah di bawah merupakan antamuka bagi Macromedia Flash MX. 

 

 
 

 a Toolbox 

b Stage 

c Timeline 

d Panel 

 

Toolbox 

 

Toolbox  terbahagi kepada empat bahagian, iaitu Tools, View, Colors dan Option. 

 

       

Gambarajah : Toolbox 
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Bahagian Tools mengandungi alatan-alatan untuk memilih, melukis, mencipta teks, memadam dan lain-

lain lagi. Bahagian View pula digunakan untuk menukar pandangan pada Stage. Bahagian Color 

digunakan untuk memilih Stroke Color dan Fill Color. Bahagian Option pula mengandungi opsyen 

tambahan untuk Tools. 

 

Stage 

 

Stage merupakan ruang kerja utama dalam Flash. Di sinilah anda menyusun semua objek sama ada 

yang dilukis atau yang diimport. Saiz Stage dan warna latar belakang boleh diubah mengikut 

kesesuaian kerja anda. Gunakan Panel Properties untuk menukar saiz dan warna latar belakang Stage. 

 

 

Gambarajah : Menukar Stage Properties  

 

Berikut adalah langkah-langkah untuk menukar saiz dan warna latar belakang Stage: 

 

 Klik pada Stage. 

 Buka Panel Properties. 

 Klik pada butang Size dan kotak dialog Document Properties akan muncul. 

 Tukarkan saiz dan warna latar belakang Stage. 

 Klik OK. 

 

 

Gambarajah : Kotak dialog Document Properties 

  

Anda boleh mengubah pandangan pada Stage dengan menggunakan Zoom Control yang terletak di 

bahagian atas Stage. 
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Gambarajah : Menukar pandangan ruang kerja 

  

Timeline 

 

Konsep Timeline atau Garis Masa diambil dari perisian penyuntingan video. Pada Timeline tersebut 

terdapat kotak-kotak kecil yang dipanggil Bingkai (Frame). Bahagian Layer pula digunakan untuk 

mengasingkan objek-objek supaya mudah diurus. 

 

 

 Gambarajah : Timeline 

 

Bahagian Layer 

 

Bahagian ini digunakan untuk mengurus Layer seperti menambah, memadam, menukar nama dan 

mengubah kedudukan Layer. 

 

  

Gambarajah : Layer pada Timeline 
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a Layer 

b Nama Layer 

c Menambah Layer 

d Menyembunyikan Layer 

e Mengunci Layer 

f Mode Fill/Outline 

g Memadam Layer 

 

Bahagian Frame 

 

 

Gambarajah : Frame 

  

a Playhead 

b Bingkai kosong 

c Keyframe 

d Tween Shape 

e Tween Motion 

f Penunjuk lokasi Bingkai 

  

Bingkai Kosong menunjukkan bahawa tiada sebarang objek dalam Stage untuk Layer tersebut. Setelah 

dimasukkan objek, Bingkai Kosong akan bertukar menjadi Keyframe. 

 

Panel 

 

Flash mengandungi beberapa Panel seperti Action, Properties, Color Mixer, Color Swatches dan lain-

lain lagi. Setiap panel ini mempunyai fungsi yang berbeza-beza. Panel ini boleh dibuka apabila hendak 

digunakan atau ditutup apabila tidak diperlukan.  Panel boleh didapati dari menu Window. 
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Library 

 

Library ialah tempat di mana simbol dan fail yang diimport disimpan. Tekan kekunci F11 untuk 

membuka Library. Library memudahkan anda mengurus segala simbol dan fail yang akan digunakan. 

Anda boleh mengumpul simbol atau fail dalam Folder atau memadam simbol atau fail yang tidak 

diperlukan. 

 

6.4 Format Fail Flash 

 

Fail Flash terbahagi kepada tiga format, iaitu Project, Flash  Movie dan Projector. 

 

  

Gambarajah : Format fail Flash 

 

Fail Project ialah fail yang digunakan semasa pembangunan. Pastikan fail ini tidak dipadam kerana 

apabila anda hendak mengubai suai persembahan Flash anda, anda akan menggunakan kembali fail ini. 

Fail ini mempunyai sambungan .fla Fail Flash  Movie pula digunakan untuk memaparkan persembahan 

Flash. Fail ini tidak boleh diedit semula. Untuk melihat kandungan fail ini, anda perlukan Flash Player. 

Fail ini mempunyai sambungan .swf. Fail Projector juga dikenali sebagai Standalone, bermaksud boleh 

dimainkan tanpa perlu perisian Flash atau Flash Player. Fail ini juga tidak boleh diedit semula. Fail ini 

mempunyai sambungan .exe. 

 

6.5 Membina Fail Baru 

 

Berikut adalah langkah-langkah untuk membina fail baru: 

 

 Klik pada menu File. 

 Pilih New. 
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 Gambarajah : Membina fail baru 

 

6.6 Membuka Fail 

 

Berikut adalah langkah-langkah untuk membuka fail: 

 

 Klik menu File > Open 

 Kotak dialog Open akan muncul, pilih fail yang hendak dibuka. 

 Klik Open. 

 

6.7 Menyimpan Fail 

 

Fail Macromedia Flash MX berbeza dengan fail Flash versi terbaru atau sebelumnya. Sekiranya anda 

menyimpan sebagai format Flash MX, fail tersebut tidak boleh dibuka pada Macromedia Flash versi 

lain. Sekiranya anda hendak membuka fail Flash pada versi yang berbeza, pilih format fail yang sesuai.  

Berikut adalah langkah-langkah untuk menyimpan fail: 

 

 Klik menu File>Save As. 

 Taipkan nama fail pada ruangan File Name. 

 Pilih format fail Flash pada ruangan Save as Type. 

 Klik Save. 
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BAB 7 : GRAFIK, TEKS DAN SYMBOL 

 

7.1 Alatan-Alatan Dalam Toolbox 

 

Tool Nama Kegunaan 

 
Arrow Tool Memilih dan memindahkan objek 

 

Subselection 

Tool 
Memilih titik 

 
Lasso Tool Memilih objek bentuk bebas 

 
Line Tool Membina garisan 

 
Pen Tool Melukis garisan 

 
Oval Tool Melukis bulatan 

 
Rectangle Tool Melukis segi empat 

 
Text Tool Mencipta teks 

 
Pencil Tool Melukis dengan pensel 

 
Brush Tool Mewarna 

 
Ink Bottle Tool Mewarna garisan 

 

Paint Bucket 

Tool 
Mewarna dalaman 

 

Eye Dropper 

Tool 
Mengambil sampel warna 

 

Free Transform 

Tool 
Mengubah bentuk 

 

Fill Transform 

Tool 
Mengubah warna dalaman 

 
Eraser Tool Memadam 

 

Stroke Color dan 

Fill Color 

Stroke Color digunakan untuk mewarna 

garisan manakala Fill Color untuk 

mewarna dalam dan teks. 
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7.2 Memilih Objek 

 

Gunakan Arrow Tool, Subselection Tool atau Lasso Tool untuk memilih objek. 

 

 

Objek yang belum dipilih. 

 

Objek yang dipilih bahagian dalam 

sahaja. 

 

Objek yang dipilih garisan luar 

sahaja. 

 

Objek yang dipilih garisan dan dalam. 

 

Objek yang dipilih sebahagian sahaja. 
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Objek dipilih secara kumpulan. 

 

 

7.3 Melukis Garisan 

 

Line Tool digunakan untuk melukis garisan sama ada garis lurus atau garis melengkung. Warna garisan 

ditentukan oleh Stroke Color. Ciri-ciri garisan boleh diubah dengan menggunakan Panel Properties 

setelah garisan tersebut dipilih. Berikut adalah langkah-langkah untuk melukis garis lurus: 

 

 Pilih Line Tool. 

 Pilih warna dari Stroke Color. 

 Klik dalam Stage dan mula melukis. 

 

 

Gambarajah : Garisan yang dilukis menggunakan Line Tool 

 

 

Gambarajah : Menukar Line Properties 
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Stroke Color digunakan untuk mengubah warna garisan. Stroke Height digunakan untuk mengubah 

ketebalan garisan. Stroke Style digunakan untuk menukar bentuk garisan. Apabila anda menukar ciri-

ciri garisan, ciri-ciri tersebut juga akan digunakan pada objek yang baru dilukis sama ada menggunakan 

Line Tool, Oval Tool atau Rectangle Tool. 

 

7.4 Melukis Bentuk 

 

Anda boleh melukis bentuk dengan menggunakan Oval Tool dan Rectangle Tool. Setiap bentuk yang 

dilukis mempunyai garisan luar (stroke) dan dalaman (fill).  

 

 

Gambarajah : Melukis bulat dan segi empat 

 

Anda juga boleh melukis segi empat bucu bulat dengan menggunakan Rectangle Tool, dengan memilih 

opsyen Round Rectangle Radius di bahagian Option. 

 

 

Gambarajah : Opsyen Round Rectangle Radius 

 

 

Gambarajah : Kotak dialog Rectangle Settings 

 

 

Gambarajah : Segi mepat bucu bulat 
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Anda boleh mengubah sebarang bentuk dengan menggunakan Arrow Tool dan Free Transform Tool. 

Gunakan Arrow Tool untuk mengubah sisi yang rata menjadi melengkung. 

 

  

Gambarajah : Mengubah bentuk menggunakan Arrow Tool 

 

Free Transform Tool pula digunakan untuk mengubah saiz objek, memutarkan objek, skew dan juga 

distort. 

 

 

Gambarajah : Menggunakan Free Transform Tool untuk mengubah bentuk 

 

7.5 Pencil Tool 

 

Pencil Tool digunakan untuk melukis seperti menggunakan pensel. Ia sesuai digunakan untuk melukis 

garisan yang lebih menarik. Warna Garisan ditentukan oleh Stroke Color. Pada bahagian Option pula, 

terdapat tiga pilihan iaitu Straighten untuk menghasilkan garisan lurus atau tegak, Smooth untuk 

garisan melengkung dan Ink untuk garisan bebas. 

 

 

Gambarajah : Opyen untuk Pencil Tool 
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7.6 Brush Tool 

 

Brush Tool digunakan untuk mewarna bahagian dalam objek. Warna ditentukan pada Fill Color. Pada 

bahagian Option, terdapat Brush Mode yang digunakan untuk menentukan kaedah mewarna. 

 

 

Gambarajah : Opsyen untuk Brush Tool 

 

 

 

a Objek asal 

b Paint Normal 

c Paint Fills 

d Paint Behind 

e Paint Selection 

f Paint Inside 

Gambarajah : Perbezaan opsyen Brush Tool 

 

Pada bahagian Option juga terdapat opsyen untuk menukar saiz berus dan bentuk berus. 
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Gambarajah : Menukar saiz dan bentuk berus 

 

7.7 Ink Bottle Tool dan Paint Bucket Tool 

 

Ink Bottle Tool digunakan untuk menukar warna garisan (stroke) atau mengembalikan garisan yang 

telah dipadam. Warna ditentukan oleh Stroke Color. Paint Bucket Tool pula digunakan untuk mewarna 

dalam objek (fill) atau mengambalikan warna dalam yang telah dipadam. Warna ditentukan oleh Fill 

Color. 

 

7.8 Text Tool 

 

Text Tool digunakan untuk mencipta teks. Panel Properties digunakan untuk mengubah ciri-ciri teks 

seperti menukar font, saiz, warna dan lain-lain lagi. 

 

 

Gambarajah : Panel Properties untuk teks 

 

 
Menukar font 

 

Menukar saiz font 

 
Menukar warna font 

 

Menukar stail font 

 
Menukar arah teks 

 
Menukar text alignment 

 
Menjarakkan aksara 

 
Menukar kedudukan teks 
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Semasa anda menaip, kotak teks akan muncul dan anda akan menaip di dalam kotak tersebut. Kotak 

teks mempunyai dua bentuk iaitu saiz tetap dan saiz tidak tetap.  Kotak saiz bersaiz tetap mempunyai 

simbol segiempat di penjuru kanan atas manakala simbol bulat bagi bersaiz tidak tetap.  

 

  

Gambarajah : Perbezaan kotak teks bersaiz tetap dan tidak tetap 

 

Format Option pula digunakan untuk mengubah ciri-ciri perenggan. 

 

 

Gambarajah : Kotak dialog Format Options 

 

 

Gambarajah 

 

Teks juga boleh ditukar menjadi bentuk (shape), supaya teks tersebut tidak berubah jika dibuka pada 

komputer yang tidak mempunyai font yang digunakan. Berikut adalah langkah-langlah untuk 

menukarkan teks menjadi bentuk. 

 

 Pilih teks tersebut. 

 Pilih menu Modify > Break Apart dan lakukannya sebanyak dua kali. 
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7.9 Mengimport Fail 

 

Anda boleh mengimport fail imej dan menggunakannya dalam persembahan Flash anda.  Format fail 

imej yang boleh diimport ialah JPEG, GIF, BMP, AI dan lain lain lagi.  Anda boleh mengimport fail 

tersebut terus ke dalam Stage atau mengimport ke dalam Library. Arahan untuk mengimport fail 

terdapat dalam menu File, iaitu Import dan Import to Library. 

 

 

Gambarajah : Menu untuk mengimport fail 

 

7.10 Symbol dan Instances 

 

Symbol adalah grafik, butang dan movie clip yang anda hasilkan dalam Flash dan boleh digunakan 

berulang-ulang kali. Ini bermaksud anda boleh menghasilkan satu objek dan objek tersebut boleh 

digunakan semula tanpa perlu melukiskannya kembali. Setiap Symbol yang dihasilkan akan disimpan 

di dalam Library. Instance pula merupakan salinan kepada Symbol yang dimasukkan ke dalam Stage. 

Instance boleh diubah warna, saiz dan fungsi. 

 

 

Gambarajah : Symbol dan Library 
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Terdapat tiga jenis Symbol, iaitu Graphic, Button dan Movie Clip. 

 

 
Graphic 

 
Button 

 
Movie Clip 

 

Graphic biasanya berbentuk imej statik atau tidak bergerak. Button pula digunakan untuk 

menghasilkan persembahan yang interaktif di mana ia akan memberikan respon apabila diklik. Movie 

Clip digunakan untuk animasi yang boleh digunakan secara berulang-ulang dan ia boleh dimainkan 

tanpa henti (looping) atau sekali sahaja. 

 

7.11 Menghasilkan Symbol 

 

Symbol boleh dihasilkan sama ada menghasilkan Symbol yang baru atau menukarkan sebarang objek 

menjadi Symbol. Berikut adalah langkah-langkah untuk menghasilkan Symbol yang baru: 

 

 Pilih menu Insert > New Symbol atau tekan Ctrl+F8 

 Satu kotak dialog akan muncul. 

 

 

Gambarajah 

 

 Taipkan nama Symbol. Pilih nama yang sesuai. 

 Tentukan jenis Symbol sama ada Movie Clip, Button atau Graphic. 

 Klik Ok. 

 Buka Library dengan menekan F11 untuk memastikan Symbol telah berjaya dihasilkan. 

 

Berikut adalah langkah-langkah untuk menukarkan sebarang objek di Stage menjadi Symbol: 

 

 Pilih objek yang hendak ditukarkan menjadi Symbol dengan menggunakan Arrow Tool. 

 Pilih menu Insert>Convert to Symbol atau tekan F8. 

 Satu kotak dialog akan muncul. 
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Gambarajah 

 

 Taipkan nama Symbol. 

 Pilih jenis Symbol yang sesuai. 

 Tentukan titik tengah untuk Symbol pada opsyen Registration. 

 Klik OK. 

 Buka Library (F11) untuk memeriksa Symbol. 

 

 

Gambarajah : Library 
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BAB 8 : ASAS-ASAS MENGHASILKAN ANIMASI 

 

8.1 Animasi Frame-By-Frame 

 

Animasi frame-by-frame merupakan kaedah menghasilkan animasi menggunakan bingkai pada 

Timeline. Animasi yang dihasilkan bergantung kepada bilangan bingkai yang digunakan. Setiap 

bingkai mungkin mempunyai gambar yang sama atau gambar yang berbeza.  Sekiranya anda 

menggunakan gambar yang sama, gunakan arahan Insert > Keyframe atau tekan F6 untuk menyalin 

gambar dari bingkai sebelumnya. Jika anda hendak menggunakan gambar yang berbeza untuk bingkai 

berikutnya, gunakan arahan Insert > Blank Keyframe. Berikut adalah contoh animasi menggunakan 

kaedah frame-by-frame. 

 

Bingkai Timeline Stage 

1 

 

 

2 
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3 

 

 

4 

 

 

5 

 

 

 

Apabila animasi ini dimainkan, anda akan dapati objek bulat berada di atas pada bingkai yang pertama, 

kemudian turun ke bawah pada bingkai yang kedua, naik ke atas pada bingkai ke tiga dan tu run 

kembali pada bingkai keempat. Pada bingkai kelima, objek telah bertukar menjadi segiempat. Dari 

bingkai kedua hingga keempat, arahan Insert > Keyframe digunakan untuk menggunakan objek yang 

sama. Pada bingkai kelima pula, arahan Insert > Blank Keyframe digunakan untuk menukar objek bulat 

kepada segi empat. 
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8.2 Tween Motion 

  

Tween Motion digunakan untuk menghasilkan pergerakan objek dari satu titik ke titik yang lain. 

Contoh, satu objek bulat bergerak dari kiri ke kanan. Untuk menghasilkan pergerakan jenis ini, anda 

memerlukan sekurang-kurangnya dua Keyframe. 

 

 

 

Langkah-langkah: 

 

 Lukiskan satu objek dan letakkan di kiri Stage. 

 
 

 Pada Timeline, masukkan Keyframe (F8) pada frame yang ke-10. 

 

 

 Kemudian, pindahkan objek tersebut ke kanan stage. 



 
MACROMEDIA FLASH MX 

 

 45 

 

 

 Klik kanan pada Keyframe yang pertama dan yang kedua dan pilih Create Motion Tween. 

 

 

 Setelah Motion Tween dimasukkan, frame akan menjadi seperti berikut: 

 

 Tekan Enter atau Ctrl+Alt+Enter untuk melihat hasilnya. 

 

Jika anda hendak menggerakkan dua objek yang berbeza, objek-objek tersebut hendaklah diletakkan 

pada layer yang berbeza. Untuk menghasilkan pergerakan yang lebih rumit, maka banyak Keyframe 

diperlukan, di mana setiap Keyframe tersebut menentukan di mana objek itu berada. 
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Berikut merupakan langkah-langkah untuk menghasilkan animasi di atas. 

 

 Pada layer pertama, namakan sebagai “laluan” dan lukiskan laluan untuk objek tersebut 

bergerak. Kemudian, kuncikan layer tersebut. 

 

 
 

 Masukkan layer yang baru dan namakan sebagai “objek”. Lukiskan objek dan letakkan seperti 

berikut: 

 
 

 Pada Timeline untuk layer “objek”, masukkan lima Keyframe dan jarakkan setiap satu. 

 
 

 Pada setiap Keyframe, letakkan objek seperti berikut: 
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Keyframe Kedudukan Objek 

1 

 

2 

 

3 

 

4 
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5 

 

6 

 

 

 Kemudian, klik kanan pada setiap Keyframe dan pilih Create Motion Tween. 

 

 Tekan Enter atau Ctrl+Alt+Enter untuk melihat hasilnya. 

 

Anda juga boleh membuat pergerakan ke atas teks dengan menggunakan kaedah yang sama. 

 

8.3 Objek Berputar 

 

Anda boleh menghasilkan objek berputar sama ada ia berputar pada satu tempat sahaja atau bergerak 

sambil berputar. Berikut adalah langkah-langkah untuk menghasilkan objek yang berputar. 

 

 Gunakan Text Tool dan taipkan teks seperti berikut. 
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 Pada Timeline, masukkan Keyframe seperti berikut. 

 

 

 Klik kanan pada Keyframe pertama dan pilih Create Motion Tween. 

 

 

 Buka Panel Properties dan pastikan “information area” dibuka. 

 Pada opsyen “rotate”, pilih CW atau CCW (arah jam atau lawan arah jam). 

 Opsyen “time” pula menentukan bilangan putaran yang akan dilakukan. 

 

 

 

 Tekan Enter atau Ctrl+Alt+Enter untuk meilhat hasilnya. 

 

Untuk menghasilkan objek yang bergerak sambil berputar, kaedahnya hampir sama cuma anda anda 

perlu mengubah kedudukan objek tersebut pada Keyframe yang kedua. 

 

8.4 Membesar atau Mengecilkan Objek 

 

Kaedah ini akan menjadikan sesuatu objek itu berubah saiz, contohnya objek tersebut pada mulanya 

bersaiz kecil dan kemudiannya menjadi besar. Berikut adalah langkah-langkahnya: 
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 Lukiskan objek seperti berikut:  

 

 

 Pada Timeline, masukkan Keyframe seperti berikut: 

 

 

 Klik kanan pada kedua-dua Keyframe dan pilih Create Motion Tween. 

 

 

 Klik pada Keyframe yang kedua. Pilih Free Transform Tool dan besarkan atau kecilkan  imej 

tersebut. 

 

 Tekan Enter atau Ctrl+Alt+Enter untuk melihat hasilnya. 
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8.5 Menghilangkan Objek 

 

Kaedah ini digunakan untuk menjadikan objek tersebut hilang. Berikut adalah langkah-langkahnya: 

 

 Taipkan teks seperti berikut: 

 
 

 Pada Timeline, masukkan Keyframe seperti berikut: 

 

 

 Klik kanan pada kedua-dua Keyframe dan pilih Create Tween Motion. 

 

 

 Klik pada Keyframe yang kedua dan kemudian klik pada objek. 

 Buka panel Properties. Pada opsyen “color”, pilih Alpha dan setkan nilainya 0%. 

 

 Tekan Enter atau Ctrl+Alt+Enter untuk melihat hasilnya. 
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8.6 Tween Shape 

 

Tween Shape digunakan untuk menjadikan sesuatu objek berubah bentuk, contohnya dari bentuk bulat 

menjadi segi empat atau dari bulat menjadi teks.  Berikut adalah langkah-langkah untuk menukar objek 

bulat menjadi segiempat. 

 

 Lukiskan objek seperti berikut: 

 

 

 Pada Timeline, masukkan Blank Keyframe seperti berkut: 

 

 

 Kemudian, lukiskan objek yang kedua seperti berikut: 

 

 

 Klik Keyframe yang pertama. Buka Panel Properties. Pada opsyen Tween, pilih Shape. 
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 Tekan Enter atau Ctrl+Alt+Enter untuk melihat hasilnya. 

 

Untuk menukarkan sesuatu bentuk kepada teks atau sebaliknya, teks tersebut hendaklah ditukarkan 

menjadi bentuk terlebih dahulu. Caranya, klik pada teks tersebut. Pilih menu Modify>Break Apart. 

Lakukan kaedah ini dua kali. 

 

  

  

 

Gambarajah : Menukar Teks menjadi bentuk 
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BAB 9 :  SCENE, BUTANG DAN PUBLISH 

 

9.1 Scene 

 

Scene boleh dianggap sama seperti satu muka surat atau paparan. Dengan menggunakan Scene, 

persembahan anda akan menjadi lebih mudah untuk diurus kerana anda akan membahagikan 

persembahan anda yang mempunyai beberapa muka surat kepada beberapa Scene. 

 

Sebelum membangunkan persembahan menggunakan Flash, anda harus membina Carta Alir untuk 

memudahkan anda mendapat gambaran awal persembahan yang akan dihasilkan. Di bawah adalah 

contoh Carta Alir untuk membangunkan sebuah persembahan korporat. 

 

 

Gambarajah : Contoh carta alir 

 

9.2 Panel Scene 

 

Panel Scene digunakan untuk mengurus Scene. Dengan menggunakan panel ini, anda boleh melihat 

semua Scene yang ada, menukar nama Scene, menyalin Scene, menukar kedudukan Scene dan juga 

memadam Scene.Untuk membuka panel Scene, tekan Shift+F2. 

 
Gambarajah : Panel Scene 
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9.3 Menambah Scene 

 

Anda boleh menambah Scene bergantung kepada berapa banyak muka surat atau paparan yang ada 

dalam persembahan anda. Cara untuk menambah Scene ialah dengan menggunakan menu Insert > 

Scene atau klik pada Add scene dalam panel Scene. 

 

9.4 Menukar Nama Scene 

 

Nama Scene biasanya merujuk kepada kandungan Scene tersebut. Ini akan memudahkan anda 

mengenalpasti kandungan sesuatu Scene. Cara untuk menukar nama Scene ialah dengan menggunakan 

panel Scene, klik dua kali pada nama Scene tersebut, tukarkan nama Scene tersebut dan tekan Enter. 

 

9.5 Menyalin Scene 

 

Kaedah ini memudahkan anda membangunkan sesuatu persembahan kerana anda hanya perlu menyalin 

Scene yang sama cuma menukar bahagian-bahagian tertentu sahaja. 

Cara untuk menyalin Scene ialah dengan menggunakan panel Scene. Klik pada Scene yang hendak 

disalin, kemudian klik pada Duplicate scene. Pastikan anda menukar nama Scene tersebut. 

 

9.6 Memadam Scene 

 

Anda boleh memadam Scene yang tidak diperlukan. Pastikan anda kenal pasti Scene yang hendak 

dipadam, kerana setelah dipadam, anda tidak boleh mendapatkannya kembali.  Cara untuk memadam 

Scene ialah dengan menggunakan panel Scene. Klik pada Scene yang hendak dipadam kemudian klik 

Delete scene. 

 

9.7 Butang 

 
Butang digunakan untuk memautkan satu muka surat ke muka surat yang lain. Butang biasannya 

digunakan sebagai menu dan dipaparkan dalam setiap muka surat. Butang boleh dihasilkan dalam 

pelbagai bentuk sama ada bulat, segiempat atau bujur. 
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Gambarajah : Contoh butang 

 

Sebelum menghasilkan butang, anda perlu tahu bahawa butang ada tiga keadaan, iaitu:  

Keadaan Bentuk Asal Maksud 

Up Timbul / Warna biasa Keadaan semasa kursor berada di luar butang. 

Over Timbul / Warna Terang Keadaan semasa kursor berada di atas butang. 

Down Tenggelam / Warna Gelap Keadaan semasa kursor menekan butang. 

 

9.8 Button Symbol 

 

Berikut adalah langkah-langkah untuk menghasilkan butang: 

 

 Lukiskan butang seperti berikut: 

 

 

 Select butang tersebut dan tekan F8 untuk menukarkannya menjadi Simbol Butang. 

 

 

 Namakan simbol tersebut. Pada opsyen Behavior pilih “Button”. Klik OK. 

 Buka Library (F11). Pastikan simbol butang ada dalam Library. 
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 Klik dua kali pada simbol butang tersebut untuk mengedit simbol. 

 Perhatikan pada Timeline seperti berikut. Terdapat empat frame iaitu Up, Over, Down dan Hit. 

 

 

 

 Masukkan Keyframe pada Over dan Down. 

 

 

 Klik pada Keyframe Over. Tukarkan warna butang tersebut. Pilih warna yang lebih terang.  

 

 

 Klik pada Keyframe Down. Tukarkan warna butang tersebut. Pilih warna yang lebih gelap.  

 

 

Setiap butang mesti ada label. Label tersebut menunjukkan maksud butang tersebut. Biasanya label 

berbentuk teks.  
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Gunakan Text Tool untuk memasukkan label pada butang. Pilih warna yang berlawanan dengan butang 

tersebut. 

 

9.9 Action Script Untuk Butang 

 

Action Script digunakan untuk menjadikan butang itu berfungsi. Arahan akan ditaip untuk menentukan 

ke mana butang itu akan pergi setelah diklik. Berikut adalah langkah-langkah untuk memasukkan 

Action Script. 

 

 Pilih butang dari Library dan letakkan di dalam Stage. 

 Klik pada butang tersebut. 

 Buka panel “Actions - Button”. 

 Klik pada “Actions”, kemudian “Movie Control”. Klik dua kali pada “goto”. 

 

 

 Klik “Go to and Play”. Pilih “Scene” iaitu muka surat yang hendak dituju. 

 

 

 Tekan Ctrl+Alt+Enter untuk menguji butang tersebut.  

 

9.10 Menukar Fail Flash Kepada Format Player Dan Projector 

Setelah siap membangunkan sebuah fail Flash, kita akan menukarkan fail Flash tersebut menjadi 

format Player atau Projector. Dua format ini hanya digunakan untuk memaparkan Flash Movie tetapi 

tidak boleh diedit. Oleh yang demikian, pastikan fail Flash yang asal tidak dipadam.  
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Format Player (swf) biasanya digunakan dalam laman web. Untuk melihat format ini, kita perlu 

mempunyai perisian Flash atau menginstall Flash Player terlebih dahulu. Jika tidak, flash movie 

tersebut tidak dapat dilihat. Jika anda menggunakan format ini untuk laman web, pastikan anda 

memberitahu penggunjung laman web anda bahawa laman web anda mengandungi flash movie dan 

memerlukan flash player yang boleh didapati secara percuma dari laman web Macromedia.  

Format Projector (standalone) membolehkan persembahan Flash dimainkan pada mana-mana PC 

walaupun PC tersebut tidak mempunyai perisian Flash atau Flash Player. 

9.11 Langkah-Langkah Untuk Publish 

Sebelum anda “Publish”, pastikan flash movie anda telah siap sepenuhnya. Simpan fail Flash anda. 

Flash movie yang telah dipublishkan akan disimpan di tempat yang sama anda menyimpan fail flash 

anda. Berikut adalah angkah-langkah untuk Publish: 

 Simpan fail. 

 Pilih menu File > Publish Setting. 

 Pilih format untuk Publish. 

 Klik butang Publish. 

 Klik OK 

 

Gambarajah : Menu untuk Publsih 
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Gambarajah : Kotak dialog Publish Setting 
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