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INTERMEDIATE EXCEL

MANIPULATING WORKSHEETS

1 OF 6 (1-2 USING WORKSHEETS)

Worksheets in Excel form part of an Excel workbook.  You can separate different subsections within a workbook by placing information for that subsection on a separate worksheet.  By default, there are three worksheets per workbook but you can insert or delete worksheets according to your needs.  You can change the default number of sheets that a new workbook opens with on the General tabbed page of the Options dialog box.  You can move between different worksheets within a workbook without having to close or reopen the worksheets.  To view a worksheet within your workbook, you click the tab of the worksheet that you want to view - in this case Sales.  The worksheet is then displayed and you can read or modify its contents.  To delete a worksheet from a workbook, you first select the worksheet that you want to delete by clicking the worksheet tab.  To delete the selected worksheet, you select Delete Sheet from the Edit menu.  Excel then displays a dialog box to ensure that you want to delete the sheet and you click OK.  The selected sheet is then deleted with all its contents and formulas.  If you want to delete more than one worksheet, you select the worksheets by pressing the Shift key while clicking an adjacent worksheet tab.  Or you press the Ctrl key if the worksheets are not adjacent to each other and click the tabs.  Once you have selected the worksheets you want to delete, you select Edit - Delete Sheet.  You click OK.  And the selected sheets are deleted.  To create a new worksheet in your workbook, you select Insert - Worksheet.  The new worksheet is then inserted to the left of the worksheet that you had opened in your workbook.  To insert more than one worksheet, you hold down the Shift key and click the number of worksheet tabs that you want to add, then you click Insert - Worksheet.  For example, if you click two worksheet tabs while holding down the Shift key and then select Insert - Worksheet, two new worksheets are added to your workbook.
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Excel allows you to move and copy worksheets to different workbooks or to change the sequence of your worksheets within a single workbook.  You can also rename worksheets within Excel.  When moving or copying worksheets, you need to be aware that calculations or charts based on the worksheets may be affected.  Charts and calculations need to be checked for accuracy after you have moved a worksheet related to them.  Also, if you move a worksheet between a set of sheets used in a 3-D formula reference, the data on the moved worksheet may be included in the calculation.  Let's say that you want to copy Helen's Expense AC sheet from the Project workbook to the Promotions workbook.  And you want to rename the worksheet "ConfH4".  To move a worksheet from one workbook to another, both workbooks need to be open in Excel.  You select Project Workbook.xls from the Window menu to move to the sheet that you want to copy.  And you select the sheet or sheets that you want to move - in this case you select Helen's ExpenseAC.  To copy a worksheet to another workbook, you select Move or Copy Sheet from the Edit menu.  Then you select the workbook that you want to move the worksheet to from the To book drop-down list - in this case you choose Promotions Workbook.xls.  If you want to move the worksheet to a new workbook, you can select the New book option from the To book drop-down list.  You can specify where you want to place the worksheet in the Promotions workbook.  You do this by selecting the sheet before which you want the worksheet to appear in the Before sheet list box.  To ensure that the worksheet is copied and not simply moved, you select the Create a copy checkbox and you click OK.  The worksheet is copied into the Promotions workbook.  And you can access the worksheet in both workbooks.  To change the name of the worksheet - Helen's ExpenseAC - in the Promotions workbook, you double-click the worksheet tab.  You can also right-click the tab and select Rename from the shortcut menu.  Then you type the new worksheet name - in this case ConfH4.  And you press Enter to save the change.

3 OF 6 (3-4 ROWS AND COLUMNS)

Excel allows you to insert rows and columns where you need them.  You can insert a number of rows or columns simultaneously or you can insert one row or column at a time.  You can also delete rows and columns to change the size, shape, or content of your worksheet.  Let's say that you want to insert a single row into your worksheet above row four.  And you want to insert a single column to the left of column C.  To add a row, you position the insertion point in the row immediately below where you want your new row - in this case in row 4.  Then you select Insert - Rows.  And a new row is inserted above your previous row 4.  To insert a column, you place your insertion point immediately to the right of where you want the new column positioned - in this case in column C.  Then you select Insert - Columns.  And a new column is inserted to the left of your previous column C.  If you want to insert more than one row or column, you select a number of rows or columns equal to the number you want to insert below or to the right of where you want the new rows or columns.  For example, if you want three rows to be inserted above row 3, you select rows 3 through 5 and then select Insert - Rows.  And three new rows are inserted.  To delete a row, you position the insertion point in the row that you want to delete.  Then you select the Edit menu.  And you select Delete.  In the Delete dialog box you select the Entire row radio button and click OK to delete a row.  And the row is removed from the worksheet.  If you want to delete a column, you place the insertion point in the column and follow the same procedure as for rows except you select the Entire column radio button and click OK.  If you need to delete more than one row or more than one column simultaneously, you select the row or column headings and press Delete.  The column that you selected is then deleted.
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You can keep selected rows and columns visible as you scroll through your worksheet.  For example, you may want to keep the row names visible on the left of the pane while scrolling beyond the page boundary to the right.  You can hide sensitive or unnecessary information in rows and columns so that they are not displayed in your worksheet.  To keep particular rows and columns visible, you position the insertion point below and to the right of the columns and rows you want visible.  For example, if you want rows 1, 2, and 3 and columns A and B to remain visible, you position your insertion point in cell C4.  Because the insertion point needs to be to the right of the columns that you want to remain visible, you are unable to keep right-hand columns visible.  Once you have positioned the insertion point, you select the Window menu.  Then you select Freeze Panes.  The rows you have selected - rows 1, 2, and 3 - remain visible when you scroll down.  And the columns you have selected - A and B - remain visible when you scroll to the right.  To unfreeze selected columns and rows, you select Window - Unfreeze Panes.  And the rows and columns are no longer kept in view when you scroll.  To hide a row, you place the insertion point within the row that you want to hide.  Then you select the Format menu and choose the Row option.  And you select Hide.  To hide a column, you follow the same process as for hiding a row except you select Column instead of Row.  When a row is hidden, you cannot view or modify its contents.  To display a hidden row, you first select the rows adjacent to it - in this case row 13 and row 15.  And you select Format - Row - Unhide.  The row is then displayed.  If you have hidden the first row or column of a worksheet, you can't display it in the usual way.  Suppose you have hidden column A and now want to display it.  To display the first column of a worksheet after it has been hidden, you select Edit.  And you select Go To.  You type A1 in the Reference text box and click OK.  And although you still can't see the hidden cell on your worksheet, you can access its contents from the formula bar.  Once you have accessed the A1 cell, you select Format - Column - Unhide.  And the column is displayed.

5 OF 6 (5-6 PREPARING FOR PUBLISHING)

When you have completed a worksheet and are ready to display it to others, you can use a few of the Excel features to ensure that it looks the way you want it to.  You can use the Zoom feature to change the view of your worksheet.  And you can customize the extent of the zoom that you want.  If you want to publish your worksheet to the Web, you can save the worksheet as a web page.  You can ensure that it appears as you would like it by previewing it as a web page before you actually publish it.  In this way you can check that the layout is aesthetically pleasing and easy to read and understand.  You can check for spelling errors on a worksheet.  You can

• check selected cells or the   entire document

• check spelling as you type using   the AutoCorrect feature

• add words to a custom dictionary

When you run the spelling checker, a misspelled word is displayed in the Change to text box of the Spelling dialog box unless the suggestions feature is activated, in which case the recommended replacement is displayed.  The original misspelled word is displayed with the rest of the cell contents next to the Cell Value text and next to Not in Dictionary.  To display suggested alternatives to the misspelled word, you click the Suggest button.  And if you want the spelling checker to always display suggestions, you select the Always suggest checkbox.  To insert the correctly spelled word you select it - if it is not selected already - and you click the Change button to replace the word or the Change All button to replace all occurrences of the misspelled word in the worksheet.  If you do not want to change the word, you can click the Ignore button to ignore this occurrence or the Ignore All button to ignore all occurrences of the error in the worksheet.  You can choose to ignore acronyms or abbreviations by selecting the Ignore UPPERCASE checkbox.  You can add a word to a custom dictionary using the Add words to drop-down list.  You can add it to the custom dictionary provided by Excel or you can create a new custom dictionary by typing a new dictionary name with the .dic extension in the Add words to text box.  Then you can click the Add button to add the new word to the custom dictionary.  You can adjust Excel so that commonly misspelled words are automatically corrected as you type.  So for example, if you type teh it will automatically change to "the".   To add a commonly misspelled word to the AutoCorrect feature, you click the AutoCorrect button.  If you have accidentally replaced a misspelled word with an inappropriate word, you can click the Undo Last button.  And if you want to end the spelling check before it is complete, you click the Cancel button.
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Let's say that you want to change the Zoom feature on your worksheet to emphasize a selection of text by enlarging it to fit within the current window size.  And you want to check the spelling of your entire worksheet, adding personal names to the custom dictionary.  You also want to include any frequently misspelled words in your AutoCorrect feature.  Once your worksheet has been checked, you want to preview it in your browser and save it as a web page.  To change the zoom setting on your worksheet to enlarge a selection of text, you first select the cells that you want to view.  Then you select View - Zoom.  You can also use the Zoom drop-down list on your toolbar.  You select the Fit selection radio button to enlarge the size of the selection and you click OK.  The view is altered so that the cells that you have selected are enlarged to fit within the window.  To check your entire worksheet for spelling errors, you select a single cell - preferably at the start of your worksheet.  The spelling checker will function no matter which cell you select but it will ask you if you want to continue at the start of the worksheet if you have not selected the first cell. And if you want to check the spelling of a specific range of cells only, you select the cell that you want to check and then activate the spelling checker.  And you select Tools - Spelling.  The first word that the spelling checker finds is Sweatsiuts.  This is a common typing error so you want to have it corrected as you type.  To do this, you select the correct replacement and click the AutoCorrect button.  The second word that the spelling checker finds in this case is a person's name and you want to add the name to your custom dictionary.  To do this, you click the Add button and the next time you run the spelling checker it ignores the name.  Once the spelling check is complete, you click OK.  To see what your worksheet will look like before you publish it to a web server, you select File - Web Page Preview.  And the web page is displayed in your browser.  You can return to your worksheet by closing the browser.  Once you have previewed your spreadsheet you can save it as a web page, so you select a single cell.  If you have a number of cells selected, you will be unable to save the entire worksheet as a web page.  Then you select File - Save as Web Page.  In the Save As dialog box you select the Selection radio button because you want to save the open worksheet only.  You can then choose to make the spreadsheet interactive by selecting the Interactivity checkbox.  Allowing interactivity on your spreadsheet enables Excel funtionality through your browser and allows you to update data in Excel from your browser.  To change the title of your page, you click the Change Title button.  You type the new title - in this case Quarterly Sales NY - in the Set Title dialog box and click OK.  You type a name for the file in the File name text box and you click the Save button.  And the worksheet is saved as a web page.

END OF MANIPULATING WORKSHEETS

SUMMARY:

You have seen how to use worksheets in Excel.  Worksheets form part of an Excel workbook. By default, a workbook consists of three worksheets but you can add or delete worksheets according to your needs. You can also move worksheets to other workbooks or change their sequence within a single workbook. You can navigate easily between worksheets in a single workbook and you can rename worksheets to better reflect their contents.  In Excel you can insert or delete rows and columns in your worksheet. You can also hide rows and columns that are inappropriate or contain sensitive information. And you can ensure that particular rows or columns remain visible as you scroll through a worksheet.  In preparing to publish a worksheet, you can view the sheet at different zoom settings using the Zoom feature. You can check the spelling in your worksheet, including frequently misspelled words in the AutoCorrect feature and adding words not recognized by the dictionary to a custom dictionary. You can also save a worksheet as a web page, change the title that appears on the web page, and include interactivity on the web page.

UNIT TEST:

1. A _____ forms part of a _____.

a. workbook

b. worksheet

2. You need to close or minimize a worksheet before you can view another worksheet within the same workbook.

a. True

b. False

3. Which of the following statements are true of worksheets in Excel?

a. When you delete a worksheet, its data and formulas are transferred to an adjacent worksheet

b. You can delete more than one worksheet simultaneously

c. New worksheets are inserted to the left of the active worksheet in a workbook

d. Calculations and charts are not affected when you move a worksheet related to them

4. Which of the following statements are true of inserting and deleting rows and columns in Excel?

a. You can insert more than one column simultaneously

b. You can delete more than one row simultaneously

c. Rows are inserted immediately below the insertion point

d. Columns are inserted immediately to the left of the insertion point

5. If you have selected rows 6 through 9, how many rows are inserted simultaneously?

a. 1

b. 2

c. 3

d. 4

6. If you want to keep row 1 and column A visible while you scroll through your worksheet, where do you place the insertion point before freezing the panes?

a. A1

b. A2

c. B2

d. B1

7. When a row or column is hidden, you cannot modify its contents.

a. True

b. False

8. Which of the following extensions is used when creating a custom dictionary?

a. .txt

b. .doc

c. .dic

d. .cdi

9. Changing the zoom setting on a worksheet affects how the worksheet appears in printed form or as a web page.

a. True

b. False

ANSWERS:

1. 1st blank: worksheet, 2nd blank: workbook

2. False

3. b & c

4. a, b & d

5. d

6. c

7. True

8. c

9. False

INTERMEDIATE EXCEL

PAGE SETTING AND PRINTING
1 OF 6 (1-3 PAGE SETTINGS)

Excel allows you to change the layout of your printed page in a variety of ways.  You can change 

• the page orientation 

• the scaling of the document to the page

• the paper size and print quality

• the positioning and size of the margins

• the positioning and size of the headers and footers

• the print options of the sheet

You can choose to orient your page either vertically or horizontally by selecting either the Portrait or the Landscape options.  You can enlarge the printed worksheet by up to 400 percent of its original size or reduce it to only 10 percent of its original size.  You can also reduce the size of a printed worksheet by specifying a number of pages that the document must fit on when it prints.  You can choose from a selection of paper sizes to print your document on.  You can choose the print resolution by selecting the number of dots per linear inch (dpi) that you want to appear on the printed page.  By increasing the resolution, you get better quality printing from printers that support high resolution printing.  On the Margins tabbed page you can readjust the margins on the left-hand and right-hand sides of the page.  You can also realign the margins at the top and bottom of the page as well as the headers and footers using the spin box arrows.  And you can choose to center the worksheet horizontally and vertically on the page using the appropriate checkboxes.
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You can choose a header or a footer to insert from lists in the Header/Footer tabbed page of the Page Setup dialog box.  You can click the Custom Header button to create your own headers.  The Footer down-pointing arrow and Custom Footer button provide you with the same options as the Header down-pointing arrow and the Custom Header button.  In the Header dialog box you can choose the section of the header in which you want to place the information.  You can format any text you have entered by clicking the Font button.  This displays the Font dialog box, which allows you to change the font, font style, or font size and allows you to add effects to the font.  You can insert the following into a header or footer:

• page numbers

• a date

• a time

• a filename

• a tab name

You can type your own header by typing the text into the appropriate edit box.  The Sheet tabbed page allows you to set a worksheet range to print.  You click the Print area Collapse dialog button in order to shrink the dialog box and choose an area of the worksheet to print.  When you have selected an area to print, you click the Print area Collapse dialog button to return to the Page Setup dialog box.  You can choose specific rows as your horizontal title for each page or you can select columns as vertical titles for each page.  You can choose to print the gridlines and the row and column headings by selecting the Gridlines or Row and column headings checkboxes.  And you can choose to print any comments you have made either at the end of the sheet or where you have placed them in the worksheet.   You can select the Black and white checkbox if you have formatted any of your data with colors but you are printing to a black and white printer.  If you are using a color printer, selecting this option may reduce print time.  And you can reduce printing time by selecting the Draft quality checkbox, which means Excel does not print most graphics or gridlines.  If your data does not fit onto one page, you can control how it is ordered and numbered using the Page order section.  You can choose to have it print down, then over or over, then down.  You can click the Options button on any of the tabbed pages in the Page Setup dialog box.  This opens the Document Properties dialog box, which allows you to further customize your page setup options for printing.  You can insert horizontal and vertical page breaks in your worksheet if your worksheet is too big to print on one page.  You can change the rows that are printed on one page by inserting horizontal page breaks.  And you can change the columns that are printed on a single page by inserting vertical page breaks.  To insert a horizontal page break, you click the heading on the row below where you want to place the break and select Page Break from the Insert menu.  To insert a vertical page break, you click the column heading to the right of where you want the page break and select Page Break from the Insert menu.  And the page breaks are inserted in the worksheet.  To remove the page breaks, you select the row below the horizontal page break and the column to the right of the vertical page break and select Remove Page Break from the Insert menu.  And the page breaks are removed.
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Let's say you want to set up your worksheet for printing so that it is oriented to landscape.  You want to add a header that shows the page number and create a custom footer that shows the date in the center of the footer.  You want to print the row and column headings and print it to a black and white printer.  To change the page setup, you first select the File menu.  Then you choose Page Setup from the options.  To orient the page so that it is printed horizontally, you select the Landscape radio button.  You click the Header/Footer tab in order to insert your header and custom footer.  Then from the Header drop-down list you choose Page 1.  You click the Custom Footer button to open the Footer dialog box.  You place the insertion point in the Center section edit box and click the Date button.  Then to close the Footer dialog box and return to the Page Setup dialog box you click OK.  You click the Sheet tab to set the sheet print options.  To print the headings, you select the Row and column headings checkbox.  And you select the Black and white checkbox because you're printing to a black and white printer.  When you have set up the page, you click OK.   This returns you to your worksheet without printing it and saves the options you have selected for when you choose to print.

4 OF 6 (4-6 PRINT SETTINGS)

Excel allows you to refine your printing options before you print a worksheet or a workbook.  You can preview a worksheet before you print it to see what it will look like when printed.  You do this in the Print Preview window.  The way the window displays the pages depends on the available fonts, the resolution of the printer, and the available colors.  The status bar at the bottom of the Print Preview window displays the current page number and the total number of pages in the whole unit.  In this case there is only one page in the worksheet.  The Next and Previous buttons allow you to display the next and previous pages of the worksheet.  In this case there is only one page so the buttons are not enabled.  You can use the zoom facility to enlarge the worksheet for a better view.  This does not affect the size of the printing.  You can print the worksheet from the preview using the Print button.  This opens the Print dialog box, which allows you to set printing options and then print the selected sheet.  You can access the page setup options by clicking the Setup button.  This displays the Page Setup dialog box.  You can view and change the margins from the preview by clicking the Margins button.  And you can see the Page Break Preview, which allows you to adjust the page breaks on the worksheet.
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You can choose to print only a section of your worksheet.  You can do this by selecting the area and selecting the File menu.  Then you select the Print option.  In the Print dialog box you select the Selection radio button.  And you click OK to print the section.  You can choose to print the active sheet by selecting the Active sheet(s) radio button.  You can select multiple sheets by clicking each sheet that you want to print while holding down the Shift key.  Each printed sheet is then printed on a new page.  You can choose to print only a selection of the worksheet by setting the print area.  Then when you print your selection, you do not need to use the Print dialog box to set the area.  To print a selected area without using the Print dialog box, you first select the area you want to print and then select the File menu.  Then you choose Set Print Area from the Print Area submenu.  To clear an area you have set for printing, you first select the File menu.  Then you choose the Print Area option.  And you select Clear Print Area. 
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Suppose you want to preview your open worksheet before you print it.  You want to view the margins and quickly change the top margin by dragging it to the center of the page.  Then you want to print the entire workbook.  To see what the printed worksheet will look like before you print it, you click the Print Preview button.  You can also choose Print Preview from the File menu.  To view and change the margins, you click the Margins button.  When you can see the margins, you place your pointer over the top margin and drag it to the new position.  When you are satisfied with the layout of the worksheet, you click the Print button.  Then you select the Entire workbook radio button.   And you click OK.  When your document has printed, the dialog box closes and you are returned to the worksheet.

END OF PAGE SETTING AND PRINTING

SUMMARY:

You have been shown how to manipulate the page and print settings of an Excel 2000 document.  

Excel allows you to change the layout of your worksheet as it will appear in printed form. You can arrange the orientation of the page so that the printed page shows the worksheet either vertically or horizontally.You can also enlarge and reduce the worksheet for the printed page and choose from a selection of paper sizes to print on.  Excel allows you to customize the margins and page breaks of the worksheet and change the size of the headers and footers that can appear at the top and bottom of the worksheet. You can insert headers and footers from a list or you can choose to customize and create your own. You can also choose what you want to have printed on your page, such as whether you want to print the gridlines and the row and column headings.  You can use Excel to print selected areas of a worksheet. You can set a print area using Excel that allows you to print using the Standard toolbar button without having to use the Print dialog box.

UNIT TEST:

1. In which of the following ways can the layout of a printed worksheet be modified?

a. By inserting and formatting headers and footers

b. By changing the scale of the document

c. By changing the printer used

d. By changing the paper size

2. Which of the following can be used in a custom header or footer?

a. Page number

b. The filename

c. The date

d. The cell number

e. The time

3. Printing to a black and white printer reduces the print time.

a. True

b. False

4. A worksheet can be printed from the Print Preview window.

a. True

b. False

5. Which of the following can be printed in Excel?

a. A selection of the worksheet

b. The worksheet titles only

c. Only the formulas in a worksheet

d. The entire workbook

6. Which of the following statements about the Print Preview window are true?

a. It allows you to adjust the margins of your worksheet

b. It allows you to adjust the printing size of the worksheet using the zoom feature

c. It allows you to adjust the page breaks in the worksheet

d. You can only view the first page of your document in the preview window

ANSWERS:

1. a, b & d***

2. a, b, c & e

3. True

4. True

5. a & d***(c)

6. a & c

INTERMEDIATE EXCEL

FUNCTIONS

1 OF 9 (1-3 ENTERING FUNCTIONS)

Excel provides a range of worksheet functions that can perform database, financial, mathematical, and statistical calculations.  A function is a predefined formula that takes a value or values, performs an operation, and returns a value in the target cell or cells.  The most basic functions include the SUM, MAX, MIN, COUNT, and AVERAGE functions.  The SUM function calculates the sum of the specified range of cells.  And the MAX and MIN functions return the largest and smallest values in a range.  The COUNT function counts the number of numeric entries in a range.  And the AVERAGE function calculates the average of the numbers in a specified range.  You can use functions to simplify and shorten formulas that you use when working with data.  For example, where calculating loan payments can be complex, the PMT function simply calculates the repayments based on the interest rate, the length of the loan, and principal amount of the loan.  Each function follows a particular pattern - it begins with an equal sign (=), the name of the function follows, and then the argument or arguments are filled in.  Arguments can be data, a range of data, or functions that produce data.  It is important to enter arguments in the correct order for a function to operate properly.  You enter functions 

• by typing them directly into a cell

• using the Function drop-down list   and the Formula Palette

• using the Paste Function feature
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Let's say that you want to find the largest number of t-shirts sold in any one month by the US branches of Award Sportswear during the last quarter.  This data is contained within a predefined range - the TshirtSalesQ4 range.  In a large or complex worksheet you may find it easier to refer to cells and blocks of selected cells by name rather than cell address.  Excel gives you the capacity to name individual cells or cell ranges.  In this way you can find data by a logical name and refer to the cells ranges in formulas.  To name a cell or range of cells select the cell and choose Insert, Name, Define.  Type the name for the selected cells in the Names in Workbook text box and click OK.  To determine the largest number of t-shirts sold, you use the MAX function.  You place the insertion point in the target cell - in this case in the T-shirts row and the Max column - and you type the function and its argument - in this case =max(TshirtSalesQ4).  It is advisable to type function names in lowercase because Excel automatically converts function names to uppercase. If it does not convert the function name you have used, you are immediately made aware that Excel does not recognize the function.  Then you press Enter and the result is displayed in the target cell.  Instead of typing a function in a cell, you can use the Function drop-down list.  To find, for example, the lowest number in the BaseballCapsSalesQ4 range using the Function drop-down list, you type = in the target cell, in this case Q5.  Then you click the Function down-pointing arrow to display the list of most recently used functions.  You select MIN from the Function drop-down list.   And in the Number1 text box you type the range name and you click OK to display the results.  Alternatively, you can select each cell in the range as a separate number in the Formula Palette and then click OK.  The result is then displayed in the target cell.  Suppose you want to determine how many records have been entered in the last 6 months - that is, the cells containing numbers in the range J5 to O12 on your worksheet.  To count the occurrence of numbers in the cell range from J5 to O12, you type =COUNT(J5:O12) in the target cell and you press Enter.  The COUNT function does not recognize textual representations of numbers nor error values.  The result is then displayed - in this case there are 48 occurrences.
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Logical functions, such as IF, AND, OR, NOT, TRUE, and FALSE, work with conditions and true and false values.  The IF function - for example - returns one value if a condition you specify is true and another value if it is not.  You can use functions as arguments of other functions - a technique called nesting.  Nesting allows you to apply a number of conditions to your function.  You can nest up to seven IF functions in an argument.  Let's say you need to see if the total sales for all items have exceeded or fallen under a particular amount.  The target maximum number of total sales is set at 17500.  To test whether the total sales meet expectations, you select the target cell - in this case Q17.  Then you type = and select the IF function from the Function drop-down list.  The Formula Palette opens showing the correct syntax for the IF function.  The first part of the argument - Logical_test - is where you include the conditions that can be evaluated as true or false.  You enter the condition for the values that you want to test, in this case P13<17500.  And then you type the response that you want to show if the statement is true in the Value_if_true text box - in this case you type UNDER.  Entering a response in the Value_if_false text box is optional - if you don't specify a value, FALSE will be displayed when the result is false.  However, you want to include a value for this so you type OVER and you click OK.  The result is then displayed in the target cell - in this case the results exceeded the target.

4 OF 9 (4-7 FINANCE AND TIME FUNCTIONS)

Some functions offered by Excel perform quite complex calculations that relate to areas such as finance and time.  When calculating advanced formulas, you may find the Paste Function feature the most useful method of entering functions and their arguments.  The Paste Function feature groups functions into categories, including financial, statistical, logical, and database categories.  If you can't find a specific function, you can look in the All category to search through an alphabetical list of all available functions.  Let's say that Award Sportswear wants to buy machinery worth $55,000 at an interest rate of 6 percent and wants to pay for the machinery over 2 years.  You want to calculate the monthly payments for the equipment, so you need to use the PMT function.  To find the monthly payments needed for the equipment, you first select the target cell - in this case cell C6.  You select the Insert menu.  Then you choose Function.  The alternative method of accessing the Paste Function option is to click the Paste Function button on the Standard Toolbar.  You select the Financial category from the Function category section of the Paste Function dialog box.  And you select the PMT function from the Function name list and you click OK.  If you require help with the function, you can click the Office Assistant button in the dialog box and select the Yes, please provide help option.  The Formula Palette opens and you can see that the text boxes are ordered so that you enter the arguments in the correct order.  It also provides a description of the function and explains what the argument selected refers to.  The first argument asked for is the rate - which is 6 percent per year and can be entered as 6% or as 0.06.  The second argument asks for the number of payments you want to make, which over 2 years equals 24 payments.  The third argument asks for the present value of the equipment or the total price, which is $55,000.   As you do not want to end the period still owing money, you type 0 in the Fv (future value) text box.  The final argument asked for - Type - is usually calculated as an ordinary annuity so can be left blank.  If you decide to make your payments at the beginning of each period - annuity due - you need to type 1 in the Type text box.  Then you click OK.  The target cell displays the result of the function you have entered - the company needs to pay $4,382.35 per month to complete the payment in two years.
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Let's say that Award Sportswear has agreed to invest $25,000 a month over 5 years at 7.5% interest.  You want to calculate the future value of the investment if it remains in the account for the full five years.  You can use an Excel function to calculate how much the investment will be worth at the end of the five-year period.  To calculate the future value of your investment, you type = in the target cell, C14.  And then you click the Function down-pointing arrow.  You select FV from the Function drop-down list.  If the function that you want to use is not displayed in the Function drop-down list, you select More functions and then select the function from the Paste Function dialog box.  You type the monthly rate, in this case 7.5% or 0.075, in the Rate text box of the Formula Palette.  Next you type the total number of payments that your company will make - 12 multiplied by 5 or 60 - in the Nper text box.  Your monthly payments are $25,000 per month, so you type 25000 in the Pmt text box.  You need not fill in the present value nor select anything from the Type text box since you have not invested a lump sum and you are making payments at the end of each month.  The result is displayed at the bottom of the Formula Palette and to display this result in the target cell, you click OK.  The value of the investment in five year's time is now displayed on your worksheet.
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Each day, month, and year is given a particular numerical value or serial number by your computer.  Excel uses these numbers in calculations and macros that involve time periods.  Usually your computer will work from the 1900 date system, but some computers and programs work from the 1904 date system.  By default, Excel for Windows uses the 1900 date system, while Excel for the Macintosh uses the 1904 date system.  With the 1900 date system, January 1, 1900, is the first possible date and the last possible date is 2958465, or December 31, 9999.  With the 1904 date system, January 2, 1904 is the first possible date and the last possible date is 2957003, or December 31, 9999.  You can check which date system your computer uses by selecting Tools - Options.  Then you click the Calculation tab.  If you want to use the 1900 date system, you need to ensure that the 1904 date system checkbox is clear and then you click OK.  Let's say that the current worksheet is accessed and altered by a number of users.  You want to include a function that displays the date and time that the worksheet was last altered but does not update each time the worksheet is opened.  You also want to display the amount of time that has elapsed between the creation of the worksheet and the latest update.  To find the most appropriate function, you select Insert - Function.  You select Date & Time from the Category list.  And you select the NOW function.  Once you have selected the function you want, you click OK.  The Function Palette displays showing the syntax for the NOW function and explains that the function is volatile and does not take any arguments.  Being volatile means that the NOW function changes the result it displays only when the worksheet is calculated or when a macro that contains the function is run. The date and time are not updated continuously.  To close the Function Palette, you click OK.  The present date and time are displayed in the target cell.  Since the displayed date and time at this point refer to the document's creation, you need to use this value to calculate the time elapsed between creation and later updates.  And so you need to enter this first result as a value.  To enter the result of the NOW function as a value, you select Edit - Copy.  And then - while remaining in the same cell - you select Edit - Paste Special.  In the Paste section of the Paste Special dialog box you select the Values radio button.  And you click OK.  The formula bar then displays the date and time instead of the NOW function.  You enter the NOW function in the cell that represents the most recent update - in this case cell D17.  And in the cell that needs to display the time elapsed you type =D17-D16 to find the difference between the creation date and the date last updated.  After you have entered the formula in cell D18, this result will change each time you update the NOW function.
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Suppose you want to create a countdown worksheet that counts down to your company's catalog release date, which is set for June 6, 2000.  You create the worksheet and you name three adjacent columns, Release Date, Current Date, and Remaining Time.  In the Release date column you insert the DATE function by selecting Insert - Function.  From the Date & Time function category you select the Date function and you click OK.  In the Year text box you type 100 for the year 2000 because Excel is working with the 1900 date system.  Since June is the sixth month, you type 6 in the Month text box.  In the Day text box you type 6 and you click OK.  And the date is now displayed.  To insert the NOW function into the Current Date column, you type =NOW() in cell B4.  And to display the number of days to the release date, you type the formula =B4-A4 and you press Enter.  The cell C4 displays a series of number hashes - this occurs because the cell is formatted to display dates and as a result there are too many numbers to fit in the cell.  To display numbers, you need to format the cell for numbers.  To do this, you select the cell and you choose Format - Cells.  And on the Number tabbed page you select Number and click OK.  The number of days remaining until the release of the catalog is then displayed.  A person checking the number of days remaining can double-click the cell that contains the NOW function or press the F9 key.  And the number of days remaining is automatically updated.

8 OF 9 (8-9 3-D REFERENCES)

You may have a number of worksheets that contain data that is related.   For example, you may have a workbook that contains three worksheets that each hold sales figures for different cities.  These data items can be consolidated or linked to each other in another worksheet to display summary information for the whole workbook.  Excel uses links or 3-D references to gather information from different places, such as cells in a single worksheet, different worksheets, or different workbooks.  For more information on linking workbooks, see the CBT Systems course "Microsoft Office 2000: Excel for Power Users".  A link is a formula that takes data from a source - or range of cells - applies a function to the data, and then displays the result in a target cell.  A 3-D reference is a particular form of link that has a source and a target in different worksheets within a single workbook whereas a link's source and target are in separate workbooks.  3-D references help you to manage, analyze, and consolidate data within a single workbook.  They can also reduce the risk of you entering data incorrectly on a worksheet because you specify the cells and worksheets where the data can be found.  And because they link the source data and the displayed results, any changes to the source data will automatically update the results.  Consolidating data on a single summary or report sheet in a workbook is a typical instance of where you may use 3-D referencing.  You specify the source areas for consolidation in your 3-D reference formulas.  You need to include the sheet name and the cell name in each formula.  You can use 3-D references to refer to cells on other sheets, to define names, and to create formulas using particular functions.  But you cannot use 3-D references in array formulas nor in formulas that use implicit intersection.  So you cannot use a 3-D reference with the intersection operator - a blank space - such as may be used in a concatenate function.  An array formula performs multiple calculations. The result can be a single result or multiple results. Because the values in the array formula must refer to the same number of rows and columns, this type of formula works well for list data, in which each record has the same number of fields. The concatenate function joins together the displayed values in two or more cells. It can also join a text string to the displayed value in a cell.   You can enter data for 3-D  referencing by

• directly typing the formula

• selecting Insert - Function

• typing = and then selecting the   function you require from the   Function drop-down list.

As with any formula, you need to ensure that you have entered the correct syntax for it when you create a 3-D reference.  You can avoid some of the risk of using the incorrect syntax by selecting the sheets and cells that you want to include instead of typing their locations.  You can do this using the Formula Palette.
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Suppose you want to use data giving the average sales and total sales of baseball caps in January 2000 in your US branches to make sales projections.  You have the sales information detailed in several worksheets in your Quarterly Sales workbook.  You insert a new worksheet for the consolidated data into your Quarterly Sales workbook.  You name the new worksheet Sales Consolidation.  And you enter the column and row labels that you need.  You select the cell that you want to hold the consolidated data on the average baseball cap sales for January 2000 - in this case C5.  And you select Insert - Function.  From the Statistical function category in the Paste Function dialog box you select the AVERAGE function and you click OK.  The Formula Palette is displayed and the AVERAGE function is automatically included in the formula bar.  To enter a source from the LASales worksheet, you first click the LASales tab.  And you click the Collapse Dialog button on the Formula Palette to view the worksheet.  The Formula Palette is minimized showing only the syntax for the selected worksheet.  Once you have minimized the Formula Palette, you select the cell that holds the data that you want to include - in this case O5.  Then you restore the Formula Palette by clicking the Expand Dialog button.  You automatically return to the Formula Palette and you place the insertion point in the Number2 text box to begin entering the next source.  You repeat the process for each worksheet and cell that you want to include.  And when you have finished, you click OK.  Once you have entered a formula into the target cell, the cell displays the result - in this case the average of all the cells that act as its source.  To display the result in number format with two decimal places, you select Format - Cells.  On the Number tabbed page you select Number from the Category list, choose the appropriate option from the Negative numbers list - in this case 1234.10 - and you click OK.  To consolidate the total sales of baseball caps made in January 2000, you follow the same steps as you do for finding the average sales.  But you select SUM as the function to consolidate the data because you want to add the contents of each source cell.  Once you have entered the formula and the sources for the sum, you click OK.  And the result is displayed in the target cell.

END OF FUNCTIONS

SUMMARY:

You have seen how to use functions in Excel.  

A function is a predefined formula that takes a value or values, performs an operation, and returns a value in the target cell or cells. Excel provides a range of worksheet functions that can perform database, financial, mathematical, and statistical calculations.  Some functions offered by Excel perform quite complex calculations that relate to areas such as finance and time. The Paste Function feature groups functions into categories - including financial, statistical, logical, and database categories - to help you find the function you need.  Each day, month, and year is given a particular numerical value or serial number by your computer. Excel uses these numbers in calculations and macros that involve time periods. The NOW and DATE functions are the most commonly used date and time functions.  A 3-D reference is a type of link that takes data from different cells within a workbook, applies a function to the data, and then displays the result in a target cell. As a result, 3-D references can help you manage, analyze, and consolidate data within a workbook.  You can use 3-D references to refer to cells on other sheets, to define names, and to create formulas using particular functions. But you cannot use 3-D references in array formulas, formulas that use the intersection operator, or formulas that use implicit intersection. As with any formula, you need to ensure that you have entered the correct syntax for the formula when you create a 3-D reference.  3-D references reduce the risk of you entering data incorrectly on a worksheet because you specify the cells and worksheets where the data can be found. And because they link the source data and the displayed results, any changes to the source data will automatically update the results.

UNIT TEST:

1. Which of the following functions do you use to find the number of times numbers and dates occur in an argument or within selected cells?

a. NUMBER

b. DATE

c. IF

d. COUNT

2. _____ provide details about what you want functions to do.

a. Formulas

b. Values

c. Arguments

d. Conditions

3. It is not important in which order you enter arguments for a function to operate properly.

a. True

b. False

4. Which of the following functions allows you to display the present date and time in a cell?

a. TIME

b. NOW

c. WHEN

d. DATE

5. Which of the following are true of the NOW statement?

a. It requires you to use the 1904 date system on your computer

b. It updates a result every five minutes

c. It is volatile and takes no arguments

d. It updates each time the workbook is opened

6. To update a cell displaying the results of a NOW function, you double-click the cell or press the F9 key.

a. True

b. False

7. Which of the following are true of 3-D references?

a. A 3-D reference displays the result from a source in a range of target cells

b. They can be used to automatically update a consolidation sheet

c. Excel automatically corrects common syntax errors in 3-D reference formulas

d. You can use 3-D references to define names

8. Which of the following can 3-D references be used for?

a. Linking data in different workbooks or applications

b. Array formulas

c. Consolidating data in a workbook

d. Referring to cells within a workbook

9. 3-D references are typically used with concatenate functions.

a. True

b. False

ANSWERS:

1. d

2. c

3. False

4. b

5. c & d

6. True

7. b & d***

8. c & d*** (b)

9. False***

INTERMEDIATE EXCEL

CHARTS AND OBJECTS

1 OF 7 (1-4 CHARTS)

Charts are a useful means of illustrating data represented in a worksheet.  The components of a chart - such as the title, legend, and chart area - are known as objects.  You use source data that is usually located in an accompanying worksheet to plot your chart.  A chart that you choose to place in a worksheet is known as an embedded chart.  A chart that you choose to place on a separate sheet is known as a chart sheet.  Excel allows you to choose from a range of preconfigured charts.  You can also choose from a list of customizable charts.  It is important to choose the correct chart to represent your data as the wrong type of chart can misrepresent figures and lead to incorrect decisions.  Using data from an existing worksheet or table, you can create and modify a chart.  By updating the worksheet or table, you automatically update the chart.
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When you choose to insert a chart in Excel, the Chart Wizard automatically opens.  You can use the Chart Wizard to format and configure the chart as you create it or you can format the chart when you have finished with the wizard.  The first step of the wizard - the Chart Type step - allows you to choose from a variety of charts.  Both the standard and the custom types provide you with a range of different types of chart for displaying your data.   The Chart Source Data step allows you to select the data range.  You can type the data range or use the Collapse dialog button to select the data.  In the Chart Options step you can 

• create or change the titles

• change the names of the axes

• display or hide the gridlines

• hide or display and position the   legend

• show or hide the data labels

• choose to show the   accompanying table simultaneously

In the fourth step of the wizard - the Chart Location step - you can choose to insert the chart as a new sheet or as an object in an existing sheet.  When you have created a chart, you can quickly modify it by double-clicking the part of the chart you want to change.  For example, if you want to change the Category Axis, you place the pointer on it and double-click.  Then you can change the axes using the Format Axis dialog box.  You can use the Chart menu on the Standard toolbar to modify a chart.  The options on the Chart menu represent the steps of the wizard.  You can also access these options by right-clicking the chart area.  You can modify the data series by right-clicking the data series you want to modify and selecting Format Data Series from the menu.  In the Format Data Series dialog box you can choose to alter the 

• border and area patterns

• column shapes

• data labels

• series order

• look of the chart
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Suppose you want to create a Columns with Depth chart that represents the sales from June to March.  You want to title the chart "Sales By Area: 99-00" and create it as a chart sheet.  Once you have created the chart, you want to change the completed chart by altering the data for Turin.  You want to change the area pattern used for Turin to red and change the chart depth to 300.  To begin creating the chart, you click the Chart Wizard button on the Standard toolbar.  Since the Columns with Depth chart is a custom type of chart, you click the Custom Types tab.  Then you select the Columns with Depth chart and click Next.  Since you want to add the data in ranges, you click the Data range Collapse dialog button.  You select the data you want to be illustrated in the chart.  And you click the Collapse dialog button to return to the wizard.  On the Data Range tabbed page you can choose the axes on which you want to display your data.  You can see how the chart will look if the series is in rows or columns by selecting the appropriate radio button.  In this case you select the Rows radio button and click Next.  On the Titles tabbed page of the Chart Options step you enter the title of your chart - in this case "Sales By Area: 99-00".  Since you want to use the default options for the remaining options, you click Next to carry on to the next step of the wizard.  In the Chart Location step of the Wizard you select the As new sheet radio button.  You can choose to enter a title for the sheet here but this time you leave the default name and click Finish.  As you can see the chart is now displayed in a new sheet.  You click the Area Sales 99-00 tab to open the worksheet and change the data for Turin.  On the associated worksheet you change the Turin data as appropriate and click the Save button.  And when you return to the chart you see that the represented Turin data has been updated.  To change the look of the Turin data series, you right-click the Turin series and select Format Data Series from the menu.  In the Area section of the Patterns tabbed page you select red and click the Options tab.  On the Options tabbed page you use the down-pointing Chart depth spin box arrow to change the depth to 300.  You can also select the Chart depth number and type 300.  You click OK.  As you can see your chart has been formatted as you wanted it.
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Once you have created and modified your chart, you can preview it before you print it to ensure that it will print the way you want it to.  There are two ways to do this.  You can preview a chart by selecting the File menu and choosing Print Preview from the list of options.  Or you can preview your document by selecting Print from the File menu.  Then in the Print dialog box you click the Preview button.   The Next and Previous buttons allow you to navigate forward and backward between charts.  However, they are not available in this case because there is only one chart available.  The Zoom button in the Print Preview view allows you to view the details of your chart by magnifying it.  This can make your chart more readable, especially when used with gridlines.  You click the Zoom button to return the chart to its normal size or you click the chart.  When you click the Setup button in Print Preview, you access the Page Setup dialog box.  You also access the Page Setup dialog box by selecting Page Setup from the File menu.  Because you are in a chart sheet, a Chart tabbed page appears in the dialog box.  The Chart tabbed page allows you determine the size of the printed chart and its print quality.  In Print Preview you can alter the margins by clicking the Margins button.  This displays the margins on the preview page and allows you to move them by dragging them.  You can choose to print directly from Print Preview by clicking the Print button.  However, if you want to set further print options, you need to click the Close button.  You can then access the Print dialog box by selecting Print from the File menu.  To print one copy of the chart as it appears, you leave the default options in the Print dialog box.  And you click OK.

5 OF 7 (5-7 OBJECTS)

You can insert objects, such as pictures, into Excel worksheets.  The two types of picture that you can insert into a worksheet are bitmap-type pictures and metafile-type pictures.  Bitmap-type pictures consist of dots, or pixels, and you use the Picture toolbar to edit them.  Unlike metafile-type pictures, they cannot be ungrouped.  Metafile-type pictures consist of separate lines and curves joined in a group that usually look like an illustration.  You can ungroup metafile-type pictures and convert them to drawing objects that can be manipulated using the Excel drawing tools.  The metafile-type pictures are more commonly known as clip art.  You can insert a complete picture into your document or choose to display the picture as an icon that opens the picture when double-clicked.  You can choose to create a new object or you can create an object from a file.   If you choose to insert an object from a file, you can link it to the source file so that changes to the source file will be reflected in your worksheet.   A picture that you insert as an object is an embedded object that is linked to its original source file.  By double-clicking a picture object that you have embedded, you open the Clip Gallery.  You can move a picture by clicking it and dragging it to any position.  You can format the picture by selecting the Format menu and choosing Picture.  You can also right-click the picture and select Format Picture.  This opens the Format Picture dialog box.  Using the Format Picture dialog box you can

• alter the colors and lines of   the picture

• change the picture's size

• crop or change the image   control of the picture

• protect the picture

• change the positioning

• insert alternative text for   web browsers to display while   they are loading the picture

If you want to delete a picture, you simply select it and press the Delete key.
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You can create and modify lines using the Drawing toolbar in Word.  You can access the toolbar by selecting the View menu.  Then you choose Drawing from the Toolbars submenu.  You can choose from a variety of shapes by clicking the AutoShapes  button.  AutoShapes is a group of ready made shapes that includes such basic shapes as rectangles and circles and a variety of lines, symbols, banners, and callouts.  To access lines, you select the Lines option.  Or you can simply click the Line button on the Drawing toolbar.  You draw a line by placing the cross hair on the spreadsheet, clicking the mouse button, and dragging the line to the size you want it to be.  You format lines using the Format - AutoShape option.  You can also double-click the line to open the Format AutoShape dialog box.  The Format AutoShape dialog box provides you with the same options as the Format Picture dialog box.  7 OF 7  Let's say you want to insert a clip art picture as an object into your Excel worksheet.  When you have added the picture, you want to add a line to link the two Feb 2000 dates.  Then you want to format the line.  To insert clip art as an object in your worksheet, you select the Insert menu.  Then you choose Object from the list of options.  On the Create New tabbed page of the Object dialog box you select Microsoft Clip Gallery from the list of options.  To access the clip gallery and choose the clip art to insert, you click OK.  In the Clip Gallery you click a category - in this case Business.  Then you browse to select the picture you want to insert.  You click Insert clip.  And the picture is inserted in your worksheet.  In order to access the Drawing toolbar, you select the View menu.  Then you choose Toolbars - Drawing.  On the Drawing toolbar you click the Line button to begin drawing the line.  Then you place the cross hair where you want the line to begin and click and drag it to where you want it to end.  To change the appearance of the line, you double-click it.  On the Colors and Lines tabbed page of the Format AutoShape dialog box you click the Dashed down-pointing arrow and select an option - in this case Dash - from the list.  Then you click the Style down-pointing arrow and choose a style - in this case 1½ pt.  When you have finished formatting your line, you click OK.  And the line appears in your worksheet as you have formatted it.  To change the color of the line to blue, you click the Line Color button on the Drawing toolbar.  And as you can see the line is now blue.

END OF CHARTS AND OBJECTS

SUMMARY:  You have seen how to create and modify charts and objects.  

Charts are a useful way of illustrating data represented in a worksheet. Chart data is located in an accompanying worksheet and any changes to the data in the worksheet are reflected in the chart.   You can use the Excel Chart Wizard to create a chart from a range of preconfigured and customizable chart types. The Chart Wizard allows you to choose the type of chart you want to represent your data, to select the data to represent, to change how the chart looks, and to decide where you want to place the chart. You can use the Chart Wizard to create a chart or to format an existing chart.  Excel allows you to insert a range of objects - including pictures - into your worksheet. You can insert two types of picture into a worksheet - a bitmap-type picture or a metafile-type picture. A bitmap consists of pixels and it cannot be ungrouped into objects. A metafile consists of separate lines or curves and can be converted into objects that can be manipulated using the Drawing  toolbar.   Once you have inserted a picture into a worksheet, you can use the formatting features available in Excel to alter the picture. You can also use Excel to create and modify lines.

UNIT TEST:

1. A chart that is inserted into an existing worksheet is known as _____.  A chart that is inserted into a separate worksheet is known as _____.

a. a chart sheet

b. an embedded chart

2. The Chart Wizard can be used only to create a chart.

a. True

b. False

3. Which of the following are chart objects?

a. Titles

b. Legends

c. Keys

d. Chart areas

4. Which of the following can you do in the Print Preview view?

a. Expand the view

b. Add data

c. Change the setup of the page

d. Review the margins

5. Which of the following are properties of a bitmap-type picture?

a. They cannot be ungrouped

b. They can be converted to objects

c. They consist of pixels

d. They are commonly known as clip art

6. A picture can be inserted as an icon.

a. True

b. False

ANSWERS:

1. 1st blank: an embedded chart, 2nd blank: a chart sheet

2. False

3. a, b & d

4. a, c & d

5. a & c*** (b)

6. True

END OF INTERMEDIATE EXCEL

