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ADVANCED EXCEL

ADVANCED EDITING

1 OF 12 (1-3 USING TEMPLATES)

Excel 2000 includes templates that allow you to create standard documents such as invoices, expense statements, and purchase orders.  A template determines the default format of the cells, worksheets, pages, and print settings in a workbook.  It also determines the number of sheets in a workbook, the style of the sheets, and the areas of the workbook that are hidden or protected.  A template sets the default text - including page headers and column and row labels.  It also determines the default data, graphics, and formulas that appear in a workbook or on a worksheet.  And it contains default settings for the toolbars, macros, hyperlinks, ActiveX controls, the workbook calculation options, and the window display options in your workbook.  The templates in Excel can be found in the New dialog box, which you access through the File menu.  If one of the standard Excel templates is not available in the New dialog box, then you need to install it from the Microsoft Office 2000 CD.To do this, you select Settings - Control Panel from the Start menu, and you choose Add/Remove Programs.  You can preview the template in the New dialog box before you use it in your document.  If you want to access templates that are not in Excel by default, you can select Office on the Web from the Help menu to download additional templates from the Microsoft web site.  You can also create your own templates for workbooks or worksheets.  Or you can customize existing templates to meet your needs.  The processes for creating a workbook template and a worksheet template are similar.  In each case you need to create the workbook or worksheet that you want to base the template on before you save it as a template.  To set a template as the default template when Excel starts up, you need to name the template Book.xlt and you usually save it in the XLStart folder under Microsoft Office\Excel on your hard disk.  For a workbook template, you usually create a workbook containing the number of sheets you want in the template.  You can also specify the page, row, and column headers, other default text, formulas, macros, or styles.  For a worksheet template, you create a workbook that contains only one sheet and you format the sheet with the styles and text you want to apply to future sheets using this template.  Then you follow the same procedure as you do to save a workbook template.
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To create a new workbook template, you first create a workbook that contains the settings you want to save in the template.  Then you select the File menu.  And you select Save As.  In the Save As dialog box, you select Template (*.xlt) from the Save as type drop-down list.  The Microsoft Office Templates folder on your hard disk automatically opens when you select the Template (*.xlt) option from the Save as type drop-down list.  And you type a name for your template, in this case Sales Report.xlt, in the File name text box.  You select the Business Planner Templates folder from the Save in text box as the location for your template and you click Save.  The Microsoft\Templates folder can usually be found using the pathC:\<operating system>\Profiles\<user_name> \Application Data\Microsoft Office\Templates\Worksheet Solutions  And your workbook is saved as a template.  If you are creating a workbook template, you can set up a preview of the first page of the template in the New dialog box.  To do this, you select Properties from the File menu after you have saved the template.  Then you select the Save preview picture checkbox on the Summary tabbed page of the Properties dialog box and you click OK.  When you have saved your new template with all the settings that you want, you select Close from the File menu to close the template.
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Let's say that you have created a new workbook template and that you want to use a template to create a new Excel document.  To do this, you first select the File menu.  And you select New.  The New button opens a workbook based on the default template.  On the folder tabbed page of the New dialog box - in this case Business Planner Templates - you select the template you want to use, in this case Sales Report.xlt, and you click OK.  If you have upgraded to Excel 2000 from Excel 97 or Excel 95, the existing templates appear on an Office 97 Templates tabbed page or an Office 95 Templates tabbed page in the New dialog box.  The template is then applied to the new workbook.  Suppose that you decide to edit the Sales Report.xlt template.  To do this, you click the Open button on the Standard toolbar.  And you select Templates (*.xlt) from the Files of type drop-down list.  You select Sales Report.xlt from the Business Planner Templates folder in the Look in drop-down list and you click Open.  In the template you can change any of the content and format settings, as well as macros, formulas, and so on.  When you have made all the required changes, you click the Save button to save the new settings as part of the template.  Any workbooks that you create before you make changes to the template are not affected by the adjustments you make to it.

4 OF 12 (4-5 USING COMMENTS)

Comments are notes that are attached to cells in the worksheet.  You may use comments to remind yourself of something while you're using the sheet or to make notes for other users on a shared worksheet.  When you insert a comment, a red triangle appears in the top-right corner of the cell to indicate that a comment is attached to it.  When you rest your pointer on the cell, the comment is displayed.  The cell does not have to be selected for the comment to display.  The name of the comment author is always displayed in the comment text box.  When you move or sort the contents of a cell, any comments attached to that cell will move to the new location.  Comments are anchored to cells in PivotTables, not to the cell contents.So when you move information in PivotTables, the comments won't move with the cell contents.  A single user can create only one comment per cell on the worksheet.  But if a workbook is shared, more than one user can add their comments to the original comment attached to a single cell.
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Suppose that you want to attach a comment to cell B2 on the first sheet of your workbook - so you select the cell.  Then you select Insert - Comment.  If the Comment button is visible on the Standard toolbar, you can click it to insert a comment instead of using the Insert menu.  And a text box containing your name is displayed so that you type in your comment.  When you have entered your comment, you click anywhere outside the comment box to save and close it.  To edit a comment, you select the cell to which the comment is attached and you select Insert - Edit Comment.  Because you have already created a comment in the cell, the Comment option that allows you to create a comment has been replaced by the Edit Comment option.  You then make your changes in the comment text box and you click outside the text box to save the changes.   If you want to remove a comment, you select the Edit menu.  And you select Clear - Comments.  You cannot remove a comment by removing the cell contents. But you can remove a comment by clearing the cell, using the Clear - All option on the Edit menu.  The comment is then deleted from the selected cell.  You can remove comments by right-clicking the cell and selecting Delete Comment from the shortcut menu instead of using the Edit menu.  You can also use this shortcut menu to make comments visible or to edit them using the Show Comment and Edit Comment options.  To delete all the comments on a worksheet, you select Edit - Go To.  Then you click Special in the Go To dialog box.  And you select the Comments radio button in the Go To Special dialog box and you click OK.  All the comments on the worksheet are now selected and you select Edit - Clear - Comments.  And all the comments are deleted from the worksheet.  You cannot remove all the comments from the entire workbook at once.You need to remove them one worksheet at a time.

6 OF 12 (6-7 SHARING AND MERGING WORKBOOKS)

Excel allows you to share a workbook so that up to 256 people can access a single copy of the workbook at once.  This is useful when a single workbook contains information that is continuously adjusted by a number of people.  The Advanced tabbed page of the Share Workbook dialog box allows you to specify personal settings, for example how often the workbook is updated and which settings appear in the personal view.  You can also specify the way in which you want Excel to resolve conflicts when different users enter conflicting information in the same cell.  By default, Excel prompts users to choose which changes to accept.  When you share a workbook, you can use a change tracking system to record the changes made to the workbook as well as who makes the changes and when they are made.  But Excel deletes the change history by default every 30 days to control the size of the file.  If you want the change history to be stored for more or fewer than 30 days, you need to enter the number of days in the spin box on the Advanced tabbed page of the Share Workbook dialog box.  When you share a workbook, some of the functions, for example merging cells, deleting worksheets, and inserting charts, become inactive.  This means that you need to carry out these tasks before you share the workbook.  Or you need to temporarily remove the shared properties from the workbook to make the changes.  You can make multiple copies of a shared workbook available in a shared location and then merge the multiple copies to one workbook periodically.  To do this, you need to ensure that the change history is enabled on the shared copies and you need to merge the various copies before the change history period expires.  If multiple copies of a workbook contain comments made by different users in the same cell, the comments appear below each other in the comment box.  You can protect parts of a workbook or a whole workbook so that it can be opened, viewed, or edited by selected people.  To do this, you specify the parts of the workbook that should be protected.  You can also enter passwords to control access or to ensure that the protection is not removed.  You can use the protection function to ensure that the change history in a shared workbook cannot be deleted.
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Suppose that you want to share a workbook on your network.  To do this, you select Tools - Share Workbook.  Then you select the Allow changes by …same time checkbox on the Editing tabbed page.  If you want to adjust the settings for the change history of the shared workbook, you click the Advanced tab.  On the Advanced tabbed page the Keep change history for radio button is selected by default.  And you use the days spin box arrows to increase the number days for which the history is kept, in this case to 40.  When you have made all the required changes in the Share Workbook dialog box, you click OK.  You are prompted to save the workbook and you click OK.  The word [Shared] appears after the filename when the file has been shared.  To save the shared workbook to a network location, you select the File menu.  And you select Save As.  In the Save As dialog box, you browse for the network location you want to use, in this case NTServer1\users\Catalog, in the Save in drop-down list.  You can also change the filename for the workbook in the File name text box if you want to.  If you want to merge shared copies of the workbook with a central version at a later date, you select Tools - Merge Workbooks.  Then you select the first file you want to merge with the current workbook in the Select Files to Merge Into Current Workbook dialog box and you click OK.  The files you want to merge may be on a network location or they can be saved on a floppy disk.If you want to select multiple files from the same location to merge them all at once, you press the Shift key or the Ctrl key and you select the files you want to merge.

8 OF 12 (8-9 PRINTING WORKBOO000-12 TOOLBARS)

Suppose that you have merged a shared workbook and you now want to print a number of sheets from the workbook.  First you select the sheets you want to print by pressing the Ctrl key and clicking the sheet tabs.  Then you select File - Print.  In the Print dialog box you select the Active sheet(s) radio button to print the sheets that you have selected.  If you have selected individual cells for printing by dragging your mouse, you select the Selection radio button.  And if you want to print all the sheets in the workbook, you select the Entire workbook radio button.  You ensure that the correct radio button, in this case All, is selected in the Print range section and that the correct number of copies, in this case 10, is entered in the Number of copies spin box.  Then you click OK and the selected sheets are printed.  You can use the Print Preview option from the File menu to preview the pages before printing or to set up a section of the document for printing.  You can also use the Preview button in the Print dialog box to preview a print selection.  You can also use the print Preview option to access specialized printing functions, such as the Page Break view.  In preview mode you can click the Zoom button to view the text as it will appear when printed.  You can also view and adjust the margins using the Margins button.  Or you can alter the page setup using the Setup button.  The Page tabbed page in the Page Setup dialog box allows you to change the way a page is viewed or printed.  For example, you can use the Landscape radio button to print the text horizontally on the page.  You can also use the Scaling section to change the amount of the page that is taken up by the text, in this case 100 percent, and you can set the paper size and print quality for printing.  The Margins tabbed page allows you to adjust the margins in the worksheet so that you can customize the way it appears on the printed page.  And the Sheet tabbed page allows you to determine whether row headings, column headings, and gridlines are printed and to set the layout of the printed sheets.  The Header/Footer tabbed page allows you to select a header or footer to print at the top or bottom of the page.  It also allows you to create a custom header or footer using the Custom Header or Custom Footer buttons on the page.  If you want to select a part of the document for printing, you click the Page Break Preview button.  In the Page Break preview, you can select the area of the document that you want to print.  Then you select the File menu.  From the File menu you select Print Area - Set Print Area.  And the area in the document is set for printing.  And you select File - Print to print the area that you have selected.  When you set a print area, the area you have selected is the only part of the workbook that is printed.To print more of the workbook, you need to set more print areas or delete the print areas and use the normal print options.
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Excel contains a Report Manager that allows you to create custom views of your workbook.  You can use the Report Manager to create print areas and scenarios in parts of your document.  A scenario is a set of default values that is applied to part of a worksheet.  To print sections of your document using the Report Manager, you first need to create reports.  A report is a combination of sections of your document.  To open the Report Manager, you select View - Report Manager.  If the Report Manager option is not available, you need to install it from the Add-Ins on the Office 2000 CD using the Settings - Control Panel option in the Start menu.If the option is still not visible, you need to select Tools - Add-Ins and select the Report Manager checkbox to make the option visible on the View menu.  Then, to create a new report, you click Add.  And you type a name, in this case Los Angeles, into the Report Name text box in the Add Report dialog box.  When you have typed a report name, you select the sheet that you want to include in the report, in this case LASales, from the Section to Add section.  You can also select the View and Scenario checkboxes and you select a view and a scenario for the report from the drop-down lists provided, if applicable.  Views and scenarios need to be created before they appear in the Report Manager.You create them using the View - Custom views and Tools - Scenarios options.  Then you click Add.

When you have added all the sections you want to include in the report, you click OK to return to the Report Manager dialog box.  If you want to print a report, in this case Chicago, you select it in the Report Manager dialog box and you click Print.

Then you enter the number of copies you want, in this case 1, in the Print dialog box, and you click OK.  The Report Manager will then print only the sections of the workbook stipulated in the report you have selected.

10 of 12 (10-12 TOOLBARS)

Excel allows you to choose whether to show or hide a toolbar in your workbook.  If you want to show a hidden toolbar, you select the View menu and select Toolbars.  In the Toolbars submenu, you select the toolbar you want to show, for example PivotTable.  You can also right-click any toolbar on the screen to display the Toolbars shortcut menu and then select the toolbar you want to show from the list.  And the toolbar appears on screen.  If the toolbar you want to show is not in the Toolbars submenu, you select Customize.  You can also select Customize from the Tools menu.  Then you browse the Toolbars listbox on the Toolbars tabbed page and you select the checkbox, in this case Auditing, for the toolbar you want to show.  The toolbar then appears on the screen.  If you want to hide a toolbar, you deselect it in the Customize dialog box.  Or you click the Close button on the toolbar.  If you want to hide a docked toolbar, such as the Standard and Formatting toolbars, you deselect it on the Toolbars submenu.
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You can customize the toolbars in Excel to contain the buttons or menu options that you want.  You can

• add or remove buttons from a toolbar

• copy or move buttons from one toolbar   to another

• copy or move a menu onto a toolbar

• add or remove toolbar separators

Suppose that you want to customize the Forms toolbar in your Excel workbook.  To do this, you can select Tools - Customize.  You can also select View - Toolbars - Customize.Or you can right-click any existing toolbar and select Customize from the shortcut menu.  If you want to add a button to an existing toolbar, in this case Forms, you select it on the Toolbars tabbed page.  Then you click the Commands tab.  On the Commands tabbed page, you select a category, in this case File, from the Category list box.  Then you select a command, in this case Print, and you drag it onto the toolbar.  And the Print button appears on the toolbar.  If you want to add separators to your toolbar, you right-click the button that you want to be first in a section and you select Begin a Group on the shortcut menu.  The separator then appears in front of the button you selected.  To place a separator at the end of a section, you right-click the button that is first in the next section and select Begin a Group again.  To remove a separator, you right-click the toolbar and deselect Begin a Group.  You can also add or remove a separator simply by dragging one button further from or closer to another.  To remove a button, in this case the Print button, from a floating toolbar, you drag the button off the toolbar.  And it is deleted from the toolbar.  You follow the same procedure to remove items from a menu.  When you have finished customizing the toolbar, you click Close.  You can customize a docked toolbar without using the Customize dialog box.  Any toolbar can be docked by dragging it to one of the screen margins where it appears as a line of buttons.  To do this, you click the More Buttons button, in this case on the upper right-hand corner of the Standard toolbar.  Then you select Add or Remove Buttons.  You select the button you want to remove, in this case Spelling, from the Add or Remove Buttons submenu.  The button is then deselected on the submenu and removed from the toolbar.  If you want to add buttons to a docked toolbar, you can use the Add or Remove Buttons submenu to do so.  To add a button to the toolbar, you select the button, in this case the Comment button, from the list.  The button is then checked on the list and it appears on the toolbar. 
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Suppose that you want to copy the Chart Wizard button from the Standard toolbar to the Auditing toolbar.  To do this, you select Tools - Customize.  Then you select the Auditing toolbar on the Toolbars tabbed page to make it visible on screen.  To copy the Chart Wizard button, you click the button and you press the Ctrl key.  You hold the Ctrl key down while you drag the button to the Auditing toolbar and the button appears on both toolbars.  If you want to move the button instead of only copying it, you do not use the Ctrl key when you drag it to the other toolbar.You can move or copy an item from one menu to another in the same way.  When you have moved or copied all the buttons you want, you click Close in the Customize dialog box.  If you have made changes to a toolbar - in this case the Auditing toolbar - and you want to return it to its original settings, you select Tools - Customize.  Then you select the toolbar from the Toolbars list box on the Toolbars tabbed page.  And you click Reset.  Excel prompts you to confirm that you want to remove your customized settings and you click OK.  The original settings are then restored.

END OF ADVANCED EDITING

SUMMARY:  You have seen how to apply advanced editing options.  

Excel 2000 includes templates that allow you to create standard documents for invoices, expense statements, and purchase orders. You can edit these templates to meet your needs or you can create new templates for specific purposes.  Excel allows you to create templates for workbooks or individual worksheets. When creating a template, you can determine the components of the workbook or worksheet, including the style and formatting options, the toolbars, macros, hyperlinks, and formulas.   Excel allows you to attach comment text boxes to cells on your worksheet so that you can make notes to yourself or to other users. You can edit or delete individual comments once you have created them. Or you can delete comments from a worksheet. Comments are attached to the cell contents on worksheets, other than PivotTables, so they move with the cell content if the worksheet is reorganized. But comments are not deleted with the cell content.  Excel allows you to create shared copies of a workbook so that multiple users can work on it at the same time. When you share a workbook, you can stipulate a length of time for Excel to keep a change history of the users who made changes to the workbook and when the changes were made. You can also choose to limit access to the workbook to protect its contents.  Once a workbook has been shared, you can merge shared copies of the document with a central copy that you update periodically before the change history expires. In this way all the changes made by various users are incorporated in one central document.  Excel allows you to print one or more sheets from a workbook, print the entire workbook, or print a selection from a sheet. You can also preview the print layout of the sheets before printing them.  You can use the Report Manager to print parts of a workbook. To do this, you create reports - that is, copies of parts of your workbook - and you print the individual reports.  Excel provides a number of ways in which you can customize toolbars. You can add or remove buttons from toolbars and you can move or copy buttons from one toolbar to another. You can also move or copy menus from one toolbar to another.  You can hide toolbars that are usually visible if you do not want to view them or you can show toolbars that are hidden.

UNIT TEST:

1. Which of the following statements are true of templates in Excel?

a. They are used only to create whole workbooks

b. They contain the print settings for a workbook

c. They determine the style used in parts of the workbook

d. They determine the format of individual cells

2. Which of the following do you need to do when you create a workbook template?

a. Create a workbook on which to base the template

b. Create all the worksheets you want to include in the template

c. Save a workbook as a template file

d. Save a preview of the workbook

3. You can edit a template to change its settings after it has been saved.

a. True

b. False

4. A _____ in the top right-hand corner of the cell indicates that a comment has been attached to it.

a. yellow text box

b. red triangle

c. cell border

5. Which of the following statements apply to comments?

a. More than one comment can be attached to a cell in a shared workbook

b. Comments become visible when you click the cell

c. The name of the comment author appears in the comment text box

d. When the cell content is moved, the comment moves with it

6. You can change comments after you have entered them.

a. True

b. False

7. Which of the following can you specify when you share a workbook?

a. Passwords to protect access to the workbook

b. The time period for which Excel stores the change history

c. The functions that are available in the shared version

d. The shared location in which the workbook is stored

e. The way in which conflicting entries are resolved

8. You can keep only one copy of a shared workbook.

a. True

b. False

9. Which of the following apply when you merge multiple copies of a shared workbook to a central version?

a. Multiple comments attached to a single cell appear one below the other when your pointer rests on the cell

b. The merge needs to occur before the change history deadline is reached

c. You need to remove the shared properties to carry out the merge

d. You need to merge the shared copies one at a time.

10. Which of the following are true of printing an Excel workbook?

a. You can set multiple print areas in your document

b. You need to print one sheet of your workbook at a time

c. You can print a selected section of cells

d. You can preview the section you want to print

11. The Report Manager allows you to set up and print multiple sections of a workbook.

a. True

b. False

12. In which of the following ways can you customize a toolbar?

a. Hide it from view

b. Add buttons from other toolbars

c. Add existing menus

d. Create new buttons

ANSWERS:

1. b, c & d

2. a, b & c

3. True

4. b

5. a, c & d*** (c)

6. True

7. a, b, d & e*** (d)

8. False

9. a & b*** (c)

10. a, c & d

11. True

12. a, b, c & d

ADVANCED EXCEL

SECURITY AND AUDITING

1 OF 10 (1-3 PROTECTING WORKSHEETS)

If your computer is not part of a network, you probably won't need to consider securing worksheets or workbooks.  But if several users access shared workbooks - either locally or across the network - you may need to protect them.  Protecting worksheets prevents users from changing important data or from gaining access to sensitive information.  To protect a worksheet, you select Tools - Protection.  Excel allows you to

• protect individual worksheets

• protect entire workbooks

• protect and share workbooks

When you protect a worksheet, it is possible to allow users to make changes to certain cells.  To do this, you need to decide which cells users can change before you protect the worksheet.  Let's say that you have a table in which you want the salespeople to enter their sales of individual items.  You want to allow them to change the data in some of the cells on the worksheet but you want to protect the data and formulas in all the other cells.  You select the cells that you want to allow users to change.  Then you select Format - Cells.  Alternatively, you can right-click any of the selected cells and select Format Cells.  In the Format Cells dialog box you click the Protection tab.  To allow users to change the selected cells after the worksheet has been protected, you deselect the Locked checkbox.  All the cells in a worksheet are locked by default.But users can still access locked cells if the worksheet is not protected.  And then you click OK.
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Let's say that you now want to prevent salespeople from deleting or modifying the contents of cells.  To do this, you need to protect the worksheet.  To protect the worksheet, you choose the Tools menu.  From the Tools menu, you choose Protection - Protect Sheet.  And you can see that the Protect Sheet dialog box allows you to specify how you want to protect the worksheet.  With the Objects checkbox deselected, you allow users to make changes to items such as graphic objects and comments.  You deselect the Scenarios checkbox to allow users to change or view hidden scenarios.  And with the Contents checkbox selected, you prevent users from making changes to locked cells, viewing hidden rows and columns, and viewing hidden formulas.  The Contents checkbox also prevents users from making changes to items on chart sheets.  To further protect the worksheet, you enter a case-sensitive password in the Password field and you click OK.  In the Confirm Password dialog box you re-enter the password that controls the removal of protection from a worksheet and you click OK.  Now users cannot change or enter data in the locked cell.  If a user tries to change information in a locked cell, an error message is displayed.  However, users can still make changes to unprotected or unlocked cells - in this case cell D9.  To remove protection from a worksheet, you select Tools - Protection and then you select the Unprotect Sheet menu option.  You type the password you used to protect the worksheet and you click OK.  If no password is set for the worksheet, any unauthorized user can unprotect the worksheet and make changes.  When the worksheet is no longer protected, you can change the data in any of the cells.
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Sometimes you need to prevent users from viewing sensitive formulas.  For example, any user can view the commission formula in cell E10, even if the cell is locked and the worksheet is protected.  Let's say that you want to hide all the commission formulas on the worksheet.  First you select all the cells that contain the formulas.  Then you select Format - Cells.  In the Protection tabbed page of the Format cells dialog box, you select the Hidden checkbox and then you click OK.  You protect the worksheet by selecting Tools - Protection - Protect Sheet.  And you specify your options - in this case you protect the workbook's content - and click OK.  You then confirm the password and click OK.  Now that the cell is hidden, you can no longer see the commission formulas in the formula bar.

4 OF 10 (4-6 PROTECTING WORKBOOKS)

Excel allows you to restrict the changes that users can make to elements within the workbook.  For example, you can prevent users from viewing hidden worksheets and from moving, deleting, hiding, or renaming worksheets.  You can also prevent users from inserting worksheets or chart worksheets or from moving or copying worksheets to other workbooks.  You can prevent users from

• recording new macros in  worksheets

• changing the size or position  of the workbook window

• closing open windows

You can protect workbooks from unauthorized changes by applying passwords to open or modify a workbook.  Let's say that you want to prevent users from moving or deleting worksheets in the current workbook and from changing the size of the workbook window.  To protect a workbook, you select Tools - Protection.  Then you select the Protect Workbook menu option.  You select the Windows checkbox to prevent users from moving, resizing, hiding, unhiding, and closing the current workbook window.  In the Protect Workbook dialog box you select the Structure checkbox to prevent unauthorized inserting, moving, deleting, hiding, unhiding, and renaming of sheets.  In the Password field you type the password that users need to enter to remove the protection from the workbook and then you click OK.  You confirm the password and you click OK.  And you return to the current workbook, which is now protected.
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Excel allows you to protect shared workbooks by preventing users from turning off the change history.  You can protect and share an unshared workbook.  If the workbook is already shared, you can protect the workbook but you cannot set a password.  To protect an unshared workbook, you select Tools - Protection - Protect and Share Workbook.  In the Protect Shared Workbook dialog box, you select the Sharing with track changes checkbox to

• share the workbook

• turn on the change history if it is  not already turned on

• prevent users from turning off  the change history

• prevent users from removing the  workbook from shared use

You set a password, which users need to enter to remove the protection from the shared workbook, by typing the password in the Password field and then you click OK.  You cannot set a password for a workbook that is already shared.To set a password for an already shared workbook, you first need to remove the workbook from shared use.  And you confirm the password and click OK.  You click OK to confirm that the workbook be saved.  And the workbook is now shared and protected with [Shared] displayed in the title bar.
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Let's say you want to use passwords to limit the access that different users have to your Expense Report workbook.  You begin by selecting the File menu.  Then you select the Save As menu option.  In the Save As dialog box, you click the Tools button and you select General Options.  In the Save Options dialog box, you see that you can specify that a backup copy be created each time you save the workbook.  You can also specify passwords to open and to modify a workbook.  And you can specify that when users open a workbook they are prompted to open the workbook as a read-only version.  To set a password for opening the workbook, you type the password in the Password to open field.  And you type the password that users must enter before they save any changes to the workbook in the Password to modify field.  In this case you choose not to recommend that the workbook be opened as read-only so you leave the Read-only recommended checkbox deselected and you click OK.  You confirm the password to open and you click OK.  And you confirm the password to modify and you click OK.  And then you click Save.  The workbook is protected with two passwords that allow authorized users different levels of access.  If you want to change or set a password on a shared workbook once it is saved, you need to unshare the workbook first - unless you rename the workbook or save it to a new location.

7 OF 10 (7-8 WORKGROUP COLLABORATION)

Excel's workgroup collaboration facilities allow you to set a workbook's properties to describe and differentiate the workbook.  And you can track any changes made to the workbook by others in the workgroup and accept or reject those changes.  When setting workbook properties, you can set both file properties and custom file properties.  File properties include

• workbook title

• workbook subject

• author

• keywords

• comments

Excel's custom workbook properties include default options - for example the name of the workbook's editor.  But it also allows you to create your own properties - for example a location or an address.  Let's say that you want to set both file and custom file properties on the current workbook.  You select the File menu.  Then you select Properties.  The Properties dialog box displays the tabbed page most recently accessed - in this case the Summary tabbed page.  On this tabbed page you enter the details for the workbook's file properties and you can see that the Author and Company fields are already completed.  The information for the Author and Company fields is taken from the information entered during the installation of Office 2000 on your computer.  In this case you enter information in the Title, Subject, and Keywords fields.  You click the Custom tab to set your own file properties for the workbook.  In the Name list box on the Custom tabbed page you can see that there are pre-existing options you can use.  In this case you select the Department option and you can see that the option is added to the Name field.  You select Text from the Type drop-down list.  In the Value field you type the value for Department - in this case Accounts - and you click the Add button.  And the property is added to the Properties box.  To add your own property, you type it in the Name field -in this case you type Editing Date.  From the Type drop-down list, you select the Date option.  And in the Value field you type the current date - 02/15/2000 - and you click Add.  The new property is added to the Properties box.  To close the dialog box, you click OK.  And you return to the workbook.
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Tracking allows you to view changes made to a shared workbook.  You can view changes made to a workbook by individual users because their changes are marked by different colored borders.  After viewing the changes, you can choose to accept or reject those changes.  Let's say that different people in a workgroup use a workbook so you want to monitor all the changes that are made to the workbook.  To do this, you want to use tracking so you select the Tools menu.  To start tracking, you select Track Changes - Highlight Changes.  In the Highlight Changes dialog box you see that you can specify the changes made to the workbook, specify whose changes will be recorded, and which cells will be tracked.  You select the Track changes while editing checkbox to enable tracking and this activates the When, Who, and Where options.  You can track all changes, which include changes made since the workbook was last saved, changes not yet reviewed, and changes since a specifiable date - in this case you select All.  When you select an option, the relevant checkbox is selected automatically.  And then you select the Who checkbox so that everyone's changes are recorded.  The Where Collapse Dialog button allows you select individual cells or a range of cells - but in this case you want the tracking to apply to the whole workbook, so you don't click this button.  The Highlight changes on screen checkbox highlights changes made to the worksheet and you can see the details of the changes by hovering the pointer over a highlighted cell.  Then you click OK to apply the changes.  You are prompted to save the document so you click OK.  And the workbook is now a shared file.  When changes are made to cells - in this case cells D9, F12, and F16 - the cells have a colored outline and a highlight in the top left-hand corner of the cell.  Also, the row and column numbers and letters are displayed in brown.  And if you hover the pointer over the cell, the screentip displays a username, date, time, and description of the change.  To accept or reject changes, you select Tools - Track Changes - Accept or Reject Changes.  In the Select Changes to Accept or Reject dialog box, you choose the Not yet reviewed option from the When drop-down list to select the changes that you have not yet reviewed.  And from the Who drop-down list you can choose to view the changes made by everyone or individual users - in this case you select the Everyone option.  You click OK to view the changes made in the Select Changes to Accept or Reject dialog box.  You now see that change is the first of three made to the workbook.  The username of the user who made the change, the date and time of the change, and a description of the change are also provided.  To accept the first change made to the workbook, you click the Accept button.  The next change is then displayed and you click the Reject button to reject the change.  The Accept All and Reject All buttons allow you to accept or reject all remaining changes without viewing them - in this case you click the Accept button to accept the final change.  The dialog box closes and you return to the workbook.  You can see that while the accepted changes are still displayed and highlighted, the rejected change is not.

9 OF 10 (9-10 AUDITING A WORKSHEET)

If you use workbooks that contain a lot of data and formulas, it can be difficult to tell the relationships between different cells.  Excel provides auditing tools that allow you to

• find the formulas to  which a cell provides data

• find the cells that provide  data to a formula

• identify the cause of an  error

Let's say that you need to find out to which formulas in a worksheet a cell provides data.  First you need to display the Auditing toolbar, so you select Tools - Auditing - Show Auditing Toolbar.  You can also right-click an existing toolbar, select Customize, and select the Auditing checkbox.  Then you select the cell that you want to audit - in this case C11.  You click the Trace Dependents button on the Auditing toolbar to trace dependent cells.  A blue arrow runs from cell C11 to cell C18 to show that C18 depends on data from C11.  To find out which cells provide data to cell C11, you click the Trace Precedents button.  As you can see cells D11 and F11 provide data to cell C11.  To remove the last set of dependent arrows to be displayed, you click the Remove Dependent Arrows button.  And to remove all the arrows from a worksheet, you click the Remove All Arrows button.  As you can see, all the arrows are now removed.
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Suppose that another user has edited your current workbook and now three error values are displayed.  To trace errors, you select a cell that contains the error value - in this case C18.  And you click the Trace Error button on the Auditing toolbar to find the cause of errors in a worksheet.  The red arrow runs from the cell that causes the error value to the cell you want to audit.  And the blue arrows indicate the cells that contain values that create the error.  Cell C11 is referred to in the formula in C18 but, as you can see, cell C11 contains a divide by zero function - the cause of the error.  You can correct the error by changing the formula so that it refers to a cell containing a number.  And you can see that the divide by zero error has been removed.  To remove the #NAME? error, you select the cell that contains the error value - in this case C18 - and you click the Trace Error button.  You can see - in the formula bar - that the error is caused by text in the formula in cell C15.  You correct the formula.  And you then see that no errors remain.

END OF SECURITY AND AUDITING

SUMMARY:  You have seen how to secure and audit worksheets and workbooks.  

You can protect a worksheet to prevent users from making changes to important workbooks. When protecting worksheets, you can also prevent users from viewing hidden formulas, making changes to graphic objects, and removing the protection from worksheets.  Excel allows you to protect shared workbooks by preventing users from turning off the change  history feature.  Protection prevents users from moving or copying worksheets to other workbooks, changing the size or position of the windows for the workbook, closing the windows for the workbook or removing the protection from the workbook. You can also remove the workbook from shared use.  Workgroup collaboration may require you to keep strict control of workbooks and what changes users make to them. For protection, you can set passwords that grant users different levels of access to a workbook.  In Excel, you can add and customize the properties of the workbook to describe and classify the file.  Tracked changes allow you see where changes were made, when they occurred, and who made the changes. If you control the workbook, you can accept or reject any changes made.  If you use workbooks that contain a lot of data and formulas, it can be difficult to tell the relationships between different cells.  Excel's trace precedents, trace dependents, and trace errors tools allow you to find the formulas to which a cell provides data, find the cells that provide data to a formula, and identify the cause of an error.  You can trace dependents on the same or different worksheets.

UNIT TEST:

1. Which of the following does Excel allow you to do to provide security for worksheets and workbooks?

a. Protect a worksheet

b. Share and protect a workbook

c. Protect a workbook

d. Share and protect a worksheet

2. Passwords for Excel workbooks are case sensitive.

a. True

b. False

3. When you've removed protection from a worksheet, to which cells can you make changes?

a. Only the unlocked cells

b. Only the locked cells

c. All cells on the worksheet

d. All cells without hidden formulas

4. Which of the following measures can you implement to protect a workbook?

a. Prevent users from running macros in a worksheet

b. Prevent users from inserting chart sheets

c. Prevent users from resizing the workbook window

d. Prevent users from renaming worksheets

e. Prevent users from renaming the workbook

5. You cannot prevent users from removing a workbook from shared use.

a. True

b. False

6. Which of the following file property options does Excel automatically apply?

a. The workbook author's name

b. The workbook title

c. The workbook subject

d. The author's company

7. Cells that provide data to a formula are _____ cells, while _____ cells are cells that receive data from other cells.

a. dependent 

b. precedent

8. Which of the following colors is applied to arrow that trace errors?

a. Blue

b. Green

c. Black

d. Red

e. Yellow

ANSWERS:

1. a, b & c

2. True

3. c

4. b, c & d

5. False

6. a & d

7. 1st blank: precedent, 2nd blank: dependent

8. d***

ADVANCED EXCEL

NUMBERS AND RANGES

1 OF 9 (1-4 NUMBER FORMATS)

Excel allows you to format the numbers in your workbook to meet the requirements of the tasks you want to perform.  To do this, you select the Format menu.  And you select Cells.  You can also right-click the cells and select Format Cells from the shortcut menu.  Excel's default number format - the General format - does not provide specific formatting for the numbers in the selected cells.  If you want a specific format for all types of number in the selected cells, you can select the Number format.  This format allows for thousands separators (,) and decimal places without placing currency symbols or other special formatting options in the numbers.  You select a number format for the selected cells from the Category list on the Number tabbed page and you apply it by clicking the OK button.  When you select a number format from the Category list, Excel displays a preview and a description of the format in the dialog box.  For example, when you select Accounting, Excel explains that this format aligns the figures in the selected cells.  A Decimal places spin box and a Symbol drop-down list are also displayed so that you can define precise decimal requirements and currency symbols for the selected cells.  The format you choose is displayed in the sample field using the first cell in a selected range as the source for the displayed number. But the sample cannot appear if the source cell is empty.
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You can create your own number format for the selected cells in your worksheet by selecting Custom in the Category list and selecting one of the existing codes in the list box below the Type text box on the Numbers tabbed page.  For example, if you want to customize the date format, you choose an existing code, such as m/d/yy, which you can adjust.  When you create a custom code, you can specify up to four sections of format code.  The sections are separated by semicolons and appear in the following order:

• positive numbers

• negative numbers

• zero values

• text values

If you specify only two sections of format code, you use the first section to format positive numbers and zero values and the second section to format negative numbers.  If you specify only one section of code, all the numbers in your worksheet take on the format you define.  If you want to skip a section when you create the custom format, you type the semicolon, which represents the end of that section, as part of the code.  Excel uses the following characters for number format code:

• pound (#) signs - to represent digits

• zeros (0) - to represent insignificant  zeros

• question marks (?) - to show extra  spaces for insignificant zeros or  fractions

• a comma (,) as a thousand separator

• a period (.) as a decimal indicator

You use the pound (#) sign to indicate how many digits should appear before and after a decimal place in the number.  For example, if you use the format ###.#, the number 123.39 is rounded off to 123.4.  But if there are more than three numbers to the left of the decimal point, the code will not prevent all the numbers from being displayed, for example 1234.39 is shown as 1234.4.  If you want to indicate a thousand separator in a number with four digits or more before the decimal point, you type a comma (,) in the code, for example #,###.00.  You use insignificant zeros to display zeros on either side of a decimal point when there are no digits to fill the places in the number or when digits are irrelevant.  For example, the code ##.000 will display the number 5.5 as 5.500.  Insignificant zeros do not change the meaning of the number, for example, the last two zeros in the number 550.00.  Question marks (?) act as placeholders for insignificant zeros on either side of a decimal point.  You can use question marks to ensure that numbers are aligned in a fixed-width font or to indicate fractions with varying numbers of digits.  For example, the code ???.??? will ensure that the decimals in the numbers 234.98 and 3.5 are aligned in the worksheet.  You can ensure that certain numbers are printed in color by placing the name of the color in square brackets at the beginning of the relevant section of code.  For example, if you want all positive numbers to appear in blue on the worksheet, you type [Blue] at the beginning of the first section of the code.  You can use only the eight colors Black, Blue, Cyan, Green, Magenta, Red, White, and Yellow in your number code.
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Suppose that you want to create your own number format for a portion of your worksheet so that, for example, there are four numbers before the decimal point and two numbers after it.  You also want to display positive numbers in green and negative numbers in red in the selected cells.  To create your own number format, you select Custom from the Category drop-down list on the Number tabbed page.  And you select one of the basic custom codes, for example #,##0.00_);[Red](#,##0.00), in the Type list box.  You edit the basic custom format to suit your purposes - in this case you type the color [Green] into the code.  The changes you make to the basic code do not remove the code from the list box.Your changes are simply applied to the selected cells.  When you have completed the custom code for the selected cells, you click OK.  And the custom format is applied to the selected cells.

If you want to remove a custom format from the Custom list, you select Format - Cells.  And you select the custom code you want to delete from the Custom Type list box on the Number tabbed page.  To remove the custom code, you click Delete.  And you click OK.  If you have selected the cells to which the custom code was applied, Excel applies the General number format to the cells by default.  You can delete only the custom formats that you have created from the Type list on the Number tabbed page.
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You can apply conditional formatting to cells in your worksheet.  For example, you may want to highlight all the cells in an expense sheet that contain negative numbers.  You can do this by applying a conditional format that applies the color red to all cells that contain negative numbers.  If you want to apply a particular format to some cells under specific conditions, you select the cells and you select the Format menu.  And you select Conditional Formatting.  In the Conditional Formatting dialog box you can define one or more conditions, for example a specific cell value or formula, that cause cells to take on a particular format.  In this case you keep the default selection - Cell Value Is - and you set a condition for the format by selecting a comparison, in this case greater than.  Then you type a value for the cell, in this case 5000.  To set the format that is applied to the cells in the given conditions, you click the Format button.  Part of the Format Cells dialog box is displayed and you can select the Font, Border, or Pattern settings for the cells that contain the condition you have set.  In this case you select Italic from the Font style list box and Blue from the Color drop-down box on the Font tabbed page.  You click OK to complete the format settings for the selected cells.  And you are returned to the Conditional Formatting dialog box where the font style you have chosen is previewed in the Condition 1 section.  If you want to set another conditional format for the selected cells, you click Add.  Then you set the condition, in this case Formula Is =SUM(A5:I20) in the Condition 2 section.  There is no comparison setting for formula conditions because Excel simply evaluates each cell and determines whether the formula condition is true or false for that cell.  And you select a format for the cells when they meet the condition, in this case a blue border.  When you have set all the conditions for the format - to a maximum of 3 - you click OK to apply the conditional format settings to the selected cells on the worksheet.  If you want to remove a conditional format at any time, you select the cells that contain the format and you select Format - Conditional Formatting.  Then you click Delete in the Conditional Formatting dialog box.  And in the Delete Conditional Format dialog box you select the checkbox for the condition you want to delete, in this case Condition 2, and you click OK.  To delete all the conditional formats at once, you can select all the checkboxes in the Delete Conditional Format dialog box.Or you can select the relevant cells and select Clear - Format from the Edit menu.  You are returned to the Conditional Formatting dialog box and you click OK to save the changes you have made to the conditional format settings.

5 OF 9 (5-7 NAMED RANGES)

Excel allows you to refer to cells or ranges of cells by means of names as well as cell references in your worksheet.  This is because it is often easier to remember and type text names when you construct formulas, for example, =SUM(Sweatsuits,Swimwear) instead of =SUM(B9:N10).  Cell or range names may contain up to 255 characters in any combination of letters or numbers but they may not contain spaces.  These names may also not resemble cell addresses, for example A12.  Underscore characters and periods may appear in range names and are often used instead of spaces, for example Total.Sales.  Names of between 10 and 15 characters in length are best because they are easily displayed in most drop-down lists.  Excel does not distinguish between uppercase and lowercase letters in cell or range names.  For example, if you name one range Total and the other TOTAL, Excel reads these as the same name and replaces the first range with the second.  Excel contains some predefined range names such as Print_Area and Sheet_Title for its own use and you should avoid using these names for your ranges.  Suppose that you want to name the cell containing the January subtotal in your worksheet.  To do this, you select the cell and you click the Name Box in the left corner of the Formula Bar.  The cell reference in the Name Box is automatically highlighted and you can type a name, in this case Jan_total, in the box.  You can also select Insert - Name from the menu bar to create a name for the cell.  Suppose that you want to define the range of cells above the January subtotal as the Jan_total instead of giving that name to the single cell.  To do this, you can select the cells and type the name in the Name Box as you do for naming a single cell or you can select the cells and select Insert - Name.  Then you select Define from the Name submenu.  In the Define Name dialog box you type a name, in this case Jan_Total, into the Names in workbook text box and you click Add.  Then you click OK to return to the worksheet.  To view the names you have created in the worksheet, you click the Name Box down-pointing arrow and a list of names is displayed.   If you want to delete a cell name or a range name, you select Insert - Name.  And you select Define.  Then you select the name of the range you want to delete, in this case Jan_Total, and you click Delete.  The name is deleted from the workbook and you click OK to return to the worksheet.

6 OF 9

Excel allows you to name a cell or range that is already labeled in the worksheet.  Labels are different from range names because labels appear as a visible part of the worksheet whereas range names do not.  Suppose that you want to use the left-hand column labels as range names in your worksheet.  To do this, you select the cells and you select Insert - Name.  And you choose Create.  In this case you select the Left column checkbox in the Create Names dialog box and you click OK.  The row and column labels then appear as names in the Name Box along with the other range names that you create.  If you want to move quickly between parts of your worksheet, you can move to a range in the worksheet by selecting a range name from the Name Box or by using the Go To menu option.  You can select the Go To menu option from the Edit menu.  You can also access the Go To dialog box by pressing Ctrl+G or the F5 key.  In the Go To dialog box you select the range you want to go to, in this case Leotards, and you click OK.  Excel then highlights the range you have chosen.  Suppose that you have several sheets in your workbook and you want to use the same name, for example Jan2000, on all of the sheets.  Excel recognizes the original sheet location of a range name throughout a workbook so you need to specify a sheet reference if you want to use a name on more than one worksheet.  To create a sheet level name, you first select the range of cells you want to name on a sheet.  Then you click the Name Box.  And you type the sheet name, an exclamation mark, and the range name - in this case NYSales!Jan2000.  To apply a sheet level name, you press Enter.  If you use a sheet level range name, for example NYSales!Jan2000, in a formula on the same sheet, in this case NYSales, you do not need to use the sheet reference.  But you do need to use the sheet reference when you use the sheet level name on another worksheet in the workbook, for example on the LASales sheet.  If you use a range name in more than one workbook and you need to use the range name in formulas in both workbooks, you need to include a workbook reference in the range name.  To do this, you enter a colon after the workbook reference in the range name, for example 1998:LASales!JanTotal.
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You can use named cells or named ranges in formulas.  To do this, you select the cell in which you want to create the formula.  In the Formula Palette, you type the formula but you include the range names instead of cell references, in this case =SUM(Swimwear,Wetsuits).  Then you click OK or you press Enter.  You can see that Excel has performed a calculation based on the ranges represented by the range names.  You can use a function to calculate the value of a single named range using the function and the range name, for example, =AVERAGE(Travel_Total).  You can use named ranges in combination with other cell references in a formula, for example = Total - N14.  And you can name formulas.  If you want to name a formula, you select Insert - Name.  And you choose Define.  In the Define Name dialog box you type the name you want to give to the formula, in this case Jan99_Total, in the Names in workbook text box.  And you type the formula you want to name, in this case =SUM(NYSales!$B$5:$B$13), into the Refers to text box.  You can also name constant values such as percentages in this way.  You click Add to add the name of the formula to the list.  And you click OK to return to the worksheet.  You can use a named formula as part of another formula.  To do this, you type the name as part of the formula, for example, Jan99_Total-B13.  And Excel calculates the result of the named formula before carrying out the rest of the formula you have defined.  

8 OF 9 (8-9 LOOKUP FUNCTIONS)  

Hlookup and Vlookup are specialized formulas that search for a variable value in a table or range of cells so that it can be entered in another cell or used in a formula.  These formulas begin by searching for a reference value - known as a lookup value - such as a text string and then look up a variable value in the same row or column as the lookup value.  Hlookup - Horizontal lookup - finds the lookup value horizontally and Vlookup - Vertical lookup - finds it vertically.  You may use a lookup function, for example, when you want to compare employees' incomes in one worksheet with information in a tax table in another worksheet.  The lookup function finds the value in the tax table that most closely resembles the income you have entered and returns the amount of tax that should be paid.  The Hlookup function searches the top row of a table or an array (a range) for a lookup value that you specify.  The lookup value can be a cell reference, a text string, or a number.  Excel then searches the table or range in the worksheet for a cell containing the lookup value you have specified.  When Excel finds the lookup value, it searches the column below that value in the table for a row that you specify.  It then returns the value of the cell that holds the column and row reference you have provided - that is, a specific row in the column containing the lookup value.  For example, you may specify that Excel should search the column beginning with the cell containing the text string Total Items Sold in the range A6:G18 for a value in the third row from the top of the table.  Vlookup works in the same way as an Hlookup but it searches for a lookup value in the left-hand column of a table or range that you specify.  It then returns a corresponding value from a cell in the same row but in a column to the right of the one containing the lookup value.  A Vlookup may, for example, search the range A6:G18 for a cell containing the lookup value ‘Liesl' and to return the value in the same row but in column 3 of the specified range.  A Hlookup formula is structured as follows:lookup_value,table_array,row_index_num,range_lookup  And a Vlookup formula is structured as follows:lookup_value,table_array,col_index_num,range_lookup  A Vlookup searches a col_index_number while an Hlookup searches for a row_index_number.  Excel searches for the lookup_value in the first row or left-hand column of the specified table_array.  The table_array is the table or range in which Excel searches for the lookup_value.  The row_index_num or the col_index_num represent the specified row or column, for example 3, that Excel should find in the table.  If you enter a row_index_num less than 1 or greater than the maximum number of rows in the specified range, Excel returns an #VALUE! or #REF! message because it cannot calculate the value.  The range_lookup value is either True or False.  If you enter the range_lookup as True or leave it blank, Excel finds a value equal to or as close as possible to the lookup value.  As a result, the True range lookup value is useful when you want to look up numbers in a range such as a tax table.  If you enter the range lookup value as False, Excel tries to find an exact match for the lookup value.  You usually use a range lookup value that is True when you want Excel to look up numbers that fall within a range of variables in a table.  When the range_lookup value is False, Excel returns an error message - #N/A - if it cannot find the value in the first column or row of the table.  If the range_lookup value is True or blank, you need to sort the table_array in ascending order but if the range_lookup is False, you do not need to sort it.  A completed Hlookup or Vlookup formula may look like this.  You can use either uppercase or lowercase letters when entering the fields for a lookup because Excel treats both cases equally.
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Suppose that you are working out the bonuses for a group of salespeople based on the sales figures in December 1999 and January 2000.  Because you need to use the sales figures on another worksheet - Holiday Sales - to work out the bonuses, you decide to use the Hlookup function as part of the bonus formula.  To begin working out the bonuses, you select the first cell you want to enter a bonus in.  Then you click the Paste Function button.  You can also select Insert - Function from the menu bar.  And you select Lookup & Reference in the Function Category list box of the Paste Function dialog box.  If you have recently used the Hlookup function, it appears in the Function drop-down list box to the left of the Formula Bar and you can select it there.If the function is not in the drop-down list, you can select More functions from the list to call up the Paste Function dialog box.  You select Hlookup from the Function name list box and you click OK.  The Formula Palette then appears on screen with the Hlookup fields entered.  In this case you type the text string Total Items Sold because you want to refer to the column in the other worksheet that contains this label.  You can also click the Collapse Dialog button and click the sheet tab for the worksheet that contains the lookup value.You then click the cell containing the lookup value and click the Collapse Dialog button again to enter the cell reference in the Lookup_value field.  Then you press the Tab button to move to the Table_array text box and Excel automatically places quotation marks around the text string lookup value.  And you click the Collapse Dialog button so that you can select a range for the lookup.  To select the range for the lookup, you click the tab for the worksheet you want to reference, in this case the Holiday Sales tab.  And you select the range of cells for the array on the worksheet, in this case A6:G18.  Then you click the Collapse Dialog button to enter the range in the Table_array field.  You can simply type the range into the Table_array text box in the same way that you normally enter a range, in this case ‘Holiday Sales'!A6:G18.  You press the Tab button to move to the Row_index_num field, where you enter the number for the row you want to reference, in this case 3.  And, in this case, you type False in the Range_lookup text box because you want Excel to match the lookup value.  Then you click OK to enter the Hlookup formula in the cell.  To complete the bonus formula in this worksheet, you type *15 into the Formula Bar to multiply the number of units sold by 15.  Then you click OK or press Enter to complete the formula and the result appears in the selected cell.  You then repeat the formula in all the cells in the Bonus column.  You cannot use the Fill formula function to copy the formula to the other cells unless you make the cell references in the formula absolute.If you do use absolute cell references, you can copy the formula but you still need to change the row index number because this will stay the same.  You can use the Vlookup function to create the bonus formula instead of the Hlookup function but the formula is likely to look as shown here.

END OF NUMBERS AND RANGES

SUMMARY:  You have seen how to use number formats and ranges in Excel.  

Excel allows you to apply a variety of number formats to your worksheets. These formats accommodate various number types and special worksheet functions such as accounting. You can also create custom number formats based on sample codes provided by Excel. These codes may include currency symbols, decimal places, insignificant zeros, and text color formats.  You can create special format settings for certain cells in Excel using the conditional formatting facility. Depending on your settings, Excel selects cells for formatting based on their value or the formulas they contain.  Excel allows you to refer to cells or ranges of cells in your worksheet by means of names as well as cell references. You can use names to provide memorable text references for complicated range references. You can also give names to formulas to make it easier to type existing formulas into new formulas.  You can use named ranges in formulas, either on their own or in combination with normal cell references.  Excel provides the Hlookup and Vlookup functions so that you can perform calculations with variable values. You use these functions to look up values in tables or cell ranges in other worksheets.  Hlookup searches for a lookup value in the first row of a range and then checks the column below the lookup value for another value, which it returns to the active cell. Vlookup searches for a lookup value in the left-hand column of a range and then finds another value in the same row as the lookup value.  You determine the lookup value, the range of cells that Excel searches, the column or row that it searches in the range, and whether it should find an exact match of the lookup value when it searches the range.

UNIT TEST:

1. Excel's default number format is the _____ format.

a. General

b. Number

c. Accounting

2. You use the _____ symbol in Custom number format code to ensure that decimal places are aligned in your worksheet.

a. :

b. ,

c. #

d. ?

3. How many sections of code may you specify when creating a custom number format?

a. 2

b. 4

c. 6

d. 8

4. If you specify two sections of code for a custom number format, the _____ section provides the format for positive values.

a. first

b. second

5. If you type the custom number code ##.000, Excel prints the number 1250.65 as _____.

a. 1250.65

b. 1,250.65

c. 1250.650

d. 1,250.650

6. Which of the following colors can you use in custom number format code?

a. Blue

b. Green

c. Peach

d. Magenta

e. Orange

7. If you adjust a default custom code, the default code is replaced by your custom code when you save the document.

a. True

b. False

8. On which of the following can conditional formatting be based?

a. A cell value

b. A cell reference

c. A formula in a cell

d. A cell's position in a range

9. Which of the following can be applied to a cell as part of conditional formatting?

a. A number format

b. A border

c. A pattern

d. A font color

10. Which of the following are valid range names within a workbook?

a. MyExpenses

b. My Expenses

c. 1999!My_Expenses

d. 1999:My_Expenses

11. Which of the following are valid range name references between workbooks?

a. 1999:My_Expenses_September

b. 1999!MyExpenses!September

c. 1999:'My Expenses'!September

d. 1999:MyExpenses!September

12. Which of the following are true of naming ranges?

a. You can use either uppercase or lowercase letters in names

b. You can name a single cell

c. You can use column an drow labels as range names

d. You can use up to 300 characters

e. You can use range names in formulas

f. You can name a formula

13. You can use a combination of range names and normal cell references in formulas.

a. True

b. False

14. You use _____ to find a lookup value in the first row of a table and you use _____ to find a lookup value in the left-hand column of a table.

a. Vlookup

b. Hlookup

15. To which of the following can a lookup value refer?

a. A cell reference

b. A cell value

c. A formula

d. A text string

16. Which of the following do you specify in Hlookup and Vlookup formulas?

a. The lookup value

b. The range of cells to search

c. The column or row to search

d. The result of the search

17. If the range lookup value is _____, Excel finds an approximate match for the value but if the range lookup value is _____, Excel finds an exact match for the lookup value.

18. Hlookup and Vlookup treat uppercase and lowercase letters equally.

a. True

b. False

ANSWERS:

1. a

2. d***

3. b

4. a

5. c

6. a, b & d***

7. False.  The new custom code is added to the list of custom codes but the original default code remains part of the list.

8. a & c*** (b)

9. b, c & d*** (a & d)

10. a & c

11. c & d

12. a, b, c, e & f*** (f)

13. True

14. 1st blank: Hlookup, 2nd blank: Vlookup

15. a, b & d*** (a & c)

16. a, b & c*** (c & d)

17. 1st blank: True, 2nd blank: False

18. True

