System Monitoring with KSysGuard

In the days of a Linux administrator, it is almost invariable that he/she will need to monitor the
system(s) for any bottlenecks. There are several programs available for this, several daemons
available, but we will cover a fairly powerful and flexible application called KsysGuard.

KsysGuard is accessible at least three ways: typing 'ksysguard' on the command line, clicking K-menu
> System > Monitoring > KsysGuard, or CTRL-ESC (this usually brings up only the process list).
Windows users will see this application as a morph between Task Manager and Performance Logs and
Alerts. Notice the information already shown at the bottom of the window.
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Sensor Browser

=% T localhost

o - i

i|_85 Processes | Memory: 240,052 KB used, 15,692 KB free | Swap: 2,672 KB used, 503,808 K& free

Be sure to explore the buttons along the top: New, Open, Save, Connect Host, Disconnect Host, Copy,
Cut, Paste, Worksheet Properties, and Configure Style. We'll be using a few of these during this
discussion, but you'll want to be at least familiar with them once you are ready to feel out this program.

Under “Sensor Browser”, you'll find all the sensors you can monitor. Think of these sensors as the
answer to questions like, “What is the average load on my CPU over the past minute?”” Here are the
major categories:
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Sensor Browser Sensor Type
-Advanced Power Management

-CPUO

-CPU Load

-Disk Throughput

Memory

Network

IR O B O Oy O Oy

-Partition Usage
[ Process Controller Process Controller
E_...gProcess Count Integer Value



Here are the sensors under Advanced Power Management, CPUO (the only CPU on this computer),
and CPU Load:

8T Iocalhos
—-Mdvanced Power Management
L.y Battery Charge
E----mFier‘nainim_:] Time

- CPUO

- Clock Frequency

Integer Yalue
Integer Value

Floating Point Value

- [ ldle Load

- Nice Load

- g System Load
- g User Load
PU Load

Integer Value
Integer Value
Integer Value
Integer VYalue

- [ Context Switches Integer Value
- ldle Load Integer Value
- Interrupts

- Load Average (15 min)
- Load Average (1 min)
- Load Average (5 min)

Floating Point Value
Floating Point Value
Floating Point Yalue

- [ Nice Load

- g Pages In

- Pages Out

- g Systerm Load
- g User Load

Integer Value
Integer Value
Integer Value
Integer Value
Integer VYalue
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Under CPU Load, here are the sensors under Interrupts:

--CPU Load
- Context Switches Integer Value
- Mg ldle Load Integer Value
- Interrupts
- gint 0 Integer Value
- gint 1 Integer Value
- {gint 10 Integer Value
- fdaInt 11 Integer Value
- fgInt 12 Integer Value
- MgInt 13 Integer Value
- fdgInt 14 Integer Value
- Int 15 Integer Value
- [MglInt 16 Integer Value
- gInt 17 Integer Value
- {MgInt 18 Integer Value
- [dgInt 19 Integer Value
- [Mgint 2 Integer Value
- Int 20 Integer Value
- gInt 21 Integer Value
- MInt 22 Integer Value
- gInt 23 Integer Value
- fgInt 4 Integer Value
- MgInt 5 Integer Value
- [MgInt 6 Integer Value
MaInt 7 Integer Value
- pMgInt 8 Integer Value
- [gint 9 Integer Value
MaTotal Integer Value
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The next major category down is “Disk Throughput”, and here are the sensors available:

_.Disk Throughput

.10
i----MRead Accesses Integer Walue
?----ﬁhﬁead Data Integer Value
%----ﬁthtaI Accesses Integer Value
E----ﬁhWrite Accesses Integer Value
5....MWrite Data Integer Value

+ L1

+1:10

+-1:11

1112

+-1:13

Under Memory, both Physical and Swap memory:

+- Lisk Throughpu

i--r*-'1er‘r'u::|r'_|,.r
- Physical Memory
- [ Application Memory Integer Value
- Buffered Memory Integer Value
- Cached Memory Integer Value
- Free Memory Integer Value
- Mg Used Memory Integer Value
-~ Swap Memory
- Free Memory Integer Value
- g Used Memory Integer Value
+-Network

Now, under Network, you'll find your interfaces and their corresponding sensors:

2 Network
<-Interfaces
--etho
~-Receiver
- Compressed Packets Integer Value
- g Data Integer Value
- Dropped Packets Integer Value
- W Errors Integer Walue
- M FIFO Overruns Integer Value
-\ Frame Errors Integer Walue
- g Multicast Integer Value
- g Packets Integer Value
—-Transmitter

- (g Carrier Integer Walue
- jil Collisions Integer Value
- Comnpressed Packets Integer Value
-y Data Integer Value
- Dropped Packets Integer Value
- M Errors Integer Value
- [ FIFO Overruns Integer Walue
- g Packets Integer Value

+-ethl

1o




The next major category is Partition Usage. Keep in mind that you can set an alert for Free Space, and
you'll begin to realize a bit of the potential this could have for monitoring servers.

+- NETWOTK
2 Partition Usage
=-home
M Fill Level Integer Value
é----ﬁhFree Space Integer Value
H Used Space Integer Value
—-mnt
- windows
E----mFiII Level Integer Value
é----gFree Space Integer Value
..Ml Used Space Integer Value
—- root
E----mFiII Level Integer Walue
‘Eﬁi Free Space Integer Value
E----ﬁﬁL.lSEr:i Space Integer YWalue
- g Table Table
- {f Process Controller Process Controller
- Process Count Integer Value

At the bottom of this, you'll see Process Controller and Process Count. Process Controller gives a
single window effectively combining something like “top” and “kill”. Again, keep in mind this can be
used on remote systems, and again you'll start seeing the potential for the Linux admin.

In order to being using the sensors, we need to start a worksheet, either by clicking File > New, or by
clicking the button New.

—Title
Sheet 1
—Properties
Rows: I
Columns: 1 p=4
Update interval: 2 sec_:_:
oK | Cancel

Label the worksheet something meaningful. If you plan on just having CPU sensors, label it “CPU”. If
you plan on having the process list, label it “Process List”.



At this point, instead of making a whole new worksheet, we are going to load in the standard
worksheets and explore them in more detail. This will give us a starting point by giving us two
worksheets already, “System Load” and ‘“Process Table”.
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| /= Open... ctri+0 'I_
|| = ©pen Recent 55 |
{d save ctrl+5
o] Save As...
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Here is the first worksheet:
e W%
System Load | Process Table |

—CPU Load ~Load Average (1 min)

CPU Load consists of CPU Nice Load, CPU System Load, and CPU User Load.

Load Average (1 min) is fairly self explanatory.

Physical Memory consists of cached physical memory, buffered physical memory, and application
physical memory.

Swap Memory is a single sensor showing used swap memory.

These particular graphs are cumulative; the sensors in a graph are added together for the entire height,
and they are broken up using the color legend. We'll come back to these graphs in a little bit.



The next worksheet, Process Table, gives a list of current processes, similar to the ouput given by
“top” on the command line.

System Load | Process Table
Mame PID | Userss | System%. Nice Vmsize | VmRss | Login | cornmand £
& aio/0 59 000 000 5 0 12 root '
& apmd 3160 0.00 0.00 0 1,556 536 root Jusr/sbinfapmd
% artsd 4225 078 0.00 0 47,264 7,968 kingttx Jusribinfartsd
@ ata/o 726 0.00 0.00 =5 0 12 root
% atd 3310 0.00 0.00 0 1,680 620 root Jusr/sbin/atd
#. bash 4554 0.00 0.00 0 3,144 1,820 kingttx Jbinfbash
& bash 5324 0.00 0.00 0 2,640 1,564 root bash
% cardmgr 2003 0.00 0.00 0 1.696 744 root Jsbinfcardmgr
¢ crond 3572 0.00 0.00 0 1,596 648 root crond
% cupsd 2654  0.00 0.00 0 5480 2,400 root cupsd
# dbus-daemon-1 3066  0.00 0.00 0 2,220 1,188 messagebus dbus-daemon-1
iy dcopserver 4203 0.00 0.00 0 22,432 B.460 kingttx dcopserver [kdeinit] --nosid
&} events/0 3 0.00 0.00 5 0 12 root
@} freshclam 3557  0.00 0.00 0 4,336 1,416 clamav Jusrsbin/freshclam
7 gam_server 4216 0.78 0.00 0 2,596 1,360 kingttx Jusrflib/gam_server
# gconfd-2 4179  0.00 0.00 0 3936 2,508 kingttx Jusrflib/gconfd-2
&} gnome-volume-ma 4172  0.00 0.00 0 17.112 6,520 kingttx gnome-volume-manager
@ hald 3081 0.00 0.00 0 4,028 2,604 root hald
@ ifplugd 2479  0.00 0.00 0 1,584 536 root /sbinfifplugd
Q init 1 0.00 0.00 0 1.564 548 root init [51 .|
Tree All Processes ¥ Refresh Kill |

Notice the difference after clicking the “Tree” checkbox:

e S e e ———— = mmamT e mmewom magees o r
3 % kdm 3204 0.00 0.00 0 2,608 B00 root Jusribin/
— 6 kdm 4044 0.00 0.00 0 3,548 1,908 root -0
= 4 startkde 4074 0.00 0.00 0 2,960 1,484 kingttx /binfsh
4228 0.00 0.00 0 1,536 348 kingttx kwrappe
4142 0.00 0.00 0 22,712 17,156 kingttx J"usn"bina"F
- 4 startkde 4171 0.00 0.00 0 2,956 1,476 kingttx /bin/sh
i {::“') gnome-volume-ma 4172 0.00 0.00 0 17,112 6,520 kingttx gnome-\
j)( 4043 4.8B5 0.97 0 43,428 18,732 root fetc/X11|
- [y khelpcenter 5548 0.00 0.00 0 33,332 21,444 kingttx khelpcer

Next to “Tree”, notice the drop down box. Here are all the filtering options:

System Processes

User Processes
Own Processes

AII Processes ¥
“Refresh” will re-list the processes if needed, and “Kill” will kill a highlighted process.



Let's return to the graph and show how to change properties of both a worksheet and a graph.

The Worksheet Properties can be accessed in at least two ways, either by clicking the properties button

=+ or by clicking Edit > Worksheet Properties. This brings up the following dialog box. Notice

b

L NIve already changed the amount of rows and cells to 1x1.

—Properties
Rows: ]_f;
Columns: =
Update interval; 2 sec:f;:

-

Cancel

.

Note this important detail: The more graphs/sensors you have, and the smaller the update
interval, the more load on your CPU to process the information and redraw your graphs or note
your logs. Weigh this against your needs.

Let's say I wanted to add another graph. I'd open the properties and add a row or column and end up
with something like this (1 column, 2 rows):

System Load | Process Table

~CPU Load
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—Drop Sensor Here




Let's drag and drop Swap Memory > Used Memory. Notice the popup once the mouse button is
released:

Select Display Type
Si-gn;:-zl F;ictter
Multimeter
BarGraph
SensorLogger

Here is the Signal Plotter:

—Used

ory: 251,408 KB used, 4,336 KB fres Swap: 2,452 KB used, 504,028 KB free

: =
You can compare the numbers against the graph in this case since we picked a graph that KsysGuard
normally notes in the status anyway.
Here is the same information as a Multimeter:

—Used
ary: 247,788 KB used, 7,956 KB free Swap: 2,580 KB used, 503,900 KB free
.

Notice that the unit is not noted here. Units for space are generally noted in KB's.



Here is the same information noted as a bar graph. In order to show you some differences, I also added
CPUO > System Load in the same display. Once a display type is selected, any additional sensors
added will take on the same type.

—Used

ory: 252,012 KB used, 3,732 KB free

Swap: 2,624 KB used, 503,856 KB free

—— [ i

Notice how difficult it is to see the graph color against the dark background. This gives us a chance to

look over the display properties and change this. Right-click in the display and select Properties. For

this particular display, here are the four tabs (Range, Alarms, Look, and Sensors):

WSLEETTT Giard

Range | Alarms | Look | Sensors

—Title
{Used|

—Display Range

Minimum \.ralue:. 0.00 5 Maximum wvalue; 100.005::

oK Apply Cancel

N STERT Giard

| Look | Sensors

m Value
Lower limit:

—Alarm for Maximum Value
Enable alarm Upper limit: |

oK Apply Cancel




Range Alarms

Normal bar color:

Font size:

Out-of-range color:

Background color:

Look

Sensors

Apply

-

Range Alarms Look Sensors
Host Sensor Label |Unit | Status Edit...
localhost CRUQ/Systemn Load System % oK
localhost Mermnory/Swap Memory/Used Memory Used KB Delete
Y [l
oK Apply Cancel

=

In Range, you can change the name of the display, and also what range to actually show.

In Alarms, you can set an alarm for a certain amount. There is a shortcoming to this, however. Notice

that the Swap Used Space is up around 2,624KB. The alarm can only go between 0 and 100, showing

it'd be best used for sensors showing percentages. Here is the display for Swap Space Used with the

max at 100, definitely not what we want. This is something to keep in mind when setting an alarm.

—Used




In Look, notice I've already changed the color for “Normal Bar Color”, and here is the remarkable

improvement:
—Used

ory: 252,244 KB used, 3,500 KB free Swap: 187,832 KB used, 318,648 KB free

In Sensors, you are able to see what sensors populate this display, edit the label of the sensor, and
delete a selected sensor.

The final type of display is SensorLogger, and this is probably the best tool for recording a baseline for
a system (use Google to find different articles on recording a baseline for your servers and why this is
important). Once you select SensorLogger, you are given a dialog box to enter a filename for the log,
and to enter any alarms you'd want noted.

sof Logger- Sy SLer GUand
—File
UsedSwapMemory.log [
—Tirmer Interval
e S A A e 2 seci,]
—&larm for Minimmum Value
Enable alarm
—&larm for Maximum Value
Enable alarm
oK | Cancel




Once you click OK, you are brought back to the display with the following:
Sensor Logger

Logging | Timer Interval |Sensor Name |Host Name |Log File

Notice we're not logging anything yet; to start logging, right-click anywhere on the line of the entry
and select “Start Logging”. The X will turn into a green check mark. Here is the file after about 45
seconds of logging:

[kingttx @tomslaptop ~]$ cat UsedSwapMemory.log
Jan 10 12:42:40 localhost mem/swap/used: 88668
Jan 10 12:42:42 localhost mem/swap/used: 88668
Jan 10 12:42:44 localhost mem/swap/used: 88668
Jan 10 12:42:46 localhost mem/swap/used: 88668
Jan 10 12:42:48 localhost mem/swap/used: 88668
Jan 10 12:42:50 localhost mem/swap/used: 88668
Jan 10 12:42:52 localhost mem/swap/used: 88668
Jan 10 12:42:54 localhost mem/swap/used: 88668
Jan 10 12:42:56 localhost mem/swap/used: 88668
Jan 10 12:42:58 localhost mem/swap/used: 88668
Jan 10 12:43:00 localhost mem/swap/used: 88668
Jan 10 12:43:02 localhost mem/swap/used: 88668
Jan 10 12:43:04 localhost mem/swap/used: 88668
Jan 10 12:43:06 localhost mem/swap/used: 88668
Jan 10 12:43:08 localhost mem/swap/used: 88668
Jan 10 12:43:10 localhost mem/swap/used: 88668
Jan 10 12:43:12 localhost mem/swap/used: 88668
Jan 10 12:43:14 localhost mem/swap/used: 88668
Jan 10 12:43:16 localhost mem/swap/used: 88668
Jan 10 12:43:18 localhost mem/swap/used: 88668
Jan 10 12:43:20 localhost mem/swap/used: 88668
Jan 10 12:43:22 localhost mem/swap/used: 88668

Now we want to use this information and monitor another computer, such as a server or firewall. First,
we connect to another host, preferably using SSH since it is the most secure. Click on File > Connect
Host, or click the Connect Host button T~ .

Rt

In order for the remote connection to work, at least ksysguardd must be installed on the remote
computer so that the local computer ksysguard client can pull the information from the remote
computer. If your remote computer has KDE, most likely it will have ksysguardd (two d-s, the second
for the daemon).



You'll be given the following dialog box:

Systerr Guard

Host: | 192.168.1.100|

| -
—Connection Type
@ ssh 1 rsh ) Daeman ) Custom command
Port: H e.g. 3112
Command:

e.g. ssh -l root remote.host.org ksysguardd

Help oK Cancel
- .

Put the host name or IP address of the system you want to monitor. Unless the host name can be

resolved through /etc/hosts or some other means, you'll want to put the IP address of the remote
computer instead. I do this by default since I have a small network anyway.

You'll notice the different connection types. Probably the most secure will be ssh, or a custom
command calling an ssh session (see the example command in the screenshot above). The only issue is
most ssh configurations disable root login by default to keep the system more secure, so the above
command will not work in many cases. If you are using rsh, don't! It has too many security issues.

In this instance, I will use the “ssh” option. Once we've clicked OK, we are prompted for the password
for SSH (unless you have listed the local host as trusted on the remote computer):

@ kingttx@192.168.1.100's password:

(814 | Cancel

b ' _

Once it connects, it'll take a little longer to bring in the available sensors for the remote host than what
you'd expect for the localhost.



Here is what we have next, but you'll notice we don't have anything monitored from the remote host.
Remember how we added a worksheet? Let's do that now by clicking the new worksheet icon. In this
case, let's have a process table; we'll 1 row, 1 column, and let's label it something meaningful like
“Remote Process Table”.

-Sensc:r Browser i | System Load | Process Table
+ a localhost
L.#192.168.1.100 . . .
..l Process Count Name (PID | User% | Sy
é----ﬂPrccess Controller {fj} aio/0 59 0.00
+-Partition Usage % apmd 3017 0.00
+- Network % artsd 3707  1.00
#-Memory & ata/o 726  0.00
?--DiEKThrDughput £ atd 3168  0.00
B PiiLoad £ cardmagr 1720  0.00
ARG ‘| | @ crond 3414 0.00
"| &% crond 4254  0.00
% cupsd 2425  0.00
#} dbus-daemon-1 2896 0.00

T Properties

—Title

Remote Process Table

—Properties
Rows: li_:
Columns: - =
Update interval: 2 sec:fgi

oK | Cancel




Now we have a blank worksheet, so let's make sure we are under the remote host and pull in Process

Controller.
Al
File Edit Settings Help
| HEE[RG[ ) d R [HND
Sensor Browser System Load | Process Table | Remote Process Table
+ 4 localhost S ——
--'#192.168.1.100 . ; . . ; ; : :
{4 Process Count Name | PID | PPID | UID_ GID | Status | User%_ System%_ Nic * |
Controller &} pdfiush 32646 5. 0 0 sleeping  0.00 0.00
+-Partition Usage M ksysguardd 30810 1 99 30810 sleeping  0.00 0.00
+- Network &y firefox-bin 28950 28945 500 5639 sleeping 1.00 0.50
+-Memory &} run-mozilla.sh 28945 28920 500 5639 sleeping  0.00 0.00
+-Disk Throughput # gconfd-2 28926 1 500 5630 sleeping 0.0 0.00
2 CPU Ldad @ firefox 28920 5639 500 5639 sleeping  0.00 0.00
e &} saslauthd 26239 26233 0 26233 sleeping  0.00 0.00
&} saslauthd 26238 26233 0 26233 sleeping  0.00 0.00
¢ saslauthd 26237 26233 0 26233 sleeping  0.00 0.00
&} saslauthd 26236 26233 0 26233 sleeping  0.00 0.00
&} saslauthd 26233 1 0 26233 sleeping 0.00 0.00
% cupsd 25946 1 0 25946 sleeping 0.00 0.00
} spamd 19368 19363 0 19363 sleeping  0.00 0.00
_f?;,'? spamd_ 19367 19363 0 19363 sleeping  0.00 0.00 ; !
Tree All Processes > Refresh | Kill
4 [ I
HLSS Processes | Memory: 251,540 used, 4,204 free | Swap: 41,644 used, 464,836 free

Again, remember the more sensors you have, and the quicker you have the updates, the more
processor load you'll create, and since this is over the network, the more network traffic you'll create.
Weigh your needs against this fact.

Once you're done, disconnect from the remote host by highlighting the host entry and click either the
host disconnect button e - or File > Disconnect Host. You'll notice any sensors for the remote

d

host still show up, but the updates are frozen. If you need to keep the information visible, great!
Otherwise, you can close that worksheet and either save or discard the worksheet when prompted.

Now that we've gone over the application and how to connect to a remote host, I'd like to stress the
importance of keeping your eye on servers and creating a baseline so you won't be caught off-guard.
True, I left that as some homework for you, the reader, to look up the importance of knowing the
baseline for the systems you are responsible for. Once you know how the server behaves under a
normal load and a normal amount of services running, you'll get a good idea what to look for in case
your server begins to become bogged down, or the network is inundated (Denial of Service,
anyone??), and you will be ready to react. Think of the ability to sit at your desk, run the sensors for
disk space on your file server, and be able to report what is left to the powers that be.

I hope this helps and gives you a tremendous tool to use in Linux administration. Granted, there are
some shortcomings with KsysGuard, and at the same time this is a powerful tool as it is.



