Top 10 Tips for Tinkering with Your PC 

1. Back up. Backing up your entire hard disk might be impractical, but make sure all your data files, customization files, Registry, and application configuration files are backed up. Don't just do it once--make it a regular habit. 

2. Make sure you have up-to-date Windows startup disks (Control Panel > Add/Remove Programs > Startup Disk). Be sure to have copies of all your device drivers handy as well. 

3. Store your user names and passwords on paper and keep them somewhere safe. If you forget your Windows password, having it in a file on your PC won't help you. 

4. The Windows Registry is not something to be fooled with unless you have some experience using it already. Even if you are familiar with the Registry, you should be extremely careful not to stray from the task at hand or you'll risk severely damaging your system. 

5. Did we mention that you should back up your PC? 

6. Partition your hard disk. Put your data files on a separate volume from your operating system and programs. Put a copy of your operating system on a separate hard disk as well: It will make backups and re-installation of software much easier. 

7. Paste a copy of each program's serial number to its CD jewel case, or use a permanent marker to write the number on the CD itself (on the label side!). 

8. If you're on a network, keep a copy of all your network settings (IP address, DNS, gateway, network card settings, and so on) handy. 

9. If it ain't broke, don't fix it. If you have no compelling reason to open the case or upgrade your operating system or applications, don't. 

10. No kidding, we really mean it: Backup is important.

Speed Up Windows 

Tidy Up Your Temp Folder
Clean up the temporary files in your C:\Windows\Temp folder that waste space and may slow start-up. Add the line 

 del C:\Windows\Temp\*.tmp > nul 

to your Autoexec.bat file to clean up this file every time you start your computer. If you're running Windows 98, you can run the System Configuration Utility, click on the Autoexec.bat file and on New (if you don't already have an Autoexec) or Edit (if you have this file), add the line, and then enable it. In Windows 95, you can typically find the Autoexec.bat file in the root directory of your C: drive. Open it in Windows Notepad and make the changes there. 

Clean Up Your System Tray
Have you noticed that your taskbar clock has a lot more company lately? That area is called the System Tray, and programs can tell Windows to load an icon there to give you status information and let you right- or left-click to perform operations. This is a handy thing, but it can be done to excess, and too many programs are loading at start-up and slowing down your system. 

Sometimes the program provides a friendly way to clean up the System Tray. Right-click on the program's tray icon to see whenter you have the option of turning it off. If all you want to do is clean the icons out of your System Tray (while still having the programs load), check out PC Magazine's TrayManager. 

If you're running Windows 95:
Go to the Windows\Start Menu\Programs\ Startup folder in Windows Explorer. You can add or remove programs here for start-up. 

If you're running Windows 98:
Go to Start > Programs > Accessories > System Tools > System Information. Then select Tools > System Configuration from the Menu. From that dialog box, click on the Startup tab. Now you can deselect those programs you want to load at start-up. 

If your program wasn't in the StartUp folder, check the Registry. Go to Start > Run and type regedit. Go to the HKEY_LOCAL_MACHINE\ Software\Microsoft\Windows\CurrentVersion section. Look for the Run key, which contains a number of strings—programs Windows loads. You can delete keys at your discretion. 

When you need to restart Windows, here's how to cut short the sometimes lengthy reboot process. Launch Notepad and type the following line: 

@EXIT 

Save the file as C:\Windows\Desktop \Restart.bat. An icon for the file will show up on your desktop. Right-click on the icon; choose Properties, then the Program tab. Make sure the Close on Exit option is enabled. Click the Advanced button, and make sure that the MS-DOS mode option is selected and that the "Warn before entering MS-DOS mode"option is deselected. Click OK to close both dialog boxes. A second icon (Restart.pif) will be created. Double-click on this icon whenever you need to restart Windows. 

Tweak UI to Speed Up Windows 
Tweak UI, a utility that offers some helpful options to speed up Windows, also gives you impressive power to customize your desktop further than you can without it. UI is included on the Windows 98 CD under Tools\Reskit\Powertoy\Tweakui.inf; Windows 95 users can download the latest version at ZDNet Downloads. The utility installs itself as a Control Panel applet. 

Under the Boot tab in Tweak UI, you can prevent ScanDisk from automatically running at start-up, further speeding the boot process. 

Another way to use TweakUI to speed up your system is to uncheck all the check-box items in the Paranoia tab that clean up parts of your system, such as the Documents folder and your Internet Explorer history, at log-on. 

Customize Your Desktop 

Drag and Drop the Right Way
Hold down the right mouse button instead of the left one. When you lift up, the default action will be in bold, but you'll be given the choice to move, copy, or create a shortcut. 

Customize the Start Menu
To customize your Start Menu, right-click on your taskbar and go to Properties > Start Menu Programs > Advanced. Because all the links in your Start Menu and Programs folders are just shortcuts in the file system, you can manipulate them as you would any other file hierarchy. The only folder in the view should be the Programs folder. Put shortcuts for frequently used programs in this view; they will show up above Programs on the Start Menu, giving you easy access. 

If you're using Internet Explorer 4 or Windows 98, you can rearrange menu items and groups simply by left-clicking on the Start button and dragging and dropping within and between program groups. The one downside is once you rearrange menu items, the Start Menu stops sorting automatically. An easy way to fix this is grabbing PC Magazine's MenuZap utility. 

One thing to keep in mind as you move things around in the Start Menu and Programs folders: Don't move any actual programs into these folders, only the shortcuts to them. 

Customize the Send To Menu
In Windows Explorer, if you right-click on an icon, there is a Send To option, from which cascades a list of links to certain programs and locations. By default, you get links there to your floppy disk drive, the Windows mail program, and possibly your Briefcase. You can add new programs to this list, and doing so can be very handy when managing files and folders. Here's how: 

Open Explorer to C:\Windows\SendTo. You'll see the links you saw in the Send To menu. Delete the ones you don't want and add the ones you need. 

Add Control Panel to the Start Menu 
Open Explorer in the Start Menu folder by right-clicking on the Start button and choosing Explore. In the right-hand pane, right-click on an empty area and select New and Folder. In the field for the name, type this exactly: 

 Control Panel.{21EC2020-3AEA-1069-A2DD-08002B30309D} 

You can create similar cascading menus for your printers and Dial-Up Networking connections by following the same procedure with these folder names: 

 Printers.{2227A280-3AEA-1069-A2DE-08002B30309D} 

 Dial Up Net.{992CFFA0-F557-101A-88EC-00DD010CCC48} 

Quick Launch
The Start Menu is a great place to put programs, but for the small number of programs you use most, the Quick Launch bar is even easier and more convenient. Quick Launch is an extension to the Windows interface installed by IE4 and Windows 98. By default, IE4 puts on the toolbar links to IE, Outlook Express, your channels, and a button called Show Desktop that minimizes all programs. You can remove any of these links by right-clicking on them and selecting Delete. To add new links to the toolbar, drag shortcuts (from the desktop or other folders) to the bar. Try not to add too many shortcuts to the Quick Launch bar; it will slow down system start-up. 

Tweak UI
Tweak UI is a utility that gives you impressive power to customize your desktop further than you can without it. It's included on the Windows 98 CD under \Tools\Reskit\Powertoy\Tweakui.inf. Windows 95 users can download the latest version at Microsoft. 

You can turn off various animations, smooth scrolling, and other bits of folderol under the General tab. 

The IE4 tab lets you turn off Active Desktop for good, clean out your typed URL history, and remove the Favorites and Documents folders from the Start Menu. 

The Desktop tab controls which special icons, such as MSN and Internet Explorer, appear on the desktop. 

Change File Associations 

Does it drive you crazy when that image file you just got opens up in Microsoft Paint or Lview Pro instead of in your preferred image editor? Here's how you can make sure that never happens again: 

In Explorer, select a file of the type you want to change. Hold down the Shift key, right-click on the selection, and choose Open With. In the dialog box that pops up, select the program you want to use to open the file type. Check "Always use this program to open this file," click OK, and off you go. 

Adjust the Taskbar 

IE4 and Windows 98 users can also add new toolbars and other familiar items to the taskbar. Right-click on an empty part of the taskbar and select Toolbars from the menu. From here, you can add the Links list from your IE favorites, the IE address bar itself, the shortcuts on your desktop, and even whole new toolbars. 

Prevent System Crashes 

HINT: Always Shut Down Properly Windows creates temporary files that need to be closed before you turn off your machine. If you just throw the switch, these files are left in limbo. Not only might you lose program data that has not been saved, but it's possible that badly written programs could be left in an unusable state. 

Run IE in a Separate Process 

If you're running Windows 98 or running IE4 under Windows 95, you may notice that sometimes IE can bring your whole system down if it crashes. This may occur because, if you installed the Windows Desktop Update (meaning that IE replaced your Windows shell with itself), then Windows Explorer is running in the same process as IE. If IE goes, so does your system. 

To prevent this occurrence, you need to run IE in a separate process from Windows Explorer. Microsoft warns that this might decrease general performance, but your browser shouldn't crash your system as often, so we think this is a good trade-off. 

Go into Internet Options (on the View menu in IE4 and under the Tools menu in IE5) and click on the Advanced tab. Scroll down the Browsing section. Select Browse in a New Process by clicking on the checkbox. Then click OK, close IE4, and restart it. 

Find the Kernel of Truth in IE Crashes
Are you an Internet Explorer user? Have you ever seen the error message "IEXPLORE caused an invalid page fault in module Kernel32.dll"? 

One of the more likely reasons is that there is at least one dynamic link library (DLL), a type of program file, located on the desktop. If so, you probably can't see it, because by default, Windows won't show such files. To make them visible, open My Computer by double-clicking on it. Select the View menu, then either Options or Folder Options (depending on your version of Windows). On the View tab, you will find an option to "Show all files." Select it. After you click OK, you may see new files, some with a DLL extension. Give each file a different type of extension or move it. 

Dial-Up Networking Hangs While Trying to Connect 

If this happens to you, you are likely a Windows 95 OSR2 user running IE4. The problem is a conflict with the View Details option in DUN and IE4 running as your Windows shell. Here's how to fix this documented bug: 

You need either to disable View Details in DUN or to uninstall the Windows Desktop Update component. First, create a shortcut for your DUN connection and add it to your desktop. You can find your connection in your DUN folder, which is in My Computer. Connect to the Internet with your new shortcut. 

Go to Start | Programs | Accessories | Dial-Up Networking. In the View menu, deselect Details by choosing another view, such as Large Icons. 

If you need to uninstall the Windows Desktop Update, go into the Control Panel, open Add/Remove Programs, click on Internet Explorer 4.0, and then click on the Add/Remove button. 

In the IE4 Active Setup dialog box, click on "Remove the Windows Desktop Update component, but keep the Internet Explorer 4.0 Web browser." 

Minimize Crashes and Crash Damage 

Though you may never be able to prevent crashes totally, a few safe computing practices will minimize crashes and crash damage. One problem occurs when the operating system or application expects one thing but gets another, such as when you've got a program using a CD or floppy disk that you remove before saving. Here are some hints to help you prevent crashes. 

1. Always shut the PC down properly. Windows creates temporary files that need to be closed before you turn off your machine. If you just throw the switch, these files are left in limbo. Not only might you lose program data that has not been saved, but it's possible that badly written programs could be left in an unusable state. 

2. When using Dial-Up Networking (DUN), don't physically disconnect your phone line from the PC before shutting down your connection. Depending on the application that's using DUN, Windows can hang waiting on the COM port. 

3. Let ScanDisk run during boot-up if your machine requires it. 

4. Store data files on a different partition from the operating system. If Windows does crash and needs to be reinstalled, you won't lose data. 

Solve Application Conflicts 

HINT: No Uninstall Program?
So you want to uninstall a program, and for some suspicious reason, the program has no uninstall program. Don't just delete that directory. Seriously consider a third-party uninstaller such as Symantec Corp.'s Norton CleanSweep, which will typically cost you between $20 and $40. 

Uninstall Programs Properly 

1. Many programs have their own uninstall option, typically accessible from the application's Start Menu group or the Add/Remove Programs applet in the Control Panel. This will usually get rid of the program. 

2. When uninstalling, Windows does not usually delete user files, which include configuration files the program creates from your input. The main clue that these haven't been deleted is the message "Some elements could not be removed." 

3. Once the uninstall is done, go into Explorer, look in the program's install directory for any files you would want to keep, and move or delete the directory. You may want to note where the program's directory is before you uninstall it by right-clicking on its shortcut and selecting Properties to see where the program is located. 

4. One common problem is that once the program is removed, its entry remains in the Add/Remove Programs list. To remove the entry manually, you will need to edit your Registry. 

Go to Start | Run and type Regedit. Go to the key Hkey_local_machine\Software\Microsoft\ Windows\CurrentVersion\ Uninstall. There you will see a series of keys, with one for each entry in the Add/Remove dialog box. 

When you find the key with the values for the nonfunctioning entry, delete the entire key. 

Change Your Default Browser 

The browser that comes up as your system's default can be a source of frustration, especially if you've switched sides at some point during the browser wars. Clicking on an HTML file in Windows Explorer, or sometimes even from links on a page you're already looking at, can open a browser other than you expect. Both Microsoft and Netscape browsers can each check to see which is the default browser and offer itself as the default. Both can also turn off this check, which presents a problem: If you want to change the default later on, how do you reenable the check? 

If you are using Netscape Communicator 4.x, make sure you exit Communicator and all its components. Go to your personal profile directory (typically, C:\Program files\Netscape \Users\Profilename). Open the file Prefs.js in Notepad and change user_pref("browser.wfe.ignore_def_check", true) from "true" to "false." Save the file and exit the editor. The next time you load Communicator or any of its components, you will once again be asked whether you want to make it the default browser. 

This is fairly simple in Internet Explorer. In IE3 or IE4, open Internet Options or Options (depending on the version you're using), located under the View menu (in IE5, Internet Options is under the Tools menu). On the Programs tab, click on the checkbox that says "Internet Explorer should check to see if it is the default browser." Now if IE is not the default browser, the program will ask you if you want to make it so. 

Prevent Hardware Conflicts 

HINT: Boot in Safe Mode
For some kinds of troubleshooting, you need to boot your PC into a mode other than the normal Start-up. 

If you're a Windows 95 user, start your machine and press the F8 key when you see the Starting Windows message. 

With Windows 98, you'll need to hold down the Ctrl key when the computer beeps after the Power-On Self Test until the menu comes up. 

See Boot Shortcuts for a complete list of boot modes. 

Diagnose Hardware Conflicts 

IRQ (Interrupt ReQuest) lines are like dedicated phone lines that ring up the CPU for attention, just as phone calls interrupt you. Sixteen IRQs (0-15) are addressable. 

You can view IRQ assignments under Windows in several ways. One method that Windows 95 and 98 have in common is under Control Panel's System option and the Device Manager tab. Double-click on Computer at the top of the tree. In Windows 98, you can view IRQs through the System Information Utility (pictured below). 

1. Several IRQs are already dedicated to system devices (such as system timer, disk drives, and the keyboard) and cannot be used. 

2. Certain IRQs have been commonly used for the standard I/O ports--serial and parallel--usually IRQ 4, 3, and 7, representing COM1, COM2, and LPT1, respectively. The IRQs that are left can be used to add new hardware. 

3. The PCI bus in most new systems permits interrupt allocation flexibility during boot-up. Replacing your non-plug-and-play ISA cards with PCI cards can be a great boon to the IRQ-challenged. 

4. Installing plug-and-play hardware can reduce IRQ conflicts. At boot-up, Windows scans for available IRQs and will assign them to hardware drivers on the fly. Buy USB peripherals in the future. This should let you free up a COM or LPT port that's currently occupying an IRQ.

When a Device in the Computer Isn't Working 

Sometimes a device, such as a scanner or network card, mysteriously stops working under Windows. If you can't find an easy solution (loose cord, power off, or the like), write down its properties such as the IP and DNS addresses on a network card and make sure you have the latest drivers handy either on disk or downloaded from the company's Web site. Then follow these instructions to delete the device from the Windows Device Manager and let Windows set the device up again. 

1. Open the System applet in Control Panel and select the Device Manager tab. Here, you will see a list of the devices in your system. 

2. Find the device in question, click on it, and then press the Remove button. You may also see the effect of a common Windows bug in the form of two or more entries for one device. In this case, remove all the entries. 

3. After you have removed the device, shut Windows down and restart.

If It Works: Windows will probably detect and reinstall the device. Because Windows analyzes the system at times like this for available resources, it will often reassign your device to different resources than it had before, and any problems should go away. 

If It Doesn't: In some cases, Windows will prompt you to insert the device's installation disk. If it doesn't find your device, you may have to run the installation routine again. 

Improve Internet Connections 

HINT: Find Your IP Settings
Finding your network setting through Windows can be a challenge. The best way to do it is to go to Start | Run and type in 

winipcfg
This undocumented program will give you all the info you need if you're having a network problem or not connecting correctly to your ISP. Click on the More Info button to get a complete IP profile. 

Connect to the Internet as Needed 

If you connect to the Internet via a modem, wouldn't it be nice if your modem dialed up and connected to your ISP every time you launched your browser, mail client, and so on? Going through IE, you can set up any Winsock application--Eudora, Netscape Navigator, or WS_FTP, among others--to dial automatically once you launch one of these applications. 

The easiest way is to run the Internet Connection Wizard. If you have IE3, go to the Start Menu and select Programs | Accessories | Internet Tools | Get on the Internet. If you have Windows 98, go to Start | Programs | Accessories | Internet Tools | Connection Wizard. 

This tip gives you the added benefit of a prompt to disconnect when you close your browser or other Internet application. 

Connect to the Web at Start-Up 

Is Web surfing your primary computing activity? If you want to have your computer dial the Internet each time you start up, here's how: 

1. You'll need a fairly new version of Dial-Up Networking. To get the latest DUN for Windows 95, go to Microsoft's Web site. If you're using Windows 98, you're fine. 

2. Once you're up and running, right-click on the Start button and choose Explore. Click on the + to the left of the Programs folder to expose its subfolders, including StartUp. 

3. Now scroll the left pane down below your drives until you find the Dial-Up Networking entry on the left. Click on it and you should see your Dial-Up Networking entries to the right. 

4. Select the connection you want to use each time you start up and then click on the Connection menu and choose Settings. Uncheck the box that says "Prompt for information before dialing." 

5. Scroll the left pane back up to the point where you can again see the StartUp folder, then drag a copy of the Dial-Up Networking connection to it. 

6. Reboot your system; you'll be on the Web in no time. 

7. If you're going online every time, you're probably going to the Web and checking e-mail. Put shortcuts to your favorite browser and mail client in C:\Windows\StartUp as well.

Get Dial-up Networking to Remember Your Password 

Sometimes, no matter how many times you check the Save Password box, Dial-Up Networking (DUN) just won't do it. This is a fairly common problem. 

Two quick tips will fix most instances of this problem. First, you must be logged on for Windows to remember passwords. That means don't hit Esc when Windows asks you to log on. If you don't want to type a Windows log-on password each time, leave your password blank under the Passwords Control Panel applet. 

Second, DUN will not remember a password unless you've made a successful connection to the server. 

If these approaches don't work, the next step is to remove and reinstall DUN. First, download the most recent version of DUN before you disable the present one. You'll find it here if you're a Windows 95 user and here if you're a Windows 98 user. 

Open the Add/Remove Programs applet in the Control Panel. Select the Windows Setup tab. Click Communications, then Details. Click on the Dial-Up Networking checkbox once to clear it, click OK, and then restart your computer when you are prompted to do so. 

After the reboot, install the new DUN and try again. 

Print Without Pain 

HINT: Keep Your Printer Close
Some printer problems stem from poor cabling. For personal printers, you should use an IEEE-1284-compliant cable--and use a short cable for better performance. A 6-foot or shorter cord should be safe. 

Getting Started 

Microsoft Windows has built-in help for you related to many difficulties that may arise from printing. You can find the Printers.txt file in the Windows folder, and it's full of useful information that may help you diagnose common printing problems. 

You can also try the Print Troubleshooter to help you out. In Windows 95, go to Start | Help. On the Contents tab, double-click on the Troubleshooting topic. Double-click on the If You Have Trouble Printing topic. 

You will also find the Windows 95 Resource Kit includes a more detailed Print Troubleshooter tool. It's also available on the Windows 95 Upgrade CD-ROM in Other\Misc\Epts\Epts.exe. 

Windows 98 users will see the Print Troubleshooter under Troubleshooting in the Help menu. Click on Windows 98 Troubleshooters, and then click on Print. 

Improve Your Printing Speed 

Windows defaults to spooling print jobs. The Print Spooler is a background program that writes data to temporary files in your C:\Windows\Temp directory. Although this lets you perform other tasks while you print, it does slow printing. 

1. On most printers, you can turn off the spooler by going to Start | Settings | Printers. Right-click on the icon of the printer you're using. 

2. Click Properties and select the Details tab. Click on the Spool Settings button at the bottom of the dialog box. 

3. Select the Print Directly to Printer option. This will tie up your application until the printer has all the data, but your print job should finish more quickly.

Printing directly to the printer will also come in handy if your print spooler crashes and you need to print before you reboot your PC. 

Try printing from Notepad or WordPad to make sure that the problem is limited to just one application and isn't indicative of a problem with Windows. If the problem occurs in one document only, try to print a blank page inside the application. If this prints, the application may have problems with memory or fonts. 

