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Chapter 4 Managing the Model

4.0.1 File Menu

The File menu is the first selection on the Main menu and consists of five major sec-
tions divided by horizontal lines. The file management section contains functions
related to model files such as saving and retrieving. The view/print section allows the
user to view a text listing of the current model and print that listing or model layout.
The model packaging section allows the user to create and install model packages
consisting of models with associated files. Exit quits ProModel, and the model history
section lists the five most recently opened models for quick retrieval. Choosing any
model in the model history will open and retrieve that model.

%5 ProModel -

Edit Yiew Build Simulation Output Tools Window Help
New
Open... Ctrl+F12
;p rie enent ,
Merge N\a“ag
Sawve F12
Save As...
Yiew Text
Print Text... nt 3

1 |P(

Print Layout... \I\e‘N
Printer Setup...
Create Model Package. .. \\I\Oda 9
Install Model Package... Pac\(ag\“
Exit Alt+F4
1. CAPROMODAMODELS\DEMOS\MFG_COST. MOD
2. CAPROMOD4\MODELS\DEMOSYALUMINUM.MOD Odé
3. CAPROMODAMODELS\DEMOS\ORDERS MOD 3 \d\J
4. CAPROMOD4\MODELS\DEERE2\DEERE2 MOD \,\\5
5. CAPROMOD4MODELS\CAM.MOD

142 ProModel User’s Guide



Section 4.1 File Management

4.1

File Management

The File menu provides six functions related to model files such as saving and retriev-
ing. Files in the ProModel format use the MOD extension. The following table

defines each of the selections available from the file management section shown
above.

New

Open... Ctrl+F12

Save F12 Submodel... [
Save As...

New Closes any currently opened model so a new model can be built. This com-
mand is unnecessary if no other model is open. If the currently opened model has
changed, ProModetill ask if you want to save the model before closing it.

Open Opens a user-specified model and clears previous model data.

Merge Merges a selected ProMoaebdel or submodel into the current model. The
same submodel can be merged multiple times into the same modiklo&eleMerg-
ing on page 149.

Save Saves an open model under the current file name. If no file name has be g
given, the user is prompted for a file name. <

Save As Saves an open model under a new file name specified by the user. T
file name still exists.

9 Note

There is also an Autosave feature that saves the model file every n minutes as speci-
fied in the INI file. This feature can be disabled. See the discussion later in this sec-
tion.
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Chapter 4 Managing the Model

4.1.1 File Management Procedures

x How To Create a new model:
1. Select New from the Eile menu.

2. Select AutoBuild from the Tools menu if you wish to start the automatic
model building routine. Or, simply begin entering data into the appropriate
modules without AutoBuild.

S HowTo  Open an existing model:
1. Select Open from the File menu.

2. Enter the necessary information in the Load Model dialog box below.

Load Model EHE
Look in: IaDemns j gl e

=] Aluminum mod Rur_offt.mod
=] Crderno.mod Sort.maod
Elec_rnfg.mod Subzdemno.rod
Mfg_cost.mod Tutorial. mod
Orders.maod

Rewvgdock.rod

File narne: I Tutarial. k0D Qpen

Files of type:  [Model [~ MOD) I Cancel |
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Section 4.1 File Management

j}( How To Save a model:

¢ Select Save from the File menu. If the model does not already have a
name, the Save As dialog box will appear.

X How To Save a model with a new name:
1. Select Save As from the File menu.

2. Enter the new file name in the Save As dialog box as shown in the follow-
ing dialog box.

3. Select OK.

SaveAs  ______________________HH|

Save in: I 3 Demos
Eﬁluminum.mudé Fur_aff.mod

#] Crdemo.mod Sort mod
Elec_rmfg.maod Subsdemo.mod
Mfg_cost.mod Tutarial.rod
Orders.mod

Rcwgdock.mod

File narne: |mfg_u:u:ust. miod Save I
Save az upe: IMDdE|$ [k 00] j Cancel |

9 Note A model may be saved as a ProModel 3.5 model by following the above procedure
and choosingroModel 3.5 (*MOD) from the Save as type box in the Save As dialog.

Model names must be eight characters or less plus an extension of up to three charac-
ters. We suggest that you use tHe©D default extension.

4.1.2 Backup File

ProModel also creates a backup file every time a model is saved. The backup file is
named the same as the model file, only with a .BAK extension.
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Section 4.2 Converting Models

4.2 Converting Models

Example

If the 3.2 (or older) model you open uses multiple routing blocks to create new enti-
ties from an existing entity, it will not run properly in newer versions of ProModel.
Though the routing block for theain entity functions as it did in previous versions

of ProModel, newer versions require that you check the new entity check box for each
newentity created from a routing. This will prevent run-time errors.

In the example below, a call center receives calls from customers who wish to place
orders for a product. After the customer places an order at Call_desk, an operator
routes the call to Bill_processing and a second routing block creates the order,
Merchandise_order. Since the second routing block creates entity,
Merchandise_order, from the main entity, call, you must check the new entity check
box for the entity. If you do not, an error will occur.

il | I Fowsing dor Call (3 hcoming enlls 11l =R

Tl i LEE Sgeni POM W11 &l |Cal Fill_mrramamg FEETH &

[ vl miaeteng [FESTY

4.2
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Section 4.3 Model Merging

4.3 Model Merging

Model merging is a powerful feature that allows large or complex models to be built
in smaller segments. A model segment may be as small as a single work cell or as
large as a complete manufacturing system. After all segments are ready, they can be
merged together to form a single model.

The Merge feature consists of two options: Merge Model and Merge Submodel.

New
Open... Ctrl+F12

Chee TR
Save F12 Submodel...
Save As. |

4.3.1 Merge Model

The Merge Model option allows two or more independent (complete or incomplete)
models to be merged into a single model. Duplicate elements found in the base model
and the merging model are treated differently according to the element type.

1. Entity and attribute names common to both models are considered com
elements in the merged model. For example, if both models contain the e
type Shaft, then the merged model will contain only the record from the b
model in the Entities table for Shaft.

2. Duplicate locations, resources or path netwankstfirst be renamed or
deleted from the merging model. Otherwise, an error message occurs and the
merge will terminate.

3. If the two models use different graphic libraries, ProMedklgive the user
the choice to append the merging model's graphic library to the base model's
graphic library.

4. All other duplicate model elements cause a prompt to appear with the choice to
delete the duplicate element from the merging model or cancel the merge
process.
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4.3.2

Merge Submodel

The Merge Submodel option allows commonly used submodels (for example, work
cells and dial tables) to be merged into an existing model in one or more places.

Submodels are created just like any other model and may be complete or incomplete
models.

When specifying a submodel, you are prompted for a “tag” to be attached to each ele-
ment of the submodel as either as a prefix or suffix. For example, you may be
developing a model with four, 12-station assembly lines. Instead of creating each dial
table individually, you could create a submodel with only the common elements of the
dial table (for example, locations, variables, arrays, etc.) and merge the submodel into
the main model four times. In the resulting model, you would then fill in the unique
portions of each assembly line. Entity and attribute names will not be tagged.

In the example below, the tag “A_" is attached as a prefix to every element of the sub-
model. A location called Quel in the submodel becomes A_Quel in the main model
and so on. Likewise, a variable called Rejects becomes A_Rejects in the merged
model.

- H

Enter tag to be attached to all identifiers
in model, if dezsired. Select OK. when
ready and click where you want the
upper left corner of new model.

% Prefix = Suffix

Tag: Iﬁ_

(1]4 | Cancel |

() Caution

Tags used as prefixes must begin with a letter, A through Z, or an underscore. For
example, the tag “3C_" is invalid and would produce an error message.
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X How To

Merge a model or submodel into an existing model:
1. Open the initial (base) model.

2. From the File menu select Merge.

3. Select Model or Submodel from the submenu.

4

Specify the name of the model to be merged in the dialog box shown
below.

Filetomerge: ________________ HH|
Lockin |3 Demos = & g [

A Auninum mod Run_off.mod
@] Crdemo. mod Sart.rmod
Elec_mfg.mod Subgdemo.mod
Mfg_cost.mod Tutarial.rmod
Crders.rmod

Rcvgdock.mod

File name: I Open I
Files of type:  [Model (~MOD) I Cancel |

5. If you select Submodel, specify a prefix or suffix to be attached to each
element of the submodel.

6. Click on the layout where you want the model or submodel to appear. A
bracket appears on the screen, representing the upper left corner of the
merging model’s layout. This bracket moves as you move the mouse,
allowing you to correctly position the layout to be merged.

7. Next you will be asked if you would like to append the graphic library file
from the model or submodel to the current graphic library file. Select yes
or no depending on your preference.

8. When the model is merged in, the graphical elements remain selected so
that you can position the merged model exactly where you want it.

() Caution

When merging models, if the zoom factors and grid scales are not the same, Pro-
Model will adjust the sizes of graphical elements in the merging model to the scale of
the original model.
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Section 4.4 View/Print Model Text

4.4 View/Print Model Text

The modular nature of ProModel makes it easy to focus on the individual elements of
a model. However, it can still be useful to see an entire model with all of the model
elements in view at one time. ProModel provides two ways to accomplish this. The
first is through the View Text option and the second is through the Print Text and Print
Layout Options.

The second major division of the File menu contains the following options.

Yiew Text

Print Text. .. +
Print Layout...

Frinter Setup...

Each of the selections defined below is covered in detail in the following pages.
View Text Displays the text of the current model data in a window.
Print Text Prints the text of the current model to either a file or the printer.

Print Layout  Prints the model layout to a printer.

Printer Setup  Opens a dialog box to allow printers to be selected and controll¢ <
Q:
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4.4.1 View Text

The View Text option displays the text of the current model data in a window. This
window may be sized or shrunk to an icon for later viewing.
X How To View the text of a model:

e Select View Text from the Eile menu. The model's text is displayed in a
window as shown in the following example.

-.I
- -
- Parnatbed Lisglan &f Hadol:= L
- L PRI <Ha d el s Solls s e wal §_caat.onid -
- -
Fode]l Hates:s
L]
8This mofsl demesalicales wems od the basic Featores of Profedel. 09 cloarls
fapnaatratee the arslyticsl]l valus aof simlation. 0t i cesncer- istult fvs
I.-| neat aywbtame tp sapect that addifdonal resowrces reduces Tmllu:t camk.
alagy clw min cine incterfaoe sormarian, the sffesor of addizienal peapls
can ba paxily cwslosated.
Tlime Upite: Alinutak
Diztancea Umited mi
Infvialisat jon Logio: BCTIMNTE mel_felals
FIFH "Fall Fisu™
- Locatisnm -
ane Cap linitz Etats Fules
Haceiue 2 1 Tiem Smriax Oldexzz. FIBPG.
M Lanhe i 1 i Bas ke Eldean. FIPS.
MC_Latha_2 1 i Hax Lo oldsat, FIPD,
o prears a i Baa e @lidean. FIPG.
Friepsac i i [:FER Olidsag, FIPS,
Bearing Gue :I.Hl I Tien Snriss Gldezz. FlPG.
Lol i Ties Aarlss Oidsas, FIPD,
-

Only the first 30 characters of names will appear in the names column.

9 Note You may leave the View Text window open for reference while editing the model.
However, any updates will not appear until you close the window and select View
Text again.
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4.4.2 Print Text

The Print and Print Layout options allow you to print a model to any printer config-
ured for use with Windows. You may also save a text copy of the file to disk.

& HowTo  Save atext copy of the current model:
1. Select Print. Text... from the File menu.
2. Select To Text File from the submenu.

3. Supply a name for the file in the Print to Text File dialog box. The default
file extension is TXT.

X How To Print the current text to a printer:
1. Select Print. Text... from the File menu.
2. Select To Printer from the submenu.

3. Select the desired options from the Print dialog box and click OK.

Print EE |
— Printer
Froperties |

Statusg: Default printer; User intervention: 0 documents waiting
Type: HPF Lazerlet Il
“Wwhere:  S\Promodelilaser

I ame: HF Lazerlet ||

Comment;
— Print range Copies
Lol | Mumber of copies: 1 =

) Fages from; b
: Ijl [T Colate
£ Selection

(] I Cancel

9 Note The entire layout may also be copied to the clipboard for editing and printing in
another application.
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4.4.3 Print Layout

You may print the layout of any model including all locations, path networks,
resources, variables and background graphics to any printer configured for use with
Windows. Regardless of the size of the model layout, the layout will be proportioned
automatically to print on one standard size sheet of paper.

“ HowTo  Printa model layout:

1. Select Print L ayout from the Eile menu.

2. Select the desired options from the Print dialog box and click OK.

Print EE
— Printer
Properties |

Status: Default printer; eer intkervention; 0 documents waiting
Type: HF Laszenlet [l
Wherer  S\Promodelhaser

Hame: HF Lazer)et [l

Comment;
— Print range Copies
= All Mumber of copies: 1 =

=) Pages _from:l I I_
) Selectinn Iﬁl [ Collate
’TI Cancel |

3. Choose the elements to be included in the layout from the dialog box
shown below.

Layout Print E3

Select lapout elements
to be printed

¥ Background Graphics
v Lacations

[V Path Metworks

¥ Besources

¥ W ariables

ok I Qancell Help |
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4.4.4 Printer Setup

ProModel allows you to print to any printer configured for use with Windows. At
times you may need to switch from the default printer to another printer or plotter.
This can be done easily through the Setup option on the print dialog box.

S HowTo TO change the printer settings:

1. Click the Setup... button on the Print dialog box to access the Print Setup
dialog box.

2. Select the desired options and click OK.

Print Setup EE

— Printer
Froperties |

Statusg: Default printer; User intervention; 0 documents waiting
Type: HPF Lazerlet Il

Where:  S\Promodellaser

I ame: HF Lazerlet ||

Carnment:

— Paper Orientation——————
Size: ILetter 31/2811in j = Partrait
Source: ILIpper tray j " Landscape

(] I Cancel

Q:) See Also  Print Manager section of the Microsoft Windows User's Guide for detailed informa-
tion on configuring a printer for use with Windows. To fit more text on a page hori-
zontally, choose the Landscape orientation in the dialog box above.
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Section 4.5 Model Packaging & Data Protection

4.5

45.1

Model Packaging & Data Protection

Model Packaging and Data Protection are powerful tools that allow you to distribute
copies of your model for others to examine and review, yet maintain the integrity of
the model. When you create a model package, ProModel builds an archive of files
necessary to run the model and allows you to distribute a copy of the model’s graphics
library. When you apply Data Protection, you can prevent others from viewing or
altering logic contained in your model.

Create Model Fackage...
Install Model Package. ..

Create Model Package Copies the current model and its associated files to a spe-
cific directory or disk agmodel name.PKG.

Install Model Package  Copies the files in a.PKG file to the destination direc-
tory you wish to use.

Creating a Model Package

The Create Model Package option allows you to copy the current model and its
ciated files to a specific directory as a single file entitetbde/ name>.PKG. This o)
file includes the model file (*.MOD), the graphic library (unless you check the <
Exclude Graphic Libranoption), and any external files you defined (e.g., read file
arrivals files, and shift files)—the model package automatically includes bitmap
imported into the background graphics.

When you create a model package, two options are available:

Exclude Graphic Library ~ Excludes the graphics library file from the model pack-
age—if not required—and creates a smaller package file.

Protect Model Data  Prevents those who install the model package from viewing
or editing the model data. When you load a model package, ProModel disables the
View Text, Print Text, Expression Search, and Autobuild features, plus the Build
menu and portions of the run-time Options and Information menus.

© Note

You may NOT use dynamic plots with protected models.
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S HowTo  Create a model package:

1. Select Create Model Package from the File menu.

Create Model Package 3 |

Createz a zingle archive fle containing the model, graphics
library, and any external files.

Pack.age file IE:\mfg_u:u:uSt.F'KG

[ Exclude Graphics Librany

[™ Protect Model Data

k. LCancel | Browse... Help |

2. Enter the name you wish to use for the model package (by default, Pro-
Model uses the name of the current model with a *.pkg extension). You
may also use the Browse... button to select the model name and
directory.

3. Check the Exclude Graphics Library  box if you want to package the
model without the graphics library.

4. Check the Protect Model Data box if you want to protect your model data
and prevent other users from changing or viewing the model data.

9 Note You may NOT use dynamic plots with protected models.

5. Click OK.
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4.5.2 Installing a Model Package

Install Model Package copies all files in a model package to a specified destination
directory and gives you the option to load the model.

& HowTo  Install a model package:

1. Select Install Model Package... from the Eile Menu.

Install Model Package |

Copiez all of the files contained in a model package file to
the specified destination directon.

Package file Ia:'xmfgcell.pkg

Destination |u::Hprumud#'ﬁmndels'ﬁmfgcell'ﬁ

(] | Eancell Eru:uwse...l Help

2. Select the model package (*.pkg) from the Install Model Package dialog.

3. Inthe Destination field, type the name of the directory to which you want
to copy the model package.

4. Select OK. After you install the model package, a dialog will appear and
allow you to load the model.
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