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Q. No.1) What is MS Excel? Write Down importance of Excel in business.

MS EXCEL:-


“MS Excel is an electronic spreadsheet which runs in windows environment .”


Spreadsheets are used in business for accounts and statistical analysis. An electronic spreadsheet uses a computer to perform numeric calculations rapidly and accurately. 


A worksheet created in excel allows user to work quickly and efficiently and to update the result easily.

IMPORTANCE OF EXCEL IN BUSINESS:-


In business working on Excel is better than paper due to following reasons:

1. Quick and Accurate Entry:
With Excel user can enter information faster and more accurately than paper work. User can use Excel to calculate expenses and revenues to determine net income for any period by just entering data and formula.

2. Easy Re-Calculation:
Excel Re-calculate the spreadsheet automatically as related values are being changed. So fixing errors is also easy. 

3. Enhanced Appearance of Information:
Excel provides powerful features for enhancing a spreadsheet so that information become easy to understand.

4. Create Charts:
In Excel it is an easy task to create charts based on the information. Charts are automatically updated as data changes.

5. Share Information With Other Users:
In Excel it is easy to share information with other users. Users can access data of a worksheet through network.

6. DataBase Management:
In Excel user can create and analyse database.

7. Data Validation:
In Excel user can apply validation rules at the time of data entry so that only valid data can be entered in a database.

8. Sharing Applications with Others:
Excel provides facility of sharing information between different packages. Files of MS Excel can be retrieved in other Applications and files of these applications can be opened in MS Excel like DBase, FoxPro, Access etc.

9. What-IF Analysis:
MS Excel provides What-If analysis facility for decision making. This is the ability of facility of changing the data and then quickly re-calculate the results of this change.

10. Professional Templates:
MS Excel provides professionally designed templates. With these templates, user can quickly create invoices and Expense & Revenue Summary, Purchase Orders, Village Softwares etc.

11. Electronic Forms:
MS Excel provides electronic forms for data entry and data searching.

Q. 2) Define Worksheet and Workbook.

WorkSheet:-

“A Worksheet is a spreadsheet made of rows and columns. It is the primary document that is used to store and work with data.”

A worksheet consists of cells that are organized into columns and rows; a worksheet is always stored in a workbook.

MS Excel worksheet is an electronic spreadsheet. Data can be entered in it and arithmetical, statistical, and other analysis can be done on the data. MS Excel worksheet contains 256 columns and 65,536 rows. There can be upto 256 worksheets in a workbook. User can enter and edit data on several worksheets simultaneously and perform calculations based on data from multiple worksheets.

WorkBook:-


“In Microsoft Excel, a workbook is the file in which user works and stores  data.”

Each workbook can contain many sheets, user can organize various kinds of related information in a single file. By default there are three worksheets in a workbook. User can add upto 256 sheets in a workbook. 

Each workbook may contain workseheets, chart sheets and macro sheets etc. The extension of Excel Workbook is .xls.

Q. 3) How many worksheets can be added in a workbook.

By default there are three worksheets in a workbook. User can add upto 256 sheets in a workbook. The number of sheets is limited by available system memory. 

The default setting can be changed by Options in Tool Menu. 

Q. 4) What happens to workbook of 97 when it is opened in MS Excel 2000?

or

Q. 4) What happens to old workbooks when I open them in Microsoft Excel 2000?

User can open files that were created in earlier versions of Excel directly in Excel 2000. All data, formulas, and formatting that was created in earlier versions are supported by Excel 2000, with the exception of sound notes in cells.

Q. 5) What is a template?

Template:-


“A template is a pre-designed, ready to use document with an attractive layout and ‘Fill_in_the_blanks’ data.” 

A workbook that user creates and then use as the basis for other similar workbooks is a Template. User can create templates for workbooks and worksheets. They produce readymade documents. 

Creating Template:-


To create a template following steps are peroformed:

1. Create a workbook that contains the sheets, default text (such as page headers and column and row labels), formulas, macros, styles, and other formatting user wants in new workbooks that base on the template.

2. On the File menu, click Save As. 

3. In the Save as type box, click Template (*.xlt).

4. In the Save in box, select the folder to store the template.

5. In the File Name box type the name of template.

6. Press Save button.

Creating a Document Using Template:-


To create a document using template following steps are performed:

1. On the File menu click on New.

2.  Click on the Spreadsheet Solutions Tabs New dialogue box.

3. Select the required template on click on Ok.

Q. 6) What is a Cell and Cell Pointer?

Cell:-


“The intersection of a row and a column on a worksheet is called a Cell.”


Cell can contain values (numbers), labels (text) formula and function or combination of them. Every cell has its own unique location address, which is identified by coordinates of intersecting column and row. For example the cell address of he cell in the upper left corner of worksheet is A1.

Cell Pointer:-


“A Cell Pointer is a dark rectangle that highlight the cell in which user is currently working.”


The cell pointer is current cursor position on the worksheet. The cell is moved with arrow keys on keyboard.

Q. 7) Write down the differences between Cut and Copy.

Differences b/w Cut and Copy:-

The differences between Cut and Copy are given below:

	
	CUT
	COPY

	Definition
	CUT command is used to move contents and formatting of cell to other position.


	COPY command is used to copy contents and/or formatting of cell to another position. 



	Source Cells
	Source cells become cleared.
	Source cells remain unchanged

	Paste Special
	Paste Special is not available with Cut command.
	Paste Special is available with Copy command.

	Menu Command
	1. Select the cells you want to copy.

2. On the Edit menu, Short cut menu or Standard Toolbar Click CUT.

3. Select the upper-left cell of the target destination.

4. On the Edit menu, click Paste.
	1. Select the cells you want to copy.

2. On the Edit menu, Short cut menu or Standard Toolbar Click Copy.

3. Select the upper-left cell of the target destination.

4. On the Edit menu, click Paste or Paste Special.

	Short Cut 
	Ctrl + X
	Ctrl + C


Q. 8) Write down the differences between Paste  and Paste Special.

Differences b/w Paste and Paste Special:-

The differences between Paste and Paste Special are given below:

	
	Paste
	Paste Special

	Purpose
	Paste is used to copy or move entire cells. Paste command copy or move values, formula, formatting and all other cell contents.


	Paste Special is used to copy specified contents from the cells — for example Instead of copying entire cells, user can copy, you can copy the resulting value of a formula without copying the formula itself, copy cell formats without copying cell numbers and text etc.

	Menu Command
	1. Select the cells you want to copy or move.

2. On the Edit menu, Short cut menu or Standard Toolbar Click Copy or Cut.
3. Select the upper-left cell of the target destination.

4. On the Edit menu, Short cut menu or Standard Toolbar, click Paste.
	1. Select the cells you want to copy.

2. On the Edit menu, Short cut menu or Standard Toolbar Click Copy.

3. Select the upper-left cell of the target destination.

4. On the Edit menu, click Paste Special. 

	Short Cut 
	Ctrl + V
	


Q. 9) Write down the differences between Print Area and Print Preview.

Differences b/w Print Area & Print Preview:-

The differences between Print Area and Print Preview are given below:

	
	Print Area
	Print Preview

	Definition
	Print area is a range in a worksheet which user selects for printing. 


	Print preview is onscreen display of printout.

Before printing  a worksheet, user  clicks Print Preview to see how the sheet will look when user print it. The way pages appear in the preview window depends on the available fonts, the resolution of the printer, and the available colors.

	Menu Command
	1. On the View menu, click Page Break Preview.

2. Select the cells you want to add to the print area.

3. Right-click a cell within the selection, and then click Add to Print Area on the shortcut menu. 
	1. Select the cells.

2. On File menu, or Standard Toolbar click on Print Preview.


Q. 10) What is a toolbar? Write down the differences between Standard and Formatting Toolbars.

ToolBar:-

“A toolbar contains buttons with images, menus, or a combination of both.” 

Excel includes many built-in toolbars. By default, the Standard and Formatting built-in toolbars are docked side by side below the menu.

Differences b/w Standard Toolbar & Formatting Toolbar:-

The differences between Standard Toolbar and Formatting Toolbar are given below:

	
	Standard Toolbar
	Formatting Toolbar

	Definition
	Standard Toolbar contains buttons to perform common task.  
	Formatting Toolbar contains buttons to format cells in worksheet. 

	Tools
	The common tools of standard toolbar are tools for New, Open and Save a file, Print, Print Preview, Spell Check, Cut, Copy Paste, Format Paste, Do, Undo, Hyperlink, Autosum, Paste Function, Sort, Chart, Zoom Percent, And Help. 
	The common tools of Formatting Toolbar are tools for Font, Font Size, Bold, Italic, Underline, Alignment, Number Format, Indent, Border, Fill Colour and Font Colour.


Q. 11) Write down the differences between Autoformat and Conditional Format.

Differences b/w Autoformat & Conditional Format:-

The differences between Autoformat and Conditional Format are given below:

	
	Autoformat
	Conditional Format

	Definition
	Autoformat is a built-in combination of formats for a cell range of pivot table.
	Conditional format is used to highlight cells that meet specific conditions.

	
	Autoformat provides 16 formats, each of which is a combination of number format, font, alignment, borders, pattern, colour, column-width and row-height.
	Conditional Format provides options for format upto three conditions.

	Menu Command
	1. Select the range you want to format.
2. On the Format menu, click AutoFormat. 

3. Click the format you want.  



	1. Select the cells you want to highlight.
2. On the Format menu, click Conditional Formatting.

3. To use values in the selected cells as the formatting criteria, click Cell Value Is, select the comparison phrase, and then type a value in the appropriate box. 

or

To use a formula as the formatting criteria click Formula Is in the box on the left, and then enter the formula in the box on the right. 

4. Click Format.

Select the font style, font colour, underlining, borders, shading, or patterns you want to apply. 

To add another condition, click Add, and then repeat steps.


Q. 12) Write down the differences between Autofilter and Advanced Filter.

Differences b/w Autofilter and Advanced Filter:-

The differences between Autofilter and Advanced Filter are given below:

	
	AutoFilter
	Advanced Filter

	Definition
	AutoFilter displays a subset of rows by comparing values.
	COPY command is used to copy contents and/or formatting of cell to another position. 



	Menu Command
	1. Point to Filter on the Data menu, then click AutoFilter. 

2. Click the arrow in the column that contains the data you want to compare, and then select the criteria.

3. To customize the criteria click Custom. 

4. To match one criterion, click the comparison operator you want to use in the first box under Show rows where, and then enter the value you want to match.

5. To display rows that meet two conditions, enter the comparison operator and value you want, and then click the And button. In the second comparison operator and value boxes, enter the operator and value you want.

6. To display rows that meet either one condition or another condition, enter the comparison operator and value you want, and then click the Or button. In the second comparison operator and value boxes, enter the operator and value you want. 


	1. Select the cells you want to copy.

2. On the Edit menu, Short cut menu or Standard Toolbar Click Copy.

3. Select the upper-left cell of the target destination.

4. On the Edit menu, click Paste or Paste Special.


Q. 13) Can Lotus macros be run  in Excel 2000?

Excel 2000 does not run Lotus 1-2-3 or Quattro Pro macros. User has to rewrite any macros that he needs in Microsoft Visual Basic for Applications.

Q. 14) What happened to the Office Assistant in Excel 2000?

The Office Assistant is now out of the box  — that is, the Assistant floats around screen outside of a window. The Assistant uses less space on screen while still providing great help when user needs it. If user does not like the Assistant, user can turn it off permanently and use the Help index or table of contents.

Q. 15) What happened to the menus and toolbars in excel 2000?

Only the items that user uses most often are prominently featured on the new personalized menus and toolbars. 

User can easily expand menus to reveal all commands. After user clicks a command, it appears on personalized menu. If user would like to see all of the commands on menus at first, user can disable the short menus. On the Tools menu, click Customize. On the Options tab, clear the Menus show recently used commands first check box.

Q. 16) Why am I asked whether I want to install some features when I use them in Excel 2000?

To improve performance and save disk space, not all features are installed when user chooses the Install Now command during setup. As user uses Excel 2000, user might see shortcuts, icons, and commands for programs and components that weren't installed. When user needs this functionality, user can just click a command, and Excel 2000 installs the program or component.

Q. 17) What happened to File Open and File Save in Excel 2000?

In the improved Open and Save dialog boxes, user can see more files at one time. User can use the new Places Bar to get to the folders and locations user uses the most, click History to see the last 20 to 50 documents and folders user has worked with, or click the Back button on the toolbar to easily return to folders user has recently visited.

Q. 18) Why does it take longer to open some files in Excel 2000?

To ensure that workbooks are properly calculated whenever user works with them, Excel 2000 completely recalculates a workbook each time user opens it. This process means that it might take longer to open an earlier version file than users were used to. If user saves the workbook as an Excel 2000 workbook, it will open more quickly the next time.

Q. 19) Has anything changed in number formatting in Excel 2000?

Additional number formats are available with the euro currency symbol. Additional date formats include formats that display four-digit years.

Q. 20) Why is the selection highlight different in Excel 2000?

When user selects cells with coloured text, the colour remains the same instead of appearing in an inverse colour scheme. As user work with the selected range  — changing the colour of the font or the colour of the cell formatting  — it's easier for user to view the new colour after user has made the change.

Q. 21) What happened to the Save as HTML command in Excel 2000?

The Save as Web Page command replaces the Save as HTML command. When user selects the Save as Web Page command, user now has the choice of saving the entire workbook as a Web page or saving only a section of the workbook. If user clicks Publish, user is provided with additional options, such as saving the selection as an interactive spreadsheet that can be used on a Web page.

Q. 22) What happened to the PivotTable Report Wizard?

Instead of using a wizard to layout user’s PivotTable report, user can now lay out the report directly on worksheet with the PivotTable and PivotChart Report Wizard by dragging the fields from the toolbar to the drop areas.

Q. 23) Why does Excel suddenly enter numbers and formatting?

Excel 2000 automatically extends formatting and formulas in lists, simplifying this common task.

MS EXCEL FUNCTIONS

Q. 1) What are Excel Functions? Write a detailed note on Functions.

Functions:-
“Functions are predefined formulas that perform calculations by using specific values, called arguments, in a particular order, or structure.”

For example, the SUM function adds values or ranges of cells, and the PMT function calculates the loan payments based on an interest rate, the length of the loan, and the principal amount of the loan.

Arguments:

Arguments can be numbers, text, logical values such as TRUE or FALSE, arrays, error values such as #N/A, or cell references. The argument user designates must produce a valid value for that argument. Arguments can also be constants, formulas, or other functions. 

Structure:

The structure of a function begins with the function name, followed by an opening parenthesis, the arguments for the function separated by commas, and a closing parenthesis. If the function starts a formula, type an equal sign (=) before the function name. As user creates a formula that contains a function, the Formula Palette will assist.


Q. 2) How Function can be entered and edited in MS Excel?

Entering & Editing Function:-

Entering formulas

Following are the two methods of entering a function:

1. User can enter a function by just typing the function according to the structure of function.

For example:  =SUM(A10,B5:B10,50,60)

2. User can use the Formula Palette to enter worksheet functions. As user enters a function into the formula, the Formula Palette displays the name of the function, each of its arguments, a description of the function and each argument, the current result of the function, and the current result of the entire formula. To display the Formula Palette, click Edit Formula in the formula bar.

Editing formulas:-

User can use the Formula Palette to edit functions in formulas. Select a cell that contains a formula, and then click Edit Formula to display the Formula Palette. The first function in the formula and each of its arguments appear in the palette. 

Q. 3) What is Formula Palette?

“Formula Palette is the Assistance in building a formula with worksheet functions.”

The Formula Palette displays the name of the selected function and each of its arguments, describes the function and each argument, and gives the current result of both the function and the entire formula. You can edit functions in a formula by clicking the function name in the formula bar and then changing the arguments in the edit boxes.

Q. 4) How many types or categories of functions are available in Excel 2000.

Categories of Functions in MS Excel 2000:-


MS Excel provides many types of functions. The list of them is given below:

1. Financial Functions

2. Data & Time Functions

3. Logical Functions

4. Statistical Functions

5. Math & Trig Functions

6. Lookup & Reference Functions

7. Text Functions

8. Database Functions

9. Information Functions

Q. 5) What is nesting functions within functions

Nesting Functions:-

“Nesting Functions mean using a function as one of the arguments of another function.” 

For example, the following formula uses a nested AVERAGE function and compares the result with the value 50.


=IF(SALE>=100000,“Excellent”,IF(SALE>=90000,“Marvallous”,IF(SALE>=80000,“VeryGood”,IF(SALE>=60000,“Good”,IF(SALE>=50000,“NotBad”,IF(SALE>=40000,“Unsatisfactory”,IF(SALE>=30000,”Alarming”,IF(SALE>=10000,”SeeTheManager”,””))))))))

Valid returns:-

When a nested function is used as an argument, it must return the same type of value that the argument uses. For example, if the argument returns a TRUE or FALSE value, then the nested function must return a TRUE or FALSE

Nesting level limits:

A formula can contain up to seven levels of nested functions. 

When Function B is used as an argument in Function A, Function B is a second-level function. For instance, the AVERAGE function and the SUM function in above example both are second-level functions because they are arguments of the IF function. A function nested within the AVERAGE function would be a third-level function, and so on.

To nest functions:

User can use the Formula Palette to nest functions as arguments. For example, user could nest the SUM function in the IF function by clicking in the Value_if_true edit box, clicking the down arrow in the formula bar Functions box, and then clicking SUM.

To switch between functions in the Formula Palette, click the name of the function in the formula bar. For example, to change the range for the AVERAGE function, click AVERAGE in the formula bar. 

Q. 6) How many functions can be nested within a function?

Nesting level limits:

A formula can contain up to seven levels of nested functions. 

When Function B is used as an argument in Function A, Function B is a second-level function. 

Two examples of nesting functions are given below:

Example 1:

=IF(AVERAGE(F2:F5)>50,SUM(G2:G5),0)

The AVERAGE function and the SUM function in above example both are second-level functions because they are arguments of the IF function.

Example 2:

=IF(SALE>=100000,“Excellent”,IF(SALE>=90000,“Marvallous”,IF(SALE>=80000,“VeryGood”,IF(SALE>=60000,“Good”,IF(SALE>=50000,“NotBad”,IF(SALE>=40000,“Unsatisfactory”,IF(SALE>=30000,”Alarming”,IF(SALE>=10000,”SeeTheManager”,””))))))))

The second IF within IF is second level function in the above example and the third IF is a third-level function, and so on.
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=SUM(A10,B5:B10,50,60)





=IF(AVERAGE(F2:F5)>50,SUM(G2:G5),0)
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