http://www.mostgraveconcern.com/freebsd/Make World Applicable to: FreeBSD 4.6 Updated: July 8, 2002 This Sheet describes the procedure for updating FreeBSD from source. Before performing this procedure, you should review the FreeBSD Handbook article Using make world. Run cvsup to update the sources: # /usr/local/bin/cvsup -g -L 2 /usr/src/stable-supfile If you've created the /usr/local/bin/cvsrun script described in the Updating Sources with CVSup cheat sheet, you can also run: # /usr/local/bin/cvsrun If you need help setting up /usr/src/stable-supfile, see the Updating Sources with CVSup cheat sheet. Read /usr/src/UPDATING carefully so that you understand any special procedures that are required. If you do not follow such special procedures, you run the risk of rendering your system unusable. Make sure you have a backup of all the important files on your system! Edit or create /etc/make.conf and enter the following options to override the defaults (located in /etc/defaults/make.conf): CFLAGS= -O -pipe COPTFLAGS= -O -pipe NOPROFILE= true USA_RESIDENT= YES Backup /etc: # cp -Rp /etc /etc.old Run mergemaster in pre-buildworld mode to update files essential to the success of buildworld and installworld: # /usr/sbin/mergemaster -p -v -w 132 (eliminate '-w 132' if 132x43 video mode is not activated) Remove old /usr/obj: # cd /usr/obj # chflags -R noschg * # rm -rf * Compile the sources: # cd /usr/src # make buildworld Compile and install the new kernel: # cd /usr/src (if you've changed directories after the last step) # make kernel KERNCONF=YOURKERNEL If you don't already have a custom kernel configuration, use GENERIC in place of YOURKERNEL above. If you wish to create a custom kernel, see the Building a Custom Kernel cheat sheet. Drop to single user mode: # shutdown now Or reboot into single user mode: # shutdown -r now ··· Ok boot -s ··· # fsck -p # mount -u / # mount -a -t ufs # swapon -a # adjkerntz -i Install the new system binaries: # cd /usr/src # make installworld Update system configuration files: # /usr/sbin/mergemaster -v -w 132 (eliminate '-w 132' if 132x43 video mode is not activated) Update /dev In most cases, mergemaster will realize when it is necessary to update the devices, and will offer to complete it automatically. If you've declined mergemaster's offer, perform these steps to update /dev manually: # cd /dev # /bin/sh MAKEDEV all Update /stand: This step is included for completeness. It can be safely omitted. # cd /usr/src/release/sysinstall # make clean # make all install Reboot to multi-user mode: # reboot