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1 SCOPE



1.1 IDENTIFICATION



	Project Code
	:
	CBEUMLP

	Project Name
	:
	CELL BROADBAND ENGINE UML PROFILE

	Program Code
	:
	CBE

	Program Name            
	:
	CELL BROADBAND ENGINE

	Document Name
	:
	TUTORIAL - HELLOWORLD UML PPU

	Document Reference      
	:
	CBEUMLP_TUT_HWUMLPPU_v003




1.2 DOCUMENT OVERVIEW

This document is a tutorial for creating a simple HelloWorld application using UML for the CBE PPE PPU target. 


2 APPLICABLE DOCUMENTS



2.1 DOWSON RESEARCH


	1
	CBE UML Profile Development - Environment Setup
	:
	CBEUMLPD_ENV_v001.doc

	
	
	
	




2.2 IBM


	
	NONE.
	
	

	
	
	
	




2.3 EXTERNAL REFERENCES



	
	NONE.
	
	

	
	
	
	






3 DEFINITIONS, ABBREVIATIONS AND ACRONYMS



3.1 DEFINITIONS

None defined.


3.2 ABBREVIATIONS

CBE
: 
Cell Broadband Engine

CBEA
:
Cell Broadband Engine Architecture

DMA
: 
Direct Memory Access

EIB
: 
Element Interconnect Bus

HDE
:
Host Development Environment

IDF
:
Interrupt Driven Framework

LS
:
Local Storage

MFC
:
Memory Flow Controller

NIC
:
Network Interface Card

OXF
:
Object Execution Framework

PPE
:
PowerPC Processing Element

PPU
:
PowerPC Processing Unit

SF
:
Synchronous Framework

SPE
:
Synergistic Processing Element

SPU
: 
Synergistic Processing Unit

SPUFS
: 
Synergistic Processing Unit File System

TDE
:
Target Development Environment

UML
:
Unified Modeling Language



3.3 ACRONYMS

DD
:
Deployment Diagram

OMD
:
Object Model Diagram

PMD
: 
Programming Model Diagram

SD
:
Sequence Diagram

SMD
:
State Machine Diagram

UCD
:
Use Case Diagram



4 TUTORIAL - HELLOWORLD UML PPU


4.1 OVERVIEW

This document is a tutorial for creating a simple HelloWorld application using UML for the CBE PPE PPU target. 

The objectives of this tutorial are to teach a user how to: 

· perform model driven development using real-time UML 
· perform automatic code generation from the real-time UML models

· build and execute the application on a Cell Broadband Engine PPE PPU target platform
· perform design level animation and debugging of the application as it runs on the target platform
After completing this tutorial, you will have learnt how to use:

· Use case diagrams to depict system functionality

· Sequence diagrams to show the intended flow of external communication between objects instances
· Object Model diagrams to show the static organization of the system under development

· Statechart diagrams to show the dynamic behavior of an object using an enhanced finite statemachine representation
· Animated sequence diagrams to show the actual flow of external communication as it occurs at run-time on the target platform

· Animated statechart diagrams to show the current state of an object instance
· Inspection of object instances, object instance attributes and object instance relationships at run-time, for an application as it runs on the target platform



4.2 PRE-REQUISITES

A pre-requisite for this tutorial is that the CBE UML Profile environment is setup and configured to support the CBE PPE PPU target. Ensure that the IBMCellBroadBandProcessorC++_i02.prp and SiteC++.prp Rhapsody property files are installed in the ‘<RHPINSTALLDIR>\Share\Properties’ directory location.

Extract the supplied CBEUMLProfile.zip file to the ‘<RHPINSTALLDIR>\Share\Profiles’ directory location. This will facilitate application of the CBE UML Profile when creating a new project.


4.3 CREATE A NEW PROJECT
Launch Rhapsody in C++ and create a new project by selecting File → New. This will pop up a New Project dialog window.
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Enter the following values in the New Project dialog window

· Project name :  HelloWorld
· In folder : \\mercury\project\ibm\cbe\source\uml\HelloWorld
· Type : CBEUMLProfile
Click on OK. This will pop up a confirmation dialog window.
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Click on Yes to create the new project.

Your browser window should now look like this.
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Click on the save icon [image: image5.png]


 in the menu toolbar. This will save the newly created project.



4.4 CREATE AN USE CASE DIAGRAM

Using the browser window, navigate to the HelloWorld project node, right click on HelloWorld and select Add New → Use Case Diagram. This will pop up a New Diagram dialog window:
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In the Name field, enter ‘UCD001 Display a welcome message’ and click on OK to create a new use case diagram.

Follow these steps to create the use case diagram :

1. Click on the Create Boundary Box icon [image: image7.png]


 to create a new system boundary box, click and drag the cursor in the diagram drawing area to create a new system boundary box. Click on the name area and rename it to ‘IBM Cell Broadband Engine’.
2. Click on the Create Use Case icon [image: image8.png]


 to create a new use case, click and drag the cursor inside the system boundary box, so that the use case is contained by the system boundary box. Rename the use case to ‘Display a welcome message’.
3. Click on the Create Actor icon [image: image9.png]


 to create a new actor, click and drag the cursor outside the system boundary box to create a new actor. Rename the actor to ‘User’. Actors are always external to the system.

4. Click on the Create Association icon [image: image10.png]


 to create a new association between the actor and the use case, click on the actor to specify association end 1 and click on the use case to specify association end 2.

[image: image11.png]Rhapsody in C++ by I-Logix In

Use Case Diagram: UCDO01 Display a welcome message]

He £ Yo Cote byos T Winbw b SEE
FECEE e A S R EE e I EE P PREIEE)
| © ¢ @t o [Prrogen Smazemaitan @ @D B DB E B
[ERr e T lE == 6E s |
INLAMOV e OAR [aae 0 =

0 E’ Use Case Diagram : UCD001 Display a welcome messag... [
N o | e | Rt | s | Prperies
Fillwerkd — —— ——
[ 2| one UEGED1 Dily vl e L |
23 ObjectodelDisgrams By | Stereovpe = IBM Cell Broadband Engine
(2 Packages
5 0 rofes L ||| oot Pacoge: oot =
2 23 e Case Diagrams || e
£/ Ucom Dy awekone meszase | Dioplay awelcome
Sy message
0 B
N
User
al i ) — |
Locate | OK_ [ Anply || |1 ucoon is
|
I3
T 0 Build  Check vodel J,Confauration ManagemerntJy Aimation

For Help, press F1

[emove | || 20,300 g i)







4.5 CREATE A SEQUENCE DIAGRAM

Using the browser window, navigate to the HelloWorld project node, right click on HelloWorld and select Add New → Sequence Diagram. This will pop up a New Diagram dialog window:
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In the Name field, enter ‘SD001 Display a welcome message’, for the Operation Mode select ‘Design’ and then click on OK to create a new sequence diagram.

Follow these steps to create the sequence diagram :

1. Click on the System border icon [image: image13.png]


 to create a new system border on the left hand side of the sequence diagram.
2. Click on the Instance line icon [image: image14.png]<



 to create an object instance. Rename the object instance by typing ‘:Display’. This is the format for a generic unnamed object instance. If you would like to give an object instance name at run-time, you may type ‘CBEDisplay:Display’. For this example, we shall use the generic unnamed object instance ‘:Display’.
3. Click on the Message icon [image: image15.png]


 to create a new event, then click on the System border and release the cursor on the object instance line, such that the message line is slanted downwards. A slanted message line is automatically created as an Event specification. Rename the event to ‘ev_start’. A confirmation dialog window will pop up asking you if you would like to realize the new event :
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Click on Yes.

4. Click on the Message icon [image: image17.png]


  this time to create a new Primitive Operation, click on the object instance line and release the cursor on the same object instance line, but a bit lower, so that you end up specifying a Primitive Operation for the ‘:Display’ class. In another scenario, a horizontal line is automatically interpreted as Primitive Operation specification. Rename it to ‘displayMessage’.
5. Click on the ‘displayMessage’ primitive operation in the sequence diagram and using the properties window, create a new Realization for the primitive operation by selecting the drop down control and selecting <New>.
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This will automatically pop up another window, where you can specify the displayMessage operation in greater detail as shown below :
[image: image19.png]Primitive Operation : displayMessage in Display

General | Implementation | Reltios | Tags | Propeties |
R |

i e

Vbt [Fubic -

Type: Primitive Operation |1 Template |
o

' Use existing type.

e |

[Mogers
I Vitual [~ Static [ Inine [~ Constant [~ Abstiact
Argumerts: DEX+$
Neme Type Value Direction

ew>
Desciiption

Locate | oK | fpoly ||





For the Argument Name, click on <New> and specify for the Name ‘szMessage’. 
For the Argument Type, we would like to specify const char* and since it is not already defined as part of Rhapsody’s built in types. Ensure that the ‘szMessage’ argument is selected and click on the properties icon [image: image20.png]


. In the Argument Dialog window, deselect ‘Use existing type’, in the C++ Declaration type ‘const char*’ and for the Default Value type ‘NULL’. 
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Click on OK. 

The Primitive Operation General properties tab window should look like the one in the image shown below:
[image: image22.png]Primitive Operation : displayMessage in Display

General | Implementation | Reltios | Tags | Propeties |
R |

i e

Vbt [Fubic -

Type: Primitive Operation |1 Template |
o

' Use existing type.

e |

Mot
I~ Vitual [~ Static [~ Inline [~ Constant [~ Abstract
Arguments: DE X $

T [N | e
B Bl
Stew>
Dessipton

Locate | oK | fpoly ||





Click on the Implementation tab and type the following text to display a message to the console window :

// Display a message to the console window

std::cout << szMessage << std::endl;

The Primitive Operation Implementation properties tab window should look like the one in the image shown below :
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Click on OK.

6. Click on the Message icon [image: image24.png]


 to create a new event ‘ev_quit’, click on the System border and release the cursor on the object instance line, after the ‘displayMessage’ primitive operation specification, such that the message line is slanted downwards. Rename the event to ‘ev_quit’. A confirmation dialog window will pop up asking you if you would like to realize the new event :
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Click on Yes.
7. We will now create a hyperlink from the use case diagram to the sequence diagram to facilitate navigation of use case realizations. Using the browser window, navigate to the Use Case Diagrams node → ‘UCD001 Display a welcome message’, right click on ‘UCD001 Display a welcome message’ and select Add New → Hyperlink. 

Enter the following values in the Hyperlink properties window:

· Text to display : select Target name

· Link Target : click on the drop down control and select ‘SD001 Display a welcome message’ 
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Click on OK.
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Click on Apply.

8. Using the browser window, navigate to the Use Case Diagrams node → ‘UCD001 Display a welcome message’ → Hyperlinks → ‘SD001 Display a welcome message’, and double click on the hyperlink to display the sequence diagram. 
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4.6 CREATE AN OBJECT MODEL DIAGRAM

Using the browser window, navigate to the HelloWorld → Object Model Diagrams → Model1 node, select Model1 and rename it to ‘OMD001 Main class diagram’ using the properties window.  
Follow these steps to create the update the object model diagram :

1. Navigate to the Display class in the browser windows, select and drag the Display class on to the object model diagram.

2. Right click on the Display class in the object model diagram and select ‘Display Options’.

Click on the Attributes tab and select Show ‘All’. This window allows you to control which attributes are displayed in the object model diagram for the Display class.
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Click on the Operations tab and select Show ‘All’. This window allows you to control which operations are displayed in the object model diagram for the Display class.
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3. Right click on the Display class in the object model diagram and select ‘New Attribute’.

Enter the following values in the Attributes properties window:

· Name : ‘counter’
· Type  :  ‘int’
· Initial Value : ‘0’
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Click on OK. 
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4.7 ADD A NEW STATECHART FOR THE DISPLAY CLASS

Navigate to Packages → Default → Classes → Display, right click on the Display class and select Add New → Statechart. 
Follow these steps to create the statechart

1. Select the State icon [image: image33.png]


 from the Drawing toolbar and create three states 

a. initialize

b. displaymessage

c. uninitialize

2. Select the Termination connector [image: image34.png]


 icon from the Drawing toolbar and create a termination state as show in the diagram below.

3. Select the Default connector icon [image: image35.png]


 from the Drawing toolbar and create a link to the initialize state

4. Select the Transition icon [image: image36.png]


 from the Drawing toolbar and create 

a. a state transition from initialize state to displaymessage state. Right click on this state transition and click on Select Trigger → ‘ev_start’. This will get entered into the Trigger field in the properties window for the state transition. This means that if the Display class receives an event ‘ev_start’ while it is in the initialize state, it will transition to the displaymessage state.
b. a self transition from displaymessage state to itself and type ‘tm(1000)’. This will get entered into the Trigger field in the properties window for the state transition. This is a way of specifying a timeout value and will cause the displaymessage state to be entered in an indefinite loop every 1000 milliseconds.
c. a state transition from displaymessage state to uninitialize state. Right click on this state transition and click on Select Trigger → ‘ev_quit’. This will get entered into the Trigger field in the properties window for the state transition. This means that if the Display class receives an event ‘ev_quit’ while it is in the displaymessage state, it will transition to the uninitialize state.
d. a state transition from uninitialize state to the termination state

The final statechart diagram should look like the statechart diagram in the image shown below:
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4.7.1 ADD CODE FOR STATE : initialize

Click on the initialize state and enter the following code fragment using the properties window :  
Action on entry : 

// Display a diagnostic message to the console window

displayMessage("Initializing the Display class.");
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Use the [image: image39.png]


 button to pop up a text editor window to enter the C/C++ code fragment.


4.7.2 ADD CODE FOR STATE : displaymessage

Click on the displaymessage state and enter the following code fragment using the properties window :  

Action on entry : 

// Display a welcome message to the console window

displayMessage("HelloWorld from CBE PPE PPU !!"); 

// Increment the display counter 

counter += 1;


4.7.3 ADD CODE FOR STATE : uninitialize

Click on the uninitialize state and enter the following code fragment using the properties window :  

Action on entry : 

// Display a diagnostic message to the console window

displayMessage("GoodBye !!");

// Exit the application normally 

exit(0);


4.8 UPDATE THE COMPONENT INFORMATION

Navigate to Component → DefaultComponent, click on DefaultComponent and rename the component to ‘PPUProgram’ using the properties window. 
In the Stereotype field, select ‘Executable’. 


4.9 UPDATE THE CONFIGURATION INFORMATION

Navigate to Component → PPUProgram → Configurations → DefaultConfig, click on DefaultConfig and rename the configuration to ‘ppu32-gcc-3.4.1-noanim’ using the properties → General tab window. This will be a component configuration with no animation support. 
Using the configuration properties window, navigate to the Initialization tab window and for 
· Initial Instances : select the ‘Explicit’ option and check the Display class. This will cause an instance of the Display class to be automatically created and launch the reactive statechart behavior for the Display class. 

Using the configuration properties window, navigate to the Settings tab window and for 

· Standard Headers : enter ‘<iostream>’ to include the iostream libraries for use by the PPUProgram component. 

· Instrumentation : ensure that it is set to ‘None’.

· Environment Settings → Environment : select ‘LinuxPPU’. This will apply specific configuration settings required for the PPU target.
Using the configuration properties window, navigate to the Properties tab window, select Filter  select ‘All’ and for 

· CPP_CG → LinuxPPU → CBEImports : enter ‘/opt/ilogix/rhapsody/Share/LangCpp/lib/linuxoxfppu.a’. 
This will cause the following entry to be made into the component configuration makefile                                        IMPORTS := /opt/ilogix/rhapsody/Share/LangCpp/lib/linuxoxfppu.a . 
This statement tells the compiler to link with the Rhapsody OXF libraries for the CBE PPE PPU target.


4.10 GENERATE CODE FOR THE ACTIVE COMPONENT CONFIGURATION

From the main menu, select Code → Generate → ppu32-gcc-3.4.1-noanim to generate the component makefile and application C/C++ source and header files. This will pop up a confirmation dialog window to create the target component configuration directory.
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Click on Yes to create the target component configuration directory.



4.11 BUILD AND RUN THE APPLICATION
The target development environment is an IBM Cell Blade Server with the SCE GNU Toolchain v3.4.1 installed.

Navigate to the target component configuration directory and build the PPUProgram using the automatically generated PPUProgram.mak file.

Type the following commands in a terminal window on the IBM Cell Blade Server:

cd /project/ibm/cbe/source/uml/HelloWorld/PPUProgram/ppu32-gcc-3.4.1-noanim
make -f PPUProgram.mak

Execute the MainPPUProgram binary file on the IBM Cell Blade Server.

This should result in the following output :

Initializing the Display class.

If you recall the statechart defined for the Display class, there is state transition defined between state initialize and displaymessage if an event ‘ev_start()’  is received by the Display class while it is in the initialize state. The dynamic behavior of the object is precisely controlled by its statechart.
Events can be sent to the Display class from another class, say ConsoleUI, which might be monitoring the keyboard input for a keystroke event ‘s’ and send the event ‘ev_start()’ to the Display class using the Rhapsody defined ‘GEN(ev_start())’ macro.


Events can also be sent to the Display class via the target level debugging and animation interface from an instance of Rhapsody running on the host development environment. We shall see how this works in section § 4.12 of this document.

For now, press ‘CTRL + z’ to terminate this application. The process will still be running in the background, so type ‘ps -eaf' to list all running processes and then type ‘kill -9 <pid>’ to kill the ‘./MainPPUProgram’ process.


4.12 PERFORMING TARGET LEVEL ANIMATION AND DEBUGGING
In order to perform target level animation and debugging of the application at the UML Model level, we will need to create a new component configuration to support animation.



4.12.1 CREATE A COMPONENT CONFIGURATION WITH ANIMATION SUPPORT

Create a copy of the existing ppu32-gcc-3.4.1-noanim configuration by selecting and holding the ppu32-gcc-3.4.1-noanim configuration with the left mouse button, holding the ‘Ctrl’ key and dragging the cursor to the Configurations node and releasing the cursor. This will create a copy of the ppu32-gcc-3.4.1-noanim configuration called ppu32-gcc-3.4.1-noanim_copy. Rename this configuration to ppu32-gcc-3.4.1-anim.
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Select the ppu32-gcc-3.4.1-anim configuration and ensure that it is the current active configuration by right-clicking and selecting ‘Set as Active Configuration’. 

Using the configuration properties window, navigate to the Settings tab window and for 

· Instrumentation Mode → Instrumentation Mode : select ‘Animation’. This will cause the application to inherit from the Rhapsody OXF animation libraries.

Using the configuration properties window, navigate to the Properties tab window, select Filter  select ‘All’ and for 

· CPP_CG → LinuxPPU → CBEImports : enter ‘/opt/ilogix/rhapsody/Share/LangCpp/lib/linuxaomanimppu.a   
/opt/ilogix/rhapsody/Share/LangCpp/lib/linuxoxfinstppu.a          /opt/ilogix/rhapsody/Share/LangCpp/lib/linuxomcomapplppu.a’

These are the libraries that are required to be linked to the application to support animation and debugging of the application at the model level for the CBE PPE PPU target on the IBM Cell Blade Server platform. 


4.12.2 GENERATE THE APPLICATION
From the main menu, select Code → Generate → ppu32-gcc-3.4.1-anim to generate the component makefile and application C/C++ source and header files. This will pop up a confirmation dialog window to create the target component configuration directory.
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Click on Yes to create the target component configuration directory.



4.12.3 BUILD AND RUN THE APPLICATION
Now go to the target development environment, navigate to the target component configuration directory and build the PPUProgram using the automatically generated PPUProgram.mak file.

Type the following commands in a terminal window on the IBM Cell Blade Server:

cd /project/ibm/cbe/source/uml/HelloWorld/PPUProgram/ppu32-gcc-3.4.1-anim
make -f PPUProgram.mak
An application compiled with animation support with launch on the target platform and attempt to establish a connection on TCP/IP port 6423, to an instance of Rhapsody running on the host development environment. 
Ensure that the host (e.g. hercules ) is reachable by issuing a ping command, prior to launching the application:  

ping hercules
Execute the MainPPUProgram binary file on the IBM Cell Blade Server. 

The application will launch, establish a connection with an instance of Rhapsody running on the host development environment and will wait for command inputs. 
An application compiled with Animation support will have to use the Rhapsody animation interface to execute and debug the application at the model level.


4.12.4 DEBUGING THE APPLICATION USING THE HOST DEVELOPMENT ENVIRONMENT

If the target application is able to successfully establish a TCP/IP socket connection using port 6423 with an instance of Rhapsody running on the host development environment, then the following animation toolbar will be automatically displayed.
[image: image43.png]MEBEPRI L & @/ 5d




Click on the Go icon [image: image44.png]


 

This should result in the following output :

Initializing the Display class.


If you recall the statechart defined for the Display class, there is state transition defined between state initialize and displaymessage if an event ‘ev_start()’  is received by the Display class while it is in the initialize state. The dynamic behavior of the object is precisely controlled by its statechart.

We will now use the Rhapsody animation interface to send an event ‘ev_start()’  to an instance of the Display class.


4.12.4.1 SENDING EVENTS 

It is possible to send events to the application while it is running on the target platform.

Click on the Event Generator icon [image: image45.png]


 to send the event ev_start() to the application running on the target platform.
This will pop up the Events dialog window :
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You may click on Select to browse the list of object instances and select Display[0]. 
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Click on OK.

Click on the Event drop-down list and select event ev_start.
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Click on OK. This will cause the application to transition to the displaymessage state as specified by the Display class statechart.
This should result in the following output :

HelloWorld from CBE PPE PPU !!

HelloWorld from CBE PPE PPU !!

HelloWorld from CBE PPE PPU !!

HelloWorld from CBE PPE PPU !!

HelloWorld from CBE PPE PPU !!
The MainPPUProgram program will display the message “HelloWorld from CBE PPE PPU !!" every 1000 milliseconds on the target console window.

Click on the Event Generator icon [image: image49.png]


, select the Display[0] object instance and send an event ev_quit() to the quit the application.

This should result in the following output :

GoodBye !!


4.12.4.2 VIEWING THE ANIMATED SEQUENCE DIAGRAM

It is possible to trace the messages that were exchanged between objects at run-time using an animated sequence diagram. You can then compare the expected message trace sequence diagram with the obtained message trace sequence diagram at run-time to verify the run-time behavior of the application.

Follow these steps to view an animated sequence at run-time:
1. Execute the MainPPUProgram binary file that has been compiled with animation support on the target platform. 
2. From the main menu, select Tools → Animated Sequence Diagram. This will pop up the Open Sequence Diagram dialog window :
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Select the sequence diagram ‘SD001 Display a welcome message’ and click on Open. 
This will open a blank animated sequence diagram.
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3. Click on the Go icon [image: image52.png]


 to start the application. The animated sequence diagram will trace events as they occur at run-time. 

As soon as the application is launched, we see the Display class constructor being called and the Display class calling the displayMessage operation.
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This should result in the following output :

Initializing the Display class.


4. Click on the Event Generator icon [image: image54.png]


, select the Display[0] object instance and send an event ev_start() to the object instance.
We can see 

· the event ev_start being sent to the Display[0] object instance

· the reflexive call to the displayMessage operation by the Display[0] object instance

· the occurrence of the timeout event tm(1000) 
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This should result in the following output :

HelloWorld from CBE PPE PPU !!

HelloWorld from CBE PPE PPU !!

HelloWorld from CBE PPE PPU !!

The MainPPUProgram program will display the message “HelloWorld from CBE PPE PPU !!" every 1000 milliseconds on the target console window.

5. Click on the Event Generator icon [image: image56.png]


, select the Display[0] object instance and send an event ev_quit() to the object instance.
We can see 
· the event ev_quit being sent to the Display[0] object instance

· the reflexive call to the displayMessage operation by the Display[0] object instance
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Thus, you can compare the intended and actual message traces as it occurred at run-time on the target platform. The comparison process can be automated using the Rhapsody Test Conductor tool.


4.12.4.3 VIEWING THE ANIMATED STATECHART

It is possible to view the current state of an object by using an animated statechart.
Follow these steps to view an animated statechart at run-time:
1. Execute the MainPPUProgram binary file that has been compiled with animation support on the target platform. 
2. Click on the Go icon [image: image58.png]


 to start the application. The animated statechart diagram can only be displayed if the application is running. 
3. From the main menu, select Tools → Animated Statechart. 

This will pop up the Open Animated State Chart dialog window :
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Select the Display[0] instance and click on OK.

This will open an animated statechart diagram.

We can see 

· the current application state highlighted in pink
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This should result in the following output :

Initializing the Display class.


4. Click on the Event Generator icon [image: image61.png]


, select the Display[0] object instance and send an event ev_start() to the object instance.
We can see

· the state transition from the initialize state to the displaymessage state. You will see a brief flicker on the tm(1000) state transition arrow head, from brown to red, as the reflexive timeout transition occurs every 1000 milliseconds.
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This should result in the following output :

HelloWorld from CBE PPE PPU !!

HelloWorld from CBE PPE PPU !!

HelloWorld from CBE PPE PPU !!

The MainPPUProgram program will display the message “HelloWorld from CBE PPE PPU !!" every 1000 milliseconds on the target console window.



4.12.4.4 VIEWING THE INTERNAL STATE OF AN OBJECT 
It is possible to view the internal state of an object at run-time by inspecting an object’s attributes and its relations. 
Follow these steps to view an animated statechart at run-time:

1. In the browser window, navigate to Packages → Default → Classes → Display → Instances → Display[0]. 
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2. Double click on Display[0]. 
This will pop up the object instance properties window:
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You can see the current value of the counter attribute. The value will keep getting updated each time is enters the displaymessage state, in accordance with the class statechart specification.

3. Click on the Event Generator icon [image: image65.png]


, select the Display[0] object instance and send an event ev_quit() to the quit the application.
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