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FLAGS AND FILTERS 

FLAG 
A flag is a single-character field that may be used to codify information about a person or to 
classify individuals in the Data Set.  Flags can be used in conjunction with the Accent feature 
and to filter information for display.  Almost all genealogy programs set at least a Sex flag 
and a Living flag.  
 
The Flags window displays all of the standard flags in a Project, i.e., Sex, Living, Birth Order, 
Multiple Birth, Adopted, Ancestor Interest, and Descendant Interest, as well as those custom 
flags that are specific to a particular Data Set.   
 
Where imported formats support something similar to the standard flags, they are mapped 
automatically to one of these seven flags.  Any custom flags that you may have created in 
your previous genealogy program will be imported with the same name they had there. 
 
All custom flags are specific to the Data Set that contains them.  The program supports up to 
250 unique flags in each Data Set.  There is no limit to the number of flags in a Project. 
 
Display the Flags window by checking it on the Window menu or by clicking on its button on 
the Layout Toolbar. 
 

FLAG MANAGER 
The Master Genealogist, provides flags that you can set to identify certain features pertaining 
to an individual. Values in a flag consist of only one character. In the Flag Manager, you will 
see the flag, the description for the flag (if there is one), and the values that can be used for 
each flag. One example of a flag is: SEX = ?MF, e.g., the sex of the individual may be 
unknown, male, or female. The Flag Manager shows you all the possible values for a flag and 
allows you to add, edit, delete, enable and disable flags within your project. 
 
For example, there may be flags in which you have no interest. You can disable these flags so 
that they do not appear in the Flags window. Or you may want different flags to appear at the 
top of the Flags window. You can move flags up or down in the window 
 
There are two types of flags. Standard and Custom. Standard flags are: SEX, LIVING, 
BIRTH ORDER, ADOPTED, MULTIPLE BIRTH, ANCESTOR INTEREST, and 
DESCENDANT INTEREST. 
The SEX flag is assigned automatically by TMG when you add a person. 
 
The LIVING flag defaults to ?. The program automatically sets it to N when a death or burial 
tag is entered, or when a birth group tag indicates that the person would be more than 110 
years old. You can change the LIVING flag to Y to use it with filters. 
 
The BIRTH ORDER flag is used to keep children in the correct order on reports like the 
Family Group Sheet when the birth dates are not known. On the Family Group Sheet the 
numbers will be printed on the report if they have been entered. 
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The ADOPTED flag is set in conjunction with relationship tags such as Moth-Ado, Fath-Ado, 
Son-Ado, or Dau-Ado. A Y indicates that the person shares an adoptive relationship in this 
family. 
The MULTIPLE BIRTH tag designates a person who is part of a multiple birth -- 2 for twins, 
3 for triplets, etc. 
The ANCESTOR AND DESCENDANT INTEREST flags can be used to indicate your level 
of interest in a particular ancestor or descendant. For example, 3 might be used for a direct 
ancestor or descendant. 
 
You can also create your own customized flags. When importing data from other genealogy 
programs, any custom flags will be imported with the same name they had there. If more than 
one data set in a project uses the same custom flag name, then in the Flag Manager, the data 
set number will appear after the flag name, e.g., CLERGY#1 and CLERGY#2. 
 

To use the Flag Manager: 
Select File > Flag Manager. 
The Flag Manager window will appear. 
 
All flags are enabled by default. 
 

To disable a flag: 
Highlight the flag name and click [Disable]. 
 

To enable a flag: 
Highlight the flag name and click [Enable]. 
 

To add a new flag: 
 Lookup: Add New Flag 
 

To edit a flag: 
 Lookup: Edit Flag Value 
 

To delete a flag: 
1.  In the Flag Manager, highlight the flag and click on [Delete] or press <F6> or <Delete>. 
2.  Answer [Yes] to confirm the deletion. 
 

To rearrange the order of the flags: 
Highlight a flag name and click [Move up] or [Move down]. 
 

To change the layout of your screen to include the Flags window: 
 See: Flags window 
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CUSTOM FLAG  
A flag defined by the user. 
 

ADD NEW FLAG 
 

To create a new flag: 
 
1.  Select File > Flag Manager or right-click on any flag in the Flags window and select 
Customize Flags from the menu. 
 
Lookup: Flags Window 
 
2.  In the Flag Manager window, select [Add] or press <F4>.  The Add New Flag window 

will appear. 
3.  In the Label field, enter a label for the flag, then press <Tab> or click in the Values 

field. 
 
NOTE: Flag names (up to 51 characters) and values (one character) can be entered using 
upper or lower case letters, numbers, and any characters except comma. A pound sign (#) can 
be used in the values section, but not in the name. Spaces can be used in the name, but not as 
a value. 
 
4.  In the Values field, list all possible values. Only one character may be used for each 

value. The first value in the list is the default value. This value will automatically be set 
by the program and remain until you change it. It is often best to use a "?" for the 
default value.  

 
Example: 
You want to indicate your relationship to the people in your data set. You could call the flag 
"Related by." Enter Related by in the Label field. 
 
Then you must determine all possible values. In this case, you may want a question mark and 
the first letters of the following words as the possible values: 
 
? = Unknown 
A = Ancestor 
D = Descendant 
C = Collateral 
M = Marriage 
U = Unrelated 
S = Self 
 
Your list of possible values would be ?,A,D,C,M,U,S. While you can use lowercase letters 
here, you should be aware that the search is not case sensitive, e.g., "A" and "a" are the same. 
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5.  In the Data Set field, if more than one data set is unlocked, you can select the data set in 
which this flag will be used. 

 
6.  Type a description in the Description field identifying the meaning of the custom flag 

and its various values. In the example above, you might have something like: 
 
 This field contains the relationship of the subject to the owner of the data set. 
 
? = Unknown 
A = Ancestor 
D = Descendant 
C = Collateral 
M = Marriage 
U = Unrelated 
S = Self 
 
7.  Select [OK]. 
 
NOTE: Be aware that if the flag name is changed, you will lose all of the values for this flag 
that you have previously set. You should experiment and be sure you are satisfied before 
setting the flag value for many individuals. You cannot delete flag values which are currently 
being used in flags. 
 
A flag can be set only to a value you have included in the list. It is perfectly safe to create new 
flags as this does not affect any other flag in the data set. 
 
NOTE: In any field in which you can type, there is a right-click menu with cut, copy, paste, 
and spell checker. The Label, Values, and Description fields support the use of hot keys: 
<F3> = Repeat previous entry 
<Ctrl>+<F3> = List previous 15 entries 
 
Temporary Flags 

It is often useful to create one or two custom flags for temporary use in building complex 
search statements when writing reports. 
 

EDIT A FLAG 
To edit all flags except Birth Order: 
1.  Double-click on the flag in the Flags Window.  The Edit Flag window will appear. 
2.  Highlight the correct value and click [OK]. 
 

TO EDIT A FLAG VALUE: 
1.  Select File > Flag Manager and highlight the flag to be edited, or right-click anywhere 

in the Flags window and select Customize Flags from the menu. 
 

NOTE: Only Custom flags can be edited. Standard flags may not be edited.  
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2.  In the Flag Manager window, select [Edit] or press <F5>. 
The Edit Flag Value window will appear. 

3.  You may make changes in any field. Be aware, however, that if the flag name is 
changed, you will lose all of the values for this flag that you have previously set. You 
should experiment and be sure you are satisfied before setting the flag value for many 
individuals. You cannot delete flag values which are currently being used in flags. 

4.  Select [OK]. 
 
NOTE: In any field in which you can type, there is a right-click menu with cut, copy, paste, 
and spell checker. The Label, Values, and Description fields support the use of hot keys: 
<F3> = Repeat previous entry 
<Ctrl>+<F3> = List previous 15 entries 
 

BIRTH ORDER  FLAG 
The Birth order flag displays the birth order for the children of a couple. This flag is used to 
number children in certain reports, such as the Family Group Sheet. If a Birth order flag is set, 
it will override dates and sort dates when sorting children in the order of their birth for 
reports. 
 
To edit the birth order flags for the children in a family: 
 
1.  Make one of the children the Subject in the Details window. 
 
2.  With the Flags window displayed, double-click on the Birth order flag or right-click and 

select Edit this flag from the menu. 
 

The Birth Order window will appear. 
 
3.  Highlight a child and click on  or  to enter the birth order number.  
 
4.  Repeat until all children have been numbered, then click [OK]. 
 
or 
 
3.  Double-click on a child. 
 

The Edit Birth Order window will appear. 
 

SEX FLAG 
The Sex flag in the Flags window is used to compile reports, generate statistics, set accents, 
audit for discrepancies, etc. Therefore, it is important that the flag be set correctly. Almost all 
genealogy programs use a flag to designate the sex of the individual. The choices for setting 
this flag are: M, F, and ?. It is rarely necessary to use the ? (unknown sex) designation. When 
you add sons, daughters, brothers, sisters, mothers, or fathers in The Master Genealogist, or in 
many other genealogy programs, this flag is set automatically. It is automatically set to ? if 
you add a child or sibling. 
 



 

 
6 of 16  

FLAGS WINDOW 
The Flags window displays all of the standard flags in a project, e.g., SEX, LIVING, 
BIRTHORDER, MULTIPLE BIRTH, ADOPTED, ANCESTOR INTEREST, and 
DESCENDANT INTEREST, as well as those custom flags that are specific to a particular 
data set. Where imported formats support something similar to these seven, they are mapped 
automatically to one of these seven formats. All other customized flags are specific to the data 
set. The program supports up to 250 unique flags in each data set. There is no limit to the 
number of flags in a project. 
 
A flag is a single-character field that may be used to codify information about a person or to 
classify individuals in the data set. Flags can be used in conjunction with the accent feature 
and to filter information for display or in reports. 
 
All genealogy programs support at least two flags: SEX and BIRTHORDER (in some form). 
Most support LIVING, many support MULTIBIRTH, and some support ADOPTED. In 
addition, in some programs, you may define custom flags for your own use. The Master 
Genealogist supports: SEX, LIVING, BIRTH ORDER, ADOPTED, MULTIPLE BIRTH, 
ANCESTOR INTEREST, and DESCENDANT INTEREST, as well as custom flags.  
 

To display the Flags window: 
Select Window from the Main Menu and check Flags or click on the Flags windowtoolbar 
button . 
 
To display the Layout toolbar which contains the Flags window tool (if it is not visible): 
 
1. Select View > Toolbars > Layout. 
2. If there is not currently a checkmark by Layout, click on it to check it. 
3. (Optional) Move the toolbar to any suitable location at the top of the Person View. 
 
To change the layout of your screen to include the Flags window: 
Click on the Flags window toolbar button  or select Window > Flags from the menu. 
 

FILTERING THE PROJECT EXPLORER 
In special cases you may desire to filter the Project Explorer so that only selected names 
appear: for instance, to determine how many people are in the Project, you can filter by 
primary name.  There are a number of filter options accessible by choosing Filter the Project 
Explorer on the Edit menu or by clicking on the funnel-shaped button on the Project Explorer 
Toolbar.  It will take longer to generate the Project Explorer when a filter is in place. 
 

NOTE:   Wildcards may be used in filter expressions, but only with a “like” operator.  A 
question mark (?) may represent a single unknown character  An asterisk (*) may 
represent one or more unknown characters.  A vertical line (| - found above the 
backslash on your keyboard) may be used as a delimiter signifying OR within any value 
field.  For example BOB|ROB will match BOB OR ROB  You may use more than one 
OR: for example, BOB|ROB|JIM|TIM. 
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You may activate one or more of the filter options at any time and may save a filter setting for 
later use.  A list of saved filter definitions can be seen by clicking on the scroll bar of the field 
to the right of the Project Explorer Toolbar or by clicking on the funnel button and then on 
{Load}.  You can load or delete any of these saved filter definitions. 
 
You may also choose to add all the filtered names to a Focus Group for Web searching or 
export via an option on the right-click menu.  
 
When you define a filter in the Picklist, you may copy it to the Project Explorer from the 
Filter the Picklist screen. 
 
In special cases you may desire to filter the Project Explorer so that only selected names 
appear.  This is intended to be used for special studies, not for routine name searches. 
 
NOTE: It will take longer to generate the Project Explorer when a filter is in place. 
 
You may activate one or more of the filter options at any time. 
 
To access the Filter the Project Explorer screen:  Click on  in the Project Explorer or select 
Edit > Filter the Project Explorer from the menu 
 
There are two ways to create filters: design one on the Filter tab or design one on the Query 
by Example (QBE) tab by filling in the provided fields. Use the Filter tab if you have 
experience creating filters, or if the filter is more complex. You can create a filter on the QBE 
tab and then look at the Filter tab to see what it looks like -- a helpful tool when you are 
learning to create filters. 
 

Filter Tab 
You can filter by Title, GivenName, PreSurname, Surname, Suffix, Other Name, 
SortSurname, SortGiven, Data Set ID, or by any flag. In addition, there are many other filter 
options including tags and tag groups, and # of... filters. Up to eight filters can be used at the 
same time. On the eighth filter, END will be assumed. The number of names in the list is 
displayed in the window heading. For more information on Name fields, lookup: Tag Entry 
 

Primary/Non Primary Tags 
If you select a tag in Field, a small box will appear to the left. Checking this field restricts the 
filter to primary tags only. Leaving the box unchecked will cause both primary and non-
primary tags to be included. 
 

Primary/Non-Primary Names 
You can also set a display filter for Primary names, Non-primary names, or Both by checking 
the appropriate box at the bottom of the window. This is a selection of what names will 
display in the Project Explorer after the filter is run. The number of names in the list is 
displayed in the window heading. Checking Primary names without setting a filter will give 
you a count of the number of people in the project. But don't forget, when the Project 
Explorer is filtered in this fashion, married names, nicknames, and other name variations will 
not appear in the list. 
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NOTE: If you have created and saved a filter, the selection of Primary names, Non-primary 
names, or Both is saved with the filter. If you do not save the filter, the setting is returned to 
Both the next time you start the program. 
 

Creating Filters 

To enter a filter: 
1.  Click on the down arrow next to the first filter field and select whether to filter by 

Surname, Title, Given name, Suffix, or by a flag. 
 
NOTE: Flags which have been disabled in the Flag Manager will still appear in this list. 
 
2.  Click on the down arrow next to the operator field and select the one you want, i.e., 

Contains, =, <>, >=, <=, >, <, Like, Begins with, Ends with, Sounds like, Is between, Is 
not between by clicking on the appropriate choice. The list of operators will vary 
depending on the Field selected. 

3.  Enter the information for which you wish to search. (See Wildcards and OR below.) 
4.  Select AND, OR, or END. If you use AND, only those records that match both 

conditions will be selected. If you use OR, all records that match either condition will 
be selected. END signifies the end of the filter definition. 

 

Wildcards 
Wildcards ( ? and * ) are allowed when you use a LIKE operator. 
? - The ? will match any one character. For example, H?T will match "hat" or "hot" or "hut". 
 *  - The * will match any string of characters. For example, MER* will match Merry, 
Merriment, Merrimac, Mercy, etc. 
 
OR 
 
A vertical line (|) may be used as a delimiter signifying OR within any value field. For 
example, BOB|ROB will match BOB OR ROB. You may use more than one OR; for 
example, BOB|ROB|JIM|TIM. 
Lookup: Filter and Accent Examples, More Accent and Filter Examples 
 

Conditional Brackets 
If you use both an AND and an OR connector, grey boxes will appear to the left and right of 
each line. Click on the box to create a parenthesis. For more information, see Parenthesis in 
Define Filter for Reports 
 

To clear the Project Explorer filter: 
Lookup: Clear the Project Explorer filter 
 
Saving, Loading, and Deleting Filters 
If you have a filter or filters that you use often, you can save the filter and reload it again at a 
later time. 
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To save a filter: 
1.  Enter the filter in the Filter the Project Explorer window. 
2.  Click on [Save as]. 
3.  Enter a name for the filter in the Save FLP file field and click on [Save]. 
 
NOTE: Filter names have the same restrictions as file names in Windows, i.e., some special 
characters such as "?" or ":" are not allowed. For more information on file naming, see 
Windows help. 
 

To load a previously saved filter: 
1.  From the Filter the Project Explorer window, click on [Load]. 

The Load Filter File Definition window will appear. 
2.  Select the file to be loaded and click on [Load]. 
3.  In the Filter the Project Explorer window, click on [OK]. 
 
OR 
>From the Project Explorer, click on the down arrow next to the field at the top of the Project 
Explorer window and select a filter from the list. 
 

To delete a filter definition: 
1.  From the Filter the Project Explorer window, click on [Load]. 
 
The Load Filter File Definition window will appear. 
 
2.  Select the file to be deleted. 
3.  Press <Delete>, or right-click and select Delete. 
4.  Answer [Yes]. 
 

FILTERS RESEARCH LOG 
The Research Log may be filtered to display selectively only those tasks of interest at any 
time.  The Filter Fields offer choices to filter based on words or phrases (e.g., location, 
surname, repository, etc.) used in either the Task name or the Keyword field.  The Keyword 
field, if carefully used, offers a very powerful tool for categorizing and selecting tasks of 
interest.  The Keyword Filter searches for information shown in the Keyword field, which is 
visible in the Research Task.  Filters in the Research Log are not case-sensitive. 
 

FILTERS 
 
A filter is a very powerful means of isolating a smaller group (of people, sources, etc., 
depending upon which report you are defining) from the total contained in your Data Set.  It 
consists of one or more filter expressions, each of which is shown on one line of the Report 
Filter screen. 
 
A filter expression has four (or five) elements: Field (sometimes with a subfield), Operator, 
Value, and Connect.  The construction of a filter is based upon Boolean logic. 
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>From a Report Definition Screen for many reports, you can choose Filtered group as the 
“Subject(s) of the report.”  Then click on the (Add) button to enter the Report Filter screen for 
a new filter. 
 
At the top of the Report Filter screen, after Save Filter As, you’ll need to enter a descriptive 
name by which the filter will be listed on the Report Definition Screen after “Filtered group.”  
You will then be able to use it again or edit it. 
 

NOTE:  Avoid the use of special characters, such as “or/or others that are used by  
Windows for other function, as they may cause problems if they appear as part of a 
filter name.    

 
There will be a blank field for each element of the filter expression.  Each field except Value 
will be followed by a scroll bar (indicated by a down arrow, an inverted triangle) which you 
can click for a complete list of possible choices for that field.  (If an item on the list under 
Field has three dots after it, a Subfield is expected for that item.) 
 
The list of available Operators varies according to the choice made under Field. 
 
You may type the appropriate information into the Value field, or you may enter (?) in that 
field, so that the program will prompt you for the appropriate value each time you generate a 
report.  This makes the Report Definition more versatile, as it can be used with different 
names, places, etc. 
 
If the filter is to consist of more than one filter expression, you will choose either AND or OR 
in the Connect field.  The last of the filter expressions will have END in the Connect field.  If 
you check the little box (under the asterisk) before a Field that contains an event tag, only 
primary tags will be considered . 
 
Use <Tab> to move from box to box on the Report Filter screen.  -  The following examples 
use the Sample Data Set 
 

Example 1   
A simple filter to isolate all the people in your Data Set whose primary Birth Dates are 
recorded as  earlier than 1800: 
*  X  (primary) 
Field:  Birth…. 
Subfield: Date 
Operator: Comes before 
Value: 1850 
Connect: END 
This will be shown on the first line of the Report Filter for a List of People report as: 
X   Birth…   Date   <  Comes before    1850  END 
(People born before 1850 = 37.) 
NOTE:   People who have no Birth tag will not be included in the result, but those with a 
Birth tab but no Birth Date will. 
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Example 2   
A refinement of the filter in Example 1 to eliminate people recorded as having been born in 
Tennessee: 
X   Birth…   Date   <    Comes before   1850  AND 
X   Birth…    Place   <>    Does not equal TENNESSEE   END 
(People born before 1850, but not in Tennessee = 30.) 
NOTE:   Again, people who have no Birth tag will not be included in the result, but those 
with a Birth tag but no Birth Date or Birth Place will. 
 

Example 3 
A different result if OR is used instead of  AND 
X   Birth…   Date   <   Comes before   1850  OR 
X   Birth…   Place   <>   Does not equal TENNESSEE   END 
(People born either before 1850 or not in Tennessee = 49.) 
 

Example 4 
A further refinement of Example 2 eliminates people with the surname Alexander: 
X   Birth…   Date   <   Comes before   1850  AND  
X   Birth…   Place   <>   Does not equal   TENNESSEE   AND 
Surname             <>   Does not equal ALEXANDER   END 
(People born before 1850, not in Tennessee, not named Alexander = 24.) 
 

Example 5 
A different result using OR instead of AND: 
X   Birth…   Date   <   Comes before 1850  OR 
X   Birth…   Place   <>   Does not equal   TENNESSEE  OR 
Surname             <>   Does not equal   ALEXANDER END  
(People who were either born before 1850 or not born in Tennessee or not named Alexander = 
61.) 
 
The more filter expressions with AND there are, the more restrictive the filter is and the fewer 
people will be on the resulting list, whereas the more filter expressions with OR, the more 
people result. 
 
Complications with filters arise when AND and OR are mixed.  Then it will be necessary to 
use parentheses to clarify the intended meaning.  (Boxes below the parenthesis marks will 
appear when this happens.  Click in the boxes to place the parentheses appropriately) 
 
The parentheses enclose a compound filter expression.  The program will process the filter 
expressions, whether single or compound, in order from first to last, so different groupings 
produce different results.  
 

Example 6 
(X   Birth…   Date   <   Comes before    1850 AND 
X   Birth…   Place   <>   Does not equal   TENNESSEE)   OR 
Surname             <>   Does not equal   ALEXANDER END 
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(People born before 1800, but not in Tennessee, plus anyone whose surname is not Alexander 
 = 53.) 
 

Example 7 
X   Birth…   Date   <   Comes before 1850  AND 
(X   Birth…   Place   <>   Does not equal   TENNESSEE OR 
Surname              <>   Does not equal   ALEXANDER) END 
(People born before 1850 who either were not born in Tennessee or are not named Alexander 
 = 32.) 
 

Example 8  
(X   Birth…   Date   <   Comes before    1850 OR 
X   Birth…   Place   <>   Does not equal   TENNESSEE) AND 
Surname             <>   Does not equal   ALEXANDERQ END 
People born either before 1850 or not in Tennessee whose name isn’t Alexander = 35) 
 

Example 9    
X   Birth…   Date   <   Comes before    1850    OR 
X   Birth…   Place   <>   Does not equal  TENNESSEE  AND 
Surname       <>   Does not equal   ALEXANDER)  END 
(People born before 1850 or else neither born in Tennessee nor named Alexander = 46.) 
 
After you have entered all the filter expressions needed to identify a core group of people, you 
can check one or more of the boxes at the bottom of the screen in order to add spouses, 
ancestors, and/or descendants to the core group.  The examples above do not include any of 
these relatives.  
 
If you feel confused by the many variations, you might try working through them yourself, 
using the sample Data set.  You’ll notice that each of the nine examples given above produces 
a different list of people, depending upon the number of filter expressions, the use of AND or 
OR, and the placement of parentheses, so it is important to be careful in developing a filter if 
you feel you need a complex one.  However, if you have no need for such filters, there is no 
reason to master them.   
 

FILTERING PLACE RECORDS 
You can display the places in all of the Data Sets in the Project, or you can choose to filter the 
places so that only those in one Data Set or only those in unlocked Data Sets appear on the 
list. 
 

FILTERING EVENT RECORDS 
When accessing the Master Event List from the Tools menu, you can  display the events in all 
of the Data Sets in the Project, or you can choose to filter the events so that only those in one 
Data Set or only those in unlocked Data Sets appear on the list. 
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When accessing the Master Event List from the Research Task screen, the filter will already 
be set, depending on several factors.  When you add a Research Task and attach it to an event, 
the filter field will say Filter by data set and will be set to All unlocked data sets.  If you  
attach a task to an event that is already attached to a  person, source, or repository, the Filter 
by dataset field will be set to the Data Set which contains the person, source, or repository.  
You cannot change the filter when you access the Master Event List from the Research Task 
window. 
 
For a list of events that happened in a certain place, highlight the place name on the Master 
Place List and click on [events].   If you wish to edit a particular event, highlight it and click 
on [Edit} for the Tag Entry screen.  If you want to go to the Person View of one of the 
principals, click on  [go to principal 1] or  [go to principal 2]or double-click on a person’s 
name in an event. 
 

FILTERING REPOSITORY RECORDS 
You can view the repositories in all of the Data Sets in the Project, or you can choose to filter 
the repositories so that only the repositories in one Data Set or only those in unlocked Data 
Sets appear on the list. 
 

FILTERING TAG TYPES 
The Master Tag Type List window also allows you to filter the list so that you can view only 
tags belonging to a particular Tag Type Group:  All groups (no filter), Name, Relationship, 
Birth, Death, Burial, Marriage, Divorce, History, Address, or Other events.   
 

FILTERING THE PICKLIST  
You can use filters to narrow the choices presented on the Picklist.  For instance, if you are 
interested only in people with a particular surname, you can filter the Picklist for that 
surname.  You can also use  combination of criteria, such as name elements and flag values, 
to display only those names that meet the criteria.  If you wish to view the names on the 
filtered list one after another, however, you will need to use the Project Explorer. 
 
 NOTE:   see note of filtering the project explorer 
 

PICKLIST FILTER 
In special cases you may desire to filter the Picklist so that only selected names appear. This 
is intended to be used for special studies, not for routine name searches. 
 
NOTE: It will take longer to generate the Picklist when a filter is in place. 
 
You may activate one or more of the filter options at any time. 
 
To access the Filter the Picklist screen: 
>From the Picklist, select [Filter]. 
 Lookup: Picklist 
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Saving Filters 
If you have a filter or filters that you use often, you can save the filter and reload it again at a 
later time. Sample filters are also included with the program. 
 

To save a filter: 
1. Enter the filter in the Filter the Picklist window. 
2. Click on [Save as]. 
3. Enter a name for the filter in the Save .FLP file field and click on [Save]. 
 

To load a previously saved filter: 
1. From the Filter the Picklist window, click on [Load]. 
2. Highlight the name of the filter to be loaded and click on [Load]. 
3. Click on [OK]. 
 

To copy a filter to the Project Explorer: 
1. From the Filter the Picklist window, check Copy filter to Project Explorer on exiting. 
2. Click on [GoTo] or double-click on the name of the person that you want to go to. 
 
There are two ways to create filters: design one on the Filter tab or design one on the Query 
by Example (QBE) tab by filling in the provided fields. Use the Filter tab if you have 
experience creating filters, or if the filter is more complex. You can create a filter on the QBE 
tab and then look at the Filter tab to see what it looks like -- a helpful tool when you are 
learning to create filters. 
 

Filter Tab 
You can filter by Title, GivenName, PreSurname, Surname, Suffix, Other Name, 
SortSurname, SortGiven, Data Set ID, or by any flag. In addition, there are many other filter 
options including tags and tag groups, and # of... filters. Up to eight filters can be used at the 
same time. On the eighth filter, END will be assumed. The number of names in the list is 
displayed in the window heading. For more information on Name fields, lookup: Tag Entry 
 

Primary/Non-Primary Names 
You can also set a display filter for Primary names or Non-primary names or Both by 
checking the boxes near the bottom left of the window. This is a selection of what names will 
display in the Picklist after the filter is run. The number of names in the list is displayed in the 
window heading. Checking Primary names without any filter will give you a count of the 
number of people in the project. But don't forget, when the Picklist is filtered in this fashion, 
married names, nicknames, and other name variations will not appear in the list. 
 
NOTE: If you have created and saved a filter, the selection of Primary names, Non-primary 
names, or Both is saved with the filter. If you do not save the filter, the setting is returned to 
both the next time you start the program. 
 

To enter a filter: 
1.  Click on the down arrow next to the first filter field and select whether to filter by 

Surname, Title, Given name, Suffix, or by a flag. 
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2.  Click on the down arrow next to the operator and select: Contains, =, <> (not equal), >= 
(greater than or equal to), <= (less than or equal to), > (greater than), < (less than), 
Equals, Like, Begins with, Ends with, Sounds like by clicking on the appropriate 
choice. 

 
NOTE: The operators that are available will vary depending on the field that was 
chosen. 

 
3.  Enter the search strings in the appropriate name field(s). (See Wildcards and OR below) 
4.  Select AND, OR, or END. If you use AND, only those records that match both 

conditions will be selected. If you use OR, all records that match either condition will 
be selected. END signifies the end of the filter definition. 

 

Wildcards 
Wildcards ( ? and * ) are allowed. 
? - The ? will match any one character. For example, H?T will match "hat" or "hot" or "hut". 
 *  - The * will match any string of characters. For example, MER* will match Merry, 
Merriment, Merrimac, Mercy, etc. 
 
NOTE: Wildcards do not work with the = operator. Use Like. 
 
OR 
A vertical line (|) may be used as a delimiter signifying OR within any value field. For 
example, BOB|ROB will match BOB OR ROB. You may use more than one OR; for 
example, BOB|ROB|JIM|TIM. 
 

Conditional Brackets 
If you use both an AND and an OR connector, grey boxes will appear to the left and right of 
each line. Click on the box to create a parenthesis. For more information, see Parenthesis in 
Define Filter for Reports 
 

Clear Filters 
To clear the Picklist filter: 
 
1.  From the Picklist screen, select [Filter] 
2.  From the Filter the Picklist screen, select [Clear]. 
3.  Click on [OK] to exit the Filter the Picklist window 
 

FILTERING SOURCE RECORDS 
You can view the sources in all of the Data Sets in the Project, or you can choose to filter the 
sources so that only the sources in one Data Set or only those in unlocked Data Sets appear on 
the list. 
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FILTER TAGS 
In addition to filtering the Tag Box to contain only Primary names and events (Edit -- toggle 
primary) or only basic events* (by accessing File -- Preferences -- Program Options:  Tag 
Box, as described above), you can choose to view only one Tag Type at a time by choosing 
Filter Tags from the Edit menu. 
 
* Basic events are Birth, Marriage, Death, and Burial 
 

FILTER EVENTS FROM THE MASTER PLACE INDEX 
The Master Place List can produce a filtered Master Event List with events that happened at 
the selected place. 
 
NOTE: This is a quick way to get a list of events that match all fields in a place record. For 
more complex filtering, use a List of Events report. 
 
To produce a filtered list of events: 
 
1.  From the Master Place List, highlight the place record and click [Events]. 
 

The Master Event List window will appear. 
 
2.  Highlight the correct event. 
 
To edit the selected event: 
Click [Edit]. 
The Tag Entry screen will appear. 
 
To go to the Person View of a Principal in the event: Click [Go to Principal 1] or [Go to 
Principal 2]. 
or 
Double-click on a person's name in an event. 
 
To exit the Master Place List: Click [Close] or press <F9>. 
 

CLEAR TAG FILTER 
To clear the tag filter and return all the tags to the screen: Select Edit > Clear filter 
 


