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2. Development Environment = Eclipse + ADT +  SDK 

• Android applications are usually created using the Java programming language[1] 

 
• Your Java project must import various Android Libraries (such as android.jar, 

maps.jar, etc ) to gain the functionality needed to work inside the Android OS. 
 

• Even the simplest of Android apps is composed of several elements such as:    
user-defined classes, android jars, third-party libraries, XML files defining the UIs 
or views, multimedia resources, data assets such as disk files, external arrays and 
strings, databases, and finally a Manifest summarizing the ‘anatomy’ and 
permissions requested by the app. 
 

•  The package(s) holding the raw app components are given to the compiler to 
obtain a single signed and deployable Android Package (an .apk file).  
 

• Like in Java, apk files are the byte-code version of the app that finally will be 
‘executed’ by interpretation inside a Dalvik Virtual Machine (DVM).  
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[1] Visit http://xamarin.com/monoforandroid for a commercial iOS and Android IDE that works with 
C# and Windows .NET 

http://xamarin.com/monoforandroid
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2. Development Environment = Eclipse + ADT +  SDK 

• Creating, organizing and managing the components of an Android app is 
better done using a ‘friendly’ workbench. 

 
• The Android developer’s workbench typically includes the following tools: 

1. Eclipse IDE 
2. Android Development Tools (ADT), and  
3. Android System Development Kit (SDK) 

 
• Eclipse IDE allows you to create and debug your Java code, and manage the 

various resources that normally are used in the making of an Android app.  
 

• The ADT plugin extends Eclipse so you can easily reach the tools of the SDK 
through the use of menus, perspectives and icons seamlessly integrated in 
the Eclipse’s IDE. 
 

• The SDK contains tools needed to transfer, profile, emulate, observe, and 
debug your applications which could run into any virtual or physical Android 
device. 
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2. Development Environment = Eclipse + ADT +  SDK 

Typical Layout of the Eclipse IDE for Android Development 
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2. Development Environment = Eclipse + ADT +  SDK 

Typical Layout of the Eclipse IDE for Android Development 
(details…) 
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Opens DDMS  Perspective 
Dalvik Debugging Monitoring System 

Opens Android SDK manager 
 

Opens Android AVD Virtual Device 
Manager 

Wizard creates a new Android Project 
 

These icons 
are added to  
Eclipse by the 
ADT plugin 

Note: The DDMS and Hierarchy View can be manually added by the user to Eclipse’s tool bar 
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2. Development Environment = Eclipse + ADT +  SDK 

SETUP 
Prepare your computer – Install SDK: Windows, Mac, Linux 
 
We assume you have already installed the Java JDK and Eclipse IDE in your 
computer 
 
• Java JDK is available at: 

http://www.oracle.com/technetwork/java/javase/downloads/index.html 
 

• Eclipse IDE for Java EE Developers is available at:  
http://www.eclipse.org/downloads/ 

 
 
The  next instructions are given to: 
 (a) User Wanting to Update their Older Android Workbench,  
 (b) First Time Users. 
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http://www.oracle.com/technetwork/java/javase/downloads/index.html
http://www.eclipse.org/downloads/


1.5    Cupcake,  
1.6    Donut,  
2.1    Eclair,  
2.2    Froyo,  
2.3    Gingerbread [1],  
3.x    Honeycomb, 
4.x    Ice Cream Sandwich 
4.3   Jelly Bean 
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2. Development Environment = Eclipse + ADT +  SDK 

Aside Note: 
 
SDKs are named after dessert 
items. Available versions at 
the time of writing are: 
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[1] By March 2012 Gingerbread accounted for approximately  66%  of the Android market share.  
See page:  http://www.appbrain.com/stats/top-android-sdk-versions 

http://www.appbrain.com/stats/top-android-sdk-versions
http://www.appbrain.com/stats/top-android-sdk-versions
http://www.appbrain.com/stats/top-android-sdk-versions
http://www.appbrain.com/stats/top-android-sdk-versions
http://www.appbrain.com/stats/top-android-sdk-versions
http://www.appbrain.com/stats/top-android-sdk-versions
http://www.appbrain.com/stats/top-android-sdk-versions


1. Click on the          SDK 
Manager icon.  
 

2. You will see a form similar 
to the one on the right.  
 

3. Select the Packages you 
want to install and wait 
until they are setup in 
your machine. 
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2. Development Environment = Eclipse + ADT +  SDK 

SETUP 
(a) Users Wanting to Update an Older Android Workbench 
If you are currently using the Android SDK, you just need to update to the latest 
tools or platform using the already installed Android SDK and AVD Manager. 
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2. Development Environment = Eclipse + ADT +  SDK 

SETUP 
(b) First Time Users  (Windows, Mac, Linux) 
 
1. Install the appropriate SDK starter package from the page 

http://developer.android.com/sdk/index.html 
 

2. Install the ADT Plugin for Eclipse 
1. Start Eclipse, then select Help > Install New Software.... 
2. Click Add button (top-right corner) 
3. In the next dialog-box enter "ADT Plugin" for the Name and the following 

URL for the Location: https://dl-ssl.google.com/android/eclipse/ 
4. Click OK 
5. Select the checkbox next to Developer Tools and click Next  > Next 
6. Accept the license agreements, then click Finish.  
7. After the installation end you need to restart Eclipse.  

 
3. Add Android platforms and other components to your SDK (see previous 

option (a) ) 
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http://developer.android.com/sdk/index.html
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2. Development Environment = Eclipse + ADT +  SDK 

Configuring the ADT Plugin 
 
The next step is to modify your ADT preferences in Eclipse to point to the 
Android SDK directory: 
 

1. Select Window > Preferences... to open the Preferences panel  
 (Mac OS X: Eclipse > Preferences). 
1. Select Android from the left panel. 
2. To set the box SDK Location that appears in the main panel, 

click Browse... and locate your downloaded SDK directory ( usually 
c:/Program Files (x86)/Android /android-sdk ) 

3. Click Apply, then OK. 
 
Done!  
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2. Development Environment = Eclipse + ADT +  SDK 

Selecting an Android Virtual Device (AVD) 
 
You should test your applications on a real phone (or tablet).  
However, the SDK allows you to create realistic virtual devices 
on which your applications could be tested.  
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2. Development Environment = Eclipse + ADT +  SDK 

Creating an Android Virtual Device (AVD) 
 
An AVD allows you to simulated devices and SDKs. 
To create a virtual unit follow the next steps: 
 
 
1. Click on the AVD Manager 
2. Click New. The Create New AVD dialog appears. 
3. Type the name of the AVD, such as “18-JellyBean" 
4. Choose a target (such as “Google APIs… API Level18”). 
5. Indicate how much memory the simulator will use. 
6. Tick option box “Snapshot” to load faster. 
7. Indicate screen size (HVGA is sufficient in general) 
8. Optionally specify any additional hardware components  
      (such as SD-card, camera, …) 
9. Click Create AVD. 
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2. Development Environment = Eclipse + ADT +  SDK 

Creating Android Virtual Devices (AVD) 
 
Some examples: 
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IceCream 4.x 

Tablet showing Honeycomb 3.x 

Gingerbread 2.3 running on a custom skin 
for Nexus-S.   See pages: 
http://heikobehrens.net/2011/03/15/android-skins/ 

and  
http://zandog.deviantart.com/ 

Phone Emulator IceCream 4.x 

http://heikobehrens.net/2011/03/15/android-skins/
http://heikobehrens.net/2011/03/15/android-skins/
http://heikobehrens.net/2011/03/15/android-skins/
http://zandog.deviantart.com/
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2. Development Environment = Eclipse + ADT +  SDK 

Testing the Emulator 
 
Click on the         AVD Manager. Choose an emulator, click Start. 
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Android Setup Tutorial 
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After you complete your setup look for the following two subdirectories in 
your file system 

C:\Program Files (x86)\Android\android-sdk 

C:\Users\1002125\.android\avd 

This folder contains your Android 
SDK, tools, and platforms 

This directory holds your 
Virtual Devices (AVDs) 
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Appendix. Creating an Android Project  (made for SDK2.2 - Froyo) 

An unabridged version of “Hello World” 

Testing Setup - Example: Hello World 



Testing Setup - Example: Hello World 
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Creating an Android Project  
To create a new project: 
1. Start Eclipse 
2. Select File > New > Android Project a 
3. Enter Project name: 01-Hello-World 
4. Click Next 
5. On Select Build Target choose row 
 Google APIs   Google Inc.  2.2     8 
6. Click Next 
7. On the Application Info form enter 

Pacakage Name:  csu.matos 
 Check box Create Activity 
 Activity name:  HelloActivity. 
 Min SDK Version: 8. 
 Click Finish. 
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OBSERVATION:  Creating an Android Project  using Eclipse 
 
The New Android Project Wizard creates the following folders and files in your new 
project space: 
 
• src/ Includes your skeleton Activity Java file. All other Java files for your 

application go here.  
• <Android Version>/ (e.g., Android 2.2/) Includes the android.jar file that your 

application will build against.  
• gen/ This contains the Java files generated by ADT, such as your R.java file 
• assets/ This is empty. You can use it to store raw asset files.  
• res/ This folder holds application resources such as drawable files, layout files, 

string values, etc. 
• bin/ The bytecode (.apk) version of your app is stored here 
• AndroidManifest.xml The Android Manifest for your project.  
• default.properties This file contains project settings, such as the build target.  
 

Testing Setup - Example: Hello World 



Creating an Android 
Project  
The following folders and files  
are created for the  
01-Hello-World project. 
 
To test the application, position 
the cursor on the code panel, 
and then click on the 
          Run menu button. 
 
The fragment of code 
illustrated on page 4  is 
executed, and its effect on the  
emulator is shown on page 12.  
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Testing Setup –  
Example: Hello World 
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Android Emulator (v2.3 skin) 
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Hang up 

Back 

Volume  

Status Bar – Notification Line 

Home 

Call 

Menu 

Tab 
Launch 

Pad 

Power 

Search 

Camera 

Numeric ID: 5554 
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Android Emulator (v4.3 JellyBean) 
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Numeric ID: 5554 
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Android Emulator 
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Keyboard OS function 
Escape Back button 

Home Home button 

F2,  PageUp Menu (Soft-Left) button 

Shift-F2,  PageDown Start  (Soft-Right) button 

F3 Call/Dial button 

F4 Hangup / EndCall button 

F5 Search button 

F7 Power button 

Ctrl-F3, Ctrl-KEYPAD_5 Camera button 

Ctrl-F5, KEYPAD_PLUS Volume up button 

Ctrl-F6, KEYPAD_MINUS Volume down button 

KEYPAD_5 DPad center 

KEYPAD_4 DPad left 

KEYPAD_6 DPad right 

KEYPAD_8 DPad up 

KEYPAD_2 DPad down 

F8 toggle cell network on/off 

F9 toggle code profiling (when -trace option set) 

Alt-ENTER toggle FullScreen mode 

Ctrl-T toggle trackball mode 

Ctrl-F11, KEYPAD_7 switch to previous layout 

Ctrl-F12, KEYPAD_9 switch to next layout 

Controlling the Android Emulator 
through (your computer’s) 
keyboard keys 
 
Keypad keys only work when 
NumLock is deactivated. 
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Android Emulator 
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Working with Emulator Disk Images 
• The Android simulator uses QEMU technology [Website: www.qemu.org]  
• QEMU is an open source machine emulator which allows the operating system and 

programs made for one machine (e.g. an ARM CPU) run on a different machine 
(e.g. your own PC).  

 
When you create a Virtual Device, the SDK  
Makes several  disk images containing among  
others:  
(1) OS kernel,  
(2) the Android system,   
(3) user data (userdata-qemu.img) 
(4) simulated SD card (sdcard.img). 
 
By default, the Emulator searches for the  
disk images in the private storage area of the  
AVD in use, for instance the “Gingerbread23” AVD is at: 
C:\Users\yourFolder\.android\avd\Gingerbread23 

 
Mac OS users should look into ~/.android/avd 

 

C:\Users\yourFolder\.android\avd\Gingerbread23 

http://www.qemu.org/
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Android Emulator 
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Moving Data, Music and Picture files 
to the Emulator’s  SDcard 

 
1. You need to add the DDMS 

perspective to your Eclipse IDE. 
2. Change to the DDMS perspective. 

Make sure your AVD has started 
(You will see a layout similar to the 
following) 

3. Click on the File Explorer tab. 
4. Expand the mnt (mounted devices) 

folder. 
5. Expand the sdcard folder 
6. Open your Window’s Explorer. 
7. Choose a file in your PC. Transfer a 

copy to the emulator by dragging 
and dropping it on top of the 
sdcard folder. 
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Android Emulator 
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Moving Data, Music and Picture files 
to the Emulator’s  SDcard 
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Android Emulator 
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Moving Data, Music and Pictures to the SDcard 
 
4.  Return to the emulator. This time you will see your selected  multimedia files 

in the SDcard. For instance… 
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Moving Data, Music and Pictures to the SDcard 
 
5.    Pictures are displayed by clicking the Application Pad and invoking the Gallery 

application 

Android Emulator 
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Android Emulator – Looking Under the Hood 
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Login into the 
Android OS shell 
 
• Although it is not 

necessary, a developer 
may gain access to the 
innermost parts of the 
Android OS.  
 

• For a Unix-like 
experience you can log 
into the system by 
executing the emulator 
and issuing selected 
shell commands. 

 



  adb is a tool located in the directory: 
  C:\Your-SDK-Folder\Android\android-sdk\platform-tools\ 
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Android Emulator – Looking Under the Hood 
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Login into the 
Android OS shell 
 
STEPS 
1. Use the Eclipse AVD 

Manager to start a  
selected AVD ( say 
Gingerbread23) 

 
2. At the DOS command 

prompt level run the 
Android Debug Bridge 
(adb) application  

  
 adb  shell          
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Android – Login into the OS shell 
If more than one emulator is running (or your phone is physically connected to the 
computer using  the USB cable)  you need to identify the target.  
 
Follow the next steps: 
 
1. Get a list of attached devices 
 

   adb devices 
 

List of devices attached 
emulator-5554   device 
emulator-5556   device 
HT845GZ45737    device 
 
 

2. Run the adb application as follows:   

 adb  -s emulator-5554  shell 
 
Remember, the adb tool is located at C:\Program Files (x86)\Android\android-sdk\platform-tools\  

Android Emulator – Looking Under the Hood 
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Hacking:  Moving an app from a Rooted Phone to the Emulator 
If you want to transfer an app that is currently installed in your developer’s phone to the 
emulator, follow the next steps: 
 
1. Run command shell:  > adb devices  (find out your hardware’s id, say HT096P800176) 

 
2. Pull the file from the device to your computer’s file system. Enter the command 
 adb -s HT096P800176 pull data/app/theInstalledApp.apk   c:/theInstalledApp.apk 
 
3. Disconnect your Android phone 

 
4. Run an instance of the Emulator 

 
5. Now install the app on the emulator using the command 
 adb -s  emulator-5554  install c:\theInstalledApp.apk 
 adb -s  emulator-5554  uninstall data/app/theInstalledApp.apk   ⟵ to uninstall 
 
You should see a message indicating the size of the installed package, and finally: Success. 

Android Emulator – Looking Under the Hood 
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More Hacking:  Install TotalCommander for Android 
 
TotalCommander is a useful Windows file manager that has been ported to Android. You 
could use it to administer the folders and files in the system’s flash memory and SD card of 
your emulator or device. 
 

Android Emulator – Looking Under the Hood 

To install the app in your emulator follow the next steps 
 
1. Start the emulator’s web browser on the URL: 

http://www.ghisler.com/android.htm 
2. Press Ctrl + Click on the “direct download” hyperlink 

to start  the app’s download. 
3. Wait for completion (scroll down Notification  line if 

necessary) 
4. Follow setup instructions. 
 

http://www.ghisler.com/android.htm
http://en.wikipedia.org/wiki/File:Total_Commander_logo.svg
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Android – Login into the OS shell 
Android accepts a number of Linux shell commands including the useful set below 

 

ls ................. show directory (alphabetical order) 

mkdir .............. make a directory 

rmdir .............. remove directory  

rm -r .............. to delete folders with files 

rm ................. remove files 

mv ................. moving and renaming files 

cat ................ displaying short files 

cd ................. change current directory 

pwd ................ find out what directory you are in 

df ................. shows available disk space 

chmod .............. changes permissions on a file 

date ............... display date 

exit ............... terminate session 

 
 

There is no copy (cp) command in Android, but you could use cat instead.  
For instance:   
 
 # cat data/app/theInstalledApp.apk > cache/theInstalledApp.apk  

 

Android Emulator – Looking Under the Hood 
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Android Emulator 
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Using an alternate SD card & userData Image 

Additional Emulator Command Line Options: 
      -sdcard   c:\My_Emulator_Data\myreallybigsdcard.img   -datadir    c:\My_Emulator_Data   

From the Eclipse menu create a new 
launch configuration:  
   Run > 
   Run Configurations >  
   New icon   
 
On the Target panel: 
  
1. Select existing AVD (Gingerbread 

in this example) 
2. Enter additional Command Line 

Options (see caption below) 
3. Click on Apply > Run  
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Android Emulator / SMS 
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Sending Text Messages from your Window’s PC to the Emulator  
 
1. Start the emulator.  

 
2. Open a new DOS command shell and type : 

c:>  adb devices 
this way you get to know the emulator’s numeric port id (usually 5554, 
5556, and so on)  
 

3. Connect to the console using telnet command like: 
 c:>   telnet localhost 5554  
 

4. After receiving  the telnet prompt you can send a text message with the 
command  (no quotes needed for the message) 
sms  send  <Sender’s phone number>  <text message> 

Windows7 – temporarily  install Telnet Client by using a command line 
1. Open a command prompt window.  
2. Click Start, type cmd in the Start Search box, and then press ENTER. 

3.    Type the following command:    pkgmgr /iu:"TelnetClient” 
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Android Emulator / SMS 
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Example:  
Sending a text Message (SMS)  
from your PC to the Emulator  
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Making a Phone Call from your PC to the Emulator  
 
1. Start the emulator.  

 
2. Open a new shell and type : 

adb devices 
to know the emulator’s numeric port id (usually 5554, 5556, and so on)  
 

3. Connect to the console using telnet command like: 
telnet localhost 5554     (this is the ‘number’ to be called) 
 

4. After receiving  the telnet prompt you can place a call (voice) with the 
command  
gsm call <caller’s phone number> 

Android Emulator / Voice 
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Example: Making a Phone 
Call to the Emulator  

Android Emulator / Voice 
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Android Emulator 
Using Eclipse’s DDMS facility 
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DDMS Emulator Controls 
It is much simpler to test telephony operations (SMS/Voice) as well as GPS services 
using the controls included in the Eclipse DDMS perspective  
 
1. Telephony Status - change the state of the phone's Voice and Data plans (home, 

roaming, searching, etc.), and simulate different kinds of network Speed and 
Latency (GPRS, EDGE, UTMS, etc.). 
 

2. Telephony Actions - perform simulated phone calls and SMS messages to the 
emulator. 
 

3. Location Controls - send mock location data to the emulator so that you can 
perform location-aware operations like GPS mapping.  
• Manually send individual longitude/latitude coordinates to the device.      

Click Manual, select the coordinate format, fill in the fields and click Send.  
• Use a GPX file describing a route for playback to the device.  
• Use a KML file to place multiple placemarker points on a map 
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Using Eclipse to test Emulator’s Telephony Actions 

Android Emulator 
 

Send text-messages 
Make a phone call 
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Android Setup & Emulator 

41 

Questions ? 
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Android Emulator 
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Appendix 1 – Connecting your Hardware Device to the Computer 
1. Make sure the USB driver has been installed in your PC ( click         SDK Manager > 

Extras > check box [Google USB driver package] to install ) 
2. Use a mini-USB cable to connect the device to your computer. 
3. Expand the Notification bar. Click on [USB connected] option.   
4. Click on [Turn on USB storage ] to mount the device. 
5. Now you could now use the Eclipse-ADT-File Explorer and your Window’s Explorer 

tool to pull/push/delete/rename files to the device. 
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Android Emulator 
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Appendix 2 – Emulator to Emulator Communication (SMS & Voice) 
1. Run two instances of the emulator (typical IDs are: 5554, 5556, … ) 
2. Dial (or send SMS) from one of them (say 5554) to the other (5556) 
3. Press the Green/Red call buttons to accept/terminate the call 
4. Try sending SMS (use numbers 5554 and 5556) 
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Android Emulator 
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Appendix 3.  
How to Transfer and Sync Your Google Contacts into the Emulator  
 
Taken from:  
http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator 

 
1. Go to your Gmail account using a web browser, click on Gmail  > 

Contacts on the left sidebar.  
 

2. Select all the contacts you want on your emulator/phone. Then 
click on More > Export and select vCard format.  Download the 
“contacs.vcf” file to your PC. 
 

3. Push the contacs.vcf file from the PC to the emulator’s SD card. 
 

4. Open the emulator’s  Contacts app hit Menu > Import.  
 

5. Choose the option Import from SD card. 

http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator
http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator
http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator
http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator
http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator
http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator
http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator
http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator
http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator
http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator
http://stackoverflow.com/questions/1114052/importing-gmail-contacts-on-android-emulator

